Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
>> No.77081420

Scrolling is goddamn slow on Fedora and there doesn't seem to be an option to change it. Am I doing something wrong?

>> No.77081571

Does syntax highlight have to be slow or is that just python doing its thang?
I tried zsh's colorize plugin, which utilizes chroma, or pygments, which i have from sublime maybe? anyways, the difference between less and cless, or cat and ccat is for ~50 loc like an order of magnitude as if

>> No.77081591

>>77081420
>Am I doing something wrong?
>on Fedora

>> No.77081603

who the fuck tought that appimage would be good idea

>> No.77081687

>>77081603
What's wrong with them?

>> No.77081713

What do you use to backup your /home anon? Rsync or something else?

>> No.77081743

>>77081146
new fag here.
Good antivirus for ubuntu?

>> No.77081928

I got a question regarding backports. I'm using Debian buster + backports for the kernel and nvidia-drivers + LibreOffice. While backports are considered ok, don't they also fall under the frankendebian category? Won't I get some conflicts sooner or later with the libraries?

>> No.77082072
File: 76 KB, 459x929, 2020-08-05-00-14-12.png [View same] [iqdb] [saucenao] [google] [report]
77082072

>void in charge of kernel images
I haven't the faintest idea why something like a kernel needs updating, every 90 minutes, but hey, i got no easy alternative.

Is there any way to control intramfs's output, i.e., stick to 2-4 versions, instead of periodically deleting shit. also, update-grub might be responsible, I should just stick to one logging level and not update the splash ever

>> No.77082099

>>77077205
>>77077205
This is very important.
http://techrights.org/2020/08/02/red-hat-layoffs/
http://techrights.org/2020/08/02/microsoft-layoffs-secrecy/
http://techrights.org/2020/07/19/azure-layoffs-and-beyond/

>> No.77082110

>>77081603
>>77081687
Appimages are 1000 times better than snap cancer, and better than flatpak shit.

>> No.77082117

>>77082072
you could create a cronjob to periodically delete it for you, if the problem is having to do it yourself

>> No.77082495

I'm interested in giving Gentoo a fair shake. Does it have NVIDA Optimus support? My laptop is cucked.

>> No.77082708

Was for about a year casual(1 per few months) ubuntu user, for now i'm sitting on it for a month as my only system daily.
I did fucked up few installs on my way with user/sudo system(some things looks like were meant to be installed for user, some things were meant to be installed for sudo, i don't remember did i picked user or sudo when i did installed ubuntu(i remember there was something about it), so i plan to make clean install(and without ubuntu this time)
Debian or Mint? I do like Mint for it's being simple, will i dodge more problems this way?
Also how do i better allocate space next time? I did it's 75/30gb for home/system last time and it was clearly stupid enough(i did thought that user installs will use home space). 30/75 next time?

>> No.77082793

when installing arch, after installing the microcode during the install, will running grub-mkconfig while installing grub also make the microcode work? the arch wiki says to RE-generate the config which makes it sound like its not done the first time. Would you just install the microcode after installing the system?

>> No.77082812

I'm stick of my current theme, which one do you guys use?
Easy on the eyes but not flat shit please. Or something that looks out of 2005

>> No.77082899

>>77082831
>https://wiki.gentoo.org/wiki/NVIDIA/Optimus
>Gentoo is breddy gud and has an actually decent community and documentation. 10/10 recommend
A lot of this stuff is way over my head unfortunately. Still have some learning to do it seems.

>> No.77082913

>>77082831
>Ubuntu's installer has you make a user account so you shouldn't run into a situation where you are always root
Should i do it again on my next distro?
I guess it's safer that way, but considering i'm only user wouldn't being always root slight better(like no way to fuck install, i still don't understand why i managed to fail CUDA install for first time, it was installed, but my tests were failing)

>> No.77082972

>>77082936
I had to abandon Debian because of it. I just couldn't get it working. The doc on Arch's wiki worked for me on Arch, but it only allowed the GPU to be on all the time. Makes me want to sell this shitty thing and just get a thinkpad.

>> No.77083013

Update boys I shat my pants just a little bit
>>77082899
It should make sense after doing an install. The handbook has a great guide. I recommend this one as all the sections are combined so you don't miss anything. Make sure it matches your architecture. This is amd64. https://wiki.gentoo.org/wiki/Handbook:AMD64/Full/Installation
Basically you need to enable some options in the kernel using menuconfig, compile and install the new kernel configuration, then just slap in the commands listed
Bro way easier than it looks
>>77082913
No it is a major security problem and makes it easy to make big mistakes. Gives you the authority to literally nuke your drive in a six character command without a second thought or pause for consideration
Also from the security side an attacker is always going to try the root account when making remote entry and thus would only need to crack a password. Whereas, with the root account disabled and user accounts used with sudo instead, an attacker needs to crack both a username and a password.

>> No.77083032

>>77082972
Ubuntu, Pop!_OS and Manjaro deal with it really nicely, just dualboot it, that's what I do. I have 80gb of space dedicated to Manjaro and the rest to Gentoo, which runs on the iGPU only.

>> No.77083074

>>77083047
You can use bumblebee if you want
I don't use open source nvidia drivers because they're all ass

>> No.77083102

>>77082936
i feel it. i can never get all of the following to work simultaneously:
- switch on demand
- external monitors
- brightness control
can anyone with working config just dump the conf files?

>> No.77083110

>>77083074
no, do not use bumblebee, it is abandonware

>> No.77083152

>>77083102
I managed to set up PRIME on Gentoo, but I don't have the config files here and the dGPU never fully deactivated so there was an impact on battery. Take a look at this, it may help you:
https://us.download.nvidia.com/XFree86/Linux-x86_64/450.57/README/randr14.html

>> No.77083158

>>77083074
If you're aware that you're running something probably malicious with privileges higher than root on your computer and still want to do so in the future, go ahead.

>> No.77083179

>>77083013
>Bro way easier than it looks
Yeah I know, and I wouldn't have a problem just following the handbook. My concern is my discrete NVIDIA GPU

>>77083032
I have openSUSE on it currently. KDE Neon also worked nicely. I'm not gonna dual boot it, I'd rather just go all in with one.

>>77083152
think I'm going to pass on Gentoo for my laptop sadly. One day I'll have some normal laptop and try it on there.

>> No.77083198

>>77083179
The site I linked is distro-agnostic, don't worry, the distro doesn't matter.

>> No.77083237

>>77081146
I want to learn to truly use computers and the internet to their true and full potential. I am quite a "noob" at it at this very moment but I am willing to learn and ready to put the effort required to acquire this knowledge. When I am talking about the "computers" I also reefer to windows so how do I go about it? Right now I am quite poor and can't afford to buy a new laptop or pc because I don't know what awaits me tomorrow because of Covid.
I only have a laptop with 4gb of ram, 1TB, 5400rpm Hdd. The cpu is a 4 core APU from AMD. Will I need to dual boot ? Will a VM be good enough? What Linux distro should I get?

>> No.77083239

>>77082708
>Debian
Ancient packages and not even that good a distro.
>Mint
Ubuntu fork without maintenance or security updates.
Why not stay with Ubuntu?

>> No.77083297

>>77081146
I used xdg-mime to change my default file manager and I have no idea what i'm doing.
Can someone explain how I would write in a default application for bittorrent just as an example?
The beginning of the code is understandable but this has me confused: ".desktop inode/directory"
full string:
xdg-mime default nautilus.desktop inode/directory

>> No.77083500

>dmenu
>zsh
What is the elegant and portable way to run commands requiring a terminal window with those two? I just want to write 'cmus' and have it open in a new term instance.

>> No.77083506

Any idea on how to force Firefox to open directories through Caja, instead of Thunar?
I've changed it with xdg-mime - no deal.
I've also removed any reference to Thunar in /usr/share/applications/mimeinfo.cache - no deal.
Xfce's Preferred Applications already accept Caja instead of Thunar, and the DE itself is happily ignoring Thunar.
What else do I need to do? Maybe call Loki and ask him to crush Thor?

>>77083297
>.desktop
File extension. Refer to the file in /usr/share/applications.

>inode/directory
Directories.

>> No.77083507

>>77083239
Stop telling lies about mint.

>> No.77083591

>>77083529
What's that got to do with security updates?

>> No.77083605

>>77083506
go to caja, right click on a folder, select open with, select caja

>> No.77083638

does ubuntu still monitor it's users?
t. newfag

>> No.77083702

>>77083671
just until you get more familiarized with the terminal, no, no

>> No.77083770

Does anyone know script to download facebook albums?

>> No.77083930

>>77083605
>go to caja, right click on a folder, select open with, select caja
Already done. Same thing - Firefox still opens Thunar instead.

In fact Thunar doesn't even appear in the list of "recommended applications", as I've deleted it from /usr/share/applications/mimeinfo.cache.

>> No.77084214
File: 29 KB, 620x533, 3g5m8ur9lae51.png [View same] [iqdb] [saucenao] [google] [report]
77084214

We did it, guys

>> No.77084337

Why cant I get use flags right? I tried using flaggie and putting them directly in make.conf, but emerge still complains about missing flags. What am I doing wrong?

>> No.77084368

>>77084337
what you're doing wrong is setting global use flags. you don't add those unless you are completely sure you'll need support for something in every single package you compile, if you don't or you're not sure if you do, you set it on /etc/portage/package.use

>> No.77084380

>>77084337
post the error message

>> No.77084585

>>77084576
Did you try awesomewm?

>> No.77084606

>>77084585
Yes, ive tried dwm i3 and awesome and they all have this same problem

>> No.77084774

Am I in trouble? I was curious about monitoring my temps on Linux Mint (I'm a noob btw) and after a quick google search the first article I clicked on said to run sensors-detect and select "YES" for all prompts. I did that and I ran sensors and it worked well enough. But later after a bit more reading other articles said to use the default values by pressing ENTER, and NOT to press yes for all. Will what I did damage my laptop? How do I fix this, would I just need to run sensors-detect again and press ENTER for defaults this time? I'm assuming that's what I should do but I wanna confirm.

>> No.77085003

>>77083239
We're getting old senpai and so do our memes.
>. In newer versions of the operating system, this safety level mechanism is largely deactivated in favour of system snapshots created by the Timeshift tool
https://en.wikipedia.org/wiki/Linux_Mint
>>77083591
Mint was pretty bad for a while. It was such a fragile hack that it even had a blacklist for packages that couldn't get upgrades without possibly breaking the system.
>>77083638
Yes.
>>77083770
gallery-dl is like youtube-dl but for images it wouldn't surprise me if it would also support zuckerrbook. Don't forget to use a proxy so it doesn't suck you out.
>>77084214
>Linux
>Chrome OS
>BSD
The tech illiteracy levels are high in this one.</wbr>

>> No.77085316

>>77085300
what do you wanna replace it to?

>> No.77085393

>>77085362
In the middle "XDATEY.mp4. X and Y isn't always the same length but the DATE is the same

>> No.77085410
File: 94 KB, 483x640, 1507400938682.jpg [View same] [iqdb] [saucenao] [google] [report]
77085410

>>77085311
You just have to find out which anomaly makes you special and cultivate it.

>> No.77085492

>>77085393
it is doable, but would require some shell script knowledge, copy all the files (cp *20190612* /some/where) to make sure you don't screw anything up

ls *20190612* | sed 's/20190612//'
this should give you a list of all the filenames but without the date, try to go from there and write a script to rename each file to the correct filename

>> No.77085495

>>77081146
I just recently installed xampp on ubuntu for web shit. I want to start cloning repos to htdocs. When I right click to open terminal I noticed it runs in root mode. I can't cd into from my home folder either. Why does it run in root? Isn't that bad? Can I run operations here in normal sudo form?

Last time I messed around with linux it was the server version so the gui is throwing me off. Also do I need xampp to serve through local host for testing or could I just do that with a true lamp stack?

>> No.77085514

>>77085492
That seems doable I'll try it right away

>> No.77085532

>>77085492
Yeah it prints out the names perfectly now. I'll sleep on this though thanks mate

>> No.77085574

>>77085340
Damn that's some cute shit anon, thank you.
---(_)
_/ --- \
(_) | |
\ --- _/
---(_)

>> No.77085578
File: 59 KB, 726x424, Screenshot_20200804_202449.png [View same] [iqdb] [saucenao] [google] [report]
77085578

>>77085574

>> No.77086112
File: 3.96 MB, 1920x1080, 1592293578348.png [View same] [iqdb] [saucenao] [google] [report]
77086112

>>77081146
How do I rice i3 to look like pic related? I'm thinking of switching to Gentoo and i3 because I been trying Manjaro with KDE and tired of UI

>> No.77086134

>>77086123
>Reddit
Fuck no

>> No.77086250

>>77086112
>install dwm
>hide the bar by pressing mod(usually alt by default(change it to super like any normal human being))+b
>set a cute wallpaper
>install a bitmap font and set it as your terminal font
>run ufetch
done.

>> No.77086640

>>77082556
I like openSuse but I'm always afraid it's a dying distro

>> No.77087121

I've tried to install Obarun, on tty1 it just hangs with the message [Starts stage1 process...] but on tty12 it seems to just work.
Is this behavior normal or do I should I look more into this?

>> No.77087210
File: 67 KB, 1018x333, Screenshot_20200805_013828.png [View same] [iqdb] [saucenao] [google] [report]
77087210

For Ubuntu I want the 388M tar.bz2 version?

What is this stuff? So tar an archive format, and bz2 is a compression format, and sig is the signature?

>> No.77087221

>>77087210
the big one is source code
>and sig is the
yes

>> No.77087302

>>77087121
Just ignore this, I fixed it.
Apparently the installer didn't automatically enable tty1 and it didn't say anywhere in the installation guide.

>> No.77087637
File: 66 KB, 528x792, 1523567842246.jpg [View same] [iqdb] [saucenao] [google] [report]
77087637

>>77085492
Did you just parse ls output?

>> No.77087653

>>77086000
>having a root account
You're doing it wrong.

>> No.77088039

>>77081146
is ssh the only way to make socks?

>> No.77088399

why do you use linux when bsd is better?

>> No.77088482

>>77088399
I don't like being cucked.

>> No.77088615

how resource intensive gnome 3 really is? I'm running out of options for touchscreen support out of the box with minimal wrenching but I want to install it on a shitty l*novo tablet/pc

>> No.77088660
File: 79 KB, 958x402, sc278.png [View same] [iqdb] [saucenao] [google] [report]
77088660

>>77088004
You can if you dare to remove the "ubuntu-desktop" metapackage among others.

>> No.77088862
File: 388 KB, 2304x1536, 1596585702676.jpg [View same] [iqdb] [saucenao] [google] [report]
77088862

XFCE4-panel crash when it try displaying an "some" emoji.
Any idea how to fix it?

>> No.77089209

>>77083638
>>77085003
What about Mint? I heard it was a good newfag distro. Does it also monitor its users?

>> No.77089272

>>77089209
apparently it doesn't, neither does pop

>> No.77089273

>>77082110
fuck outta here with your windows executables

>> No.77089382

I am just mad. I set on debian and on opensuse my static ip but all of the sudden network manager doesn't bother to connect my ethernet to each other. Also I don't understand why usb 2.0 standard transfer files with 10MB/sec and it keeps slowing at the end to 400kb/s.

>> No.77089855

>>77082110
This, I can have some old package on my arch install with no issues.
>>77089273
How is that related to windows?

>> No.77090021

>>77089963
Why not just use RAID?

>> No.77090747

>>77082565
I use it

>> No.77090915

>>77088862
A lot of times emojis render to unpredictable sizes, and a lot of programs don't handle this correctly with varying results. Try a different font or stop using xfeces.

>> No.77091079
File: 126 KB, 622x670, 1557270932691.jpg [View same] [iqdb] [saucenao] [google] [report]
77091079

>>77081146

>> No.77091517

I want to try out Gentoo, I've looked at the handbook and going through all of that on my phone is going to be a painful process.
Can I install Gentoo using a live image, say something like Ubuntu?

>> No.77091537

>>77091517
>wants to try gentoo
>doesn't want to do the meme portion that is the only reason anyone recommends gentoo
Gentoo is unironically shit, and even stallman doesn't recommend it. If you want to do an "everything from source" system, then install FreeBSD and use the "ports" system instead.

>> No.77091558

>>77090968
BSD is a cuck license.

>> No.77091711
File: 332 KB, 650x366, 2313136666666.jpg [View same] [iqdb] [saucenao] [google] [report]
77091711

This is me, when I go outside to catch some sun knowing my Debian stable + backports just works and requires 0 maintenance. So comfy I never get stressed over it.

>> No.77092207

Seeing a lot of criticism of systemd on a few website, is it even that bad considering the easy hate some linux software seems to get ? and has it any impact for my use (basic daily driver to browse the web mostly) ?

>> No.77092336

>>77092323
Systemd-bootd will replace grub. Systeme will replace systemd.

>> No.77092876

>>77092457
GRUB is nasty to conf and install. Why can't it just come as an efi-file and a config like rEFInd? Why don't we all just use refind to boot everything?

>> No.77092999

Is there any real point to Slackware in this day and age?

>> No.77093012
File: 351 KB, 778x1100, 1581812172671.jpg [View same] [iqdb] [saucenao] [google] [report]
77093012

>>77092985
I replaced both with systemd on my Gentoo system. ;^)

>> No.77093144

>>77093012
That's like eating steak with ketchup

>> No.77093185

>>77093012
How does the systemd bootloader thingy work in practise?

>> No.77093581

>>77092957
>ExpandDrive wants $80 for lifetime program so it can do smart sync
I guess I need to reorganize my folders and do selective sync... fucking bullshit.

>> No.77093800

Hey /fglt/, you may know best:
Which distros come with telemetry? On my list so far: Ubuntu and Clear Linux.
Also, any DE with telemetry?
And: are these opt-in or opt-out?
Any info highly appreciated.

>> No.77093863

>>77093800
KDE has telemetry but it can be disabled or you can choose the level of it, although it's fairly opaque

>> No.77093911
File: 31 KB, 1545x317, screenshot_2020-08-05_19-30.png [View same] [iqdb] [saucenao] [google] [report]
77093911

>>77093881
In the settings menu

>> No.77093982

>>77093911
>fairly opaque
Do you get more info in a tooltip if you mouse hover that button?

>> No.77094037

>>77092816
If that's what you're supposed to do, then the tools, along with all the online help, along with the MFing package dependencies, shouldn't be telling you to install the ntp package.

>> No.77094362

>>77093911
wtf
is that enabled by default???'
what does it send???

>> No.77094606
File: 2 KB, 380x46, 1578722772925.png [View same] [iqdb] [saucenao] [google] [report]
77094606

Why is this happening? It's reading my wildcard as a literal * AND running it as an actual wildcard

>> No.77094631

Tried to launch TailsOS on my laptop for fun but it had a intel integrated GPU bug.

:( how am I supposed to look at cat pictures without the NSA tracking me now?

>> No.77094678

What is there to know about the Logical Disk Manager? I only even click "next" to automatically set up my drives, never really cared before.

>> No.77094831
File: 29 KB, 500x479, bubbo.jpg [View same] [iqdb] [saucenao] [google] [report]
77094831

>>77094678
>see the partition layout simply out of interest
>have partitions you like to keep and make sure the installer doesnt fuck them up
>delete the old partitions
>want to create EFI system partition of a different size than the default
>bubbo :D

>> No.77094940
File: 49 KB, 1105x660, screenshot_2020-08-05_20-49.png [View same] [iqdb] [saucenao] [google] [report]
77094940

>>77094362
disabled by default, at most what it sends

>> No.77095035

>>77094831
thanks anon

>> No.77095142

>>77095090
whatever you do, do NOT use arch for your server

>> No.77095155

>>77095142
I believe you, but just so I understand, why not?

>> No.77095219

>>77095173
Oh, right. That makes sense. Rolling release is fine for a desktop, maybe not so much for a server. I'll probably just use Debian. Thanks.

>> No.77095657

>>77095173
>you have to update it often and that's just a pain in the ass
Doing pacman -Syu daily is a pain in the ass?

>> No.77095693

>>77091517
Yes you can. I even did a thread recommending that a while ago here on g
>>77091537
You have no idea what you're talking about. Stallman doesn't recommend Gentoo because it facilitates the use of proprietary software

>> No.77095705

>>77095693
..and unironically because they call themselves Gentoo Linux instead of Gentoo GNU/Linux

>> No.77095706

As someone that doesn't really care about privacy, is it still worth using Linux?

>> No.77095712

>>77095142
B-B-BUT LUKE SAID IT'S GOOD ON A SERVER!!!

>> No.77095752

>>77095737
I probably should, but I can't be bothered.

>> No.77095763

>>77095732
they do have experimental musl profiles, and stallman apparently dislikes that

>> No.77095775

>>77094606
What is it that makes users so hostile to regarding manuals?

>> No.77095823

>>77095657
on a server, it is. what if one of the updates requires manual intervention? you can't just stick pacman in a cron job and have it not break eventually.

>> No.77095844

>>77095752
went linux in order not to have the shitty updates and have a snappier system, privacy is not the only reason to switch, but you must mostly ask you what you do with a PC to know if it's worth it to switch

>> No.77095847

>>77095729
but I want to get gid of it

>> No.77095897

>>77095775
Sometimes you don't know the correct terms to search for - then it's a good idea to have a friendly community. Feel free to join us!
>>77094606
Read the "Pathname Expansion" part of the bash manual. More on this here: https://mywiki.wooledge.org/BashPitfalls#for_file_in_..2F.2A_.3B_do_if_.5B.5B_.24file_.21.3D_.2A..2A_.5D.5D

>> No.77095958

Just did an lsmod on my custon configured gentoo kernel and got this
Module Size Used by
nvidia_drm 49152 9
nvidia_modeset 1138688 18 nvidia_drm
nvidia 19271680 980 nvidia_modeset
snd_hda_intel 36864 0
snd_intel_dspcfg 16384 1 snd_hda_intel
snd_hda_codec 110592 1 snd_hda_intel
snd_hda_core 73728 2 snd_hda_intel,snd_hda_codec
efivarfs 16384 1


I have an amd cpu, what do you I need to disable to get rid of those inter things?

>> No.77095996
File: 1.18 MB, 5000x5000, 1586663008484.jpg [View same] [iqdb] [saucenao] [google] [report]
77095996

>>77095973
H-happy hacking!

>> No.77096017

>>77095958
snd_hda_intel is for sound I think so you probably want it

>> No.77096024

How do you have all your windows auto open up when you startx?

>> No.77096046

I found my old laptop that does not have a fan. Distro recommendations for it?

>> No.77096068

>>77096017
>>77096038
Fuck, I thought I could have the configuration with only nvidia and efi modules (especially since I saw what lsmod shows on other systems with like dozens and dozens of entries). Oh well, I guess intel stays.

>> No.77096083

>>77096046
if it doesn't have a fan but it should, it will overheat and it doesn't matter what distro you run, get a fan and install gentoo. If it is passive cooled by default, then install something lightweight like void or arch idk

>> No.77096174
File: 89 KB, 1048x932, 1504597753693.jpg [View same] [iqdb] [saucenao] [google] [report]
77096174

Redpill me on Xresources vs Xdefaults. Why do they both work, which was first, which is for chads and why?

>> No.77096199

>>77096067
How do you tell them where to go,like when i close them they are in the spot i want on that monitor but opening them just makes all of them on the default monitor but not where and what size i put them on.
For example terminals and programs running in them

>> No.77096212

>>77096203
pls no bully

>> No.77096242

>>77096203
Sorry bro, only 2 weeks on gentoo

>> No.77096406

>>77096352
>nooooooo you can' t just use uppercase letters!
>everything must be unified!
>hail systemd!

>> No.77096473

>>77096406
Well, good point.

>> No.77096535

I've been having a weird issue with dmenu lately.
If I try to type anything it instantly closes. However this is not consistent. Sometimes after a reboot it works just fine then next time when I startup my machine the issue is back.
Anyone have an idea what the issue is and how to fix it?

>> No.77096614

>>77081146
Hello. Sorry for the engrish. Can you advice me a linux distro with these features:
1. It's binary, but one can easily build packages from the source to the point of making the whole system source-based without too much hassle. Good if the the packager can use local package files. There should be an option to mark package as a source-based/custom, which would stop the attempts to replace it by the official package, or just assign the package to certain repository(ies).
2. There're build scripts. This would allow to use similiar build scripts from other distros with little changes.
3. The building of the source doesn't enter chroot at all. Everything is done at the host.
4. It uses glibc by default. I don't care about init system.
5. It has explicit support of the local and remote repositories for both the binary packages and the build scripts.

Void was fine, but the chroot it enters is an absolute shit. Really. The last time i used it bootstrapped a base system with a different version of gcc than that of the host. Every. Single. Time. This is an absolute bullshit.

Arch doesn't support build-script repositories natively, and aur is a garbage can full of shit. Also, as far as i know, the binary repositories apply by order for all binary packages, be they just (non)official binaries, or aur package build with makepkg -si.

>> No.77096616

>user has a problem on distro a
>hops to a different distro without problem a but with problem b
>hops to a dif....
Why are peooe like that?

>> No.77096644

>>77096614
didn't read alll this

>> No.77096721

>>77096644
GNU/Advanced user, is that you?

>> No.77096729

>>77096700
What makes it special?

>> No.77097164

>>77096644
I hurred somewhere you can rebuild arch linux completely from source using the ABS.
[arch build system]

>> No.77097580

>>77091383
Try opening them from a terminal, wine game.exe or proton game.exe in the game files (if you installed proton-ge from the AUR)

>> No.77097588

Is there any practical reason for me, a macOS user, to use GNU/Linux instead?

>> No.77097731

So I put this into my mpd config
log_file "~/.config/mpd/log"
and now i get this when starting
exception: failed to open log file "/var/lib/mpd/.config/mpd/log" (config line 37): Permission denied

What is going on? I use gentoo btw

>> No.77097770

>>77097588
That depends. There are plenty of very good reasons to leave the Apple ecosystem but none of those things are arguments for Linux per se. Some reasons you might move to Linux are that you want a leaner OS that isn't full of spyware and backdoors, you want to be able to do more to tailor it to your specific tastes and needs (but are also willing to put in the work to learn how,) or you just want software that you don't have to pay for.

>> No.77097790

>>77097759
Sure I did, but the issue is that it is trying to find log files /var/lib/ instead of .config/mpd and for some reason even merges the default path ("/var/lib/mpd/log") and this one together. I want to start this shit as a user and not as root.

>> No.77097799

>>77097790
don't start the daemon, then. Run mpd from your user

>> No.77097802

>>77097790
are you using your config or the one in /etc?

>> No.77097806

>>77082872
i don't have an optical drive on my laptop but i use udiskie for handling automatic usb mounting

>> No.77097814

>>77097799
That's what I'm doing, man. I'm starting this a user.

>>77097802
Since I'm starting it as a user I assume it uses the config file I created in .config. It doesn't complain about any other folders I specified there.

>> No.77097827

>>77097731
try explicitly setting the log and other files, instead of ~ put /home/<user>/.config/...etc or /home/<user>/.mpd/...

replacing <user> with your actual username.

Seems like it is getting confused by the tilde, which it shouldn't, but it is.

>> No.77097919

>>77097907
same

>> No.77097981

>>77097844
I definitely didn't create the folder as root, seeing as I just created every other folder in .config/mpd/ including mpd folder with the same command.

>>77097827
Anyway, I stole it from the arch config and put "syslog" there and now it just works.

>> No.77097986

>>77087574
Go to https://www.adobe.com/support/flashplayer/debug_downloads.html and download the "flash player projector", there is a linux version further down the page.
open the flashplayer binary and then open the swf file you want to run

>> No.77098012
File: 77 KB, 500x667, dank-memes-23.jpg [View same] [iqdb] [saucenao] [google] [report]
77098012

>>77081420
You should be able to adjust it via imwheel if I'm not mistaken.

>> No.77098051

Is there a reason why you SHOULDN'T pacstrap an entire DE when installing arch?

>> No.77098325

>>77097642
Bump

>> No.77098385

https://www.youtube.com/watch?v=08fwJPUD7dE
>a friendly gnu linux user teaching you how to rice your gnome desktop
My sides, anons. 100% would hang out with this guy.

>> No.77098739

What is the latest version of IceCat available for Debian? On GNU, v60 was posted last year. Is that stable enough that there won't be security vulnearbilities?

>> No.77099397

what's the reason using stable distro on desktop like centos/debian stable? isn't rolling or fixed release is just better?

>> No.77099614
File: 442 KB, 3009x2413, 1579008907196.png [View same] [iqdb] [saucenao] [google] [report]
77099614

>cringe

>> No.77099646

>>77099408
You can either get a bloated shit distro or a glorious minimal disto that requires setup. There's barely a middleground. Ubuntu and Mint are bloated shit.

>> No.77099658

>>77099614
go back

>> No.77099763

So I have a list of mail addresses I want to send a newsletter to. Can this be done with a simple shell script?

>> No.77099815

>>77099646
Are you telling me to, perhaps, install Gentoo?

>> No.77100227

>>77100210
I have a python script i want to make sure is not sending any data in the background that it shouldnt

>> No.77100760

>>77100731
if I got you right, dmenu.

>> No.77100764

>>77100195
>close everything connecting to the internet (you can do that, right? you aren't running windows, are you?)
>open wireshark
>run python script
this is assuming you actually know what you're doing

>> No.77100869

>>77094606
the wildcard will match a literal asterisk

>> No.77100966

There's a small delay whenever I use my GLOBAL hotkey to play/pause a music track in DeadBeef on Manjaro KDE/X11. When I use foobar2000 on Windows 10 this doesn't happen and the global hotkey works instantly. I don't even know where to start with this issue. Is this a KDE problem? X problem? Deadbeef itself? I haven't tried other music players. Perhaps, I will try researching whether CMUS has global hotkeys and try it there.

>> No.77101116

>>77097642
krunner looked awesome to me, but after using it a bit, its kind of shit. it will often re-order items just before i select an item, so i end up selecting the wrong item. there is no way to restrict search to certain collections except globally, and then there isn't even a way to easily move between collections in the search results, so you have to move down one item at a time. you can't configure alternative actions. i've been using rofi which comes with some basic functionality like app launching and window switching, its extensible, and there are a lot of scripts already written by anons to achieve quite a bit with it.

>> No.77101185

>>77100966
probably deadbeef, could be KDE. with my MPD/i3 setup, there's noticeable but not terrible(100ms maybe?) delay there.

>> No.77101655

In ncmpcpp how can I change the "Album" column on the playlist to display "Album Artist" instead?

>> No.77101794

>>77099408
MX Linux or Xubuntu.

>> No.77101984

>>77101655
nm, figured it out. Use capital "A" in song_columns_list_format in the config. It doesn't seem to be documented, but works anyway.

>> No.77102013

>>77101854
I don't know where the favorites are stored, but if you know and can write a script to grab them then you can pipe it to rofi.

>> No.77102499

>>77100033
grep -v ^%$ textfile.txt | shuf -n 1

>> No.77102543

is there any distro where i can get mate DE without poetteringware (SöystemDicks, Pulseaudio/Libpulse, etc)

and is not gentoo/funtoo/cloveros

>> No.77102617

>>77102013
Just found an script in Github doing something similar, i'll need to look for where those favourites are stored. Hmm, thought i'd be more involved that just using xbindkeys and pipelines. Nice surprise.

>> No.77103025

>>77102991
i genuinely like the GNOME aesthetic but the devs are also retarded unfortunately

>> No.77103271

Is there a cmd for the terminal to check if the drivers and hardware are running fine?

>> No.77103890

>>77100402
run it in virtualbox so it can't send the signals to management engine

>> No.77104176

Not spefically Linux, but where do you find the weeb wallpapers that seem to accompany the linux ricing?

Just using Fedora, and just want to meme it a bit more

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action