Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Maintenance is complete! We got more disk space.
Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
>> No.74230823

you all stink, take a shower

>> No.74230843

>>74230823
My shower is in the shop.

>> No.74230869

>>74230704
Uncertain. Remains to be tested in court. Of course, ethically and socially speaking, the correct would be for the state to compel ISPs to release source code for transparency and liberty. But don't hold your breath for that in a ridiculously neolib country like America.

>> No.74230884

make this year the year of Hurd, unironically

>> No.74230944

>>74230823
nope
I'll stink up the whole network, until proprietaryfags run away

>> No.74230971

Who "mitigations=off" here?

>> No.74231196

>>74231131
i never used opensuse, but ubuntu should be very noob friendly

>> No.74231237

>>74231214
nothing much, just downloaded a large report from my email and the html is minified

>> No.74231349

>>74231320
It does! thanks anon

>> No.74232995

>>74232697
Make something better, or at least make an example for such.

Still having this problem:
>I'm having an openldap client which doesn't work to login after boot up. However if login to one of my local users and log out again, I can login to my LDAP accounts just fine. Any hints on what to look at here?

>> No.74233054

>>74230648
my usb Logitech unifying receiver sometime doesn't get detected. I can't tell if my usb suspend fucks it or not. It drives me crazy cause all the sudden it works.

>> No.74233140

>>74231131
Kubuntu. Way more fine tuned than SUSE.
>hacker shit in the terminal
Don't be like that, sometimes it's more convenient to do stuff from there. It's not always "hacker shit", just simple stuff. Like moving a misplaced file without starting browsing with file manager or quickly checking disk space or something like that.

>> No.74233154

>>74233140
Also scripting.

>> No.74233608
File: 186 KB, 640x655, 1563735558069.png [View same] [iqdb] [saucenao] [google] [report]
74233608

>>74230648
>tfw configured kernel literally takes a single cigarette break to compile.

wtf bros

>> No.74233707

Can someone point me to a reasonably comprehensive article explaining how a web server works and the individual components of a LAMP stack & how they interact

I want to learn system administration and I feel like thats a pretty basic concept I need to grasp

>> No.74233791

>can't install texlive-bin correctly to compile even simple pdf
>firefox displays cursor in overleaf with 6 character offset
I hate this

>> No.74234096
File: 13 KB, 300x300, 2795415-9653374716-king..jpg [View same] [iqdb] [saucenao] [google] [report]
74234096

>>74233592
>nix is not linux thing
>I specifically mentioned things that are not linux

>> No.74234119
File: 101 KB, 500x555, 1556307046684.jpg [View same] [iqdb] [saucenao] [google] [report]
74234119

>>74233608
>bros
we are not your "bros".

>> No.74234132

>>74232995
>at least make an example for such.
>I've just made examples for such
Holy fuck, is this the international day of the brainless ghouls?

>> No.74234159

>>74234096
yeah, my point is that you can't lump in nix with things you call dead technologies

>> No.74234264

>>74234205
I use linux because nix is currently best supported by it, otherwise I'd hop on to windows just like that
you made it sound as if nix was dependant on linux

>> No.74234443

>>74234236
stop using KDE Neon

>> No.74234512

A new Project Trident release (based on the Linux kernel for the first time) will be out soon. It completely abandons its BSD base.

>> No.74234526

>>74234264
I gave examples of unique OSes that are nothing like typical Linux distros. And by Linux I obviously mean the GNU/Linux system with all its common traits.

>> No.74234576

>>74234526
>obviously
while I agree with you to certain point that the current standard way of gnu/linux system management is bad, the way you phrased it wasn't obvious
it just sounded like you're against the entire linux ecosystem not the standard base
>Linux is all used up, it has 0 decent ideas
See? when you say 0 ideas you're not referring to standard practices but to the entire thing, whether it be niche ideas or mainstream ones

>> No.74234708

>>74234236
Your DE can break anytime, but I'm sure you already knew that.
>>74234545
By the way you are writing, I can tell you will never get good enough.

>> No.74234817

can I edit what gets run when I enter a dmenu item? I'd like to run a script right before or right after I start up a specific software

>> No.74234864

>>74234817
Dmenu uses .desktop files.
I believe you can modify the .desktop file in itself to add some extra options or functionality.

You could also create a copy of the original .desktop file and name it something else like "firefox custom" which keeps the original menu entry.
Just renaming the .desktop file isn't enough, take a look at it's insides and you'll quickly figure it out.

There could be a prettier way to do this.

>> No.74234956

>>74234545
It’s worth doing if you want any potential users to be sure what ground they’re standing on. It doesn’t involve very much, just including a LICENSE file and a brief copyright statement at the top of each source file.

See https://en.m.wikipedia.org/wiki/License-free_software for license-free software.

>> No.74235051

>>74234864
I think dmenu uses /usr/bin/, but that aside my worry is that modifications done to .sh or .desktop files don't persist through a software upgrade. I went ahead and assigned a custom i3 keybind to a script && software instruction, it looks like this does the trick too

>> No.74235088

>>74235051
"dmenu will look for executables in the directories defined in your $PATH."

That was from Arch wiki.

You could create a folder just for your own custom executables and include it in your $PATH.

>> No.74235120

>>74234817
You shouldn't listen to morons and actually read the manpage.
DESCRIPTION
dmenu is a dynamic menu for X, which reads a list of newline-separated
items from stdin. When the user selects an item and presses Return,
their choice is printed to stdout and dmenu terminates. Entering text
will narrow the items to those matching the tokens in the input.

dmenu_run is a script used by dwm(1) which lists programs in the user's
$PATH and runs the result in their $SHELL.

Consult the documentation of your WM as to what is piped into dmenu or if a wrapper is used.
Also, dmenu works like a command line and you can add arguments to whatever your run.

>> No.74235502

I’m using a ThinkPad T470 with a fresh arch install and I’m still configuring everything but it’s going pretty smoothly. My one issue is the screen brightness shortcut keys built into the keyboard don’t change the brightness at all. I’ve checked the backlight page on the wiki and tried what it suggested with no success. The most progress I’ve made so far is being able to change the brightness manually from the terminal using xbacklight -set #. Anyone have any recommendations?

>> No.74235756
File: 13 KB, 512x512, 532-512.png [View same] [iqdb] [saucenao] [google] [report]
74235756

I need a battery indicator that will show two(2) batteries. the one that comes with awesome-extra was good but I don't use awesome anymore. thanks

>> No.74235959

>>74230823
showers are bloat.
i bathe in a river

>> No.74236282

What's difference between KDE Plasma and Neon

>> No.74236303

>>74236282
KDE neon is using a stable Ubuntu long-term. KDE Plasma is what I hope you're already using, over GNOMEd DE.

>> No.74236320

>>74236303
I USE GNOME BECAUSE ITS SO SHIT IT DOESNT DO ANYTHING THATS WHY ITS GOOD SO I DONT WASTE ITME USING IT BIG BRAIN

>> No.74236328
File: 160 KB, 368x410, ewww.png [View same] [iqdb] [saucenao] [google] [report]
74236328

>>74236320

>> No.74236338

>>74236328
Like for real. The taskbars for example. Absolute dog shit with broken or no functionality at all. Makes me think why they are even included in Gnome.

Mean while when I booted up KDE it looked like space rocket flight station and I fucking logged out instantly and went back to Gnome

>> No.74236353
File: 8 KB, 122x121, Screenshot_2020-01-03.png [View same] [iqdb] [saucenao] [google] [report]
74236353

I simply want to know how to run this application in Linux Mint. It doesn't have a file extension. It just says discord-image-downloader-go-linux-amd64
Found here: https://github.com/Seklfreak/discord-image-downloader-go/releases

>> No.74236377
File: 930 KB, 672x787, 1577849767454.png [View same] [iqdb] [saucenao] [google] [report]
74236377

>>74236320
Seething for no reason, kek
>>74236338
>The taskbars
GNOME doesn't have taskbars.

>> No.74236422

>>74236353
Stop using discord

>> No.74236429

>>74236189
KDE is based. Fuck off

>> No.74236440

>>74236353
>discuck
>mint
>lacks the absolute fucking basics of how executables on unix-like system works
pottery

>> No.74236441

>>74236429
Yes it is.

>> No.74236444

>>74235942
in pseudocode: print BAT1 BAT2 | bar

>> No.74236460

>>74235164
If you have xorg input synaptics installed you can do that in the mouse/touchpad settings on xfce.

>> No.74236487
File: 23 KB, 763x69, doubleIP.png [View same] [iqdb] [saucenao] [google] [report]
74236487

How do I entirely reset my network configuration?
I'm having my first go at "remotely" managing a headless debian box
The process of stuff I did was as follows
Configure wifi through wpa_supplicant and editing my interfaces file, it connected just fine with DHCP and I was rocking a .103 address.
- Install network-manager
I went with network-manager because it's slightly more familiar
network manager was kind enough to let me know that wls33 was managed by /etc/network/interfaces, I cleared up the entiries in that file, rebooted my system and network manager connected me just fine. Following this I used nmtui to set my static IP to .11
This also worked perfectly fine

I now plugged out the monitor and peripherals and carried on through SSH
I wanted to test out pihole, I ran the automated script but it hung at one point, forcing me to reboot my machine. I ran the included uninstall script in hopes of cleaning up.

This is where I noticed a second ip on my interface (pic related) that wasn't previously there.
I have no idea in which configuration it actually lives, but I was still able to SSH through the .11 address & my router reported the .103 address as connected.

>> No.74236590

>>74236487
If your stuff is static you could just ditch the networkmanager and do the configuration with systemd. (I did)

>> No.74236628

how do i bring back or abort the background process in new shell? i exited the previous one when i started the process and now it seems i cant reach it

>> No.74236666
File: 92 KB, 1072x773, windowborder.png [View same] [iqdb] [saucenao] [google] [report]
74236666

>>74236613
Try here

>> No.74236680

Oh now I remember why I don't use KDE, it fucks up the fucking scaling.

>> No.74236697

>>74236666
Nah it is not that. There's HUMONGOUS border here.

https://i.imgur.com/o8YGmIs.png

Look at that fucking shit WHAT THE FUCK

>> No.74236734

This shit is mad slow on my 1050 laptop and I have to fill lot more CATPCHAs than on Gnome, I'm going back home. This was a mistake like the last time.

>> No.74236840

lol the entire i7-7700HQ lags when I click tab in Firefox, seems like Plasma is resource hungry as fuck

Here is me clicking this web page and reply box/captcha to post this
https://i.imgur.com/tl96NF4.png

>> No.74236899

So my new thinkpad is coming today, and I am not sure which distro to install. I'm running mint on my current laptop, but it was my first GNU/Linux distro I stuck with after distro hopping a few months ago. I am trying to learn python and eventually other languages, so I want a "just werks" distro for my new laptop, but something a bit more advanced. Was thinking of installing Debian and leaving space to dual boot something else or use as storage. Does anybody have any suggestions for better distros for this purpose? Also I will be using my old laptop to try arch or gentoo.

>> No.74236926

Holy shit that was painful thank fuck I am back on Gnome.

>> No.74236927

what do i google to learn about tabs filling formating in bash:

name[ESPACE]text2
bigname[ESPACE]text2

how to make bigname fill the espace without pushing the 2 column aside, all i get from google is tab completion/suggestion wich seem is a different topic

>> No.74237186

Is now a good time to build new PC or are they releasing some relevant CPU/GPU/Memory/NVME arhitecture in next half a year

>> No.74237697

I'm fed up with Mint because audio is fucked up and today my screen was flickering like it wanted to give me epilepsy. I'll switch to Arch. Opinions?

>> No.74237795

>my linux stops working
>install different linux
anyone else do this lol xD

>> No.74237821

1st time using Unix, so forgive me if I sound naive.
How do I play a wav file in UNIX terminal using the default commands? (e.g. no sudo/aplay/etc)

>> No.74237845

What's the best virtual desktop program for Ubuntu I want to test other distros without downloading to USB and rebooting

>> No.74237860

>>74237664
Wait till seed ratio 1:1 is reached then shut down deluge.

>> No.74238074
File: 35 KB, 957x418, fairu.png [View same] [iqdb] [saucenao] [google] [report]
74238074

>>74237860
I tried that already but they popped again
>>74238008
I couldn't find that setting phrased like you specified but I enabled tree view and it looks like they are all child processes of a single daemon (?)

>> No.74238334
File: 77 KB, 493x392, file.png [View same] [iqdb] [saucenao] [google] [report]
74238334

Whats the issue what do I need to sign what is this garbage
When I used VirtualBox on Windows it worked without problems

>> No.74238362

>>74238334
The repository 'http://download.virtualbox.org/virtualbox/debian disco InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

great
working the os
not having the os work for me
ust rtear

>> No.74238624

https://gist.github.com/reillysiemens/ac6bea1e6c7684d62f544bd79b2182a4

hahaha what the fuck do these billies want me to do to have basic fucking windows function jesus christ tap dancing fuck there is no way this is necessary for something i can do out of the box on windows

>> No.74238674

>>74238666
No, I disabled it when I installed Ubunto

>> No.74238728

My old IOGEAR KVM switch doesn't work in Ubuntu, my mouse and keyboard dont light up. It functions just fine when I press it over to my Windows machine. what do i do?

>> No.74238729

>>74238666
>>74238674
Okay so now I can't access my BIOS anymore, it just crashes if I press Delete/F12 on the Dell logo screen.

Why is basic virtualization function so hard to get working in Linux when I can just install Virtualbox on Windows and it just works

>> No.74238737

>>74238334
>>74238362
>>74238624
>>74238729
qemu works without a cringe proprietary botnet backdoor bloat malware spyware kernel nsa module

>> No.74238744

>>74238737
Isn't it slower tho? I'll try it.

>> No.74238803

So I fucking installed "qemu" and now it says its not found someone come and kill me

>> No.74238890
File: 995 KB, 1280x720, 1514138191351.png [View same] [iqdb] [saucenao] [google] [report]
74238890

Do I have to write my own plugins to allow previews/thumbnails for arbitrary files? I thought I can just provide a simple shell command for a given file pattern, but it doesn't seem to be the case for nautilus, dolphin or konqueror.
I'm a little lost, fellas. I thought that was a common feature.

>> No.74238944
File: 205 KB, 439x510, 1514140044320.png [View same] [iqdb] [saucenao] [google] [report]
74238944

>>74238828
>>74238884
That was kinda my windows experience in a nutshell. On linux 90% of the time I just
>dnf install [program name]
and am done. No wizards and I know where the configs are.

>> No.74239010

>>74238890
>Do I have to write my own plugins to allow previews/thumbnails for arbitrary files?
What kind of files? Dolphin should support images for pictures and videos, Idk what is wrong with your system.

>> No.74239359
File: 34 KB, 1100x217, fart.png [View same] [iqdb] [saucenao] [google] [report]
74239359

Can you anons bash like that

>> No.74239375

>>74239359
stop using bash

>> No.74239479

>>74236899
install arch. you're going to learn a lot of things. even the post-installation is fun.

>> No.74239603

>>74239461
https://wiki.debian.org/LTS
https://wiki.debian.org/LTS/FAQ

>> No.74239731

>>74239524
Bad. The good solutions to that problem are Nix and Guix.

>> No.74239864

>>74239720
Who's the one other person playing SL with you?

>> No.74239931

>>74236353
>fglt
chmod +x discord-image-downloader-go-linux-amd64
./discord-image-downloader-go-linux-amd64

from the terminal navigated to the location of the file.

>> No.74239959

>>74239875
Checking SL's downloads page it looks like there is a Linux installer. Theoretically any distro of Linux can run SL if the appropriate video drivers are installed. If you just need a change of pace for an OS there are new friendly distros like Ubuntu, Mint, etc. If you want an OS that you are absolutely positive will not run SL I'd recommend TempleOS.

>> No.74239995

>>74239400
snap is a package format for universal distribution of programs across linux distros.
It is good because it should work on every linux system with snapd installed, it is bad because it builds a seperate pseudo sanboxed enviroment for the programs that does not respect the system settings (arguably this could also good but in practice it's not) so the packages are usually slow and look like shit because you should configure the look of snaps seperately, and use much more memory because they load seperate instances of dependencies. Popular alternatives are Flatpak and Appimages

>> No.74240065

>>74239995
that is really REALLY poor design

>> No.74240145

>>74239995
key word is "pseudo sandboxed", huh?
from what I know flatpack doesn't really sandbox either and has some security issues. Tried it for GIMP, was unimpressed.

>> No.74240190

how can I get my sd card to work on my loonix laptop? When I inserted it I got a notification about some ext4 shit (I dont remember the exact message and the notification no longer shows up) and I cant access the card or its contents

>> No.74240454

>>74240231
not him but I believe it's the "ntfs-3g" package

Also an unrelated question of my own
I've been messing with a headless debian box today, mainly setting up a static IP through various methods.
The simplest being just setting parameters in /etc/network/interfaces
What I'd like to know is which tools/programs does that file actually use to set the parameters and stuff like wpa ssid & password resolution

Is stuff like network manager a frontend for the same set of tools or are they different approaches
And how does the systemd networkd approach play into it

>> No.74240457

>>74240360
manpages are way better for documenting software

>> No.74240698

>>74240457
tldr is for most what man tries to be.
If you have a more complex program that ls with it's own syntax, language or ecosystem? Noone would try squeeze that much info into a manpage.

>> No.74241005

I wonder if I should bother giving a tiling wm a try.
I'm on a 1080p 15" laptop mostly. 99% of the time I have my terminal/browser and editor tiled to half the screen and I already have hotkeys to tile to half the screen.

>> No.74241576
File: 108 KB, 1942x1080, Screenshot from 2020-01-03 16-01-07.png [View same] [iqdb] [saucenao] [google] [report]
74241576

I just want to say that the default "pressure" needed to reveal the dock that I set on Auto-Hide is retarded. I had to keep flicking at the bottom of the screen with my cursor to get it to show. I'm grateful that there was a setting for this. 0 is idle for me.

ubuntu 19.10

>> No.74241816

Is this guide still relevant?
https://gist.github.com/cryzed/e002e7057435f02cc7894b9e748c5671

>> No.74241894

>>74241576
What is pressure?

>> No.74242085

>>74232697
Linux is a kernel

>> No.74242248

pls recommend distro to turn this laptop into a torrent and multimedia machine. I don't need it for anything else

>> No.74242881

If I were to develop a server application in C# on windows, what would it take to get it running on debian, wihout changing too much of the source code?

>> No.74242904
File: 140 KB, 450x399, 1568285237988.jpg [View same] [iqdb] [saucenao] [google] [report]
74242904

>>74242893
>or should i just do it in java
Please do the needful, sir.

>> No.74242976

>>74230648
Can someone describe how these are different from a common Linux distro like Debian?
UNIX, Plan9, BSD & Haiku.

>> No.74242991
File: 60 KB, 650x429, 42a.jpg [View same] [iqdb] [saucenao] [google] [report]
74242991

>>74242922

>> No.74242992

>>74242899
i may consider doing this in the future but i think i'm gonna go with java just so i have more things to put on my resume (as i'm already doing """something""" with C#)

>>74242904
sir, look forward to my needful doings

>> No.74243015

>>74242965
>wrapping your head around it as the "new linux sound stack" as freetards would like.
"freetards" supported JACK from the day one and reject PulseAudio and freedesktop to such an extent that they don't include even freedesktop-related stuff - like in Hyperbola repos. fucking retard.

>> No.74243065

i installed debian 10.2 buster
please help me unlock SID and experiemental

>> No.74243080

>>74243015
freetards are any group who puts ideological choices before the better choice.
freetards don't have to agree with each other, on the contrary, a stable of freetard discussion is inventing a newer "freer" standard to then complain about how "legacy" code isn't free enough.
Pulseaudio supporters are freetards just the same as idiots who are trying to push through wayland because "newer, freer (((safer)))" with ideological justifications before technical ones.
Never go full freetard, if you're acting the fool with your favourite freedumb project it's all fine until you start screeching at someone using "non-free", by your standards, alternatives that work better.

>> No.74243128

>>74243065
edit
/etc/apt/source.list
replace mentions of "buster" with sid, it will not have an updates or security repo, these are safe to blot out.
Ideally the better option would be to enable the buster-backports "release" which is a repo that has tested far newer software that is from testing/sid.
apt -t=buster-backports install xyx
This will pick buster-backports edition of the xyz package, leave the t flag out to just use buster repo.
I do not recommend running sid directly, testing is valid but pointless in the face of backports for anything other than "testing".

>> No.74243178

>>74243128
thank you! i will try the buster-backports way.

>> No.74243179

>>74243146
You have terrible taste in software licenses, and have either been here far too long or not long enough to understand how pol and anon work in relation to one another.

>> No.74243360

>buy Ryzen 3600
>Radeon 5700
>x570 chipset motherboard
>Ubuntu 19.10 fails to boot
what the fuck? what distro do i need to use to use my brand new hardware? also fuck windows, i'm _never_ using that shit.

>> No.74243383

>>74237821
aplay buttsex.wav

>> No.74243390

>>74243360
Do we get an error code, 19.04 was the release that "fixed" everything wrong with ryzen + linux.
Try buster 10.2 and just enable backports for a new kernel if it boots.

>> No.74243532

>>74243502
have you considered the tiling meme?
fell for it and do not regret as everything else with "bars" is wasteful as heck

>> No.74243807

is this the proper way to mount a formatted harddrive?

sudo mkdir /mnt/hdd1
sudo mount /dev/sda1 /mnt/hdd1

The idea is to have a designated place for it in the mnt directory ("hdd1") and then mounting it there. If I install another secondary-harddrive, I intend to name it hdd2.

Is that all you have to do for it to always be mounted there?

>> No.74243820
File: 5 KB, 656x56, Screenshot from 2020-01-03 20-19-08.png [View same] [iqdb] [saucenao] [google] [report]
74243820

>>74243807
me, I know it's /dev/sda1 because of this

>> No.74243832

>>74243807
better to setup fstab with uuid for the drive.

>> No.74243873

>>74237821
that's an interesting question, because certainly it could be done just by redirecting data to some device
https://unix.stackexchange.com/questions/1974/how-do-i-make-my-pc-speaker-beep#1980
I found this and tried some but didn't work.
Depends on the kernel

>> No.74244208

>>74244197
cucklord has spoken

>> No.74244391

>>74244346
>restricted use of software
*restricted the abuse of its users.
Do you enjoy being beaten up? Because I would enjoy beating you up. Why would you restrict freedom?

>> No.74246199

>>74230648
What distro do I install to learn how to maintain most other Linux distros?
To clarify, I've previously installed and used Debian, Arch and Alpine and i'm currently typing this in Fedora 31 Workstation but I lack the kind of understanding for specific file placements/configs that someone who installed LFS would have.
But I'm not sure LFS is too practical in this case.

>> No.74246476

>>74246072
>ifconfig
ifconfig on Linux is dead and replaced by ip which unifies a lot of functionality from other commands as well (route, netstat, etc.). To my knowledge it has feature parity with the old tools and is a worthy replacement. In fact the traditional network scripts have been updated to use it. I was talking more about the various new networking daemons and managers like NetworkManager.
>netplan is just a sort of abstraction layer
Yes, that's also a problem. It's quite a lot of abstraction layers and good luck if one of them breaks.
Anyway, it goes something like this:
The absolute lowest level is the kernel which houses the network stack and operates the interfaces.
The level above that are tools which configure the kernel. These can be "ip" ran manually by the user, network scripts that use ip and other tools to configure the same thing on boot, or other network managers and daemons which use their own methods to configure the kernel.
The scripts are really just glue that interprets the config and passes it to other tools. so they use ip for standard ethernet interfaces with static configuration, call a dhcp client for dynamic configuration, wpa_supplicant for wifi, etc.
The level above that is variable. You can use netplan which is some kind of translator of a generic configuration to a tool-specific one. Or you can use configuration management software like Ansible or Salt. Or combine all of that together... From here on out it's frontends upon frontends upon frontends.

>> No.74246608
File: 33 KB, 640x427, x-org-logo.jpg [View same] [iqdb] [saucenao] [google] [report]
74246608

>ubuntu's xinit package is a 900mb installation
how do i reduce this massive bloat and ensure that my wm loads upon startx

>> No.74246695

>>74246608
>uses Ubuntu
>cares about bloat

>> No.74246720

>>74246695
debian's is about the same, and its a minimal installation, thanks for the friendly gnu/linux answer though you cock

>> No.74246847

>>74246720
>thanks for the friendly gnu/linux answer though you cock
maybe he just did a minimal install of friendliness

>> No.74247098

>>74246988
You can change it later. What you need is allow-discards option in the crypt device settings so the mapped device will appear with trim support. You need it enabled in the filesystem too.

>> No.74247122

Why does Ubuntu (18.04, if relevant) mouse input feel like absolute garbage compared to Windows? Even after sliding the 'pointer speed' thing to maximum, it feels like it's responding slooooowwwwwly, and there's literally no other option in the settings menu besides the speed slider and the 'natural view' thing that explains nothing.

There doesn't seem to be an option otherwise, as any combination of Googling brings up SEO'd 'how to disable mouse acceleration' blogshit, and that's literally the exact opposite of what I want.

Booting back into Win10 and it just 'feels' right, straight out of the box. Higher refresh rate, pointer acceleration, fucking black magic, whatever, I've no fucking idea how it does it, but it's little things like this that bring me back to Windows every time I get the urge to boot into a liveUSB and see how the other half live.

>> No.74247129

>>74247098
So I can't trivially do it during installation? I need to install my new OS, enable FDE during that, and then follow the wiki's instructions both for enabling TRIM and making it work with the FDE?

>> No.74247199

>>74247129
idk, depends on your installation program. Point is don't worry about it, you can add the option to crypttab afterwards.

>> No.74247206

>>74247199
Thanks anon.

>> No.74247428

>>74247122
Maybe you have an Nvidia GPU in which case you need the proprietary driver (not going to work on a live cd).
Or maybe it's just that the default Ubuntu interface (GNOME) is really heavy and inefficient.
Try something like KDE Neon or Kubuntu and see if that's more responsive for you.

>> No.74247440

Probably asking too much here, but:

Is it possible through this QEMU/KVM thing or anything similar to use a windows virtual machine and play with shit there, without discernible latency issues, only one GPU, one keyboard and mouse, and monitor?

I'm trying to avoid going back to Windows on bare metal as much as possible, dual booting is a bit of a pain in the ass (even if it's fast) and there's stuff I want to run that just won't give me a chance through any compatibility layer.

>> No.74247459

>>74247428
>Nvidia GPU
You know, I actually do; a fucking ancient GTX 760. I hadn't thought of that.

Roll on the days when you can build liveCDs like you can Ninite apps; Ubuntu base, check, proprietary extensions, check, delete all the partridge-in-a-pear-tree preinstalled garbage, check, etc, spit out an ISO, done.

>> No.74247482

Daily reminder that Stallman is innocent: http://sterling-archermedes.github.io/

>> No.74247495

>>74247440
>only one GPU
no gonna need two for GPU passthrough

>> No.74247544

>>74247495
I have an iGPU (Intel graphics 46000HD). Would it be possible to use the dGPU to process whatever I would want to run, and use the iGPU to display it? All I want is not to get rid of the dGPU if I'm not using the virtual machine.

>> No.74247675

>>74247440
Yes, I have it setup with two GPUs, each with its own display output.
But first check if your CPU supports the relevant virtualization extensions (Intel VT-d or AMD-Vi). Intel CPUs of the k-type with unlocked multiplier infamously don't support VT-d, probably as a fuck-you to customers.
Check here:
https://ark.intel.com/content/www/us/en/ark.html
or
https://www.amd.com/en/products/specifications
Also check if your motherboard supports it. You can find chipset specifications on Wikipedia and see if it has an IOMMU. It should be enabled in BIOS/UEFI as well.

>> No.74247712

>>74247675
It's an i5 4460. Supports VT-d and VT-x. Board supports both as well. Maybe I should try this.

>> No.74248578
File: 156 KB, 269x148, 105399-1.png [View same] [iqdb] [saucenao] [google] [report]
74248578

Whatever happened to Emerald? It looks better and is more customisable than every single window decorator, but I don't see it anywhere and it's a pain in the ass to install on Ubuntu. Why is that? It looks a little more modern than stuff like XFWM or Metacity which are still used today

>> No.74248645
File: 26 KB, 540x527, 1577024462079.jpg [View same] [iqdb] [saucenao] [google] [report]
74248645

>>74246199
Unironically Ubuntu. Great online support, simple commands, stability (LTS), widely used by people around the globe.
Install the Xubuntu or the Kubuntu flavours, though, the official GNOME desktop is pure nightmare fuel.

>> No.74248683
File: 97 KB, 689x473, 1561329976861.png [View same] [iqdb] [saucenao] [google] [report]
74248683

>>74234119
>we are not your "bros".

Exactly. We are his "frens". ;)

>> No.74248697

Problem: still can't update Ubuntu 19.04 to 19.10

At some point during the update (either from USB or downloaded) I can hear four clicks, like switch, from the speaker (click-clack x2) and then screen goes dark.

Google gives no help.

>> No.74248727

>>74246199
CentOS

>> No.74249206

I tried editing my keyboard layouts but it turned out to be a nightmare.
I just want my german umlauts öäü to be some programming friendly shit but also I want be able to switch back without hassle.

>> No.74249605

>>74248986
Is this a trole :(
Its an actual problem.. I posted about it months ago and its not fixed.

>> No.74249901

Manjaro is so comfy lads...

>> No.74249947

Would there be any negative effect, regarding the use of older packages, from using Debian stable? I've tried distros that use newer packages, e.g. Fedora, which have been extremely unstable, and distros such as Ubuntu seem to have kind of a middle ground -- mostly stable but occasionally becoming buggy. I'm really tired of dealing with that kind of shit honestly and would like something that won't give me any difficulty in that area. I don't really use my computer for anything special other than web browsing and some media viewing/listening. I might occasionally run a VN or something in wine.

>> No.74249969

>>74249947
not really, the only thing you'll be missing is new features

>> No.74250010

>>74248569
Please someone answer this, it's too stupid for the #Alpine-Linux IRC channel.

>> No.74250132

>>74249947
I've had a different experience, with little to no difference in stuff like crashes and bugs with new software with old. The only thing Debian has going for it is bugfixes on old versions of software, if you don't require new versions of software it can be fine for a desktop.

But personally I find myself needing newer versions of stuff (like mpv for videos or wine) and then having to fuck around with backports or just saying fuck it and installing something with new packages.

With 18.04, I'm adding PPAs and repositories left and right, same with Debian stable. With 19.10 there's less of a need, since most applications are up to date (or good enough), same with Fedora 31.

>>74249901
It's like riding a unicycle on a dental floss tightrope over a wilderness of razor blades

>>74249206
your DE should manage that, unless you're a wm only pleb, then look at the arch wiki for help.

>>74248578
Compiz was only kept around for Unity, and emerald was abandoned. Not sure the reasoning why, they were good projects. But the compositors we have now are pretty good, maybe not in terms of eye candy but in functionality.

>> No.74250219
File: 239 KB, 1280x1090, 1526312578363.jpg [View same] [iqdb] [saucenao] [google] [report]
74250219

>>74249893
Well it does boot, otherwise the installer couldn't possibly work. How many things did you install manually?

>> No.74250235

>>74250219
Yes, 19.04 boots properly and works properly, it's the update process for 19.10 that sharts itself.

>> No.74250273

>>74250235
Sounds like some deep fuckery is going on. I really strongly recommend nuking the system after backing up home. But before you do that, how much did you install manually?

>> No.74250304
File: 52 KB, 1290x302, file.png [View same] [iqdb] [saucenao] [google] [report]
74250304

>>74250273
I press "Upgrade" here and then it starts downloading and installing files until you hear the click-clack coming from speaker, at which point screen goes black (doesn't actually turn off, it has back light on).

>> No.74250435

>>74250417
Yeah I can, but why? There's almost nothing installed, lol.

>> No.74250564

>>74250549
19.10 from USB did the same thing. I should probably do an official bug report somewhere.

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
reCAPTCHA
Action