Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 37 KB, 750x395, 15432048147140.jpg [View same] [iqdb] [saucenao] [google] [report]
71621276 No.71621276 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Do not dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: Please spend at least a minute to check a web search engine with your question.

$ man %command%
$ info %command%
$ %command% -h/--help
$ help %builtin/keyword%

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux:
https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page
>What are some cool terminal commands?
http://www.commandlinefu.com/
http://cheat.sh/
>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/
http://overthewire.org/wargames/bandit/
>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html
>Which web browser performs best on GNU/Linux?
https://linuxreviews.org/firefox-vs-chromium

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

/t/'s GNU/Linux Games: >>>/t/861783

Previous thread: >>71600078

>> No.71621362
File: 62 KB, 600x600, cris.jpg [View same] [iqdb] [saucenao] [google] [report]
71621362

>>71621276
Packets sent to 255.255.255.255 from my archtop do not reach any devices on the network. Doing so from my gentoopad, hoever, works fine. iptables -L comes up blank. I'm out of ideas. Please help.

>> No.71621544
File: 1.33 MB, 3547x2550, 1543235583747.jpg [View same] [iqdb] [saucenao] [google] [report]
71621544

/fglt/ seems to be the oist clever place on /g/. Please explain this conic.

>> No.71621572

>>71621544
= vs ==
assignment vs equality test

>> No.71621794

>>71621572
Holy shit. Thanks. I knew I can count on you.

>> No.71621966

>>71621362
When using ping manually setting interface to the one connected to the router makes it go through. ifconfig also shows lo and tun devices. I guess broadcast packets are sent to one of those instead? Why would that be happening?

>> No.71621992

>>71621966
check the route table

>> No.71622095

>>71621992
Hm. Just a few minutes ago I ran route and there were no entries with broadcast address. Now there are:
10.75.10.1 10.75.10.5 255.255.255.255 UGH 0 0 0 tun0
10.75.10.5 0.0.0.0 255.255.255.255 UH 0 0 0 tun0
no-mans-land.m2 _gateway 255.255.255.255 UGH 0 0 0 enp8s0

What could this mean?

>> No.71622125

>>71622095
Oh wait, that's genmask.

>> No.71622215

oh my fucking god why does webkit take so long to compile!

>> No.71622317

Is there a way to pull https://en.wikiquote.org/wiki/Richard_Stallman into a file for fortune(1) use? Already searx'd, but the scripts I've found seem all outdated. Maybe a cli ninja can write a simple grep regex for it?

>> No.71622387

>>71622317
Fortune format is simple as shit.

%

Quote

%

>> No.71622404

>>71622387
I'm struggling at the hard part through; extacring the quotes from wikiquote.

>> No.71622548
File: 50 KB, 500x527, 15367084548800.jpg [View same] [iqdb] [saucenao] [google] [report]
71622548

>> No.71622627
File: 34 KB, 399x500, 15354528330860.jpg [View same] [iqdb] [saucenao] [google] [report]
71622627

>>71622317
>When I released GNU Emacs and people started using it, they started sending me improvements in the mail. So I would get a message with a bug fix, and a message with a new feature, and another bug fix, and another new feature, and another... and another... until they were pouring in on me so fast that just taking advantage of all of the help people were giving me was a big job. Microsoft doesn't have this problem.

>> No.71622643
File: 49 KB, 655x640, dog wink.jpg [View same] [iqdb] [saucenao] [google] [report]
71622643

Hey guys, still a windows shitter here trying to make the move to Linux here. Any linux distro you would recommend to a programmer here, and with what desktop environment? I want something minimal and that doesn't distract me too much.

>> No.71622690

>>71622643
install gentoo

>> No.71622752

install guix

>> No.71622838

>>71621544
In case you still didn't get it from the other anons post, if you're not a programmer it might not be clear, but there is a difference between "=" and "==" in a lot of programming languages.
So on the 3rd line of code inside the if statement it should be "==" to test equality, but they accidentally wrote "=" instead which sets the variable to true.

Also I think a slightly deeper meaning to it is that if an AI does something it's always because we programmed it to, even if its creators just aren't smart enough to see it.
A perfect example of that was this news story a while back about 2 AI chatbots that "developed their own language", but in reality it was just 2 chatbots reaching equilibrium with each other in an unpredictable way as their inputs/outputs lacked any intelligible original English input. There was absolutely no language there whatsoever.
So that kind of reminds me of the comic.
They saw what they wanted to see, but the reality is much less interesting. Just like in the comic, the robot is already equipped with functions like "kill()" that the programmers put in there, they just never thought the variable "isCrazyMurderingRobot" would get flipped until someone made a typo.

>> No.71622847

>>71622643
Arch will teach you the basics
dwm is minimal and good

>> No.71624218

dm-crypt or ecryptfs for /home enctyption? It's a separate partition from /
also how bad is the overhead on 3rd gen dual core mobile i5 and an SSD

>> No.71624270

>>71622643
even though I wouldn't use it myself, unironically ubuntu
packages are fresh enough for dev work, there are guides for everything and gnome 3 is gimped enough that you wouldn't be tempted to rice it too much
or you could go full autism and do what >>71622847 says

>> No.71624483

this shit is driving me up the wall

on open media vault 4
can't do jack shit because can't update kernel for some reason, all other updates go through but not kernel
can't install plugins because of unresolved dependencies with unupdated kernel
kernel canyt update because inbuilt update utility reports it's own kernel data as corrupt
so I'm in a vicious circle with this
OMV forums are super useless
how do I fix this

>> No.71624527

I need an OS that acts as a glorified ipod. I want to be able to access music through a media player, and I want to be able to remotely control the computer from a smartphone. I also need it to support Firefox. What's the best OS for this application?

>> No.71624547

>>71624483
Which kernel?

>> No.71624610
File: 14 KB, 542x277, update.png [View same] [iqdb] [saucenao] [google] [report]
71624610

>>71624547
update is linux-image-4.19.0-0.bpo.5-amd64 4.19.37-4~bpo9+1 or at least this is what the error code points to
this is present in the updates menu but if I try to install it gives out an error stating it is corrupt data

>> No.71624867
File: 407 KB, 492x611, 1527637160902.png [View same] [iqdb] [saucenao] [google] [report]
71624867

>> No.71624951

OK kids, chad here. Give me the best distro right now, b/c I dont have enough time to waste with distro hopping; the chicks are waiting for my dick.

>> No.71624965
File: 94 KB, 483x640, 1507400938682.jpg [View same] [iqdb] [saucenao] [google] [report]
71624965

>>71624867

>> No.71624995

>>71624951
>the best distro
gentoo
>the chicks are waiting
void is the second best one if compiling everything takes too long

>> No.71625050

>>71624951
Install GNU Guix System GNU/GNU Linux-Libre, or as I've recently taken to calling it GNU/GNU GNU system plus GNU.

>> No.71625105

>>71625050
You forgot the "System Distribution".

>> No.71625221

>>71624995
tell me what makes void so special
imho its shit, has no packages, the main dev is missing plus a musl meme that is trash just like on alpine
is it just the meme that somehow appeared on /g/ that arch users who are too cool for arch but too stupid for gentoo have to switch to void in order to be part of the cool numales?
tell me, why does void even exist? why would anyone use it? there is not any reason. nit a single one that another distro wouldn't do in a better way. no?

>> No.71625277

What audio visualizers do you guys use?
I've been using qmmp's builtin one, but i like having each app do one thing and do it well so i want to have a standalone visualizer. Any good ones out there or should i make my own?

>> No.71625311

>>71625105
Afaik GuixSD is now simply "Guix System",happened when it went out of beta.

>> No.71625323
File: 31 KB, 396x385, 1560890679112.jpg [View same] [iqdb] [saucenao] [google] [report]
71625323

>>71625277
>audio
>visualizers
>>>/v/

>> No.71625338
File: 1.38 MB, 707x531, 2019-06-28-092355_707x531_screencap.webm [View same] [iqdb] [saucenao] [google] [report]
71625338

>>71625277
ProjectM, there's a standalone version which hooks into pulseaudio, so you can visualize anything
it's milkdrop-compatible

>> No.71625339

>>71625221
>has no packages
1-Name a package
2-You can package it yourself or ask someone to package it for you, this is how package repos grow after all.

>too stupid for gentoo
implying gentoo is hard to get used to?
I just prefer the binaries because i don't see much point in compiling everything

>> No.71625361

>>71625338
looks nice, thanks anon

>> No.71625394

>>71625277
There are countless on Github. I have tried many visualizers and didn't use any for a while (the best one, I think, was cava), but then i discovered that mpv supports all ffmpeg filters and now I just use them if I really need visualization, which i usually don't need; music is for listening, you know.

>> No.71625426

>>71625339
Gentoo provides binaries for huge things you don't want to compile such as browsers.

>> No.71625464
File: 1.37 MB, 1063x590, 2019-06-28-093136_1063x590_screencap.webm [View same] [iqdb] [saucenao] [google] [report]
71625464

>>71625361
there's tons of presets for it as well
to be clear, milkdrop is the visualization system of winamp. yes, that one.

>> No.71625471

>>71625426
>gentoo has a pussy out mode
today /g/ lost all its credits

>> No.71625510

>>71625426
I know that, what i mean is do you really notice much performance difference when you do compile stuff? Didn't feel like much of a difference when i gave it a whirl, and i spent a whole day setting flags n micromanaging everything

>> No.71625530

>>71625464
you really should include audio in these mate

>> No.71625539

>>71625530
/g/ doesn't support webms with audio

>> No.71625553

>>71625539
oh. there i go being a newfag.
Why though?

>> No.71625566

>>71625553
idk, i only learned recently other boards support audio, and i don't know which ones
i only really visit /g/

>> No.71625586

>>71625471
/g/ never got any credits, the whole install gentoo meme roots on trolling newfags into the most difficult to install system; a shortcut for "lurk moar", later forgotten and connected to rms because of the sticky, resulting in further stupid memes until in '07 redditors started installing gentoo unironically, hoping rms and /g/ would be proud. It's embarrassing.

>> No.71625615
File: 46 KB, 569x760, 1560967981307.jpg [View same] [iqdb] [saucenao] [google] [report]
71625615

>>71625539
>>71625566
there's a thread on >>>/wsg/ just for this
you owe us one
>>>/wsg/2917895

>> No.71625640

>>71625615
i know this because i scrape that tiktok shithole regularly, never knew WHY /g/ doesn't support audio though, what's the reason behind it?

>> No.71625648

>>71625640
>>2919730

>> No.71625669
File: 29 KB, 512x422, 1560983769820.jpg [View same] [iqdb] [saucenao] [google] [report]
71625669

>>71625640
>>71625648
>>>/wsg/2919730

>> No.71625679

>>71625615
I made this rare Stallman for you's.
https://i.4cdn.org/wsg/1561679394906.webm

>> No.71625706

>>71625679
Can you crop the black bars?

>> No.71625709

>>71625615
uh, might take me a moment, i didn't write my screen recording script with audio support, since i only use it to post things on /g/

>> No.71625722

what distro do I install if I just wanna get the GNU/Linux experience and learn lots about it (with no prior knowledge)

>> No.71625728
File: 584 KB, 1920x1080, 1560896851593.png [View same] [iqdb] [saucenao] [google] [report]
71625728

>>71625679
>>>/wsg/2923756

>> No.71625750 [DELETED] 
File: 453 KB, 864x864, its_GNU-Linux.png [View same] [iqdb] [saucenao] [google] [report]
71625750

>>71625679
>2919730
based

>> No.71625781

>>71625706
For you: >>>/wsg/2924009

>> No.71625795

Xubuntu 18.04 user here.
There's a problem with libinput in this release, which doesn't allow me to use xinput to set the mouse slower. Supposedly, one of the ways to fix it is to remove libinput and install evdev.
Will there be any problem if I remove libinput and install evdev?

>> No.71625802
File: 58 KB, 314x272, Screenshot_2019-06-28-02-00-32_1.png [View same] [iqdb] [saucenao] [google] [report]
71625802

>>71625679
>lolwut?

>> No.71625819

>>71625781
Thank you!

>> No.71625862

>>71625728
This guy didn't went on stage sober, didn't he?

>> No.71625965

>>>/wsg/2924039

>> No.71625979

Why does firejail literally not work on any program that they list support on in their github?

>> No.71625981

>>71625679
sauce?

>> No.71626020

>>71625981
It's been a while since I cut it, but i think the source must be the Revolution OS documentary.

>> No.71626043

>>71625615
>>71625709
>>>/wsg/2924052

>> No.71626052

revolution os is a must watch for everyone itt
if anyone didn't watch it, its on youtube with like 100 subtitles

>> No.71626106

>>71626052
>youtube
Here's what a real buddy would do: you post a FUCKING youtube link so we can just watch it in mpv without getting tracked by the BOTNET. Don.t bother, i did the hard work for you https://www.youtube.com/watch?v=Eluzi70O-P4

>> No.71626148
File: 65 KB, 737x754, 1560866930528.jpg [View same] [iqdb] [saucenao] [google] [report]
71626148

>>71626052
>>71626106
>he never read OP
>he didn't have already watched all videos provided through the OP pasta

>> No.71626181
File: 63 KB, 511x554, 1535884952223.jpg [View same] [iqdb] [saucenao] [google] [report]
71626181

>> No.71626186

Explain the Solus Kevin meme.

>> No.71626259

>>71626106
You still get tracked using youtube-dl, retard. A real buddy would post a privacy respecting mirror.

>> No.71626293

any advice on how to get from late beginner to intermediate linux or even neckbeard linux user status?

>> No.71626363

so I just installed arch linux, but I'm trying to figure out which desktop environment to go with. Any recommendations/?

>> No.71626531

Hewwo, I updated my Plasma to 5.16.2 on KDE Neon and now the trackpoint on my T440s is kinda lagging (especially noticeably when going slow). On 5.15.5 it was fine.
Are any here that also run the newest Plasma and have this issue with the trackpoint?

>> No.71626549

>>71626363
MATE

>> No.71626750

i want to try lunix in a VM, does VMware let you back up images of your machine in case you fuck something up?

>> No.71626828
File: 15 KB, 455x186, etc_passwd.png [View same] [iqdb] [saucenao] [google] [report]
71626828

So I have a desktop Linux installation that I've used for a long time. Somewhere along the way the ID and GID of my main user changed from the standard 1000:1000 to some other numbers. All my files have those IDs. This isn't problematic in its own right, but mildly annoying in some situations.
Now I'm reinstalling the whole system and not sure what's the best way to handle this minor issue. There are several options:
>create the user account on the fresh install with the same old IDs
or
>create the new user account with 1000:1000 and suffer whenever i'll need to access old files
or
>change IDs of the old account and modify every file to be owned by 1000:1000

what do?

>> No.71626861

>>71626828
>change IDs of the old account and modify every file to be owned by 1000:1000
sounds sensible

>> No.71626996

>>71626828
or #4: Add your new user to both groups and save the problem for your future self.

>> No.71627026

>>71626996
I considered doing that, by many files are only user readable, which means I'll still have to modify them so I might as well go with #3 (or still suffer like in #2) .

>> No.71627092

>>71626828
find /mnt/point -uid 1234 -exec chown 1000 '{}' \;
find /mnt/point -gid 1234 -exec chown :1000 '{}' \;

>> No.71627624

major PC browsers: Falkon > Seamonkey > olde-Firefox > Piss > Shit > Chromium > nu-Firefox > Chrome >>> Microshit browsers

>> No.71627632

>>71627624
t. autistic retard

>> No.71627637

>>71627624
Linux is a kernel.

>> No.71627657

>>71627637
I agree, and?
>>71627632
I hate nerds.

>> No.71627782

>>71627624
Falkon, Chromium, Chrome, and nu-Edge are 99% the same shit.

>> No.71627802

>>71621276
If I post the description for a job listing just requires just a high school diploma and Linux experience, can you guys tell me what I should study?

>> No.71627817

>>71627802
if you can install gentoo you're fine

>> No.71627993

What is the TC equivalent for servers? I'm looking for an encryption software that makes it impossible to access the operating system physically, only remotely. The software needs to support both encryption and decryption because I want to make backups and download them, then I want to be able to decrypt them completely when I need to. TC doesn't protect a running system from physical access and also doesn't have a decryption feature for non-system partitions. What are the alternatives if any?

>> No.71628184

>>71621276
>2) Do not dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
Why?
I tried Linux and like it but I had to go back to Windows because some software I use is not supported. I did this just by putting the old hard drive back in, I really hate Windows and was going to try and create a partition for dual booting. I haven't heard anything bad about it except for possibly corrupting the HD if already in use before partitioning.

>> No.71628216

>>71628184
tbqh there's nothing wrong, at least in bios+mbr land. The OP only leads readers away from wisdom.

>> No.71628225

Sometimes Manjaro will refuse to open files but will let existing programs run and function. For example i won't be able to open images or video files in any program and their 'images' will appear not recognized, unlike usually where you will get a thumbnail or thr logo of the program that is set to open it.
This bug has been driving me crazy and the only solution i know is to restart. Help?

>> No.71628283
File: 1.63 MB, 480x360, 1497898828877.webm [View same] [iqdb] [saucenao] [google] [report]
71628283

https://www.youtube.com/watch?v=huFYl8-Omws

>> No.71628292

>>71628184
>I tried Linux and like it but I had to go back to Windows because some software I use is not supported.
why don't you use WINE, friend?

>> No.71628398
File: 197 KB, 1183x1024, 2795415-9653374716-king11..jpg [View same] [iqdb] [saucenao] [google] [report]
71628398

Consider switching to and supporting the next generation of free operating systems. Use NixOS, GuixSD.

>> No.71628421

>>71628225
Works fine for me on Xfce. Maybe it's DE problem?

>> No.71628456

>>71628216
So if I go down that road, do you think I have to format whatever hard drive I'll be using before installing both OS's?

>>71628292
1. Because I'm retarded
2. I don't think photoshop and lightroom work properly in WINE, I read you have to use an old version and it doesn't work well. I'm also going to be taking this laptop into basically the Australian desert for a couple of months shortly, so I'm going to want those programs to play with my photos when I'm bored with no internet.

>> No.71628581

>>71628456
>photoshop and lightroom
Use Inkscape/Gimp and Darktable instead.
Quit using closed-source corporate software. GPL-licensed alternatives are your real friends.

>> No.71628597

>>71628216
how about bios+gpt?

>> No.71628622

>>71627782
Falkon has some sick themes tho. also completely un-g**gled.
chromium, chrome and edge all look like the same flat Material Design bullshit anyway.

>> No.71628757

>>71628597
Looks like it will still work
https://wiki.archlinux.org/index.php/GRUB#GUID_Partition_Table_(GPT)_specific_instructions

>> No.71628901

>>71628421
I'm on KDE. if you're a pro, do you think i should try switching the DE?

>> No.71628935

>>71628901
Dunno man. Maybe install xfce to see whether the problem still happens or not and do a clear install later.

>> No.71629040

Any reason to use mx linux over manjaro just for systemdless ?

>> No.71629073

>>71629040
Why you want systemdless system in the first place?

>> No.71629091

>>71628581
I will definitely check out Darktable, Lightroom is moving towards some cloud based shit that I don't want a part of anyway. I'm just hesitant to learn a new program that takes more than a couple of hours to become proficient in. But I guess I'll have time.
I would still like to dual boot Windows and Linux for the time being. I just don't know how best to go about it yet.

>> No.71629095

Complete rookie here, some hints on partitioning an SSD + HDD setup on installation? Is it wise to put /home or some other /etc on HDD, or just put everything on SSD and mount the other drive after installation?

>> No.71629186

>>71629095
Main SSD gets efi, root, home, swap, whatever
>/
>/home
Other drives go in /mnt
>/mnt/Games
>/mnt/Data
>/mnt/Storage
Then I replace the /home folders with symbolic links.
>ln -s /mnt/Data/Desktop ~/

>> No.71629241
File: 202 KB, 657x506, 1519787019122.jpg [View same] [iqdb] [saucenao] [google] [report]
71629241

>pema-noob ubuntu fren
>playing with virtual machines for the first time
>install windows for the firs time in 10 years
>literally dont know what to use it for
Tell me some cool distros and ill try.

>> No.71629246

>>71629073
Less bloat but seeing how it doesn't even matter now I guess sticking to manjaro is better now

>> No.71629304

>>71629241
Nods os

>> No.71629415

Want to install manjaro alongside with win10. I want to use two different disks (win10 on ssd, manjaro on hdd). What are the steps? Some people recommend to unplug the ssd with windows, install manjaro, then plug the ssd and launch from manjaro some command to configure grub. Do you have some step-by-step instructions?

>> No.71629505

there is no /sqt/ now so,
i have a folder raw/ where i have several files with html content, each file has just a filename of a unxi timestamp.
I need to fix my shell script in a parent directory that would concatenate the files into a big one.
But by default, the folder is sorted from the oldest timestamp (by nature).
I thought i could simply swap
>cat raw/* > file
for
>tac raw/* > file
but that also reverts each line in those files as well.
i was thinking of something like
>cat $(ls raw/ | sort -r) > file
but that doesnt do shit

>> No.71629609

>>71629091
Don't be hesitant, they're all software of the future. contribute to the extinction of proprietary overlords

>> No.71629638

>>71629505
ls has a reverse flag cat $(ls -r) > file

>> No.71629640

>>71626181
*xorg breaks*

>> No.71630396

>>71627092
You don't need to quote {}, actually, since it is part of find instead of the shell. That's also why ; must be escaped.

>> No.71630411

>>71628216
>wise men use windows

>> No.71630792
File: 389 KB, 540x758, 1561716838323.png [View same] [iqdb] [saucenao] [google] [report]
71630792

>> No.71631168

How do I fschk on arch? I booted into a live iso, mounted the hdds and fun fschk but I get an error.

>> No.71631183

I would like a file manager where I can take notes on a folder-by-folder basis.
Just a tile inside the file manager window that cats a .notes file or something.

Would definitely smoothen out my workflow a bit.

>> No.71631185

>>71631168
Install professional distros, not amateur pajeet garbage.

>> No.71631212

>>71631185
Bad post.

>> No.71631229

>>71631185
based post

>> No.71631235

I installed manjaro a week ago. What should I learn to do with it before attempting to install Arch?

>> No.71631311

>>71631168
you need to unmount the volumes before fsck'ing

>> No.71631312

>>71631235
How does Manjaro feel like? Would you recommended it for other beginners?

>> No.71631344

>>71631312
Not the person you replied to but it's a good first linux distro that doesn't hold your hand that much.

>> No.71631352

>>71631235
Before installing Arch it's a good idea to have some favorite softwares, you know what to install on your naked system. So learn to use pacman and try lots of programs, WMs, etc. Installing itself is just following the guide.

>> No.71631361

there is no sqt thread so i'll post here i guess
so i tried to port forward ssh and vnc it kinda succeed and maybe not, i could connect ssh, vnc but port checker website said the port is closed 'connection refused', is there something wrong?

>> No.71631435
File: 18 KB, 699x455, 1561721773858.png [View same] [iqdb] [saucenao] [google] [report]
71631435

>> No.71631444

>>71631352
I'm gonna add that playing around with installing WMs and DEs are better with a bare Arch install as packages will be left behind from previous DEs. You could uninstall them all but for a beginner it would be better to play around with installing WMs and DEs with a bare Arch install

>> No.71631458

>>71631435
Glad to see people learned that it's GNU/Linux.

>> No.71631666

So I installed arch linux with plasma 5 as the DE... now what? Feels the same as before when I was using kde neon except now I get to use le pacman. Just reinstalling stuff around here might install some software development stuff on here, but not sure what else I should do desu. Any essential stuff I should add?

>> No.71631671
File: 119 KB, 960x596, frequncy.jpg [View same] [iqdb] [saucenao] [google] [report]
71631671

>>71630792
>Guix + Gentoo

>> No.71631681

>>71631458
>GNU/Linux
>my erection reaches 100 on vertical axis

>> No.71631782

>>71631666
>Any essential stuff I should add?
Nice digits.
Now you have to install SATAN.

>> No.71631952

>>71631666
Read the whole archwiki.

>> No.71631996
File: 20 KB, 250x256, richard0.jpg [View same] [iqdb] [saucenao] [google] [report]
71631996

Why is RMS such a megachad.

>> No.71632066

>>71616749
ok, thanks for your answer

>> No.71632898

How does sudo generally work in Mac compared to Linux?
Linux seems to use it whenever you install anything or change files that aren't the current user's.
But with Mac it looks like you can just install shit whenever and wherever via Homebrew without using sudo. Why? What's the difference between sudo brew and brew?

>> No.71633458

baby question here, how do i make xrandr custom scaling settings stick? what file do I need to save them in?

>> No.71633612

>>71630396
The man page recommends quoting it, and I agree it's not a bad idea. Not everyone is using bash.

>> No.71633832

Is it necessary to clean pacman cache often? How long/big do people usually wait until they decide to clean it?

>> No.71633833

I might be retarded but how do I tell awesomewm to react to ACPI events. Automatically launch programs on AC plugged in for example.

>> No.71634156

I've been trying to switch from wicd gabrage to NetworkManager for the past few hours and after following many steps found on the internet from echo chambers to linux forums to stack exchange I can say I am done fucked.
Just how do I setup wpa_supplicant (it is the same as NetworkManager, right?) to use WPA2 personal?
Funnily enough, everytime I want to get rid of wicd, it stop being a bitch and now it works after restarting.

>> No.71634180

where do i learn about bash scripting?

>> No.71634291

>>71634180
http://mywiki.wooledge.org/BashGuide

>> No.71634769

what to do when my light locker triggers with such a delay i can easily say aloud this very sentence
using memejaro xfce, after turning on from suspended it takes like 10 seconds to display a locker

>> No.71634910
File: 44 KB, 417x590, screen.png [View same] [iqdb] [saucenao] [google] [report]
71634910

I want to list every file in the current directory along with some information, like disk usage. The script I made (pic related) doesn't work on filenames with spaces in them, and I can't figure out why. Help pls

>> No.71634955

Just switched to Manjaro. Pretty comfy but there is one big problem that is ruining the experience for me. How can I add the middleclick scrolling function on my mouse? I really miss that and it's driving me nuts

>> No.71634973

So my friend got me into this mess but can't get me out. "Just use fdisk to delete those windows partitions you don't want" he said....
Now I can't boot.
I was dual booting and wanted more space for ubuntu.
I resized my ubuntu partition and made sure I set the boot flag in parted, but it says to insert a bootable drive when I start up.
Any ideas? The partition is in fstab.

>> No.71635027

>>71634955
If you’re using Firefox, you have to enable “auto scroll” under preferences.

>> No.71635045

>>71635027
wow I'm really stupid. Thank you anon

>> No.71635425

>>71634910
https://mywiki.wooledge.org/ParsingLs

>> No.71635459

>>71634955
On GNU/Linux, more specifically Xorg, middle click ist used for pasting the selection clipboard. It's pretty convenient tbqh.

>> No.71635526

>>71635459
Oh, I knew that worked for the console. Never bothered to test in somewhere else. thats neat

>> No.71635662

>>71635459
by the way, how to turn this off, i mean the automatic copying of selected text, its really annoying when i press shift + end to select all the line, delete and then ctrl+v or whatever combination just to end with the same result

>> No.71635677

>>71625221
Void is for the people who like arch but gell for the "systemd is bad" meme

>> No.71635965

>>71635677
> things arch users believe

>> No.71636025

>>71634973
Re-run grub to generate your bootloader

>> No.71636401

Is there a way to generate an imagehash (like used at warosu.org to search for images) from the cli?

>> No.71636544

>>71636025
How do I do this exactly? I found "grub.efi", but I can't launch it.

>> No.71636605

>>71636401
Figured it out.
md5sum meme.png | awk '{print $1}' | xxd -r -p | base64

>> No.71636653
File: 7 KB, 534x173, Screenshot_20190628_210002.png [View same] [iqdb] [saucenao] [google] [report]
71636653

The gray triangle on the black background doesnt match to the gray background before it, that is there is a thin blue line between it.
Pic related, Konsole, zoomed in for clarification.
How can I fix this?
Or what's it called so I can google it?

>> No.71636756

startx wmname wont work even though I have a case structure in my xinitrc specifying that window manager
when I run xinit wmname -- rest of argiments it works without prepending / or . as its stated in manpage, that would match the case in xinitrc function proving it works

>> No.71636847

>>71636544
read the arch wiki on grub

>> No.71636867

>>71636653
There is literally nothing you explained in the image you posted

>> No.71636987
File: 1.44 MB, 720x720, 1484468330036.gif [View same] [iqdb] [saucenao] [google] [report]
71636987

Hey /g/, what's the best lightweight and user-friendly distro for daily use?

>> No.71637028

>>71636653
Please use a search engine that respects your privacy like searx.

>> No.71637066

>>71636987
>windows console font
reported

>> No.71637153

>>71636867
2nd attempt then.
Arrow points to inconsistency
Left of it is a gray bg, right a black bg, and the triangle char should align perfectly to the gray bg, but it doesnt. If you look closely, you can see that the gray triangle char is also slightly moved upward.

This is Konsole, 0 line width, and Hack Nerd Font Mono, so it shouldnt be the font

>> No.71637169
File: 7 KB, 534x173, Screenshot_20190628_210002.png [View same] [iqdb] [saucenao] [google] [report]
71637169

>>71637153
Forgot pic

>> No.71637344

How do i allow other programs to open links in firefox?
Everytime a program tries to open a link it states that a firefoxinstance alr4eady exists and it cant make a new one.
But i just want everything to open in a single firefox instance/profile instead.
I changed the .desktop firefox profile to use
/usr/lib/firefox/firefox --no-remote'

But that dosent fix the opening links option
I also added "-P default" to the end of that line and still nothing(my profile is named default in the profiles.ini)
How do I get links to open in an existing firefox instance from other programs?

>> No.71637387

>>71636847
There is a lot of stuff, and I barely know where to begin. I tried generating a new .cfg file, but it fails; and I don't know if that'll solve anything.

>> No.71637559

>tired of aplaymidi -p 28:0 *mid
Any good midi player to recommend ?

>> No.71637870

On my thinkpad x200s, how come I can boot from some linux images and not others? For example I can boot from manjaro and mint just fine, but most other distros and live images wont boot at all.

>> No.71638465

>>71637344
Every program I have which tries to open links does exactly what you're asking right out of the box, on every distro I've ever used. Perhaps the question should be have you done something to break it

>> No.71638708

>>71637870
linux a kernel is

>> No.71638773

>>71636987
Yikes! Dilate seething cringe, oof have sex.

>> No.71638972

>>71638773
>friendly

>> No.71639087

>>71637344
--no-remote is the opposite of what you want.
Firefox's built-in "Always check if Firefox is your default browser" option generates a desktop file under ~/.local/share/applications, which works for me.

>> No.71639090

>>71638972
>>friendly
Banter is friendly. We've discussed this, anon.

>> No.71639102

>>71636987
Source Mage GNU/Linux

>> No.71639150

>>71638465
Literally very program i use, from the cli, to even hexchat or other clients
Nothing loads
I have configured nothing outside of stock config's. I've only had this install up less then a week

>>71639087
firefox is found but it wants to create a NEW INSTANCE instead of a new tab.
Deleting the .desktop files and reinstalling firefox to generate stock files nets no gain

>> No.71639228

Copying something, then closing the application because all I wanted to do was copy that one line, and trying to paste into another application doesn't work. Why? It makes more sense to close the program rather than minimizing it, pasting and then closing it once I've pasted,

How do I make my clipboard behave like all computer users that have ever copypasted something would prefer it to behave? I'm on KDE btw ;)
Jesus fuck I hate that I'm compulsed to use Linux because of my ((((undiagnosed)))) autism

>> No.71639291

>>71639228
a kernel linux is

>> No.71639306

>>71639228
that's xorg shit, it's related to clipboard ownership

>> No.71639386

>>71639150
What happens if you completely close firefox, then run "firefox&" in a terminal, and then once it starts up run "firefox&" a second time. It should just open a 2nd window.

>> No.71639407

>>71639386
Directly launching firefox yes
Running another program that wants to open a link in firefox, no

>> No.71639436

>>71639407
But does it change the behavior if the 1st instance of firefox launched was done from your terminal instead of the .desktop file?

>> No.71639488

Hello, I installed Guix along the XFCE desktop environment and currently everything works fine except that I can't see numbers. How do I fix this?

>> No.71639490

>>71639436
It just takes focus from the terminal to the existing firefox instance.

>> No.71639505

>>71639488
Xfce*

>> No.71639861
File: 24 KB, 960x390, 1509555417048.jpg [View same] [iqdb] [saucenao] [google] [report]
71639861

>> No.71640123

mpv wont play files, especially the short ones, untill the very end when --keep-open is in the config, when called with --no-jeep-open it plays till the end
supposedly its a problem with pulseaudio and it presumably works on alsa, but what to do when i wouldnt like to fuck around with my audio server?
firefox, any other browser, audacious, vlc all of them play it normally on pulse audio

>> No.71640136

>>71639490
But was the "existing firefox instance" started from the terminal?

>> No.71640158

>>71640136
Yes, from the first forked firefox command, the second one just moved focus to the existing one launched from the same console

>> No.71640199

>>71640158
That's really weird. What distro are you on?
And what if you do "firefox --new-window"?

>> No.71640252

>>71640158
>>71640199
Or even "--new-tab". I wonder if it would fix your problem to add the --new-tab flag to the end of the .desktop file (make sure it's at the very end)

>> No.71641090

>>71621276
Day two of firefox being broken for me on Debian. Updating didn't do anything. Is it broken for anyone else? At first I thought it was an ethernet driver being screwed up somehow, but other browsers work fine.

>> No.71641139

>>71621276
Ok bros, you win. I can't use Windows 10 anymore. What is a good distro that I can use to play all my vidya?

>> No.71641196

>>71641139
>What is a good distro that I can use to play all my vidya?
Fedora

>> No.71641293

>>71637066
that font is a PC-specific thing, not a Windows-specific thing

>> No.71641305

>>71639861
>virgin colour-me-in vs. chad exploitable

>> No.71641696
File: 20 KB, 400x268, melon.jpg [View same] [iqdb] [saucenao] [google] [report]
71641696

Going to try Wayland
wish me luck

>> No.71641748 [DELETED] 
File: 344 KB, 1934x1094, screenshot_default.png [View same] [iqdb] [saucenao] [google] [report]
71641748

https://github.com/GitSquared/edex-ui/releases/download/v2.2.2/eDEX-UI.Linux.x86_64.AppImage

Leet haxxor niggas, Tron desktop is not real!

>> No.71641781
File: 344 KB, 1934x1094, screenshot_default.png [View same] [iqdb] [saucenao] [google] [report]
71641781

https://github.com/GitSquared/edex-ui/releases/download/v2.2.2/eDEX-UI.Linux.x86_64.AppImage

Leet haxxor niggas, Tron desktop is now real!

>> No.71641831
File: 1.70 MB, 305x654, android fan.gif [View same] [iqdb] [saucenao] [google] [report]
71641831

how do i manage services that is not installed through native package manager? (e.g. openssh in flatpak)
its hot now so have a fan

>> No.71641958

>>71641831
>flatpak
Check RedHat tech service pages

>> No.71642010

>>71641090
>using anything but stable
just come already to fedora

>> No.71642022

>>71641196
if you don't have an optimus setup, I guess.
Because steam crashed on my laptop trying to use a fancy prime sync setup or whatever rpmfusion suggested.
The best solution still is go complete rendering on the nvidia card I guess.

>> No.71642047
File: 193 KB, 420x560, 1334642831061.jpg [View same] [iqdb] [saucenao] [google] [report]
71642047

>>71642022
>if you don't have an optimus setup
>nvidia
Correct.

>> No.71642095

>>71641958
nice joke idiot, every tool has its own documentation website and its source page.
>>71641831
http://docs.flatpak.org/en/latest/reference.html
I'm not sure what you're referring, flatpaks use the host's systemd so the services should also be managed outside of flatpak. The desktop utilities and libraries are actually what runs in the sandbox of flatpak.
For example the service probably executes something like flatpak run openssh -d or whatever

>> No.71642123

>>71642095
>shill is buttmad
What a surprise

>> No.71642149
File: 239 KB, 945x400, FedoraMagazine-945x400.jpg [View same] [iqdb] [saucenao] [google] [report]
71642149

>>71642123
lol, I thought you were just an esl trying to give actual advice but you're actually retarded.
Stay mad and keep breaking the standards on your shitty pajeet distribution, Red Hat has achieved a pretty neat system that other distributions soon try to imitate, even Gentoo has support to be a Red Hat clone like debian and arch.

>> No.71642184
File: 153 KB, 768x768, angrery.png [View same] [iqdb] [saucenao] [google] [report]
71642184

I want to hear your best icon themes right fucking now

>> No.71642201

>>71642184
hicolor
gnome

>> No.71642212

>>71642201
wrong
>>71642184
the one I'm using
Vertex

>> No.71642216

>>71642212
>wrong
wrong

>> No.71642235
File: 317 B, 127x13, filedeleted.gif [View same] [iqdb] [saucenao] [google] [report]
71642235

>>71642201
Die
>>71642212
pls no generic shit
Give me your quaintest icon theme (right fucking now)

>> No.71642244

>>71642216
wrong
>>71642235
wrong

>> No.71642258

>>71642235
>icon theme
Delft

>> No.71642557
File: 1 KB, 66x33, 2019-06-24-210809.png [View same] [iqdb] [saucenao] [google] [report]
71642557

>>71621276
whose fault is this? i3, ALSA, PulseAudio?

>> No.71642573

>>71642557
>whose fault is this?
Yours.

>> No.71642610
File: 32 KB, 780x439, oh my god - it even has a watermark.jpg [View same] [iqdb] [saucenao] [google] [report]
71642610

>>71642258
>everything is a square meme

>> No.71642627

>>71642610
Meh, I got tired of searching and settled, for now.
What do you suggest?

>> No.71642675
File: 886 B, 30x253, icons.png [View same] [iqdb] [saucenao] [google] [report]
71642675

>>71642627
I don't know that's why I'm asking.
What would really salt my petunias would be a nice windows 95 type icon set but with nuanced modern touches, yet still retaining a muted sense of nostalgia.
I'm using classic but it really doesn't jive with the rest of the theme

>> No.71642682
File: 17 KB, 1013x765, CDE.png [View same] [iqdb] [saucenao] [google] [report]
71642682

This aesthetic is also a goal but I haven't looked into it too much yet.

>> No.71642770

>>71642573
it couldn't be

>> No.71643606

Is Arch unstable/hard to maintain?

>> No.71643654

>>71622643
I'm a programmer (C++) and I use Ubuntu. It works fine, there are all the programming packages you can possibly want.
Install the current LTS version (18.04) and you'll be fine.
I might migrate to something else considering Steam will stop working, but for now it's fine.

If you want to mess with Linux config files, etc. you should install a second one (any distro, or even a BSD) in a VM or a separate system. Messing with config files, etc. on your main machine is counter-productive and stupid, and works only if you are a NEET with nothing better to do.

>> No.71643664

>>71642557
Without knowing any detail I would say PulseAudio.

>> No.71643670

>>71641781
It's super useful to have a widget reminding you of the manufacturer and the type of chassis you're running on.
Just in case it changes while you're hacking a Gibson.

>> No.71643674

>>71639488
>everything works fine
>I can't see numbers

>> No.71643982

So I got shilled into trying out trying out wayland, I start weston and I cannot for the life of me find out anywhere where the keybindings are for all the shortcuts, in i3 it was super+enter to spawn a shell, super+shift+q to close a window etc

Where the fuck are these in wayland? super+enter I think is not even defined.

>> No.71644020

>>71643982
If you used i3 then why aren't you using Sway? It's an i3 clone for wayland.

>> No.71644042

>>71644020
What? Sway is a clone of i3 not the other way around? Also how do I make binds on Sway its not mentioned anywhere on the wiki

>> No.71644055

>>71642682
You know you can quite literally compile CDE on Linux, right?
It's not even too hard.

https://sourceforge.net/p/cdesktopenv/wiki/LinuxBuild/
https://mike632t.wordpress.com/2015/09/09/compiling-cde-on-debian-8-0-jessie/

>> No.71644084

>>71644042
That's what I said anon.
>It's an i3 clone
means sway is a clone of i3.

The sway config is basically the same as i3's. It'll automatically use your i3 config if it doesn't find a sway config (so probably the first time you run it you'll already have the right keybindings from your i3 config)

>> No.71644214

>>71642557
>fault
It's a feature, puls allows you to go endlessly over 100%.

>> No.71644232

>>71644055
Linux is a kernel.

>> No.71644894

Anyone manage to get topmenu to work on Manjaro XFCE?

>> No.71644962

My Arch install has been fine for a year but I noticed /boot partition has 3 megs of free space left, does it ever increase, is it safe to leave as is? If not, is it safe to just take 50 megs from /home and add to /boot with gparted on running system?

>> No.71645102

>>71638773
well memed

>> No.71645190

hi, today I installed cinnamon environment on Ubuntu 16.04
after installation I have rebooted my computer and the login screen was still gnome so I had to choose cinnamon on the login screen
when I logged in I have deleted gnome and unity which was there unused
after reboot my login screen is in plaintext terminal and after login the is no gui
on the google I foun that I shoud use ctrl+alt+F1-7 shortcuts to open the gui but it didn't work
what should I do?

>> No.71645232
File: 160 KB, 327x327, new-logo-crop.png [View same] [iqdb] [saucenao] [google] [report]
71645232

>>71645190
oh and when I turn the computer off or on there's still this gnome booting screen

>> No.71645244

>>71643606
No if you can read

>> No.71645271

>>71645190
sudo service lightdm restart

>> No.71645349

>>71645271
Failed to restar lightdm.service: Unit lightdm.service not found.
did I really fucked up?

>> No.71645453

>>71645349
sudo apt-get install lightdm

>> No.71645476

>>71645232
I'm pretty sure that's plymouth.
https://wiki.ubuntu.com/Plymouth

>> No.71645629
File: 9 KB, 152x225, 1526561486463.jpg [View same] [iqdb] [saucenao] [google] [report]
71645629

>>71645453
>there's no something
>lol just sudo apt-get install anything
I'm slowly starting realize that many thing work that way
Thanks you!

>> No.71645678
File: 118 KB, 800x533, 1334640295113.jpg [View same] [iqdb] [saucenao] [google] [report]
71645678

>>71645629
Good to hear.
You're welcome.

>> No.71645822
File: 1.65 MB, 1062x1500, 1529501457922.png [View same] [iqdb] [saucenao] [google] [report]
71645822

>>71621276
w3m won't display image in neofetch for me with gentoo :(

>> No.71645851

Is there some headless daemon i can run on my server that i can then run some headless apk on my android that allows me to copy/paste in both directions?

Is there some offline text to voice converter that will take sentences and prodices a wav/mp3 from them?

>> No.71645887

>>71645822
https://github.com/dylanaraps/neofetch/wiki/Images-in-the-terminal

>> No.71646083

>>71644084
this doesnt seem to be true, I press super+enter but no shell comes up

>> No.71646234

is youtube-dl having problems right now? suddenly i can't download videos

>> No.71646247

>>71646083
But you said you were using weston, not Sway.
But either way, even i3 defines a $mod variable that you customize. You should try all the modifier keys to see which one sway has by default (e.g. try ctrl+enter, alt+enter, shift+enter, super+enter) one of them should work.

>> No.71646257

>>71646234
nvm i just have to update it

>> No.71646281

>>71646234
>>71646257
Jewtube wants to break it because they don't like you being able to save the data they send you (it's like they want to sing you a song and force you to not remember it, it's fucking retarded).
So youtube-dl is one package you always have to keep up to date.

>> No.71646288
File: 163 KB, 723x666, 1561300884178.png [View same] [iqdb] [saucenao] [google] [report]
71646288

any way to get safe exam browser to work on linux? I need it for uni

>> No.71646326
File: 1.18 MB, 1600x900, 1530534304381.png [View same] [iqdb] [saucenao] [google] [report]
71646326

Made the switch to KDE.

I feel like a fucking retard for using GNOME for so damn long. KDE is the best DE, objectively.

>> No.71646339

>10TB external HDD, ext4
>well over 1TB free space
>writes already slowing to 3mb/s and below

What in the actual fuck is this. I appreciate drives slow down as they get full, but a full terabyte of free space?? I thought ext4 was supposed to be intelligent in how it handles fragmentation.

>> No.71646343

>>71646288
GNU/Linux*

>> No.71646348

>>71646326
now combine it with i3

>> No.71646361

>>71646257
update will do the trick usually. sometimes you can fix it it with --rm-cache-dir also

>> No.71646379

>>71646326
I used KDE for a long time, then I switched to GNOME for a long time, recently I tried KDE but I just can't use it anymore. It just feels too bloated.

>> No.71646383

>>71646361
>>71646281
i was using the one on the aur so there was no update yet, had to get the one on github

>> No.71646461

>>71644962

It's probably safe to leave it, but I wouldn't take any chances. Please do not resize the boot while running, though. Get a gparted live cd.

>> No.71646465

>>71646247
Sorry im confused, I thought weston was the implementation of the wayland protocol, so I pretty much start via weston like starting up xorg on startup, then through that you can either choose to use sway as the wm or i3, what is happening when im starting up weston? I see a DE.

>> No.71646615

>>71646247
But regardless I've started up sway and edited the config to Mod1 so it's alt yet alt+enter does not open a shell as it says in the config "exec urxvt" (I have it installed)

>> No.71646795

>>71646465
>>71646615
I guess I don't know. Wayland confuses me.
But are you sure you're editing the right config? When I tried sway I remember it initially used my i3 config. Even when I made a sway config and reloaded it still used the i3 one. I had to restart to get it to use the right one.
There's also a system config somewhere in /etc/ I think

>> No.71646815

>>71646795
Yes the config is correct. Literally every other keybind works except when trying to get up the terminal for some reason, urxvt being the terminal.

>> No.71646862

>>71646326
As much as I hate both, I can't imagine using gnome over kde.

>> No.71646933 [DELETED] 

crashed while copying files from one partition to another, more than half of them are missing now
when i moved I did cut, so the files arent in the original location anymore
am I fucked?

>> No.71646955

>>71645851
>Is there some headless daemon i can run on my server that i can then run some headless apk on my android that allows me to copy/paste in both directions?
Hmm. So there are some android remote control apps and pastebin/pastebin clones that are close, but idk of anything quite like this. KDE Connect and Dukto for a graphical version of this sort of.
> Is there some offline text to voice converter that will take sentences and prodices a wav/mp3 from them?
mmm, Like, piping text into espeak and saving the output? If you have a windows program in mind you might look for web/linux alternatives on https://alternativeto.net/

>> No.71647128

>>71646288
looks bad.
https://www.reddit.com/r/linuxquestions/comments/apviyz/how_to_run_safe_exam_browser_on_linux/
>>71646933
When you say crashed, like the whole OS, the transfer, or your file manager? The files shouldnt actually delete until they have been moved. Try re-pasting, refresh the folder etc. Worst case scenario you should be able to see them on via dd-rescue.

>> No.71648427

https://www.vidarholen.net/contents/blog/?p=766

>> No.71648461

What is a convenient yet redpilled way to encrypt a directory from the cli? I thought about using Tar and GPG and was wondering what you guys would use.

>> No.71648475

>>71648427
The best trolling is trolling the trolls.

>> No.71648571

https://github.com/microsoft/WSL2-Linux-Kernel

>> No.71648627

>>71648571
Extremely based, I can finally install the Linux/GNU app, instead of just GNU

>> No.71648655
File: 1013 KB, 500x296, 1519978941816.gif [View same] [iqdb] [saucenao] [google] [report]
71648655

>>71648627
>gnu/linux is now merely an app on win10

>> No.71649744
File: 46 KB, 1360x232, Screenshot from 2019-06-29 17-34-17.png [View same] [iqdb] [saucenao] [google] [report]
71649744

Is this that gnome RAM hogging that I hear so much about? Or is it supposed to be worse?

>> No.71649991

>>71649744
unused ram is wasted ram

>> No.71650038

have been using arc theme for a while, what other light themes are you using

>> No.71650072

>>71649991
True, but I get annoyed and suspicious when my fan picks up for no discernable reason.

>> No.71650177

>>71645887
I tried that and it didn't work. Neofetch -v just tells me that w3m can't open images. I have all the right dependencies and they're all using the right use flags

>> No.71650535

>>71643982
>falling for gayland

>> No.71650591

>>71648571
>Windows Subsystem For Linux
>windows susbsystem
>for linux
>windows
>for linux
>not for windows
>FOR LINUX
nuff said

>> No.71650675 [DELETED] 

just testing something
let @c=':%y z^M:%d^Mi^M^[<80><fd>ak:r!fortune | cowsay^M:%y +^M:%d^M^M'

>> No.71650930

>>71646815
Oh, do you have Xwayland installed? Urxvt doesn't run natively in wayland, it requires xwayland.
Alternatively use a different terminal which does support wayland, such as termite.

>> No.71651089

>>71646955
>clippboard
I dont really want to install 50+ kde deps just for this should-be-simple task

>text
I dont use windows...i dont know of any such programs.

>> No.71651186

does anyone on how to format a cd rw i just want to install some firmware. Idk how to linux yet. also does anyone know why my terminal has a ~> when sometimes it has a ~$. how do you change that?

>> No.71651214
File: 1.45 MB, 1008x960, 1561835606.png [View same] [iqdb] [saucenao] [google] [report]
71651214

>>71651186
forgot to add pic

>> No.71651302

>>71651186
CTRL+c makes your GNU $

>> No.71651331

>>71651186
>>71651214
It's just saying you don't have cdrecord installed. I don't know what cnf does, but can't you just try installing it? What distro are you on?

The $PS1 variable determines the prompt appearance.
But what are you doing exactly when the prompt changes? It normally shouldn't be changing.

>> No.71651379

>>71651214

You're a retard my man.

sudo zypper ref
sudo zypper in cdrecord

Then use cdrecord. It's currently not installed.

>> No.71651400
File: 3.20 MB, 3024x3557, 0629191219_HDR~2.jpg [View same] [iqdb] [saucenao] [google] [report]
71651400

>>71651302
wat
>>71651331
to your first question. this is a fresh install of opensuse tumbleweed.
to your second question idk i havent done anything. i launched super terminal or something like that and put my password in once.

>> No.71651461
File: 2.23 MB, 2989x2437, 0629191229~2.jpg [View same] [iqdb] [saucenao] [google] [report]
71651461

>>71651379
I appreciate your punctuation and honesty. I've run into an issue as you see here.

>> No.71651462

>>71651400
Well I've never used opensuse, but it does have cdrecord in its repos:
https://software.opensuse.org/package/cdrecord?search_term=cdrecord

You just have to install it. Use the standard installation command for your package manager.

Try ctrl+d to exit whatever prompt you're in.

>> No.71651473

Your internet is not working. You can't proceed without setting up your fucking connection, obviously.

>> No.71651475

>>71651461
Are you connected to the internet on that machine?

>> No.71651507
File: 2.66 MB, 1008x1344, 1561836804.png [View same] [iqdb] [saucenao] [google] [report]
71651507

>>71651475
>>71651473
I connected my phone to it via tether tho. why is this so hard.

>> No.71651525

\$ on the end of your $PS1 should show up as $ if you're normal user and as a # if you're root.
You could also specify some other char such as a >.
echo $PS1

>> No.71651616

>>71651507
I don't know. Just test it.
ping gnu.org
what do you see?

>> No.71651630

>>71651507

It's really basic shit, but it feels hard for you because you have no knowledge about using a command line whatsoever. I'd recommend that you delete Tumbleweed aka a distro for advanced users and get normieshit like Ubantu, regular OpenSUSE or Fedora.

I also don't know why your tethering doesn't work, probably wrong IP/no DNS.

>> No.71651715
File: 1.04 MB, 1008x756, 1561837614.png [View same] [iqdb] [saucenao] [google] [report]
71651715

>>71651525
well what the fuck. I didnt do anything fancy.
>>71651630
How do you learn if you dont struggle in the first place anon.
>>71651616
nothing happens

I dont have eth0 for some reason

>> No.71651831

>>71651715
It doesn't need to be eth0, they can have different names. You can run "ip a" to see what you have. But your problem is just that, regardless of the interface name, you're not connected.

I've never used tethering to a phone, so I have no experience at all that I can offer you.
If I were you I'd try searching the web for any information on how to connect a linux box through tethering with a smart phone.

>> No.71651883

>>71651715
>>71651831
Also keep in mind the problem could always be on your phones end, not the PC.
Don't phones like to make it a pain in the ass to do tethering because they want to be sure they charge you money for some special tethering service bullshit? (which is obviously 100% just a gimmick to make you pay twice for what you already have, but that's beside the point)
Have you ever successfully done this tethering to that same phone but with a different device than your PC?

>> No.71651915

>>71651883
nah its plug n play with my windows machine

>> No.71651960
File: 1.85 MB, 1344x1008, 1561838542.png [View same] [iqdb] [saucenao] [google] [report]
71651960

SUCCESS NEVER TASTED SO SWEET

>> No.71652016

Mom's gonna be super mad when she gets the bill for the data overages.

>> No.71652038

>>71652016
She got unlimited so we are in the clear.

>> No.71652145

>>71651616
> 64 bytes from wildebeest.gnu.org
Cute

>> No.71652171

fuck it im installing ubuntu this too hard for my head. I think i installed it wrong anyways

>> No.71652212

>>71652171
i also have an arch usb. do i do that one instead?

>> No.71652237

>>71652212
Arch is even more advanced.

>> No.71652335

>>71652171

Go for Ubanto first, get used to Linux and switch.

>> No.71652437

>>71652430
>>71652430
>>71652430

>> No.71652441

>>71652212
If installing linux is hard at all try manjaro. Most hardware works just werks on install or know just try ubuntu. Just use something basic to get to know the linux system. good luck =)

>> No.71652582

>>71622643
debian or arch

>> No.71652604

>>71626293
install arch/gentoo/lfs

>> No.71652694

>>71652604
glfs*

>> No.71652706

>>71652441
GNU/Linux*

>> No.71653121

>>71652437
Why did you kill it?

>> No.71653158

OK so here's the deal
>Intel Celeron N3060
>4GB of ram

Which distro do I use?

>> No.71653197

>>71653158
Debian

>> No.71653271

>>71653197
You think Xubuntu will still be too bloat

>> No.71653274

>>71653158
Fedora

>> No.71653293

>>71652437
Is dead.
Start a new one.

>> No.71653309

What the fuck happened to the other thread? >>71653293

Did a mod delete it or did the OP? I actually want to know, because if a mod deleted it for the image then I'd be pretty pissed off. Although my image of the mods as normalfag cancer can't really get any lower than it already is.

>> No.71653330

>>71653309
I would like to know this as well.

>> No.71653341

>>71653309
Get rekt, degenerate

>> No.71653365

>>71653341
Cry moar for me offliner
you never belonged here

>> No.71653375

>>71653365
Weeeeeeeeeeew! hehe

>> No.71653390
File: 101 KB, 425x450, 1561129274756.jpg [View same] [iqdb] [saucenao] [google] [report]
71653390

ooh subreddit drama

>> No.71653410

>>71653390
It's 1 sided.
Some faggot (and probably some mod) crying about a little anime.

>> No.71653429
File: 6 KB, 250x250, 1561178818508.jpg [View same] [iqdb] [saucenao] [google] [report]
71653429

>>71653410
is there like some designated thread maker?
what if he's banned?

>> No.71653436

>>71653410
>crying about a little anime
>on an anime shitposting forum
Fucking autists.

>> No.71653498

>>71653429
That's what I was wondering too.

I have half a mind to remake it with the same image, but my experience messing with the mods has taught me they are mostly normalfags beyond the shadow of any doubt. There's no point in messing with them.
If they can't take a little flavor every now and then and would rather 4chan just be a predictable and sterile place then I guess they win.
Someone else make it with some "approved material".

>> No.71653538

>>71653524
>>71653524
>>71653524

>> No.71653557
File: 739 KB, 500x248, abandonthread.gif [View same] [iqdb] [saucenao] [google] [report]
71653557

>>71653538
Noice.

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action