Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Maintenance is complete! We got more disk space.
Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 917 KB, 788x7273, freedom.png [View same] [iqdb] [saucenao] [google] [report]
68698226 No.68698226 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread, or as I've recently taken to calling it, Friendly GNU+Linux Thread.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: Please spend at least a minute to check a web search engine with your question.
*Many free software projects have active mailing lists.

$ man %command%
$ info %command%
$ %command% --help
$ help %builtin/keyword%

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux:
https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page
>What are some cool terminal commands?
http://www.commandlinefu.com/
http://cheat.sh/
>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/
>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html
>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

/t/'s GNU/Linux Games: >>>/t/825628

Previous thread: >>68678028

>> No.68698253

First for Arch GNU+Linux

>> No.68698261

arch = simple to use
void = simple to understand

>> No.68698272

>>68698253
>>68698261
>>68698226
install gentoo

>> No.68698279

>>68698272
>need to have build dependencies for everything installed
bloat

>> No.68698318

So...
If someone know something about that ... >>68697885

>> No.68698662

I am a frequent lurker of these threads and I have a bit of a problem, I've looked online and haven't found much so wondering if I could get some help here. so basically my situation is this
>running xubuntu on a t410, using xfce
>trying to wean myself onto only using the terminal for as many actions as possible for fun, efficiency, etc
>working on using gsettings to change the system settings
>right now starting small, trying to change desktop background
> use "gsettings set org.gnome.desktop.background picture-uri "file://home/name/Downloads/pigture.jpg""
>nothing happens
>check file name and path, everything seems to be in order
>try changing via xfce customization thingy, works
what am I doing wrong? does the xfce personalization gui program override gsettings or did I just do something wrong?

>> No.68698702

>>68698662
I have no idea what XFCE is or does sorry.

>> No.68698719

>>68698702
xfce is the de that im running, came with xubuntu

>> No.68698745

>>68698662
>using xfce
>org.gnome
Are you sure that command applies to xfce and isn't for gnome?

>> No.68698756

>>68698318
journalctl -b -1

Will show you the logs from your entire last boot, scroll to the very bottom and you will likely see why it hung.

>> No.68698769

>>68698745
well I used gsettings list-schemas and it seemed to be the only one that had anything to do with desktop bacgrounds, I'll check again though

>> No.68698806

>>68698745
>>68698769
yea so I checked again and there doesn't appear to be a schema other than the org.gnome one which has anything to do with desktop backgrounds

>> No.68698841

>>68698806
Did you try this?

https://askubuntu.com/questions/380550/xubuntu-how-to-set-the-wallpaper-using-the-command-line

>> No.68698861

So I want to build and install new kernel on an old Debian laptop, so I don't need many features present in default kernel.

I followed this manual and compiled the kernel on my main rig in a user folder https://www.cyberciti.biz/tips/compiling-linux-kernel-26.html up until "sudo make modules_install", as I understand this will actually install kernel on my main rig.

So how do I install this kernel on my laptop now? Do I put it on a thumbrive, plug it into a lappy, cd into the kernel dir and run all of those commands after the "sudo make modules_install"?

How can I add an option to boot into older kernel in Grub in case something fucks up?

>> No.68698878
File: 186 KB, 1128x261, 1512667793762.png [View same] [iqdb] [saucenao] [google] [report]
68698878

>>68698756
I'm not sure of what i'm supposed to see

>> No.68698929

>>68698878
>39 output lines suppressed due to ratelimiting

lol idk
Maybe that's the network driver error from your first screenshot.

Is it compiled as a module? You can try to rmmod that shit before shutdown to see if its causing the hang. Its likely a known issue with a real solution if that is actually the problem, in which case you can probably just google it.

>> No.68698986
File: 694 KB, 726x1006, 1530034078294.png [View same] [iqdb] [saucenao] [google] [report]
68698986

>>68698929
>in which case you can probably just google it
I have found nothing, that's why i came here...
But I will google for "rmmode" cause I don't understand..

>> No.68699010

>>68698861
make modules_install will only install the kernel modules, you need to copy the kernel itself to /boot and configure grub it. You'll also probably need to generate an initramfs.

Debian probably has an official guide for how to do this, judging from your url
>linux-26
that's pretty old, don't follow that guide.

>> No.68699019

>>68698986
I would try and read the extra output that was suppressed or whatever.
journalctl -u systemd-shutdown

Might show it.

>> No.68699047
File: 14 KB, 428x58, 1518210572261.png [View same] [iqdb] [saucenao] [google] [report]
68699047

>>68699019
For the rmmod, pic related, i have found it, it is a temporary kill or a permanent one ?
Also I will use your journalctl command

>> No.68699050

wine would probably be easier for me to use but manjaro makes me seem cooler on the internet

>> No.68699085

>>68699019
>-- Logs begin at Thu 2018-11-01 20:59:03 CET, end at Wed 2018-11-28 21:33:01 CET. --
>-- No entries --
lel

>> No.68699138

>>68699085
Shit like this is the reason I always have systemd.debug-shell in CONFIG_CMDLINE

Crap just stops and I can switch tty and find out why in single user mode.

>> No.68699140

>>68698841
huh, so it seems like none of these commands have any effect whatsoever. I used the xfconf-query method and tried using gsettings again and both have no effect, the only way I seem to be able to change the background is through the desktop settings gui. I might be doing something wrong, but idk. It seems to work for everyone else. At first I thought maybe xfconf-query was overriding the gsettings but it doesn't work either, is there another process that is maybe taking priority?
I am also thinking it could be a problem with the way xfce is labeling my display/monitor

>> No.68699263

>>68698861
Dont do this.
Look up how to build a deb and then install it using your package manager

>> No.68699301

>>68699263
Yeah don't do it, just use the binary kernels. Debian absolutely sucks for any kind of customization, all of your shit will break.

It isn't like gentoo/portage where packages check your current kernel's source code and build against it automatically.

>> No.68699318

>>68699138
Is it safe to rmod thinkpad_acpi ?
I have uninstalled thinkfan and the problem seems to have appeared since i have done some things in it, but i don't remember it this module was already enabled.

>> No.68699333

Will most USB express cards work with Linux out of the box? Was thinking about getting one to add some usb 3.0 ports to my thinkpad but I'm not sure if it'll function

>> No.68699375

>>68699318
Sounds like you are fucking with tons of shit and don't really know what you are doing.

You should just start over and skip unnecessary shit like thinkfan, nobody uses that crap anymore.

>> No.68699408

>>68699375
>and don't really know what you are doing.
Indeed, but it's also because its installation was a fuckin 150 steps process...And now it's fucked, but all went great before that.

>> No.68699452

>>68699333
I would say yes, but before you buy it look it up.

>> No.68699479

>>68698226
I'm trying to burn an iso of ubuntu to a usb to install to a dualboot, I've got 500gb free in my HDd, gonna do 150gb for ubuntu

So question - I used dd if=/root/Downloads/ubuntu.iso ect ect ect I got error dd: error writing /dev/sda2 no space left on device

So yeah, how do I format the drive to turn it into a bootable usb to install linux dualbooting

Also the host is kali as I learn for the oscp so I allready have grub

>> No.68699490

>>68699333
All of them should work OOB, it's USB we're talking about. I say, take the risk.

>> No.68699522

>>68699452
https://www.amazon.com/ExpressCard-34mm-Adapter-Dual-Port/dp/B0045BLP1S/ref=sr_1_9?s=electronics&ie=UTF8&qid=1543439323&sr=1-9&keywords=expresscard+usb+3.0
It's pretty cheap, should I bite the bullet?

>> No.68699560

>>68699479
Why are you writing the ubuntu iso to your sda2 (usually your first internal HDDs second partition) again?

>> No.68699608

>>68699522
Did you even read that page?

https://www.amazon.com/ask/questions/Tx36YBFU1UU1GIJ/ref=ask_ql_ql_al_hza

>> No.68699627

>>68699560
Fuck me

How do I undo?

>> No.68699645

>>68699627
You can't, you fucked up whatever that partition was.

>> No.68699653

>>68698226
Why is smbmap such garbage? it fails at literally the only job it is supposed to do, and smbclient works perfectly
[email protected]:~/trash# smbmap -L -H 192.168.0.104
[+] Finding open SMB ports....
[+] User SMB session establishd on 192.168.0.104...
SMB SessionError: STATUS_ACCESS_DENIED({Access Denied} A process has requested access to an object but has not been granted those access rights.)
[email protected]:~/trash#
[email protected]:~/trash#
[email protected]:~/trash# smbclient -L 192.168.0.104
Enter WORKGROUP\root's password:

Sharename Type Comment
--------- ---- -------
ADMIN$ Disk Remote Admin
C$ Disk Default share
IPC$ IPC Remote IPC
NETLOGON Disk Logon server share
Public Disk
SYSVOL Disk Logon server share
Users Disk
Reconnecting with SMB1 for workgroup listing.
Connection to 192.168.0.104 failed (Error NT_STATUS_RESOURCE_NAME_NOT_FOUND)
Failed to connect with SMB1 -- no workgroup available

>> No.68699654

>>68699645
/boot/

But not /boot/efi

So reinstall the base os?

>> No.68699718

>>68699654
Tough question, you might be able to reinstall just the packages that touch /boot. There's the kernel and grub, remake the initrd.

I don't know enough about Kali to tell you how to go about doing that.

>> No.68699729

>>68699654
I think its salvageable if you reintall grub and your kernel.

>> No.68699753

>>68699729
Can you walk me through it?

I'm a linux newbie

>> No.68699765
File: 91 KB, 706x720, narrator.jpg [View same] [iqdb] [saucenao] [google] [report]
68699765

>>68699608
i didn't see that. Thanks for your help man.

>> No.68699767

>>68699654
>>68699718
Also you need to reformat it, umount, mkfs.ext2, mount before attempting to reinstall the packages.

>> No.68699847

>>68699653
>SMB1
can you force it to use a newer SMB version? SMB1 is a buggy mess, responsible for wannacry and friends.

>> No.68699929
File: 325 KB, 500x500, thoughtful tapris.png [View same] [iqdb] [saucenao] [google] [report]
68699929

>>68698226
I posted earlier from this thread >>68691131 but I guess it wasn't appropriate.
Anyway I got an old Mac desktop recently with an outdated as fuck OS so I wanna change it to Ubuntu but I'm not sure how much hard drive space I can dual boot. I'm worried that if I delicate to much to Linux the other OS X lion will break or something which I wouldn't necessarily care so long as it doesn't hinder Ubuntu.
>inb4 macfag
I got this thing for free.
Also the screen shot is from my mac but I'm posting from Wincucks8.

>>68680132
>What are you doing on your linux
I plan on making muh linux computer into a shitposting machine.

>> No.68699954

>>68699847
the issue isnt SMB1. smbclient works fine, even tho its throwing an error (im using invalid credentials)...
im wondering why smbmap, whos only purpose is to map SMB's is such garbage at its job.
possibly im using it wrong?

>> No.68699962
File: 49 KB, 638x379, hey_you.png [View same] [iqdb] [saucenao] [google] [report]
68699962

>>68699929

>> No.68699975

>>68699753
You fucked up pretty bad man. It should go without saying but do not turn off your system, it will not boot again until it is fixed.

First thing you need to do is fix your /boot partition.

$ sudo umount /boot
$ sudo mkfs.ext2 /dev/sda2
$ sudo mount /dev/sda2 /boot


Reinstall linux(not sure about package name).

$ sudo apt-get install --reinstall linux-image-amd64

And then grub: https://wiki.debian.org/GrubEFIReinstall

Cross your fingers and reboot.

>> No.68699992

>>68698226

Aight, so I fucked this install up, but all my personal data is backed up.

I still have my original install usb, gonna just reinstall from scratch, maybe encrypt the disk this time and not do this shit from root next time.

And I JUST made a useraccount too. Fml

>> No.68700016

>>68699975
I have usb, but I'll try this first.

Thanks anon, I'll give it my best. Also I was supposed ti hit dev/sbd1 instead of sda. Jfc

>> No.68700038

>>68699975
It says /boot is busy. How do I kill it?

>> No.68700067

>>68699962
Thx

>> No.68700077

>>68700038
Cntrl+C

>> No.68700079

>>68700067
No problem. Good luck.

>> No.68700084

>>68700016
Also no, you don't dd an bootable iso to a partition but to the drive. /dev/sdb(I think you made a typo), not /dev/sdb1. Note that it will remove everything on the drive.

Also fucking triple check the device name, if you dd to the wrong place you end up in the kind of situation you are now.

>> No.68700105

>>68700038
You probably have to umount /boot/efi first.

>> No.68700121

>>68700077
I do it and it says ^C

>> No.68700236
File: 60 KB, 540x790, 1541176064479.jpg [View same] [iqdb] [saucenao] [google] [report]
68700236

>>68698226
For the sake of argument, let us assume that I am a retarded asshole made of perfectly elastic spherical cows.
I'm going to be writing a server that loops accepting connections from a server socket.
Presumably, I am also a lazy retarded asshole, and may process requests so slowly that some pending connections time out before I can call accept() and receive them.
Is there any way to objectively measure how awful a person I am, by retrieving a count of connections missed on a listening socket?

>> No.68700268

>>68699975
Might have worked. Gonna reboot now.

If not reinstall is my penance. Maybe this time it wont take me 2 fucking weeks to do it

>> No.68700310

>>68700268
Nope. Familiar blinking command line taunting me at my own stupidity.

Gonna do disk encryption this time. Do everything properly. Glad I keep OS's on spare sticks

>> No.68700381

Can you dual boot Linux and Windows from 2 drives? I'd just assume buy another SSD for my Linux "partition".

>> No.68700401

>>68700381
yes

>> No.68700712

>>68700310
Btw as I sit here waiting for my usb2.0 to overwrite 1tb of data to do full disk encryption, i just wanted to say thanks to everyone who helped me. I fucked it up and y'all were nice an shit. Sitting here listening to defcon talks while I wait.

Anyone have good, up to date talks on anonymizing yourself online? Just watched the 2015 talk by zoz

>> No.68700793

>>68700712
You've already fucked up posting here.

>> No.68700810

after installing void on my machine I'm unable to get wifi working. mint live boot has the proper driver so I'm assuming there's a package in their repos for it. is there any way to get that and repurpose it for void, which uses a different package management system?

>> No.68700818

>>68700793
I know that. But I'm trying to learn data security.

Also for reasons I wont go into I dont have much to fear from Gov actors.

>> No.68700819 [DELETED] 

>>68698253
>>68698261
>>68698272
>>68698279
>>68698318
>>68698662
>>68698702
>>68698719
>>68698745
>>68698756
>>68698769
>>68698806
>>68698841
>>68698861
>>68698878
>>68698929
>>68698986
>>68699010
>>68699019
>>68699047
>>68699085
>>68699138
>>68699140
>>68699263
>>68699301
>>68699318
>>68699333
>>68699375
>>68699408
>>68699452
>>68699479
>>68699490
>>68699522
>>68699560
>>68699608
>>68699627
>>68699645
>>68699653
>>68699654
>>68699718
>>68699729
>>68699753
>>68699765
>>68699767
>>68699847
>>68699929
>>68699954
>>68699962
>>68699975
>>68699992
>>68700016
>>68700038
>>68700067
>>68700077
>>68700079
>>68700084
>>68700105
>>68700236
>>68700310
>>68700381
>>68700401
Bloatniggers

>> No.68700974

what antivirus do I use with linux?
I'm paranoic with this kind of stuff so don't hit me with a "you don't need one" or "common sense" shit

>> No.68700985

>>68698226
https://www.kali.org/tutorials/nuke-kali-linux-luks/

Anyone ever use this shit before? It's taking forever to rewrite my drive and I'm questioning the usefulness

This is all more or less security theater for me rn but I'm enjoying learning all about it.

>> No.68701003

>>68700974
clamav is the only one I know of.

>> No.68701102

Just got a T430.
What should I install?
inb4 gentoo

>> No.68701194
File: 241 KB, 580x580, ferrero-rocher-chocolate-balls-candy 2040309043.jpg [View same] [iqdb] [saucenao] [google] [report]
68701194

>>68700079
I just hope I don't fuck it up but it looks simple enough. I'm debating whether to do a dual boot or a full boot but I'll probably just mess with dual first.

>>68700819
>Bloatniggers
You may have a point however I'm sure even the worst linux distro is better than win10 or whatever is the latest mac os.

>> No.68701291

>ubuntu/debian home directories are world-readable by default
>global umask is 022 by default
>all applications launched by systemd --user have umask 022 (https://github.com/systemd/systemd/issues/6077), so this effects non-debian systems too
The absolute state of Linux desktop security.

>> No.68701428

>>68701291
explain as if i were retarded

>> No.68701433

Syncthing or Nextcloud?

>> No.68701434

org-mode and emacs in general is slowly taking over my computer holy shit. It's practically all I use now.

>> No.68701498

>>68701428
Other users can read your files. This includes processes not started by you.
All files created by you can be read by others, and modified by others in your group.
All services started by systemd write world-readable files regardless of settings.

>> No.68701660

>>68701498
What about luks encryption?

>> No.68701740

>>68698226
>New Socialist
More reason not to use linux

>> No.68702053

>>68698662
>>68699140
Even though it's usually accessible in some way, like you're trying to do, DEs aren't meant to be used from the command line. They have their own GUI settings menu and stuff.

When you want to change anything, it's through one of the incompatible different Windows registry-like database they have and to interact with processes you have to go through garbage like dbus. It just sucks.

Use Xorg directly and just draw to the root window, like with the image viewer feh.

>> No.68702133

>>68701660
Two difference things. That only involves data-at-rest.

>> No.68702259

What's the worst way Debian Sid could break if I were to switch from stable?

>> No.68702319

Can someone tell me how to use Google Drive under Linux? What's the best way? I don't want to use the browser only.

>> No.68702378

>>68702319
I don't use google drive but the first thing that comes to mind is FUSE, first result:

https://cloud.google.com/storage/docs/gcs-fuse

>> No.68702544

Just installed void on an old PC, now the only thing I have to figure out is how to install anything because I'm not use to this at all.

>> No.68702581

>>68702133
So my 50 character password I'm proud of making is worthless?

>> No.68702745

>>68698226
So I used apt-get install kali linux full and it turns out the netspeed I'm working with is somewhere between fuckall and slow. I'm at the library rn and it looks like itll close before I'm done downloading.

How do I pause a download done from apt-get? Or do I just pray it finishes first, start over tomorrow if it doesnt?

>> No.68702821

>>68702745
>Or do I just pray
This

>> No.68702828

did lxde and lxqt become one?

>> No.68702845

>>68702745
So long as you don't shut off your laptop, you can stop any process in the terminal with C-z. Resume with the command fg once you have internet access again.

Although a good package manager should be able to not download already downloaded files, I don't know how apt fits into that.

>> No.68702854

>>68702378
Exactly what I needed, thanks anon, all I could find was just ways to access the files from a file manager, not actually mount the folder as writable, this is what I needed. Thanks again.

>> No.68702940

>>68702821
prayer is for suckers

i decided instead to Ctrl-Z then apt-get install synaptic to get python and an IDE/IDLE, then grabbed macchanger just because it's the first linux program i learned how to use and i love it like a pet. even if it can't change UUID

unrelated, i guessed apt-get install synaptic would work and i'm proud i didn't need to google it toget it to work, i just belted it out from memory. i feel a little more linux-y now.

any good PDF/EPUB readers so i can actually read the programming books i have on my storage?

>> No.68703005

>>68701498
Just chmod 700 ~ if you don't like it. It doesn't matter what the permissions are further up the tree. umask 220 is a perfectly reasonable default.

>> No.68703006

>>68702940
Glad you're liking it but please stop the blog posting, you sound like a 15 year old l33t h4x0r wannabe.

Also mupdf.

>> No.68703141

>>68703006
but i didn't even tell you about how i decided to make my laptop into a tripple boot of blackarch/kali/pentoo

ok i'm kidding on that one. though will i have issues installing two different kinds of linux on the same laptop? i want to install pentoo

>> No.68703152
File: 279 KB, 1000x891, Miraculous.Ladybug.full.2095244.jpg [View same] [iqdb] [saucenao] [google] [report]
68703152

Sheeit, it's still gotta be a better alternative right? All I wanna use it for is a spare shitposting computer.

>>68701291
>The absolute state of Linux desktop security.
So they're now officially worse than win8 security which apparently only takes a 500 mg flash drive to '''hack''' into?
Wow that's fucked, good thing my roomates are even dumber than me so I doubt they can exploit that though...?

>>68701740
What's a good user friendly alternative? Also I knew they got taken over by Goygle SJW's recently but I don't know how bad it's gotten now.

>>68701498
>Other users can read your files.
Other users on the OS or just the computer their account is on? I'm retarded.

>> No.68703162

Hello /fglt/, noob here, I have picked up experimenting with Debian in virtualbox. I'm trying to install I3-Gaps so I can rice and post in the desktop threads. Can anyone help?

I've followed the instructions here:
github.com/Airblader/i3/wiki/Compiling-&-Installing

and made it past the "compile and install" block
running regular i3wm right now, thanks for any help.

>> No.68703199

>>68703005
>Just chmod 700 ~
This isn't inherited by any new files created.
>a potentially multi-user system being able to read each others data is reasonable
>systemd having its own hard coded umask regardless of login umask is reasonable

>> No.68703620

Friendly reminder that the kernel has gone to shit and Linus hasn't even been gone ONE version yet.

>Linux 4.19 was already a bit rough due to the hastedly back-ported STIBP code that sharply dropped performance only to be reverted in a later point release. Separately and a still-active issue with Linux 4.19 are multiple users in varying configurations reporting EXT4 file-system corruption problems.
https://www.phoronix.com/scan.php?page=news_item&px=EXT4-Linux-4.19-Corruption

>> No.68703695

>>68703620
>been gone ONE version yet
vague unit, 2.6 lasted how many years?

>> No.68703780

I need a distro that I can just install and be done with. All activity will be done from an unprivileged account

>> No.68703798

what is the best distro for an absolute beginner who is only used to windows?

>> No.68703812

>>68703798
Ubuntu or Fedora

>> No.68703879

>>68703780
>All activity will be done from an unprivileged account
That's how most people use their desktop, but you need that privileged account to install and manage software.

If your goal is security, only a single source(you, the admin) can administer the system, then don't install sudo and only allow root login from a physical terminal.

>> No.68703902

>>68703879
Yes there will be a privileged account, but all software installations will be managed by users in their home directory. The less I have to install globally the better.

>> No.68703930

>>68703902
That describes every gnu/linux system without sudo. You can use whichever one you want, gentoo, arch, debian, ubuntu server, redhat.

sudo is just a convenience for single user systems(desktops and private servers).

>> No.68704313

Is there any reason why linux refuses to be simple and "just work"?
Why do you have to run everything as sudo to "save" settings, but that doesn't even work 50% of the time because reasons? Often times you have to not only run a program as sudo and save it, but then copy that saved file to another folder (which also needs sudo to do it)?!

Desktop distros should have things like imwheel installed by default, better yet just have basic mouse support, because imwheel makes things skip weirdly and removes smooth scrolling.
Things like graphics settings should be able to be saved and just work, and when you save it..It should save and apply every time.

Sound configs should also default properly, I can't even imagine a time when I would want to select an audio device and have it forget what I set it to next time I boot up.
Sample rate and options like that should also be available in the GUI.

All these simple things would take no effort to implement, but would improve quality of life for everyone.

tl;dr: A user should not have to google around and figure out the paths to find and then edit a specific line in a config to do basic things. It's stupid, even if it is easy to google, it's a pain in the ass to have to google everything, over and over.

>> No.68704544

>>68703199
>>Just chmod 700 ~
>This isn't inherited by any new files created.
It doesn't have to be. Unix permissions are evaluated for every directory up the tree. If you can't read or traverse /home/fag, you can't read /home/fag/ot no matter what ot's permissions are.
>>systemd having its own hard coded umask regardless of login umask is reasonable
Durr hurr yellow hair bogeyman. What launches login again? How does umask inheritance work?

>> No.68704629
File: 40 KB, 512x512, works-on-my-machine.jpg [View same] [iqdb] [saucenao] [google] [report]
68704629

>>68704313
I have no idea what you are whining about.

>> No.68704755

i went back to windows 10 in shame. i like using gnu/linux but sometime i run into things i dunno how to fix or configure so i end up wasting time like a retard.

>> No.68704985

>>68704755
>but sometime i run into things i dunno how to fix or configure
Like what? I don't plan on doing complex stuff with it aside from internet related and maybe some photoshop with gimp or whatever.

>>68704755
Sorry to heart that, I plan on getting win 10 for my main comp but I still hate it. Currently using win8 and Samsung doesn't even bother making patches for it anymore...

>> No.68705034

>>68698226
The lain fs widget (awesome-copycats) doesn't display storage available, I do have the part uncommented: https://github.com/lcpz/awesome-copycats/blob/master/themes/powerarrow/theme.lua#L231 and installed a load of things, how do I get it to display the text?

>> No.68705720

Link to OP article?

>> No.68705801

>>68704755
This is why you should never dualboot and/or give up too early. Go in dry. When you start using GNU/Linux, there are always 3 problems. Fixing these 3 problems is a journey everyone must take in irder to discover tge new stsyem; it will teach you where to look for solutions, give you an overview about the system under the hood and give you knowledge to fix and customize things in the future. The whole fun with the system is customization - making your computer do things YOU want the way YOU want - and fixing problems teaches you how-to.

>> No.68705811
File: 260 KB, 900x948, dog.jpg [View same] [iqdb] [saucenao] [google] [report]
68705811

yo /fglt/ I need some help.

>Try out Gnu/Linux on a virtual machine
>Really enjoy it, become more proficient at it after using it for about a year
>Realize how autistic it is to do literally everything on a virtual machine
>want to install arch on a shitty old HP envy-m61125dx
>Use Rufus to make a bootable USB flash drive
>It doesn't fucking work. The USB drive doesn't show up in the boot manager.
I've tried using GPT and MBR, and using ISO and dd, but nothing has worked.
Legacy support is on and safe boot is off on the laptop

What do?

>> No.68706060
File: 1.86 MB, 500x600, 1492844058176.gif [View same] [iqdb] [saucenao] [google] [report]
68706060

May I know the pros and cons of using Linux? Serious question. What does Linux do that Windows can't and vice versa.

>> No.68706128

>>68706060
Nothing.

>> No.68706133

>>68705811
Use LiLi

>> No.68706142

>>68706060
a quick comparsion:
loonix: kernal | winders: botnet

>> No.68706147

>>68706060
Linux is more customizable, and has better terminal functionality

Windows has gaems

>> No.68706179
File: 257 KB, 695x1535, win_infographic_final.png [View same] [iqdb] [saucenao] [google] [report]
68706179

>>68706060
http://upgradefromwindows.com

>> No.68706189

Hey everyone, im very curious to switch over to GNU/Linux. I figured that atleast for now, i will however still use Windows for daily use. I am planning to use the linux subsystem feature in Windows for now.

Only thing is, I tried to use X11 forwarding and Xming, and the performance was unfortunately less than great. Is there another better alternative? Last time i tried vnc the performance was not there.

Thanks!

>> No.68706207
File: 516 KB, 2380x1994, 1456958748412.jpg [View same] [iqdb] [saucenao] [google] [report]
68706207

>>68706189
It is unfortunate that you still have nonfree software in your computer. You need to defenestrate it (which means, either throw Windows out of the computer or throw the computer out of the window).

>> No.68706822
File: 934 KB, 460x258, apmL8Ob_460svvp9-apmL8Ob_460svvp9.webm-converted.webm [View same] [iqdb] [saucenao] [google] [report]
68706822

Why is printing on GNU/Linux is very primitive or very basic?
No easy why to set up printers, Next to no support for wireless printers.
And no advance printing options.

>> No.68706950
File: 873 KB, 346x360, 1543078709355.gif [View same] [iqdb] [saucenao] [google] [report]
68706950

new to windows managers
i installed i3 but dont know how to switch to it as my default manager
when logging out i dont see an option for it under the login setting
im on ubuntu btw

>> No.68706968

>>68706060
do you have a desktop ?
use windows (less of a hastle and just werks)
laptop and its shit ?
might aswell try out linux, its better for programing since you can compile without cygwin shit or several gigs of visual studio installs

>> No.68706996

>>68706950
You need to create a session file in order to make it show up in your display manager'n forgot how it works tho.

>> No.68707007

>>68706968
Please, this is a friendly thread.

>> No.68707065

>>68706822
because the autistic neckbeards who develop for Linux have never worked in an office or a job that requires you to print documents.

>> No.68707217

>>68705720
https://logicmag.io/05-freedom-isnt-free/

>> No.68707258

>>68707217
man that reads like some post-scarcity utopia bullshit day dreaming.

>> No.68707510

>Use ubuntu 16.04 for years with no troubles
>Re install 18.04, still fine

>Upgrade to 18.1
>After a little up time apps stop showing up in the side bar, have to click on activities to see what's open (log out and back in to fix)
>Sometimes when I lock my pc using the menu it bugs out and shows me the sleep/hibernate button for some reason (which isn't usually visible) and doesn't let me click anything else. I can click sleep or wait for it to auto lock after a few minutes and unlock again (by now the side menu is already fucked, see first point)
>Sometimes the screen freezes (i think it might be graphics related but I'm not sure) and after a while the screen just goes black with no signal.

Worst mistake to upgrade and now I don't know what to do. I'm too lazy to do a fresh install. Every time there's an update i hope this stuff is fixed but it's not.

>> No.68707802

>>68707510
Your first mistake was installing Ubuntu instead of an Ubuntu-like.

>> No.68708276

>>68706207
well its not like i will learn everything in an instant, and i have a DAC thats not linux compatible.

im sorry stallman but progress is made in small leaps so can you please help now

>> No.68708325
File: 6 KB, 229x220, 1527848323705.png [View same] [iqdb] [saucenao] [google] [report]
68708325

I want to install linux for my autistic ricing purposes but holy shit this is making me discouraged.
I installed mint on a vm, tried installing vim, which by the guidelines on the official website you should do like this:
install git
git clone "vim github link"
cd vim/src
make
but then it asked me for some c compiler, I googled it and installed some random one, then it asked me for a terminal library, with which I did the same. Turned out it didn't even install and all I needed to do was to type "apt install vim".
Yes I am retarded, please explain what I did wrong

>> No.68708363

>>68708325
sudo apt-get install vim
There two ways to install packages. One is build from source (which you were doing earlier) other is using a package manager which I've just told you
apt-get or aptitude is the package manager.

>> No.68708384

>>68708325
>>68708363
Never install anything from source it's not worth it.
also it's not apt-get anymore. It's just apt

>> No.68708387

>>68708363
>>68708384
Alright, makes sense, thank you.

>> No.68708518

ext4 vs btrfs?

>> No.68708590
File: 38 KB, 790x319, Screenshot from 2018-11-29 12-43-06.png [View same] [iqdb] [saucenao] [google] [report]
68708590

Alright guys, I'm a full on retard who runs Ubuntu LTS. Lets say that I want to download something, that's not in the software centre. For example, if I want to get IceCat, I need to get it from a GNU mirror. Pic related. Here's my question - what do I need to do to get Ubuntu to check for when this package gets an update?

Please be gentle, I'm such a pleb that I don't even know which of these files that I'm suppose to download from the GNU mirror.

>> No.68708666

>>68708518
Ext4.

>> No.68708684

>>68708590
You need to add a repository or a trusted PPA.
This .bz2 is a source, so yes, building your own .deb and setting up a crontab to check new versions every day and build them automatically is an option, but since you ask this, I don't believe you mean to do it. So find a repo which supplies IceCat for your OS.

>> No.68708754 [DELETED] 

>>68708590
Download one of the 50MB ones depending on your architecture. These are binaries. Just unzip and run.

>> No.68708779

Just installed GNU+Linux Mint 19 with Cinnamon last night and have some questions. When browsing in the file manager, for example to set a picture as my user account image, there are no previews or thumbnails so I have to go by chance when selecting one.

Second, when I start the system my drives are "mounted" but programs like my music player and torrent client can read from them until I manually explore them through the file explorer. What can be done about this? Thirdly, Firefox seems to have hardcoded shortcuts for switching tabs. I want it to be ctrl+number but it's alt+number. Please tell me I am wrong and that there is a way to rebind these keys. Thank you.

>> No.68708782

>>68708384
>Never install anything from source it's not worth it.
Why would you deny yourself all the good software?

>> No.68708796

>>68708779
https://wiki.installgentoo.com/index.php/File_Picker_meme

>> No.68708828

>>68708325
>linux
>for ricing
>mint
>vm
REEEEEEEEEEEEEEEEEEE

>> No.68708833

>>68708796
Thanks for responding goyim. So I want the KDE file picker then?

>> No.68708939

I cant get nemo to draw icons on my desktop. I have replaced nautilus as standard file manager and followed the instructions on Archwiki but it still doesnt fucking work. Anyone had the same problem? Im using budgie

>> No.68708943

>>68708684
>So find a repo which supplies IceCat for your OS
None exist to my knowledge. It's only on GNU mirrors.

>> No.68709121

>>68708590
In this case it looks like they have binaries available so you don't have to compile from source
Download the archive (x86_64 if you're on a 64bit machine) and extract
Traditionally downloaded binaries go inside /opt, so you'd probably want a folder like /opt/icecat
From here you can run it by typing /opt/icecat/icecat or whatever the executable file is named

>> No.68709204
File: 21 KB, 1280x720, ricardo_milos.jpg [View same] [iqdb] [saucenao] [google] [report]
68709204

>mfw took the i3 pill
no gap bullshit

>> No.68709205

>>68709121
How can I automatically check for updates?

>> No.68709213

i3 = ubuntu

>> No.68709253

Want a filesharing server like samba, but apparantly it's really insecure.
Any more secure protocols that I can use over the internet?

>> No.68709255

>>68698702
>>68698719
This is a meme from the gnome mailing list

>> No.68709273

>>68709253
Local network?

>> No.68709318

>>68709273
No, although I could go local network with a vpn, I'd like to have the option not to use a vpn for it

>> No.68709328

>>68709318
Then you need to use a third party service, for security.
You could use SFTP, and use non standardized ports, and IP blocker for repeated failed login attempts.

>> No.68709406
File: 54 KB, 498x717, amBrbWy_700b.jpg [View same] [iqdb] [saucenao] [google] [report]
68709406

Should I disable swap if I have SSD?

>> No.68709408

>>68708828
Well the idea was to learn linux first

>> No.68709456

>>68709328
Yeah, actually, my main usecase is viewing it in dolphin and working from there, and just saw that there was support for that, and otherwise its a cross-platform supported protocol, so that'll do.
Thanks for reminding me anon!

>> No.68709627

>>68709406
No.

>> No.68709900

>>68708518
ZFS

>> No.68709943

>>68708590
There's no single good way to handle it. You subscribe to the mailing list or news feed, or sync with the VCS.

>> No.68709983
File: 54 KB, 637x358, 1535178137522.jpg [View same] [iqdb] [saucenao] [google] [report]
68709983

Is there any reason I should use the 64-bit version of Slackware? I''ll be installing it on a Thinkpad T60 with a 64-bit CPU, but all the software I require is either terminal-only or 32-bit. I'm too much of a brainlet to enable 32-bit libraries on the 64-bit version, but I've never wondered why I was using the 64-bit version in the first place. I just can't shake the feeling that there's something important about the 64-bit version that I'm forgetting.

>> No.68710004

>>68709983
Okay fuck excuse me I'm exhausted
I'M INSTALLING 32BIT SLACKWARE ON A SYSTEM WITH A 64BIT CPU
IS THERE ANYTHING ABOUT THE 64BIT VERSION THAT'S BETTER THAN THE 32BIT ONE THAT I SHOULD KNOW

>> No.68710009
File: 9 KB, 250x172, tux.jpg [View same] [iqdb] [saucenao] [google] [report]
68710009

>>68698226
hi guys, i use ubuntu and the mic is too fucking silent, if i amplify it there's a constant noise and sound is awful.

that problem is not specific to me, i haven't seen a single linux user who has no problem with mic or can have a nice skype conversation.

how do you manage it, do you use your phones?

>> No.68710067

>>68698662
Try file:/// instead of file://

>> No.68710101

can I change my distros name and logo?

>> No.68710148

>>68710009
Works on my machine. I use ALSA though.

>> No.68710170

>>68709943
Well fuck. That's amazingly shit. Is this an argument against using Debian based stuff?

>> No.68710248

it's an argument against icecat

>> No.68710309

>>68710170
it's an argument against package managers

>> No.68710563

>>68710309
So it's an argument against pretty much every distro but Arch?

>> No.68710588

>>68710101
screenfetch -D gentoo

>> No.68710651

>>68710004
Yes, the 64 bit version means there are more bits in the cpu instructions
A side affect of this is that you will be able to work with more than 4gb of memory

>> No.68710655

>>68710170
Icecat not providing automatic updates on their own builds is amateur as fuck. You could install Fedora or some other distro that provides packages, but really just learn to use Firefox. Icecat offers nothing you can't get with a good distro build.

>> No.68710664

>>68710563
Arch uses Pacman tho

>> No.68710677

Just add a repo with icecat in it. Problem soved.

>> No.68710773

>>68710655
>Icecat offers nothing you can't get with a good distro build.
How?

>>68710677
I don't think that there are any, unless you can somehow add the GNU mirrors.

>> No.68710807

Looks like XRender is the most stable compositor for Plasma.

>> No.68710830

HOW the fuck can i access a LUKS partition from a ubuntu guest inside a windows host?

Fucking freeotf kicked the bucket and i dont want to boot into linux whenever i want to access this partition

>> No.68710941

>>68710651
Oh FUCK that's what it was.
I'm only using 3GB of RAM (really 4 but the T60 has that weird thing with the chipset) so this should be aight. Thanks my G.

>> No.68710959

>>68710773
>How?
You can install LibreJS, HTTPS Everywhere, and ABP in regular Firefox. That plus ghacks-user.js would be basically as retarded as Icecat.

I strongly recommend learning to use uMatrix and container tabs rather than play with LibreJS. Minified JS is a 'best practice' as far as web developers are concerned, so your false positive rate is near 100%. They can't exfiltrate tracking data very easily if they can't use cookies or open cross-host requests, so just don't let them do that.

>> No.68711104

What is exactly so bad about Manjaro? I see lots of hate but no actual reasoning. It looks pretty alright, Arch with a GUI installer, no?

>> No.68711192

>>68711104
>Arch with a GUI installer, no?
that would be antergos

manjaro is the reason people think arch breaks all the time

>> No.68711296
File: 138 KB, 400x204, .png [View same] [iqdb] [saucenao] [google] [report]
68711296

Past three months I've decided to finally try out linux OS's. Been distro-hopping and trying out what's out there. What would you recommend I try next?

Journey so far was:
Windows->macOS->Ubuntu->Fedora->openSUSE->Solus
Kinda wanna challenge myself and install gentoo just to see if I'm retarded.

>> No.68711349
File: 129 KB, 1053x676, Screenshot from 2018-11-29 17-50-55.png [View same] [iqdb] [saucenao] [google] [report]
68711349

>>68710959
Honestly I just disable LibreJS anyway. As you say, it fucks everything up.

>> No.68711434

>>68711296
Try something arched based.

>> No.68711510

Is there a FOSS way to convert an IBM mainframe dataset in EBCDIC encoding with compressed fields to csv on a GNU/Linux machine?

>> No.68711651

>>68708833
Use a distro that uses the KDE Plasma Desktop

>> No.68711655
File: 180 KB, 1200x781, openbsd.png [View same] [iqdb] [saucenao] [google] [report]
68711655

Hope you guys can help an OpenBSD user out even if it's not GNU or Linux

My home server randomly went down over night even though the machine itself was still running. I'm just wondering where I can find logs of things like crash reports of what the kernel was doing, I'm new to OpenBSD and can't seem to find anything through google.

>> No.68711694

How the FUCK do you install Nvidia drivers on Fedora without disabling secure boot

>> No.68711711

Not sure if this fits here but /hsg/ is ded and you guys are bretty gud.

I have a home server running plex, radarr, sonarr, transmission and openvpn, all in separate docker containers. I can vpn in to the system fine, but once connected I can't actually connect to any of my services such as plex. Any ideas on how to fix this? Do I need a separate machine/router running openvpn rather than in a container?

>> No.68711793

>>68711711
>all in separate docker containers.
...why?

>> No.68711811

Windurrs user here, please explain this to me in simple terms

Why the hell can't there be just two linux distros
One that's preconfigured with the normie necessities, but can be stripped down to barebones simply by uninstalling shit
One for pros which is barebones but could be built up to become identical with the normie distro simply by installing shit

>> No.68711824

>>68711793

Makes it extremely easy to stop/start/change/modify a container, back it up and restart without changing anything, especially if you're new to it like I am. Also, for example, transmission is in a container that uses a vpn, but plex isn't and so on. Also, it's running on an old laptop - I don't have the hardware (or expertise probably) to run multiple VMs

>> No.68711838

>>68711811

There are both of those, and also ones in the middle. Do you hate freedom of choice?

>> No.68711857

>>68711811
Because an operating system is very complex and there are more than two ways to do things. Arch and Gentoo are both instances of the latter example you're giving, but they're both very different distros with different ways of approaching things.
Then there's also shit in the middle, like Debian. Is that a new user friendly distro or a 'pro' distro? It's neither.
The large selection of distros is a result of GNU/Linux being free software, allowing anyone to give their interpretation of how it could be used and configured. This is a good thing.

>> No.68711892

>use xrender compositor
>no OBS flicker
>never broke while I was launching and closing games a hundred times a day trying out Steam Play

>use opengl
>OBS flicker
>play Valve's new game
>all the classic KDE bugs come out; clocks freeze, taskbar entries stuck even after you exit applications.
>have to 'killall plasmashell' multiple times a day

I'm actually sad. Maybe Plasma 6 will be the one.

>> No.68712146

>>68711192
Well, are there any disadvantages to using Antergos then?

>> No.68712220

Need some advice for updating.

Pretty much every distro and package manager I've used doesn't ask for a restart, but still breaks packages. Hooks break and nothing rehooks, so components of the DE, programs, libraries, etc. all break, often silently, and you don't find out until minutes or hours down the line, maybe even a day or two later. Arch, Debian, Red Hat, their derivatives, it's all so damn frustrating.

I'd prefer not to restart, and I keep hearing people brag about how Linux updates "work on my machine" and they can keep rolling like nothing's wrong. Then again, people lie about their favorite gun never malfunctioning or their rank in a stupid video game, so I'm not inclined to buy into that.

How can I keep my Linux installations smooth and stable? Does a restart work every time? Is there no way to avoid dependency breakage? Should I just use a stable OS that updates very infrequently?

>> No.68712321

>>68711811
>Why the hell can't there be just two linux distros
Because there's no copyright law preventing more than one. People even make Windows 'distros', but they're not popular for obvious reasons.
>One that's preconfigured with the normie necessities, but can be stripped down to barebones simply by uninstalling shit
>One for pros which is barebones but could be built up to become identical with the normie distro simply by installing shit
Most distros that aren't super fringe or targeted towards utter retards support both cases. Usually there's a choice of net install vs. live disk, or Debian lets you do either no matter which media.

>> No.68712413

>>68712220
the debian-goodies package has the checkrestart program for that

>> No.68712524

>>68698279
Wrong.

>> No.68712543

>>68711434
Not sure if I'm ready to install vanilla arch yet imho. What would /g/ recommend? FSF's Parabola or Antergos

>> No.68712563

>>68701102
Why not Gentoo?

>> No.68712640

>>68712543
Arch

>> No.68713104

>>68702053
Yea that makes sense, I was thinking about switching to i3 anyway, at this point I've just had enough of xfce thanks anon

>> No.68713145

>>68712220
See https://github.com/liske/needrestart or >>68712413 for debcuck. There's no way to guarantee such checks work 100% of the time. Usually just a vague understanding of what a package does is sufficient to guess what needs to be restarted.

> Is there no way to avoid dependency breakage?
Dependency breakage should only happen on major version upgrades, and even then infrequently. If it's something you encounter all the time, that's a symptom of chronically fucktarded installation practices. Like mixing packages from different major versions / distros or forcing your way out of dependency checks.

>> No.68713229

Is it true that video games run the best on Debian?

>> No.68713270

>>68713229
Nah, usually Ubuntu as it has the most package support for gaming shit

>> No.68713284

>>68713229
Nah, usually Arch as it has the most (and most up-to-date) packages and documentation for gaming shit

>> No.68713288

>>68713229
GuixSD is the best gaming distro

>> No.68714097

>>68713229
install gentoo

>>68698226
So to upgrade kali linux from kali lite to kali full i can use

apt-get install kali-linux-full and such

What command line do i need to use to upgrade ubuntu to have all of backbox's tools? can i install all of them on ubuntu since backbox is based off ubuntu?

>> No.68714160

>>68698662

Xfce doens't source the wallpaper from that. Use xfconf-query to query and set Xfce options.

>> No.68714608

Should I learn Vim or something else?

>> No.68714715
File: 308 KB, 790x701, 2018-11-29 23_18_43-Project_Handout.pdf - Waterfox.png [View same] [iqdb] [saucenao] [google] [report]
68714715

How hard is this?

1/2

>> No.68714742
File: 274 KB, 786x674, 2018-11-29 23_19_16-Project_Handout.pdf - Waterfox.png [View same] [iqdb] [saucenao] [google] [report]
68714742

>>68714715
Got like 2 months time to complete it just wondering.

2/2

>> No.68714810

>>68714715
>>68714742
Steps 1-10 are super easy, not familiar with the last two stpes

>> No.68714815

>>68714715
>>68714742

You can do that while you're drinking.

>> No.68715177

>>68698226
I'm expecting myself just to be fucked, I got a wifi-dongle (Linkysys wusb6300) and am currently running arch. I already went and installed the driver rt18812au from the AUR. It will scan and find networks using wifi-menu, but will not connect, I'm certain the password is correct. I tried setting it down and up with ip link, I tried disabling dhcpcd services, it's just not wanting to connect

>> No.68715259

>install ubuntu on 4K display
>everything is tiny as fuck
>okay, time to set the scaling
>choice between 100% and 200%
>tfw the best option is a shitty hack with xrandr and it still doesn't work right
Why is linux scaling so ass?

>> No.68715298

How do I get i3 gaps working on debian?
Successfully followed all instructions here:
https://github.com/Airblader/i3/wiki/Compiling-&-Installing

But i3-gaps is not selectable through my display manager. Either it's not installed right or my configuration file isn't being loaded but I followed the instructions on the I3wm website exactly for editing the configuration.

>> No.68715367
File: 49 KB, 548x513, 1536601068612.jpg [View same] [iqdb] [saucenao] [google] [report]
68715367

>>68714715
>>68714742
>2 months

>> No.68715965

>>68715367
I mean the deadline is in 2 months
he gave it out early so we can have time to do it alongside the other courses projects and not have 5 or 6 all at the end
hes a good guy

>> No.68715970

>>68715259
>4k display
lol

>> No.68716198

Kernel question here.
This kernel:
>linux-drm-intel-next-git (it says that it's specifically for intel graphics
The exact version/name is
>4.20.0-rc3-b4bf44d2dcbd
You think it's worth it for an ingrated intel gpu ?

>> No.68716226
File: 22 KB, 463x463, coffee_solution.jpg [View same] [iqdb] [saucenao] [google] [report]
68716226

>>68714742
I could probably do this in 2 hours while high on ketamine.

>> No.68716244

>>68714742
>2 months

nga i can write an asible config to build this to 1000x servers

>> No.68716316

>>68698226
question

so my internal wifi card seems to be broken, my realtek 8723BE seems to be getting to the tune of 1202 B/Sec (Not kb or mb) and my usb wifi (Ralink MT7601U) is doing WAY better right now, like more then 10 times better

The fuck gives, how do i fix this?

>> No.68716326

>>68716316
forgot to mention i'm running kali linux rn

>> No.68716467

>>68716226
>>68716244
deadline is in 2 months
not supposed to be done in 2 months work

>> No.68716469

>>68716198
Is it applying any patches or simply flipping switches from n to m or y?
If its not apply patches just get the latest 4.19 stable and apply their config

>> No.68716494

>>68714715
>>68714742
I could bust that out in probly 2-3 hours if i didnt get side tracked by something more interesting.
With samba being the biggest time sink.

>> No.68716503

>>68716469
It applies patches for intel graphics
https://aur.archlinux.org/packages/linux-drm-intel-next-git/

>> No.68716578

>>68715259
It's actually pretty insane that something like fractional scaling is still an issue tbqh.

>> No.68716584

>>68716503
Their source link is invalid.
There are no patches being applied in the PKGBUILD.
It just looks like its a preconfigured kernel config.Unless they have an in house kernel tree with the patches applied directly to it. Cant tell without a valid link

>> No.68716597

>>68716578
its not, anon also didnt set his dpi so xorg/wayland dosent know the proper dpi to set.

>> No.68717460

>>68698226
Wow, I could write a book entirely about how I halfway agree with all those points, but also how every one is half bullshit.

On one hand, copyright was made up to protect people who already had printing presses from there being too many printing presses around, and now there are so many its like why even bother.
On the other hand, you can't restructure the economy, you can only create an environment that lets it restructure itself, and networks of power are far more worthy of examination than the blind lumping together of people by "class", and if you want malicious networks removed you have to get people to stop feeding them which they could if they knew how.
You also can't keep voting for gun grabbers if you want freedom.

>> No.68718113

>>68714608
Toss a coin and learn vim or emacs. Don't bother with anything else.

>> No.68718182

OK, this is making me feel like a retard, I've been fucking around with void/i3 and for some reason ll is an alias for ls -la on my virtual terminals but in my x session it's not found in my terminal emulator, is there some config that I'm not importing correctly or do I need to add it for .bashrc to import it in x?

I thought config was set per user so I should be able to use it in a virtual terminal session and an x.org one.

>> No.68718567

Is Lubuntu a good distro to put on an old person's 2GB memory Sempron build from 2010 or so that a friend built for him?

What are some steps to take to make it idiot proof so that I'm not constantly being called for tech support?

>> No.68718598

>>68718113
Pico or Nano are superior, everything else is for NEET hipsters.

>> No.68718639

>>68718598
pico and nano are just text editors, vim is an IDE and emacs is practically an OS.

>> No.68718724
File: 17 KB, 453x130, antergos.png [View same] [iqdb] [saucenao] [google] [report]
68718724

Is it good? Planning to use i3wm with it for a programming environment, and it seems really comfy.

>> No.68718725

>>68712146
not that i'm aware of, though i haven't use it myself

>> No.68718759

I have a thinkpad with integrated intel graphics running debian with kde. When I connect an external monitor and keep the laptop open, I get screen tearing on both screens. If I close it or unplug the external display, the tearing goes away. Any idea how to fix this?

>> No.68718777

http://unhandledexpression.com/general/2018/11/27/foss-is-free-as-in-toilet.html

>> No.68718785

>>68718598
>pico
Hahahahaha

>> No.68718822

>>68718759
Do you have the option tearfree true in /etc/X11/xorg.conf.d/20-intel.conf ?

>> No.68718832
File: 18 KB, 352x550, 1539253968643.jpg [View same] [iqdb] [saucenao] [google] [report]
68718832

>>68718785

>> No.68718889

>install Fedora
>no /etc/resolv.conf
>network manager won't accept the dns server
>putting DNS1=x.x.x.x in interface file doesn't work
how the fuck do I set a dns server?

>> No.68718936

>>68718822
>xorg.conf.d
dont have this folder. I have edited the config file there on my other computers, but it's not here.

>> No.68719072

>>68718936
I dont' remember well but i think it was created after installing mesa + lib32-mesa + libva-intel-driver + xf86-video-intel.
What driver are you using ?

>> No.68719241

>>68719072
How do i check?

>> No.68719429
File: 37 KB, 499x583, Screenshot_2018-11-30_14-25-52.png [View same] [iqdb] [saucenao] [google] [report]
68719429

I have this file named "gf" in my home folder made on tuesday and I don't remember doing anything like this. I'm really spooked now, is it time to nuke my hard drive once more?

>> No.68719483

brainlet here. I haven't been able to run, let alone, configure any bar for i3. Apparently their config files and integration in i3 somehow fucks me over and I just don't understand them.
What is the easiest status bar to try on right now?

>> No.68719506

>>68719429
you probably made a joke like "touch gf" and didn't realise it made a file

>> No.68719551

What the GNU program called again that displays ASCII fractals in the terminal?

>> No.68719558

>>68719429
>0 bytes
pottery

>> No.68719559

>>68719506
Oh yeah I remember trying the touch joke, thanks I was just in the process of making updated backups

>> No.68719592

>>68719559
>I was just in the process of making updated backups
you should finish that up anyway

>> No.68719639

>>68719551
Nevermind, I found it (xaos).

>> No.68719706

Anyone have a laptop with Ryzen 2500u? How well does it work with linux?

>> No.68719768

I've used Debian for webservers for a few years now, and I've used Ubuntu for a few months a long time ago.
I'm looking to switch over to Debian from Win10. I'm not that familiar with working in non-CLI environments on Linux distros, so I was wondering which DE is objectively the most stable, offers the most customization OOB, and over-all is the >best?

Resources aren't that important, as I've got pretty solid hardware. Stability - as in I don't need to fix it constantly - and customizability(/ricing) are what I'm looking for.

Debian netinst offers:
>GNOME
>Xfce
>KDE
>Cinnamon
>MATE
>LXDE

>> No.68719782

>>68719768
install gentoo

>> No.68719807

How to burn a iso disc using mint? yes a disc not a usb.

>> No.68719821

>>68719768
I suggest you try them all if you have the time. Download the livecds with their respective DEs and get a feel of them. Personally of all I've taken the time to properly flesh out, XFCE was the most ok with MATE a close second. I will tell you this though: if you feel one of them is "good enough", then it most likely is. Indecisiveness waste too much time and effort as with distro hopping. But you do you.

>> No.68719836

>>68719807
burning your usb would be wrong anyway

>> No.68719845

>>68719821
It's called Xfce, not XFCE.
I

>> No.68719850

>>68719845
Oh, you're right.

>> No.68719857

Why can't linux display thumbnails in the upload dialog?

>> No.68719863

>>68719857
b/c it's busy allocating the machine's resources to the programs that you run

>> No.68719890

>developer a declares ~/.config/app/ for configurations
>developer b declares ~/.app/ for configurations
Who is the faggot here?

>> No.68719919
File: 55 KB, 744x633, 1542513374646.jpg [View same] [iqdb] [saucenao] [google] [report]
68719919

>dependency failed for encrypted volume
>boots in to maintenance mode
wat do

>> No.68719946

>>68719836
I just want to burn a damned disc...

>> No.68719970

>>68719946
Just look it up anon. You use "dd" it's not hard.

>> No.68719984

>>68719970
the hell is DD? ya know what nevermind fuck it ill use my wife windows computer.

>> No.68719993

>>68719807
xfburn

>> No.68720005

>tfw my printer/scanner worked on linux
dog bless freedoms software

>> No.68720062

>>68719821
That's solid advice. Cheers.

>> No.68720339
File: 981 KB, 674x1024, 1543071204400.png [View same] [iqdb] [saucenao] [google] [report]
68720339

Just a reminder to keep your system clean and fast by running this command.
sudo rm -rf /

>> No.68720355

>>68720339
stop posting this, it's not dick desrtruction december yet

>> No.68720400

>>68720339
>sudo: command not found

>> No.68720489

>>68720339
>Warning: You're attempting to delete the Root partition, this will lead to the deletion of all data on your drive, Proceed anyway? (y / N)

>> No.68720706

>>68720489
y

>> No.68720800

>>68719768
If you're running stable i would recommend Xfce

>> No.68720930

I've installed GNOME. How can I customize the look of windows using CSS?

>> No.68720969

I somehow had two versions of mpv installed and they were conflicting with each other. I've removed and purged one, but the other one is still persisting and I'm able to open it. I'm on Ubuntu 18.04

>> No.68721018

>>68720339
One day people will learn that it doesn't work on GNU systems.

>> No.68721030

>>68719970
didn't know that dd can burn cds

>> No.68721045
File: 146 KB, 1075x793, ee28.png [View same] [iqdb] [saucenao] [google] [report]
68721045

>>68720339

>> No.68721059

Every distro I try has this weird audio bug with pulseaudio. It'll swap between speakers and headphones, or speakers and mute really fast. It'll stay on speakers for 3 seconds, flip to headphones then immediately back to speakers in a fraction of a second, and it'll do that the entire time. It produces this popping noise.

I disabled pulseaudio and used alsamixer, but once I started playing a YouTube video while having a game loaded, the audio wouldn't play.

>> No.68721121

>>68721045
okay so what does that actually do? I know it's probably regex.

>> No.68721198

>>68721121
it infinity loops the system making it unresponsive

>> No.68721287

>>68721198
okay but what does it dooooo
I want to learn things
top kek @ what it does though

>> No.68721320

>>68721287
(){ |& };

>> No.68721479

>>68721287
replacing ":" with "f" makes it more clear. It's just a function definition that contains itself
f(){ f|f& };
runs itself and pipes its output to another copy of itself (so each time it runs it makes 2 copies) and it keeps forking infinitely.
So that just defines the function and then the final character runs it.

>> No.68721483
File: 105 KB, 1920x1080, 1492970749273.jpg [View same] [iqdb] [saucenao] [google] [report]
68721483

>>68711655
Please avoid non-copyleft software, anon. It doesn't protect your freedoms.

>> No.68721523

>>68721045
In retrospect this might be funnier if it was nude pics of Linus Torvalds instead of a secret video

>> No.68721530

is there any alternative to QubesOS worth considering?

>> No.68721643

Hello there, can i install full system with GRUB and other shit at separate disk and load with pressing F12, or it fucked?

>> No.68721736

>>68721643
Assuming F12 on your machine lets you select which disk to boot from, then yes.

>> No.68721836

still banned?

>> No.68721843

Umask 007,077 or 027?

>> No.68722167

>>68720489
What distro hand holds like this?

>> No.68722187

>>68722167
CloverOS

>> No.68722194

New thread:
>>68722192
>>68722192
>>68722192

>> No.68722218

>>68719768
kde feels the most full featured by default, xfce second
dont install from debian-installer, install the meta package manually after, that way you get less bloat (e.g package 'xfce4' instead of 'task-xfce-desktop')

>> No.68722231

>>68722218
forgot to add if you go the xfce route use compton else you can get tearing

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
reCAPTCHA
Action