[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology

View post   

[ Toggle deleted replies ]
File: 42 KB, 650x300, ximg_58c0939c2d487.png.pagespeed.gp+jp+jw+pj+ws+js+rj+rp+rw+ri+cp+md.ic.5lDzHl2vQG.png [View same] [iqdb] [saucenao] [google] [report]
66272872 No.66272872 [Reply] [Original] [archived.moe] [rbt]

Is is not possible to scrill highlight in linux? In iterm2 i could scroll while highlighting to copy large sections of logs files, in ubuntu i have to use shift + - to zoom way out to select large areas and even that doesnt always fit. When i google it get i gey "nope dont work like that".

>> No.66272891

>i could scroll while highlighting to copy large sections of logs files,
fucking diversity hires.

>> No.66272923

Fuck off NEET had you ever worked a dev job you would have needed to send another dev a large section of logs or needed to copy them and place it in a text file for later reference

>> No.66272962

If you're perusing large log files why are you doing it off the bare shell rather than in your preferred text editor?

>> No.66272979

Doing it in less. In iterm2 i could ctl c and then scroll while highlighting. In ubutnu it wont scroll through the buffer while highlighting. Id just cat it but the logs are huge. I could tail -1000f but that is kinda gay i just would like to be able to scroll in less

>> No.66273040

works on my machine, just hold mouse button and scroll... what's the issue?

>> No.66273096

>i don't know how to grep and use stdout/stdin
>as a matter of fact I know nothing about unix-alikes

fucking diversity hires.

>> No.66273359

Everyone knows grep and stdout go pat yourself on the back somewhere else retard. Neither of those will resolve my buffer issues with less and likely will have the same scrolling buffer issue

>> No.66273395

>buffer issues
Get a load of this click n' drool diversity hire!
Learn sed/awk/grep and fuck off.

>> No.66273436

>just use a start and end expression to search for a 1000 line block instead of highlighting from less
No fuck off you have autism

>> No.66273437
File: 66 KB, 528x792, 1457921761338.jpg [View same] [iqdb] [saucenao] [google] [report]

Jesus Christ. You... You know absolutely nothing about Linux or GNU tools, do you?

This is sad. You're essentially asking us how to use notepad and calculator on Windows to balance your check book. /g/ is not your tier 1 technical support. Go read a book on Linux administration.

>> No.66273460

Not an arguement. Yes I asked how to fix scrolling in less, if you dont know anything about less then piss off idiot

>> No.66273487

>i can't get text out of a whole system designed around text.
You're a dumb fuck.

>> No.66273503

>I'll insult you so you giv homework answers!
Go read about unix tools and pipelining, pajeet. You know nothing about how to actually use your operating system.

>> No.66273521

I have the text already you idiot. I dont need to grep for it i need to enable mouse inputs in less

>> No.66273533

ps -ef | grep java. wow hard stuff. This doesnt solve my problem you idiot

>> No.66273542

>mouse input on a unix system
Get a load of this diversity hire!

>> No.66273575

>i dont know how to enable mouse inputs in less so use grep instead.
I said no

>> No.66273591

>needing mouse input in a terminal text pager!
holy fuck! you design software or are you a java monkey?

>> No.66273701

Set your terminal scrollback to a reasonable amount

>> No.66273750

I have unlimited scrolling, and can mouse wheel the entire file, but it will not scroll while highlighting

>> No.66273765

Not sure what crappy terminal emulator are you using OP, but it does work with urxvt.

>> No.66273808
File: 275 KB, 600x414, Peek 08-06-2018 15-43.webm [View same] [iqdb] [saucenao] [google] [report]

You mean this? It works for me.

>> No.66273816

use vim instead of a fucking pager.
:beginninglinenumber,endinglinenumber,w filename

mail --attach=- < filename

>> No.66273824


>> No.66273849
File: 178 KB, 288x415, 1517369393038.png [View same] [iqdb] [saucenao] [google] [report]

> He thinks that's Portuguese

>> No.66273881

>he thinks he's better than the huehues

>> No.66273882 [DELETED] 

idiot burger

El goblino...
El atrocidad...
La luz extinguido...

Era una noche oscura en el cerro de Ortega, solo se veían las estrellas brillar como chispas centellantes; cuando Doña Carolina decidió salir un rato a refrescarse en su pequeño patio cubierto con laminas y una enredadera de pasiflora que llenaba todo el techo y perfumaba la pequeña casita.

Salio de la cocina y se sentó en su hamaca tranquilamente; mientras su esposo Baudelio estaba ocupado arreglando sus cosas para al día siguiente irse a trabajar muy temprano en la mañana; todavía estaba arreglando su machete para que tuviera buen filo.

Cuando en ese momento Doña Carolina escuchó ruidos que venían del techo. De repente ella volteo al techo sin pensar, cuándo vio horrorizada como algo parecido a una mano movía las tejas con gran facilidad hasta tener un agujero cada vez mas grande; en eso la pobre mujer le grito a su esposo -¡Baudelio ayúdame algo esta en el techo!
Como su esposo sabia que ella le temía a las ratas no le dio importancia; pero Carolina vio que la criatura de repente paro de mover las tejas de barro y como se asomaba el ser con unos ojos centellantes y negros; ella grito de nuevo.

En eso su esposo finalmente se dio cuenta que algo malo le pasaba, cuando ella empezó a gritarle:-"Trae el machete"; Baudelio tomo el machete y corrió al patio, al ver el movimiento la criatura trato de escapar.

Pero Baudelio al ver que no estaba abajo con su esposa se fue corriendo con su lámpara de mano al techo y lo alcanzo a aluzar con su lámpara, en eso la criatura huyo de un brinco; los dos se quedaron boquiabiertos al ver a un ser que jamás habían visto.

Al día siguiente les daba vergüenza hablar de lo ocurrido la noche anterior pero otros vecinos hablaban de un supuesto ser que llamaban el goblino que andaba por la zona matando animales y también escucho platicar a otros pobladores que lo habían visto rondando el lugar buscando mas víctimas.

>> No.66273980

Yes. I cant do it. My scrill bar on the right is at the maximum size and it thinks there is no where to scroll

>> No.66274005

I cant do it in vim either, it wont highlight scroll

>> No.66274009


Diversity is our strength!

>> No.66274077

Ok i got it to work in vim i will just use thay next time

>> No.66274222

Try rope

>> No.66274280

Get help

>> No.66274386

Wow. So good. A basic comprehension of text tools.
Now how do you get that into a file without copy and paste?

>> No.66274491

>boss standing over you shoulder
>wants you to quickly copy and past part of a log and send it to him
>uh on second sir let me write a start and end expression for grep and pipe it in to a text file
>wtf is wrong with you just copy the fucking lines im in a hurry

>> No.66274581

ps -ef | grep java | xclip -selection c
so hard I know

>> No.66274614

Im not searching for java its an arbitary section of a log with a start and end

>> No.66274630

Why can't you just copy and paste what you want, scroll down and do it again? It doesn't take much time.
Even worms have enough of a brain to figure it out.

>> No.66274658

Doing thay 15 times takes a lot of time and is error prone. Anyways i am just going to cat the file i got it figured out stop replying

>> No.66274661

then have sed or awk print out those lines or open it in a graphical text editor like emacs, gedit, etcetera

>> No.66274694

>i am just going to cat
Why are you going to concatenate two files?

Linux users everyone.

>> No.66274739

Dude i already know this stop fucking bumping my thread i said i fugred it out an hour ago

>> No.66274745

command > file

>> No.66274980

Fucking congratulations. You still have no idea what you're doing.

Here's your participation trophy from 1995:

And of course, if you've been following along for a week or two, you know that this (BING!) is a Useless Use of Cat!

Rememeber, nearly all cases where you have:
cat file | some_command and its args ...

you can rewrite it as:
<file some_command and its args ...

and in some cases, such as this one, you can move the filename to the arglist as in:
some_command and its args ... file

Just another Useless Use of Usenet,
Randal L. Schwartz

>> No.66275089

>highlighting from less

holy shit this is golden, someone screencap this. Who let retard nigger monkeys post on /g/?
Chances are tomorrow we'll see a blog entry on medium on how racist/sexist/discriminatory is the hacker known as 4chan
However, I see that GNU/linux is still working well enough as retard filter

>> No.66275182

>However, I see that GNU/linux is still working well enough as retard filter
Are you kidding me? cat abuse and cut n' paste are tools of the typical Linux user. Linux became a Windows replacement rather than a Unix clone in the early 00's.

>> No.66275202
File: 72 KB, 882x624, 1523735035473.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.66275208

i used sage u fag, also if you're done with the thread why are you still responding?

>> No.66275374

I actually wanted someone to post this image but didn't want to ask. Thanks
> cat abuse
poor kitties
anyways, my point is - it's allowed to be a n00b here. It's also allowed to not know shit about linux - but you never go asking shit on an ugandan echidna breeding forum without googling first. And, if you do - you just out yourself as a retard, mainly because you just tried to use an OS to show off, and not because you're comfortable with it.
If it's not for showoff reasons but because your job requires it - then, given you can't even learn some simple text processing - you shouldn't be trusted with that.

>> No.66275903

Linux is a kernel, you retard

>> No.66275913

>typical linux user.

>> No.66276549

>he doesn't know how to echo or cat...

>> No.66276649

>in less
is this bait?
less is a pager, it's whole purpose is to format input into single screen pages, it makes no sense to have or use scrollback with it

>> No.66276808

being a passive aggressive cunt won't give you answers here, OP. Also, RTFM.

>> No.66276883

get help with your suicide

>> No.66276928

>get help with your suicide
Isn't that just consensual murder?

>> No.66277615
File: 37 KB, 400x527, dr.k.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.66277620
File: 987 KB, 1280x904, tumblr_okjkfeRSpV1vk4d2jo3_1280.png [View same] [iqdb] [saucenao] [google] [report]

>talks about iterm2 (a TERMINAL EMULATOR)
>then goes on about mouse support for fucking less on linux
What has one to do with the other?
Are you implying macos' less has fucking mouse support? are you fucking retarded? The fuck are you trying to do with less??

>> No.66277808
File: 294 KB, 2186x2340, act-senate-candidate-philip-nitschke-data.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.66277925

cat /var/log/diversity.log > /home/tranny/out

Then open in Gedit.

>> No.66278032

Why the fuck would you use cat instead of cp?
Goddamn Linux users are retarded.

>> No.66278080

macfag here
yeah that's the real issue. OP seems to be talking about something that exists in macOS terminals, where you can left click at the bottom of the text you want, move the mouse up to the top, and it will smoothly scroll up while highlighting everything as you go.
It's actually a really nice feature, but it has nothing to do with less and everything to do with how scrollback is handled.
It would perhaps explain op's solution of using cat. perhaps Linux terminals do provide this convenient scrollback feature, but maybe it wasn't working in less. using cat would just put the text in the terminal output directly, which i'm guessing would have more success. just a theory.

>> No.66278173
File: 1.47 MB, 660x582, 1524958910192.png [View same] [iqdb] [saucenao] [google] [report]

I checked. In the basic term emulators like Gnome shell and Konsole it works trivially, but less does not scroll because the scrolling down action does not emulate a down key press. Can you do me a solid and check whether it works in your less?

>> No.66278202

If you don't know how to yank to a clipboard properly from a cli or vim than I don't know what's wrong with you.

>> No.66278214

Because using cp supports child sex trafficking. Cat is a much more legal, moral and worksafe option.

>> No.66278375

>Anyways i am just going to cat the file
Screen vomits then manually searches the vomit to cut n' paste from terminal.

The absolute state of nu-/g/.

>> No.66278398

wait a sec.. it doesn't!
If I scroll with a two finger swipe (no click), I will actually scroll through the less output very well, but when i'm clicking to highlight, the scroll up takes me above the 'less' content on the screen into the command line entries which are shown ABOVE the less output.
In short, you can't do the highlight-scroll thing in less. It does work in regular stdout output though such as with cat.
so OP makes even less sense now!

>> No.66278399
File: 284 KB, 600x580, snap face.jpg [View same] [iqdb] [saucenao] [google] [report]

>this whole thread

>> No.66278413

>yank to a clipboard properly from a cli or vim
I know how to do it in vim, with y, but that only copies to VIM'S clipboard, not the system keyboard.

>> No.66278450

Then yank to the system clipboard? You can choose where you yank your shit you double nigger

>> No.66278468
File: 183 KB, 640x720, Zane-Double.png [View same] [iqdb] [saucenao] [google] [report]

Thanks for the confirmation, anon
> OP makes even less sense now!
I see what you did there

>> No.66278567

I guess my vim was not compiled with that support? on the vim wikia, it says to press + or * to get to the system clipboard, but in my vim, + goes down a line, and * goes down a full page. Handy, but unexpected.
Really the whole clipboard thing is bullshit. On Loonix it's even worse since I think there's like 3 clipboards in total: the vim clipboard, the selection clipboard (middle click to paste), and the traditional system clipboard (right click>Paste, or CTRL+V in non-terminal programs to paste.)

there should honestly just be one system clipboard, and when you yank vim lines, it should put that directly in that clipboard. The same one used when selecting something in a browser and copying it with CTRL+C. One clipboard to rule them all.

>> No.66278610
File: 193 KB, 860x484, Producing energy with memes.png [View same] [iqdb] [saucenao] [google] [report]

>the scroll up takes me above the 'less' content on the screen into the command line entries which are shown ABOVE the less output.
Thanks for brightening up my day OP.

>> No.66278700

I'm not OP, but you're welcome!

>> No.66278710

No, that would make Unix a click n' drool UI.
Something that will never happen.

>> No.66278718

>stop learning things!
>stop teaching people stuff!
>all that's for nerds!

>> No.66278784

OP works in IT.
He should know this already.

>> No.66278785

How would it make it a "click n' drool" UI? I think it would just make things make more sense. Plus you could easily paste from other applications into vim using vim's 'p' command.

>> No.66279254

Of course less won't scroll back with your mouse cursor. It's a goddamn tty application used to window an input stream. It doesn't know what a mouse is, and it maintains a fixed output buffer. OP totally fails to understand the tools he's trying to leverage, and he refuses to learn as is evidenced by him catting fucking everything to the terminal and copy/pasting like a goddamn animal.

This thread was both enraging and endlessly entertaining.

>> No.66279286
File: 1.38 MB, 480x640, 20180608_220646.gif [View same] [iqdb] [saucenao] [google] [report]


>> No.66279365

>catting fucking everything to the terminal and copy/pasting like a goddamn animal.
how would you do it? I think what OP wanted was to get a large block of several lines of output from a log file, without an obvious connecting string of characters in common between them to grep, and putting it in the regular clipboard.

>> No.66279387

You're missing less(1) which is key to the topic of the thread.

>> No.66279402

xclip file
now it's all in the clipboard, lol

>> No.66279409

btw you can use either copy buffer (XA_PRIMARY or XA_SECONDARY with the -selection flag)

>> No.66279414

>Hmm what line numbers do I need
nl BASEDXD.log | less
>Looks like I just need lines 120 through 450..
sed -n '120,450p' BASEDXD.log > 20180608_ISSUE_SOYXD.log

Wow oh my god look how hard it is to lrn2lrn2

>> No.66279453

scroll highlight? works for me in konsole and other terminal emulators.
I think you are a retard...

>> No.66279462

you can do that, though

also, you can copy and paste multiple lines in Vim

>> No.66279478

I didn't read the thread though, just OP's post.

after reading some of the posts I posted >>66279402

>> No.66279533

>I didn't read the thread though, just OP's post.
basically no matter how brainlet people think copying with the mouse is, OP is still the biggest brainlet for thinking it would work in less, when even on his own operating system, it wouldn't have worked anyway.

Also, doing it with the mouse will probably end up being the standard way on Loonix soon, as I don't think Wayland has anything similar to that xclip thing >>66279402 mentioned.

>> No.66279556

I love it when an answer makes me snigger

>> No.66279568

>OP is still the biggest brainlet for thinking it would work in less, when even on his own operating system
I don't have a mac so I didn't know if they modified less to work with the trackpad.

>> No.66279598

They made it work with the trackpad when just scrolling up and down, but not while also highlighting.

>> No.66279687

Well if you're not a cock waving narcissistic tripfag who is basically retarded, you can use awk to directly get the line range you want, or use grep to pare things down and pipe into vim, where you can copy a range of lines to the clipboard interactively.

>> No.66279741

You are spoiled, every terminal emulator on Linux that isn't Konsole sucks.

>> No.66279785

I do it in XCFE Terminal and GNOME Terminal. But OP is trying to scroll-highlight inside of less, which isn't going to work regardless. He should either open it in a text editor or cat it out and then scroll the scrollback, but he refuses to do that and insists on an answer on how to make less scroll-select.

>> No.66279796

>shift + arrow up/down
>shift + page up/down

>> No.66280036

obvious bait

>> No.66280049

>t. diversity hire

>> No.66280095
File: 1.23 MB, 634x977, REC-2018-06-09T00:46:14-04:00.webm [View same] [iqdb] [saucenao] [google] [report]


>> No.66280135

Fuckin' linux users can't even read the thread.

>> No.66280201

Now scroll while selecting INSIDE of less. It's dead stupid but that's what OP asked.

>> No.66280231

retard just use screen or tmux

>> No.66280243

That would make it worse since they also have their own scrollback buffers that are different than your terminals.

>> No.66280350

idk about tmux, but I put this in my .screenrc
termcapinfo xterm* [email protected]:[email protected]
altscreen on

This makes Screen's scrollback go into your terminal's scrollback. Of course if you switch windows in screen it kinda intermingles scrollbacks and makes a mess. But you can still view Screen's own scroll back the usual way with ctrl-A [.

>> No.66280354

>he actually need to copy some error logs to askubuntu; because something broke and he doesn't know how to fix it
Nice larping, faggot

>> No.66281175

><Start line>gg
><End line>gg
It's that easy

>> No.66281316

I can select and scroll fine on kubuntu
try a different terminal emulator..
'terminator' is the most feature rich probably. I just use konsole

>> No.66281346

Of course it is, the kernel doesn't decide over such things.

>> No.66281359

oh nvm just realized OP is so retarded he thought it would work in less...


why don't you use | more where it will work? instead of less? fucking retard

>> No.66281718

>linix is easy to u-

>> No.66281797

Have you tried copy and pasting from a Windows terminal?

>> No.66281883

>can't resize windows terminal by default
>can't check log files of any type on windows by default
>can't copy paste on windows terminal by default
>can't ssh at all, ever

the list is near limitlesss

>> No.66282845

> the vim clipboard
I hope you realise there's no "vim clipboard"? It has like 10-15 registers you can yank into, I forgot how many exactly.

> I guess my vim was not compiled with that support? on the vim wikia, it says to press + or * to get to the system clipboard, but in my vim, + goes down a line, and * goes down a full page. Handy, but unexpected.
Holy shit you're fucking retarded anon

>> No.66282890

>diversity hire: the thread

>> No.66282992

>shift or mouse

>> No.66283056

if you're running tmux you can do C-b [ to go into copy mode, then select text to copy into the tmux buffer that you can then paste with C-b ].

>> No.66283097

>not using TTY exclusively
What a faggots, haha
t.posting from a phone

>> No.66283106

he's actually not though
vim needs to be compiled to allow using the "(*|+)y and "(*|+)p registers to manipulate the system clipboard. otherwise they do absolutely nothing except, surprise, interact with vim instances.
if YOU would RTFM ("man vim" by the way) you'd know this.

>> No.66283182

Yes but if there's no support, then it won't make vim suddenly scroll around instead. Will it? If that's what it does then both me and vim are retarded, sorry

>> No.66284263

nigger are you being serious

>> No.66284728

yeah >>66272891 here
I actually know sed/awk so copypasta'n screen barf isn't what I do.

>> No.66285593

just use tmux

>> No.66285612

Linux is a kernel.

>> No.66285661

It’s just called Linux

Name (leave empty)
Comment (leave empty)
Password [?]Password used for file deletion.