[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology

View post   

[ Toggle deleted replies ]
File: 35 KB, 400x300, 1503809649741.jpg [View same] [iqdb] [saucenao] [google] [report]
66088685 No.66088685 [Reply] [Original] [archived.moe] [rbt]

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources: just like in /sqt/ spend at least a minute to check a web search engine with your question.
*Search: qwant, searx, ixquick or startpage.
*Many free software have active mailing lists.
*Many free software has an active bugzilla/github where you can check and report errors

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):

/g/'s Wiki on GNU/Linux: https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
>What are some cool programs?
>What are some cool terminal commands?
>Where can I learn the command line?
>Where can I learn more about Free Software?
>How to break out of the botnet?

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

Previous thread: >>66072256

>> No.66088703

Sorry if it's a dumb question but...

Am I able to put folders in my ~/.local/bin folder or am I only meant to put files?

For example I have a python script in my ~/.local/bin folder and can run it anywhere by typing <script>.py in my console... What I want to know is if I can have python scripts in ~/.local/bin/<folder> and access them? I've tried making a folder, but I seem to only be able to access the scripts if they're in ~/.local/bin


>> No.66088718

bash looks for executables in your $PATH variable, if you want ~/.local/bin/folder to be search just add it to your $PATH

>> No.66088719


Don't put scripts in the bin folder.

>> No.66088728


It's in my home bin folder, I thought that was okay?


>> No.66088729

I put scripts in ~/.bin

>> No.66088746


bin is for binary executables only.

Fight me.

>> No.66088749

What do I install to be able to write to NTFS partitions from Ubuntu? I am able to read them fine, but only that. I'm using 18.04.

>> No.66088758

watch out folks, we got ourselves a badass over here

>> No.66088765


>> No.66088778

Disable windows fast boot.

>> No.66088783

On a lighter note, what does /g/ think about turning off apt-get recommends and suggests in Debian?

>> No.66088798


>> No.66088818


Yea, I always turn em off but had a nagging feeling there could be a counter-argument to keep them on...

>> No.66088908

Good evening, I had been trying to set up Plex, SAMBA and qbittorrent webui in a spare machine I have. I installed Ubuntu Server 18.04 and used the script from this git repo: https://github.com/htpcBeginner/AtoMiC-ToolKit

However, the script was broken somehow and Plex wasnt installed, so I manually downloaded it and it worked.
Now, I have been trying to set up SAMBA for 4 hours and I had not be able to do it.
Instead of just asking simple questions, is there a good guide about Ubuntu Server? I feel lost using some scripts from random guys.

>> No.66088922

Install GuixSD

>> No.66088977

samba is not that hard to setup yourself using one of the countless guides people have written, you don't need to rely on scripts.

>> No.66088998

the time on my machine is few minutes late compared to the real time. How can I synchronize it?

>> No.66089006

I know this might be more of a dumb question, but.. how do I disable laptop mousepad? I want to make it so that I can easily open terminal, and just run a command to disable/enable it whenever I want, since it gets in the way when I type and when I am at the desk I use wireless mouse anyway.

>> No.66089010


What this guy said, definitely don't use pre-rolled scripts.

It sounds like you don't know much about *NIX and are trying to do a bunch of stuff at once.

Your best bet will be to break down these tasks into smaller chunks and focus on each one so you properly learn the software.

> set up samba
Super easy for basic configs if you read the man

> Plex
sudo dpkg -i debfile

> Qbittorrent
Use deluge

But after you samba you'll also want to make sure you know how to setup your fstab entries properly.

Really you should have a VM for Plex, a VM for your Torrentbox, etc... All running on a hypervisor so if you want to blow one away you can without affecting the rest of your shit, or docker images at least.

> Learn hypervisor's

> Learn docker

>> No.66089053

bs, anything that is executable can be there

>> No.66089067

did any of the easily searchable solutions not work for you guys? Unironically not trying to be a dick buy search "linux synch system time" and "linux turn off touchpad" offers numerous different options.

>> No.66089083

You write your scripts using binary?

>> No.66089100

Sorry, I for some reason didn't add Linux and got generic Windows answers.

Probably the 6AM brain isn't working yet.

>> No.66089332

You don't?

>> No.66089436

I'm a new user of Linux. I started using Ubuntu, without really thinking too much which distro to start in.

Now I'm just really wondering why the hell is there so much pointing out why 'x' is worse and 'y' is better.

I'm getting a feeling it's like a cult or a league of teams where everybody is unironically attacking others all the time why they suck and why their option is better.

Why the hell is there so much unnecessary bashing? On the other note, I'm going to try out Debian soon and fuck around in Arch also probably and find out my preference. However, what the fuck is this cult-like autist mentality going around?

>> No.66089468

How are Intel drivers for Linux?

Out of interest I launched "Game Dev Tycoon" in Windows and it was exceptionally fluid and fast. Take game on Linux is visibly scattering.

I wonder if it's a driver problem or poorly ported game.

>> No.66089518

It's fun. No one really cares what anyone else is running. I mean, except ubuntu or mint. Only an absolute newbie dumb ass would run that absolute garbage on their machine. But other than that.

>> No.66089528


As a absolute newbie dumb ass I find it gud for now, I still have a lot to learn. So everybody is just shitposting, because they have to project their autism? I see.

>> No.66089550

>being this obvious

Have you ever had friends that just shit on each other every now and then? It's like that. If you don't get it, you just won't get it.
We do have our zealots though. People who say "only X is good" without pointing out positive values in the alternatives are typically tech illiterate and following whatever trend they read about first.

>emacs vs vi(m)
No one really gives a shit.

>arch vs gentoo
No one really gives a shit


>> No.66089558

Should I edit the dircolors to my own color themes, or should I follow a "standard" (blue for directory, red for archives, pink/purple for image/video files, etc)?

>> No.66089566


Look I get it, don't worry. I just don't like too much of shitposting. If someone has a case for why 'x' is better etc.. no problem.

Was just wondering what is up with that, since this was my first impression.

>> No.66089627

>Why the hell is there so much unnecessary bashing?
Its like this across the entire computer/tech realm. There's not a scientific principle that can prove X is better than Y so people have to resort to feelings.

>> No.66089735


>> No.66089774

Pretty good usually, I think most Intel drivers are open source.

>> No.66090150

Is fstab executed from top to bottom? I need to place a mount there but this mount relies on another hdd to be mounted which also has entry in fstab, so should i place the mount entry i want to execute as last at the bottom?

>> No.66090174

Suck it and see my friend.

>> No.66090182

Computers always read text files from top to bottom, so that is how it gets parsed and therefore yes.

>> No.66090272

Dude, it's fucking COLORS. Use whatever looks better to you.

>> No.66090292

What are you doing with your life if you are so bored that you edit terminal colours? Get a job you smelly slob.

>> No.66090335
File: 71 KB, 1080x1350, 1512940176879.jpg [View same] [iqdb] [saucenao] [google] [report]

Can I make vim hyphenate words if they hit the textwidth limit?

>> No.66090346

I'll be using Ubuntu for now.
Is there a way to merge dock and activity bar functionality?

>> No.66090354


Well I don't want to get used to X colors and then eventually stop being a NEET and get a job that doesn't allow me to use my custom colors.

I also want it to be logically thought out. For example, I think it makes sense to have javascript, json, etc. extensions appear as orange.

>> No.66090375

sensors isnt working correctly on my system., it just shows cpu: 0rpm and no temp

I have my cpu fans unplugged (d15) and its running just fine. Ideally i want to be able to set up a pwn curve that the fans only turn on at 65 degrees

>> No.66090563

Absolute newbie dumb ass here

I fucked up my first installation by playing with the packages. I want to start all over again. How do I remove what I have installed?
When I boot with the USB drive I used to install mint, I can modify the partitions. Here is what I have :
>/dev/sda1 ntfs [size] [used] Windows 7 (loader)
>/ded/sda5 ext4 [size] [used] Linux Mint 18.3 Sylvia (18.3)
>/dev/sda6 swap [size] unknow

Basically I want to keep the win7, to remove the mint, and I have no idea what the third thing is
I have the option to format the partitions, but I have to choose the new file system and I don't know which one to pick

Any help would be greatly appreciated, thank you

>> No.66090583

When you do a fresh install just tell it to do so over the top of those old partitions, no need to manually wipe them first since that will happen anyway. if you are using mint the whole thing will be guided to help.

also you've backed up that windows partition, right anon?

>> No.66090594

uh oh, were you truing to dual boot on a single? either way just format sda5 and sda6. youll need to set up windows in the grub menu after you reinstall though.

>> No.66090617

If possible I would use separate hard drives for windows and linux, it saves on headache.
In the installer, is there an option to re-install over the existing mint? If not you'll have to manually do it. I think the install option is "something else" and then you might have to delete and remake the Mint partition.

>> No.66090705

>also you've backed up that windows partition, right anon?
I didn't
There's no important data on it (I bought a reconditioned laptop), but I don't want to lose win7 completely

>if you are using mint the whole thing will be guided to help
>youll need to set up windows in the grub menu after you reinstall though
>In the installer, is there an option to re-install over the existing mint?
I did not find how to do it in the installer. I can get a list of the partitions but I don't really know what to do next
I think I'll use the diskmgmt.msc from windows and then re-install mint

Thank you for your answers

>> No.66090717

>I did not find how to do it in the installer. I can get a list of the partitions but I don't really know what to do next
>I think I'll use the diskmgmt.msc from windows and then re-install mint
its not an option in the installer. you have to edit your grub config after you reinstall mint over your existing partitions. the easiest way is just deleting them. you could always try booting into a live usb and deleting the partitions with gparted or something

>> No.66090761

> you have to edit your grub config after you reinstall mint

You shouldn't have to do this anymore. Grub has it's config set during install and then during updates and it will pick up Windows installs on it's own.

>> No.66090764

with windows its still a pos to get working. Ive never had it work properly with windows 8 so i imagine 7 is similar

>> No.66090789

How do I undervolt compred to linux (on manjaro)?

>> No.66090827

Hm Ive had it pick up Win7 installs consistently for a couple years
I install Linux on my desktop with every drive except the Linux drive unplugged so I'm not sure when Grub picks up my Windows install, maybe the first Linux update that has a kernel update and grub-mkconfig gets run

>> No.66090951
File: 327 KB, 616x720, thinking sebas.png [View same] [iqdb] [saucenao] [google] [report]

It's working now. Here is what I did if you're curious
>booted in win7
>opened diskmgmt.msc
>deleted the two "non-windows" partitions
>extended the windows partition to use all the entire disk
>tried to reboot
>it didn't work (error: no such partition) and entered grub rescue mode
>forced reboot by pressing the power button
>booted with the live-USB and re-install mint
>it works now, I think grub fixed itself during the mint installation

Thank you for your time. Even though you didn't give me the exact answer, your questions and remarks helped me understand what was going on

>> No.66091210

I'm attempting GPU passthrough, but I'm stumped on trying to get the VM to actually boot an installer image. OVMF keeps dumping me at an efi shell
Since OVMF boots a Linux distro image successfully it looks like an issue with my Windows 10 ISO. I got it from microsoft.com/en-gb/software-download/windows10ISO
Where do get an image that works in UEFI?

>> No.66091246

windows fucking ADDED linux

>> No.66091256

I'm gay for Greg

>> No.66091562

Who is this guy?

>> No.66091573

Only GNU. Linux is as always just a kernel.

>> No.66091592


linux is nice to use except for bluetooth. I seriously can't connect shit to it except the speakers.

>> No.66091643

probs a windows 8 10 thing. deliberate sabotage, especially with them adding there shitty version of ubuntu

welcome to 2017/16

blueman. use blueman

>> No.66091656

a wise man once said, "if you don't know, then you don't care"

>> No.66091696

why does blueman makea difference? Isn't it just a front end?

>> No.66091711

yeah but its usually a good fix. what hardware are you using for your bt? isnt onboard or some shit? shouldnt make a difference either way

>> No.66091745

T440 memepad (onboard) and xbox one controller also a bluetooth mouse.

anyway, blueman doesn't fix it.

Why is bluetooth so terrible on linux? This shit JUST WERKED on windows.

>> No.66091765
File: 988 KB, 1000x1000, 1527282301544.png [View same] [iqdb] [saucenao] [google] [report]

>abusing REEE as expression towards generic anger

>> No.66091775

hoe to use correctly

>> No.66091984
File: 18 KB, 800x400, LInuxVsWIn.png [View same] [iqdb] [saucenao] [google] [report]

I just started using Linux and got Ubuntu 16.04.

I ran into a 'big' problem today. I wanted to have more comfy desktop environment. It started breaking and I didn't end up liking it. I decided to purge the whole GNOME environment, but I can't open terminal. I googled few answers and can't fix it. I said fuck it, let's just install Ubuntu 18.04, so I download .iso on my USB drive to boot it and it doesn't recognize it in boot system. It says Ubuntu, I press enter and it just goes to GUI screen for log in.

What the hell do I do?

>> No.66092001

upgrade to windows

>> No.66092023

no way you couldn't open a terminal emulator let alone the proper console. boot into recovery mode OR

edit your grub conf

/etc/default/grub to have the next boot end up in text mode. In summary you will set these parameters:


After saving changes you need to run:

sudo update-grub
sudo systemctl set-default multi-user.target

then just type something like apt-get install KDE or whatever. just fix your shit negro

your usb drive sounds like an issue with whatever you used to install it

>> No.66092039

try arch. it seems to work

>> No.66092047
File: 38 KB, 604x404, Wat8.jpg [View same] [iqdb] [saucenao] [google] [report]


Update*, I can't open terminal from search engine.. but if I go to a map and choose open from terminal, the terminal opens normally.

>> No.66092056

yeah, meme-ing is what got me hear in the first place.

>> No.66092154

Intel is the most Linux-friendly tech giant, Linus said this in his fuck you Nvidia video I think.

>> No.66092216

isnt it amd, for their gpu division as well?

intel actually makes a lot of open source hardware as well

>> No.66092240

Is it possible to customize the tty login, like placing it on the center, adding a clock, or adding shutdown and reboot without logging in first?

>> No.66092284

He sounds like a nice guy, he encourages newbie kernel hackers to send in patches that other maintainers would consider a waste of time because he wants more people to get involved.

>> No.66092322

im on cinnnamon in debian. can i remove the lock screen after decrypt? i want it to be so when i decrypt i stay in the console, and then enter my username and password then it boots into cinnamon and all the good stuff.

>> No.66092344

is it possible to run ubuntu completely from usb stick?
And i don't mean live cd, i mean actually install it there
I am making a nas and don't want to waste a sata slot for an OS hdd

>> No.66092398

You could do this but it won't update, as in, it'll just show the time when you entered the tty, that's how it is with agetty anyway, maybe there's a better and more sophisticated alternative out there.

>> No.66092405
File: 151 KB, 937x456, Screenshot from 2018-05-26 15-21-41.png [View same] [iqdb] [saucenao] [google] [report]

Okay additional problems, I tried to remove GNOME through terminal, but I get pic related error.

I can't burn .iso onto my USB, because any .exe file can't be open through WINE, it simply starts loading in activities panel and then stops and nothing happens.

So, I can't run terminal through search, but can open it through maps and can't run .exe files, because they just don't load.

Pic related is error I get when I try to remove GNOME.

>> No.66092419

yes, install it to the usb... not difficult!

>> No.66092430

just get a display manager

>> No.66092443

I tried opening wine configuration tool, but it doesn't work.

>> No.66092494

I am not giving up on MPD on my phone.

Why is it that when I only select the HTTP stream in MPD, I cannot adjust the volume anymore with my client?

>> No.66092506

You could go hardcore into termux and running mpc as usual. No need to deal with apps.

>> No.66092532

So I love Linux and open source and want to get the best Linux for my machine. Which is the best Linux that provides the best Linux desktop? Please no bully I'm new to Linux.

>> No.66092562

If you want to get a taste of Linux and Open Source, look into Android.
If you want a GNU/Linux system and Free Software, check out Debian.
If you're a bloody beginner to GNU/Linux, try Ubuntu.

>> No.66092622

you can do that? just go into the installer and ┬Ęselect usb stick in the hdd list? will that really work?

>> No.66092685

Thanks for pointing out what I need, I didn't know that actual term so I was lost without an idea on what to search. So right now I installed lxdm and it even has those three things I wanted
Although, tty is still faster, I wish I can customize it or perhaps there's a "non graphical" display manager available around

>> No.66092724

yes... it will

try it

>> No.66092795

if you are lying i will hunt you down

>> No.66092839

Literally who?

>> No.66092919


Posted from my GNUphone

>> No.66092930
File: 388 KB, 1039x716, Screenshot from 2018-05-26 16-16-52.png [View same] [iqdb] [saucenao] [google] [report]


I'm starting to lose my nerves a bit, since I can't solve anything by googling and even when I try things, nothing changes.

halp, all these problem started after downloading GNOME

>> No.66092944

Try a search engine which respects your privacy.

>> No.66093327

Maybe I enjoy using an operating system that actually works? Only an 15 year old absolute autist on summer break actually has the time to install and configure something like Arch Linux to be able to do any real work.
Don't get me wrong, I'm sure it's a great distro. And i run Fedora on my server. But for my desktop? I don't have time for that shit

>> No.66093350
File: 20 KB, 800x400, received_10211925165589455.png [View same] [iqdb] [saucenao] [google] [report]

Joke on you, I can't even get into log in menu anymore. Will have to re-install everything.

Linux is fun, pic related

>> No.66093372

What does the "ttyl" thing when you shutdown the computer actually mean?

>> No.66093388

It's useful to find out the flaws and features of softwares. On the other hand it also divides the community. Win/Lose.

tl;dr put salt on ur meals

>> No.66093402

Linux is a kernel.

>> No.66093585

>What does the "ttyl" thing when you shutdown the computer actually mean?

tty1 is your lowest run-level. You do most of your computing including all gui stuff on level 7. You can swich between runlevels at any time with ctrl + alt + f1 thru f7. This is useful if your graphical environment hangs up, you can swich to runlevel 6 and close the offending programs from the terminal for example.

>> No.66093618
File: 1.28 MB, 2272x1704, stallman.jpg [View same] [iqdb] [saucenao] [google] [report]

Should I swich from ubuntu to fedora?

Does it have the same good hardware support?

Ubuntu broke the upgrade path for my 17.04 install and i need to install something new, and I was always bothered by outdated software in Ubuntu.

I am a gnome user

>> No.66093630
File: 490 KB, 604x481, 15269537798013-b.png [View same] [iqdb] [saucenao] [google] [report]

Is there a way to make i3 look and behave as bspwm?

In particular I need the gaps to be the same between all the windows and screen edges.
In essence, I want to remove any "multiple windows inside frame" looks.

I really want to try Sway 1.x, but i3 confuses me.

>> No.66093650

i switched from fedora to debian because of nvidia drivers being shit for me.

just go debian

>> No.66093809

isn't windows a kernel too?

>> No.66093830

Windows is Linux.

>> No.66093831

If you're resource constrained, Transmission is much lighter than Deluge and has most of the same features. The only issue is that you need to stop the program and edit a json file rather than directly using the webui to configure it. Both work fine with Transdroid.

>> No.66093846

Debian Stable with the backports repo enabled and a third party browser package (I use the Mozilla build of Firefox Nightly with /usr/bin/firefox-nightly symlinked to the binary in /opt) is supremely comfy. I get current kernels, X, Mesa, and Nvidia drivers but the system as a whole is still rock solid.

Ironically sort of true with WSL.

>> No.66093851

You mean Apple. Windows is an OS, Linux is a kernel like UNIX (Apple), a processor in your hardware that converts hardware into software.

>> No.66093862

>I did something unsupported without fully understanding the consequences and it's linux fault because it let me

fedora uses a standard-ish kernel but it'll be far more updated than ubuntu which generally translates to better driver support, if you absolutely need a vanilla kernel or a bleeding edge kernel (spoiler: you probably don't) you can use the vanilla kernel repo to get them straight from git, generally no more than a few days old
fedora doesn't provide non-kernel proprietary drivers in their repo but rpmfusion covers that as well as any other strictly proprietary stuff, amd support sucked in the catalyst days but amdgpu is baked into the kernel now so it's fine unless you need the amdgpu pro drivers (but you can thank amd for that), nvidia support is sometimes okay but I haven't had a nvidia card for years so I can't tell you the current situation (it probably works okay)
chances are if ubuntu works fedora will almost certainly work too

>> No.66093871

are you me? although in saying this nvidias drivers STILL give me screen tear even with forced composite pipeline enabled. its beyond annoying

>> No.66093872

There is no Linux in the WSL.

>> No.66093888

Linux uses the FreeBSD kernel developed by Nintendo.

>> No.66093895

easiest way to get rid of screentear is to enable vsync through the driver or an xorg conf, it sucks if you want to disable it through games but it beats wrestling with a compsitor for hours

>> No.66093900

rtorrent is better than them all in all aspects

>> No.66093902

Guys ...

>> No.66093916

>not using aria2

>> No.66093921

I end up using Compton since Novidya's vsync can't handle multiple monitors of different size / refresh rate.

>no security whatsoever
>no IPv6 or DHT support
>needs a separate webui
rtorrent was great before Deluge and Transmission matured. It's not really necessary now.

>> No.66093931
File: 43 KB, 640x671, X6GTYRw_d.jpg [View same] [iqdb] [saucenao] [google] [report]

>a processor in your hardware that converts hardware into software
hopefully b8

>> No.66093941

wheres the setting in the driver? im not even gaming on this machine, just watching anime

does it even work on newer cards that well?

>> No.66093951

i like the text based UI in rtorrent
does aria2 have a built in UI at all?

>> No.66093960

How do I get the rename (linked to prename) command used in Debian on my phone in Termux? I really miss it. Termux just provides the crippled util-linux rename command. It drives me nuts.

>> No.66093961

It all depends on how you invoke it. I use compton -b --backend glx --vsync opengl on a 750Ti and it works.

>> No.66093962

rtorrent has a built in UI
those other claims might be wrong too

>> No.66093972

They were all true, UI included, last time I used rtorrent.

>> No.66093980

when did you last use rtorrent because clearly rtorrent matured too then

>> No.66094014
File: 28 KB, 250x327, arthur.jpg [View same] [iqdb] [saucenao] [google] [report]

>using Arch for a month straight with no problems at all
>pacman -Syu then shut down the machine and go to bed
>wake up
>ERROR: device '/dev/mapper/linux-archlinux' not found. Skipping fsck.
>mfw a single pacman -Syu fucked my entire encrypted volume's boot

Is it time to finally move to Gentoo? I've been willing to try it already since I'd get even more knowledge on GNU/Linux and would be able to fix this kind of shit easily. Please notice that none of the workarounds I've found in the forums worked, I'm seriously thinking of backing up my shit and moving to Gentoo, since I can still access the encrypted partition.

>> No.66094023


>> No.66094029

Make sure to sit down before watching: https://www.youtube.com/watch?v=BBQ7ukwK56Q

>> No.66094033

The year of the systemd/linux desktop anytime now.

>> No.66094083

Nope, I just checked the github and you're full of shit. There's no webUI.

>> No.66094111

this is the friendly thread so i will spare insulting u

did anyone but u say webUI?

>> No.66094153

hmm sort of fixed it. added "option "triplebuffer" to my config. videos look smoother at least but i dont think its fixed everything

>> No.66094159

You could customize the prompt but it's very barebones, mine shows an ascii art and basic info like kernel version, tty number and static clock but that's about it really, see the man page of whichever getty is responsible for your tty.

>> No.66094174

Yeah, I know. Shit fucking sucks. I wish I had tracked the time I already spent fixing Arch bugs in my life. I'm almost certain it wouldn't be shorter than 50h.

>> No.66094189

which kernel?

>> No.66094209


>> No.66094213


>> No.66094231

why does he even have a github account when everything is done outside of github?

>> No.66094242

Dick waving? What a stupid question.

>> No.66094251

how is linux any secure when everybody can look at the source code?

>> No.66094262

to push hist git commits?

>> No.66094267

Windows uses the Windows NT Kernel which was hand written by Bill Gates, and still gets updated by him for recent Windows updates.
It's a tough job but that's why he's a billionaire

>> No.66094270

why linux doesn't have antivirus while windaids have

>> No.66094275
File: 261 KB, 1280x720, 1527351315813.png [View same] [iqdb] [saucenao] [google] [report]

Top kek.

>> No.66094281

Billy is just bussinessman, retard.
Also stop shilling malware, Jamal.

>> No.66094283
File: 111 KB, 600x592, lim brainlet.png [View same] [iqdb] [saucenao] [google] [report]

>security through obfuscation

>> No.66094293


>> No.66094311

i3-gaps exists

>> No.66094345

>i3-gaps exists
With shitty gaps that depend on inner and outer regions and with some "smart outer/inner gaps" fuckery.

In bspwm I set 1 border width and 1 Gap with. No matter what happens, gaps both between windows and with screen borders are constant. I want the same with i3.

>> No.66094353

Look into bspwm, it should do what you're searching for.

>> No.66094379

Obfuscated code is how Lennart pwned everyone.

>> No.66094385

Do you have any proofs to back that up?

>> No.66094399

>still using systemd

>> No.66094400

>calling others jamal when he can't understand a joke

>> No.66094418

Stop being racist.

>> No.66094425

stop putting /sqt/ in the general sticky

>> No.66094431

>he thinks I wasn't pretending
>implying you aren't jamal
fucking tyrone I swear

>> No.66094432


>> No.66094448

I'm already using it.
Point is I want to configure i3 to at least look the same so I can try Sway.

>> No.66094451


>> No.66094462

You can try sway without i3.

>> No.66094581

>can try sway without i3
What do you mean? It's config compatible with i3.

>> No.66094675

Why don't you try it then?

>> No.66094684

Hello, I'm extremely new to linux(have never used it before) but I've heard that I can use a live cd to access a laptop's harddrive because my aunt bricked it but wants her files off of it.

Tried a few live cds from different recommended lists on google but none of their file managers actually show the hard disk partitions in order for me to find whatever files are on there and copy them back to a cd or usb.

Would be grateful if you /g/uys can recommend me a live cd distro that would help me out.

>> No.66094718

just get the laptop connected to the internet and download ntfs-3g, if you're using ubuntu:
sudo apt-get install ntfs-3g

>> No.66094771

you can make a live cd yourself

>> No.66094775

Alright, I'll try that now. Thank you.

>> No.66094786

Do you happen to know any distro with rich set of packages for arm.
I want android sdk specifically, debian has it, but some old version and it won't build my app.
Want to setup cute little server for autobuilding my app after commits.
Building it myself would require digging into those massive poorly described sources to change configs and its neither easy neither enjoyable.

>> No.66094851
File: 2.11 MB, 3968x2976, IMG_20180526_190050.jpg [View same] [iqdb] [saucenao] [google] [report]

Okay guys I have downloaded 18.04 LTS Version and instalation went through succesfully, thinking I actually fixed it... Then I restart and login and I knew shiw is goinh down again when GNOME logo poped up, even though I was watching installer removing all GNOME related shit, then I get this error.

I can access Ubuntu through USB boot and try it out, but after installation nothing happens. The fuck do I do now? This is actually my first day using Linux and I already managed to break it in a way that even community doesn't have an answer and it all happened because I downloaded a fucking DE. What the fuck.

>> No.66094900

Any spectrwm users here?

A while ago I had issues with setting focus_mode to "manual". Whenever I changed that option in the config (and no other), spectrwm would abort on launch.
I tried it on Ubuntu in a VM as well as Raspbian on a Raspi.

Has anyone got experience with this behavior?

>> No.66094962

Tyrone please
Give back the stolen macbook

>> No.66094980

he probably liked a video and got it for free though

>> No.66095038

why would tyrone care about whats on the drive
he can just wipe it and install fresh, no?
fugging idiot

>> No.66095044

>Why don't you try it then?
Because it has the same bullshit as i3 does.
Since i3 is more popular, I am how to make it more like bspwm.

>> No.66095056
File: 57 KB, 661x661, 1526828662783.jpg [View same] [iqdb] [saucenao] [google] [report]

Gnome don't let you go. M'kay

>> No.66095059

depends who he stole it from.
it's mostly slutty girls that have macbooks, go figure out the rest

>> No.66095062

Why don't you try it without sway?

>> No.66095144

Gentoo has long been one of the best ARM distros.

>> No.66095239

Linux gives you lots of options. And people enjoy and care about this stuff so sometimes have strong opinions.

I imagine if you went on a forum for guitar enthusiasts, you'd find people arguing over what strings are better or some shit.

>> No.66095242

Try what?

>> No.66095275


>> No.66095292

Whenever I disconnect my secondary monitor and re-set my xrandr outputs, there seems to always be a "virtual" output I can't switch off. It also fucks with full screen applications, games in particular. Any idea how to fix this?

$ # two monitors connected and on
$ xrandr
Screen 0: minimum 320 x 200, current 2880 x 1024, maximum 8193 x 8192
LVDS-1 connected 1600x900+1280+0 (...)
1600x900 60.01*+ 40.00
VGA-1 connected primary 1280x1024+0+0 (...)
1280x1024 60.02*+ 75.02
HDMI-1 disconnected (...)
DP-1 disconnected (...)
HDMI-2 disconnected (...)
DP-2 disconnected (...)
DP-3 disconnected (...)
$ # disconnect VGA monitor
$ xrandr
Screen 0: minimum 320 x 200, current 2880 x 1024, maximum 8193 x 8192
LVDS-1 connected 1600x900+1280+0 (...)
1600x900 60.01*+ 40.00
VGA-1 disconnected primary 1280x1024+0+0 (...)
1280x1024 60.02*+ 75.02
HDMI-1 disconnected (...)
DP-1 disconnected (...)
HDMI-2 disconnected (...)
DP-2 disconnected (...)
DP-3 disconnected (...)
1280x1024 (0x69) 108.000MHz +HSync +VSync
h: width 1280 start 1328 end 1440 total 1688 skew 0 clock 63.98 KHz
v: height 1024 start 1025 end 1028 total 1066 clock 60.02Hz
$ # there is now still a workspace outside of LVDS-1

>> No.66095294

Linux is a kernel.

>> No.66095312

Wish that was the case at this point. I've wasted my time for some stupid contracts and payment docs that I told her to backup a million fucking times...

>> No.66095316

Also, I tried turning off VGA-1 and DP-3, and making LVDS-1 the primary output again. Still no change.

>> No.66095367

Suppose I have this:

- subdir1
- subdir2
- subdir1
- subdir2


How can I copy the file doc.tex to every directory in one go?

>> No.66095382

I want to try i and actually use it. For that I need tiling WM. Choice is between i3 clone(sway) and awesome clone (way-cooler).

I definitely don't want to fuck around with Lua, so sway is my choice.

>> No.66095400

Reconnecting the monitor on VGA-1 immediately activates it again.
When I try to run, say, $ cd ~/.wineprefixes/vidya/drive_c/Racer && wine SWEP1RCR.EXE, I only get a black screen, BOTH displays switch to 1024x768 (only VGA-1 should do this) and the CPU temp goes up as if it's rendering anyway. Killing it with xkill and pgrep settles the computer down again. After starting the game in the way described above, I get the following error at the very end:
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0.0"
after 559 requests (559 known processed) with 2 events remaining.

>> No.66095422

Can you list all terminal commands and explain one by one?

>> No.66095434

Do you want a copy in every subdirectory only, or also in the maindirs?

$ for d in maindir{1..3}{,/subdir{1,2}; do cp doc.tex "$d"; done

>> No.66095440

There's books for that.

>> No.66095447

Forgot a closing brace before the first semicolon.

>> No.66095452

yes bro,
maindir and subdir should get a copy of doc.tex

>> No.66095466

info coreutils

>> No.66095482
File: 455 KB, 2976x3968, 33522444_10215043145570140_4940728698539081728_n.jpg [View same] [iqdb] [saucenao] [google] [report]

I'm putting a second hard drive in my laptop for Linux and the second drive already has two partitions for Linux and Windows. How do I safely put a single Linux partition over both of those without fucking up my hard drive?

>> No.66095489

Note that
assumes that each maindir has the same number of subdirs and they're all called the same. A better way would be to use find as follows:
find . -type d -execdir cp /absolute/path/to/doc.tex {} \;
You can also limit this to a certain recursion depth, see the manpage for find.

>> No.66095508


>> No.66095512

Dude I honestly don't know how to repair this, unless I'm gonna return it to shop so they fix it.

>> No.66095513

bro man you saved my life thank you

i forgot that find has a -d flag

>> No.66095541

>assumes that each maindir has the same number of subdirs

This is not true name or number does not matter

>> No.66095560


>> No.66095621

when kde neon 18.04 comes out, would I need to reinstall?

>> No.66095953

Is it bad style to put shell scripts under ~/bin?

>> No.66095994

Bin is the binaries folder.

You should take a look at an article about Unix folder structure.

>> No.66096019

Have you taken a look at /bin /usr/bin? There are shell scripts already in there m8.

>> No.66096073

Boot from whatever Linux distro you're going to install and nuke the Linux and Windows partitions on that drive during partition setup. I'm assuming you have Windows on the first hard drive. When it comes time to write grub to disk, you select the first drive. Grub will handle booting of Windows and Linux.

>> No.66096097

Is there a way to make grub default to the Windows drive?

>> No.66096155

Some applications will not work right without their recommends. Example python3-pip

>> No.66096182

It's because Linux for desktop objectively blows and users tend to shit on each other to compensate for their terrible OS

>> No.66096215

>I decided to purge the whole GNOME environment, but I can't open terminal.
You probably okayed removing vital shit from your system and didn't realize it. Reinstall and make a separate /home directory so if something like this again you don't have to reformat everything. If there's a minimal Ubuntu version, use that and install your desktop environment or windows manager afterward.

>> No.66096327

sudo nano /etc/default/grub
Where 0 is the first in the list, 1 second, 2 third.
sudo update-grub

>> No.66096448

I decided to go with fedora as my main distro. I hear a lot of hate on gnome though so should i go with the KDE spin? Also, can RHEL be trusted?

>> No.66096544

That's the correct directory.

>> No.66096565

Unix was a proprietary system in the 70s; nobody uses Unix anymore.

>> No.66096630

Fuck this gay shit, I'm not even gonna try to fix it anymore. Downloading Gentoo at this moment, gonna back the fuck up of everything to my external HDD then install Gentoo.

Fuck Arch lol.

>> No.66096677

Install Debian Sid.

>> No.66096711

Your on 4chan, what the fuck did you expected?

>> No.66096914

this adds nothing to the comment, Unix folder structure is still a very useful thing to know

>> No.66096920

>tfw too stupid for dbus
>tfw can't write a simple program to turn off X blanking and DPMS when firefox is playing video

>> No.66097019


>> No.66097074
File: 50 KB, 604x377, 15268761567463-b.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.66097160

Or you could simply refer to the system this thread is all about. Hint: It's not Unix.

>> No.66097178

When i set that HDD timeout thing to 10 minutes, where the HDD spins down when not used it does nothing, any idea why?

>> No.66097319
File: 129 KB, 1240x1559, 1527367519548.jpg [View same] [iqdb] [saucenao] [google] [report]

What are some cool terminal commands?

>> No.66097325

sudo rm -rf /*

>> No.66097334


>> No.66097336

this, pretty fun one man

>> No.66097337

curl cheat.sh
wget -qO- cheat.sh

Gives you brainlet friendly command examples.

>> No.66097347

That doesn't work on GNU/Linux, senpai.

>> No.66097350

How the fuck does that command does this kind of shit, bro? Jesus, that's so fucking cool!

>> No.66097364

works on mac and busybox

>> No.66097373

Suppose I were to buy one of those "Radeon Pro" workstation cards. Could I then go and use the regular AMDGPU driver with it, or must I use the AMDGPU-PRO one? I hear AMD is pushing the non-pro driver upstream, and I'd very much like to be rid of nonfree binary drivers. But I'm interested in a workstation card because the cheapest Radon Pro that can drive four monitors is the same price as the cheapest regular Radeon that can drive four monitors - except its single-slot and has a much lower TDP.

>> No.66097422
File: 412 KB, 431x700, 1527368223832.png [View same] [iqdb] [saucenao] [google] [report]


>> No.66097471
File: 1.34 MB, 3640x1920, Screenshot from 2018-05-14 15-42-38.png [View same] [iqdb] [saucenao] [google] [report]

Is there a good Gnome extension for viewing disk drive space. I can use Conky but I'd prefer something that wouldn't keep polling my disk drives preventing them from entering into a suspend state.

>> No.66097480

I need stable distro i with up to date or at least ability to install up to date stuff for work... npm, php and rest of that shit should be up to date. Dont recommend arch or something fast moving i need stable for job

>> No.66097692

Void Linux.

>> No.66098022

Debian GNU/Linux

>> No.66098032


Yeah that doesnt look like stable

>> No.66098071

How does it make it unstable?

>> No.66098098

They lost control over domain github how does that spell stable project to you?

>> No.66098121

>They lost control over domain github
True, therefore they are making new ones, while continuing to operate as usual. All this means in practice is that greater care longer to be reviewed.

>> No.66098162

Putting that aside do updates break stuff? I used arch and while it was stable it still broke once or twice a year bigger problem were version changes of stuff i need for work so i went to ubuntu for last year but its so boring and well ubuntu... i need ability to at least hold specific updates back without screwing system up

>> No.66098389

>Putting that aside do updates break stuff?
There was that one 'dash' update that broke some scripts. It was an upstream mistake though.
Other than that it is the most stable distro I've used.

>i need ability to at least hold specific updates back without screwing system up
Void is OK for that. It allows partial updates and version freezes.

>> No.66098432

what's the best way to get/make a vpn killswitch? (i think) i just want all networking to stop when my vpn disconnects (which i've set up with openvpn in ubuntu's network manager).

>> No.66098466

>i need stable for job
I run arch on my work laptop. I also run arch on my desktop at work.
>stable for work
Dont update when you are working?
Update on the weekends at home?

I update my work desktop once a month and my laptop once a week. I have never had the "MUH XORG HALP MEEEE" problems.Just make sure you check your configs when things are updated, they might change :)

>> No.66098520

I used arch before and it broke rarely once or twice a year, problem is new versions of stuff (for work i need to use specific versions of sw) i need for work and u cant do patial updates without problems down the road (that i know of)

>> No.66098547
File: 90 KB, 785x757, 1501448676194.gif [View same] [iqdb] [saucenao] [google] [report]

How do I make Faggotfox use the KDE file picker on Buttbuntu 18.04? I want my fucking thumbnails. Thanks, that is all.

>> No.66098549

Yeah networkmanager has this annoying philosophy of "maintain as much connectivity as possible under all circumstances". I made a killswitch with ufw and nmcli. The bits you need are:
1.) a way to pick out the IP address of the VPN server you're connected to. You could hardcode it if you only connect to one server, but I want to take advantage of my provider having servers in many places, so I hacked some shit together with ip route show (OpenVPN adds a route to the VPN server IP), grep, and awk.
2.) nmcli connection monitor [interface]. OVPN creates a tunnel device (almost certainly tun0 unless you have others set up) that you can use this command to watch. The command blocks until the device changes state - in this case it goes away when the VPN drops.

I can post my script if you want, but it has some complications that you'll have to take out

>> No.66098554

You could easily create a chroot/docker/env with the software versions required for your working environment while keeping the main system up to date.

>> No.66098696

There is something on the arch wiki about that.

>> No.66098841

say I have a crontab that executes a script. can I read messages in journalctl if I run echo inside the script?

>> No.66098920

there is a ppa somewhere

>> No.66098931 [DELETED] 

Why does my sound quality sound so terrible?
Using a motherboard's audio, no realtek drivers installed. Also don't have windows installed, I looked at the motherboards website for drivers but they're all for windows.
Like there's no bass at all, it's all very trebley and if I mute and turn my speakers up I can hear a lot of noise where there wasn't when I was using windows 7.

>> No.66099107

systemd does not use crontab

>> No.66099154

Yes but the standard output should go to syslog.

>> No.66099173

systemd does not use syslog it uses journalctl

>> No.66099182

opensuse or fedora?

>> No.66099271

Gnome Extensions --> Dash to Dock / Dash to Panel

>> No.66099397

It has a syslog interface you absolute brainlet. Do you think every program that logs output was redesigned specifically for that shit?

>> No.66099416

systemd does not use syslog.
systemd uses journalctl
You can configure systemd to output to syslog but it isnt always reliable and has a history of not working. journalctl always has privilege.Even if you configure syslog, it still outputs to journalctl and there is nothing you can do to stop the duplication of data.
By using systemd you accept that journalctl will ALWAYS be running

>> No.66099419

actually, the rsyslog daemon is asking systemd for log entires

>> No.66099421


>> No.66099495

Not really if im allowed to ask this but the tittle said friendly thread so maybe someone will help me

Im using Kali Linux to try to get a wifi password using Reaver, everything worked as seen in pretty much all tutorials until I arrive to the beacon part, everyone else I see get stuck in the "Waiting for beacon" but mine got to the "Received Beacon from " and the following "vendor:" but after that it stayed there doing nothing, its been an hour and nothing happens, is this normal or did I fuck up somewhere?

>> No.66099570

why would they be in "Waiting for beacon" and not actually connected to the wifi?

>> No.66099602

>wps bruteforcing in 2015+3
modern raccess points lock the wps auth after a couple of wrong attempts, so don't waste your time with dead attacks

>> No.66099746

Is a tiling window manager useless @1080p?
I have an i3 setup and with half screen Firefox I can barely read any page.

>> No.66099814
File: 127 KB, 1440x900, 2018-05-26-194241_1440x900_scrot.png [View same] [iqdb] [saucenao] [google] [report]


>> No.66099901

it's for a college course

>> No.66099990

do you have the dll ?

googling for 5 seconds say there might be a program you need to run first to install this dll don't u have it maybe it's here http://www.tobias-erichsen.de/software/virtualmidi.html

>> No.66099999

You are obviously missing some libraries needed to run that. Try searching for the dll and see if you can find an exe to install the libraries

>> No.66100004
File: 172 KB, 1440x900, 2018-05-26-200132_1440x900_scrot.png [View same] [iqdb] [saucenao] [google] [report]

yeah, I just google it.

but now it doesn't have sound.

>> No.66100071

tiling wm are meme at every resolution
Use fluxbox

>> No.66100147

> .gif doesn't move
Hello 2003

>> No.66100171

stop using Google

>> No.66100181

who else /qubes/ in here?
top-tier comfy desu

>> No.66100229

whys that

>> No.66100400


>> No.66100431

and what do you suggest we do about it?

>> No.66100446

with the power of memes we could end this.
can you make the memes?

>> No.66100453

so can I output something into journalctl or whatever? I need a way to read output from a script that my server runs via crontab and journalctl looks like the easy way. the script is run every hour

>> No.66100504

Just look at how your distro does it, try man cron. And /var/log/syslog, why are you even asking about this here?

>> No.66100553

?? it's the friendly linux thread where shoulrd it go

>> No.66100564

Tree-based TWMs are useless at 1080. Try spectr, dwm, Awesome, ...

>> No.66100699

I want to make a quick text list of all the bands and albums in my music collection. The closest I've gotten to what I want is "ls -R -I "*.mp3"" but it lists every folder twice for some reason, and that'll take forever to clean up in the text file. I thought "ls -R -d" too but it didn't work at all.

If it's possible, what modifiers should I use to just make a list of each band folder and the album folders within them, and nothing else?

>> No.66100735

does the latest version of fedora still have gnome memory leak?

>> No.66100825 [DELETED] 

The direct bruteforcing approach used by reaver will not work on a modern day AP.
You could try the Pixie Dust attack, but it relies on the AP vendor not implementing a secure random numbers (the 128 bit ones) for the WPA handshake, so only a few vendors (Ralink is a good example, if they are still vulnerable) will be affected by this.

See https://github.com/wiire-a/pixiewps.

>> No.66100835
File: 107 KB, 661x440, Untitled.jpg [View same] [iqdb] [saucenao] [google] [report]

The direct bruteforcing approach used by reaver will not work on a modern day AP.
You could try the Pixie Dust attack, but it relies on the AP vendor not implementing a secure random numbers (the 128 bit ones) for the WPS handshake, so only a few vendors (Ralink is a good example, if they are still vulnerable) will be affected by this.

See https://github.com/wiire-a/pixiewps.

>> No.66100854

>and that'll take forever to clean up in the text file
| sort -u

>> No.66100882

On a systemd system, systemd is in charge of /dev/log and the logging system. Using the libc's syslog funciton, you are outputing to it, and then any daemon for alternative logging that is interested can ask systemd for the logs on another Unix domain socket that systemd is providing, i.e. /run/systemd/journal/syslog .

I'm going to leave some links for you:


>> No.66100952

tar c * | tar tf -

>> No.66100965

| awk '{ if (!dups[$0]++) { print } }'

>> No.66101311

Currently running Xubuntu (xfce) with Matcha theme. What wm is running? would replacing it with i3 be as simple as installing i3 and purging the other wm?
What other files are there? I plan on ricing slowly but surely as i naturally progress towards the peak of the zuggarat that is linux.

>> No.66101362
File: 76 KB, 853x636, optimus.jpg [View same] [iqdb] [saucenao] [google] [report]

does anyone here use a laptop with an optimus system for their gpu? i want to swap to linux but it doesn't seem to play well
Fedora now supports nvidia drivers so i was thinking of using it

>> No.66101401

I tried these out, thanks for the suggestions. sort and awk got it pretty close to what I was looking for. An example of what both are outputting:

./Wobbler/2011 - Rites At Dawn:

I'm guessing the easiest way to clean it up further would be to send it to a text file first, and then modify the contents of the file?

>> No.66101443

>What wm is running?
> would replacing it with i3 be as simple as installing i3 and purging the other wm?
Learn to google nigger

>> No.66101448

just install i3, logout and the xfce session manager should have a dropdown option to choose what DE/WM you want. no need to uninstall xfce unless you are really strapped for storage space. A few times I've installed xfce when I never intended on using it over i3. But it just made it easier for me because I use all the extras that come with xfce like thunar, the calculator and so on.

>> No.66101458


>> No.66101478

Try find . -type d -links 2

>> No.66101517
File: 72 KB, 385x407, homeServal.jpg [View same] [iqdb] [saucenao] [google] [report]

thx man

>> No.66101518

new to scripting. Using the default is3 and i3staus I'm trying to add a line shoing free RAM.

awk '/MemFree/ {print $2}' /proc/meminfo

shows this in KiB. How to I change that command to output in megabytes instead?

>> No.66101527


>> No.66101541


>> No.66101693

Install mediainfo then cd to your music directory.
find . -type f -name "*.flac" -exec mediainfo --Inform='General;%Album% - %Title%' "{}" >> 1.txt \;

>> No.66101719

fuck this screen tear man, nothing fixes it.

Fuck nvidia,

>> No.66101722

is tearing still a thing with wayland?

>> No.66101727

mpc -f %artist%/%album% listall | sort -u

>> No.66101739

idk man. maybe i should just try arch with wayland. All i want is to watch my anime and not have windows... is it so difficult in current year?

>> No.66101753 [DELETED] 

To see the full list of parameters:
mediainfo --info-parameters

They fall into the category of General, Video, Audio, Text, Chapters. Be sure to wrap the parameter in % %. Man mediainfo for more details.

>> No.66101801


>> No.66101810

show me your vim configs

>> No.66101851
File: 41 KB, 256x256, azureus.png [View same] [iqdb] [saucenao] [google] [report]


>> No.66101903

new thread

>> No.66101917

find -type d | sort -u
Using that gets it incredibly close to what I want, I really appreciate that suggestion. The rest of the work it needs from this point would just be easier in a text editor.

I see where you're going with this but all the info I need is there in the folder names themselves. That program could be useful later on, though.

>> No.66101925

You missed the links bit

>> No.66102006

I tried it with links earlier and it made it worse, that's why I just did find and sort.

>> No.66102716

Yeah, Linux on desktop is either an OSX clone, a Windows clone, an abortion or something that is only usable for people who can already use Linux flawlessly with pure CLI skills (e.g. spectrwm or i3 or whatever).

A major issue for Linux as a desktop is that Linux is literally unusable for anything but basic web browsing (unless you want to web browse without mouse acceleration) without a CLI. And yet 99.9% of all desktop distributions try to hide the CLI and claim that their system is totally like Windows or OSX.
If Linux wanted to enter the age of desktop computing, it would need a distribution where the GUI learning curve would align with the CLI learning curve. Maybe by having a small console bar at the bottom of the screen, which could be used to invoke software or commands. If a command is invoked, a terminal window with the output would open.
You'd have instant synergy - X11 windows would open normally, while CLI tools would open like they were windowed software.
For a beginner, this would be a huge boon as they'd naturally get accustomed to the command line, while still having a pretty familiar way to use the GUI.
Add in intellisense-like autocomplete to the console field and you have decent discoverability. You could also work with sane aliases (maybe like Powershell), but that would make learning Linux harder again.
Also, using filesystem-related commands, like pwd, cd and the like, would invoke a graphical representation of whatever folder you are interacting with. It would be like a permanent ls hovering above your terminal, but you could also use the mouse to interact with it, which in turn would cause your latest interaction to display as a command in the command bar.
You could extend this to GUI shortcuts - use a desktop icon to invoke a program and the command bar will show you the command for it.

I wish I had enough autism and time to actually do this myself. Can't be worse than stock KDE.

>> No.66102731

cron -r

Name (leave empty)
Comment (leave empty)
Password [?]Password used for file deletion.