Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

2017/01/28: An issue regarding the front page of /jp/ has been fixed. Also, thanks to all who contacted us about sponsorship.

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 32 KB, 604x453, 1479909979987.jpg [View same] [iqdb] [saucenao] [google] [report]
62579647 No.62579647 [Reply] [Original] [archived.moe] [rbt]

Previous: >>62569804

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources:
Your friendly neighborhood search engine.

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux:
https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux

>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page

>What are some cool terminal commands?
http://www.commandlinefu.com/
http://bropages.org/

>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/

>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html

>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/t/'s GNU/Linux Games: >>>/t/769497

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

>> No.62579704

>>62579647
How long a beard do Alpine users have?

>> No.62579712
File: 73 KB, 750x562, 1273930839c.jpg [View same] [iqdb] [saucenao] [google] [report]
62579712

When you come to /g/ for the friendly gnu/linux thread, and it's freshie fresh.

>> No.62579733

>>62579704
Psych ward head shave for using a router distro.

>> No.62579752
File: 49 KB, 500x671, 1494514379584.jpg [View same] [iqdb] [saucenao] [google] [report]
62579752

>>62579704

>> No.62579873

Slackware or gentoo? No memes please

>> No.62579883

I'm ready to dual boot Xubuntu 16.40 with Windows 10. Before doing that I'd like to have some clarifications (warning: they might sound very stupid!) :
1) can Windows 10 and Xubuntu have worse performance when one more OS is installed on the same computer?
2) in the first part of the installation, the system asks whether you want to install Xubuntu along with Windows or "do something else"; most people recommend to click on this second option so you can establish the partitions for your Xubuntu installation, but I'm afraid to fuck something up, so would it be the same if I clicked on the first option? Obviously I don't want to delete any content from Windows because I have important stuff there.

>> No.62579916

Be honest. How many GNU/Linux users would use Windows instead if it were free?

>> No.62579965

>>62579916
It's stupid easy to pirate so I don't see this being a real concern.

>> No.62579975

>>62579873
Depends on the purpose, what do you need it for?

>> No.62579977

>>62579916
There are some reasons why I'd still use GNU over Windows:
1) much better customization makes it look much more beautiful
2) it lets you browse porn more freely

>> No.62579978

>>62579916
None I guess. Once you get the taste of hacking every corner of your system, Windows feels like a jail, even if it would be free.

>> No.62580016
File: 78 KB, 640x640, 1492445146966.jpg [View same] [iqdb] [saucenao] [google] [report]
62580016

>>62579965
Publishers often refer to copying they don't approve of as “piracy.” In this way, they imply that it is ethically equivalent to attacking ships on the high seas, kidnapping and murdering the people on them. Based on such propaganda, they have procured laws in most of the world to forbid copying in most (or sometimes all) circumstances. (They are still pressuring to make these prohibitions more complete.)

If you don't believe that copying not approved by the publisher is just like kidnapping and murder, you might prefer not to use the word “piracy” to describe it. Neutral terms such as “unauthorized copying” (or “prohibited copying” for the situation where it is illegal) are available for use instead. Some of us might even prefer to use a positive term such as “sharing information with your neighbor.”

A US judge, presiding over a trial for copyright infringement, recognized that “piracy” and “theft” are smear words <http://torrentfreak.com/mpaa-banned-from-using-piracy-and-theft-terms-in-hotfile-trial-131129/>.

>> No.62580023

>>62579975
I want to:
>play around with unpopular programming languages
>do light web-browsing
>further my knowledge of and experience with linux
>not get hacked
>on underpowered hardware

>> No.62580038

>>62580023
define "underpowered hardware"

>> No.62580045

I've been using Mint for some time. I like it, but I'm getting pissed at shit like synaptic not working properly, and I'm considering to switch back to Ubuntu.

Questions:
1. Anons who use [X/K/etc.]Ubuntu: do you need/want to remove lots of crap when you install the system?
2. Is it worth waiting until 17.10 is released, or is the beta stable enough?
3. Are they still bundling adware with the system?

>> No.62580082

>>62580038
2015 Chromebook-tier (I'm not going to get a Chromebook, but something with similar specs)

>> No.62580110

>>62580045
I've used both Ubuntu and Xubuntu, then my further replies are only based my limited kbowledge.
>1. Anons who use [X/K/etc.]Ubuntu: do you need/want to remove lots of crap when you install the system?
No. On Ubuntu I simply removed Amazon store, but it wasn't a big issue anyways.

>2. Is it worth waiting until 17.10 is released, or is the beta stable enough?
Why not going for 16.04 LTS? It's the stable released and it's going to be supported for long.

>3. Are they still bundling adware with the system?
No since 16.04 LTS.

>> No.62580128

>>62580082
If it has a good dual core or More Cores (TM) or you are up to a challenge, go Gentoo (keeping it small and avoiding extra, large shit like qt, webkit etc included is part of the fun)

Otherwise, get a binary distro. Consider Salix too.

>> No.62580160

>>62580110
Thanks.
On using LTS vs. 17.10: which version of MATE are they using? If possible I'd rather use 1.18 and above to avoid the GTK2 vs. 3 issue.

>> No.62580176

>>62580128
Thanks anon. You can bet I'll be keeping it small, my disk space is going to be limited.

>Salix
Interesting. Haven't seen it before. Thanks for the heads up.

>> No.62580247
File: 427 KB, 473x558, made in GIMP.png [View same] [iqdb] [saucenao] [google] [report]
62580247

>>62580016
4 u

>> No.62580279

>>62580160
I never used Mate, I'm sorry.

>> No.62580316

systemDE when?

>> No.62580320

>>62580316
>wath is GNOME

>> No.62580321

>>62580316
When kerneld is finished.

>> No.62580327

>>62580045
Xubuntu user here:
1 - no
2 - no
3 - no

>> No.62580355

>>62580327
>3 - no
That's not correct. The amazon botnet is still bundled with Ubuntu, but in newer versions it's now opt-in instead of opt-out.

>> No.62580382

>>62580355
Not in Xubuntu, that's a vanilla Ubuntu only thing.

>> No.62580387

How do I change wallpaper on Linux selection screen?

>> No.62580401

>>62580387
You mean GRUB?

>> No.62580411
File: 42 KB, 500x753, 123456.jpg [View same] [iqdb] [saucenao] [google] [report]
62580411

>>62580401
here

>> No.62580413

>>62579883
1) They will both use up some disk space but that's it. I cannot think of any way for them to affect each other's performance.
2) I'm not familiar with the ubuntu installer, here's the wiki page for it though if you haven't seen it already: https://help.ubuntu.com/community/WindowsDualBoot

>> No.62580441

>>62580401
>GRUB
Ok I think I can do it, thanks

>> No.62580458

>>62580411
Source on that image please?

>> No.62580464

>>62580411
Easiest way would be: Move picture into /boot/grub/ and run update-grub. But it depends pretty much on your distro. Some distros define it directly in /etc/default/grub, some define it with a shell script.

>> No.62580498
File: 539 KB, 731x512, 1481358386568.jpg [View same] [iqdb] [saucenao] [google] [report]
62580498

>> No.62580503

Manjaro is pretty good so far. Why would anyone ubunto now?

>> No.62580507

>>62580498
thanks!

>> No.62580518
File: 423 KB, 1250x802, 1498494177853.jpg [View same] [iqdb] [saucenao] [google] [report]
62580518

>>62580498
Original

>> No.62580566

>>62580382
>>62580355
>>62580327
As long as it's just the Amazon botnet and I don't need to uninstall half the system to get rid of it, I'm fine.

>>62580279
I just checked their repositories; the LTS is still using 1.12, while 17.10 is already on 1.18. I'll go withg the later then.

Thanks, you guys.

>> No.62580580

>>62580413
Thank you. One more question: in a dual-noot environment can I access all the files on Windows once I'm inside Xubuntu?

>> No.62580592

>>62580518
thanks too

>> No.62580600

Does Arch really warrant such a long beard? its not that hard

>> No.62580611

>>62580580
>One more question: in a dual-noot environment can I access all the files on Windows once I'm inside Xubuntu?
It should be possible, will probably require some work though.

>> No.62580621

>>62580600
Copypasta'ing 10 commands is so hard

>> No.62580623
File: 1.86 MB, 1280x800, 1496187025552.png [View same] [iqdb] [saucenao] [google] [report]
62580623

>>62580498
>>62580518
Old libreboot version.

>> No.62580630
File: 1.07 MB, 384x384, 1504760699783.gif [View same] [iqdb] [saucenao] [google] [report]
62580630

My dad wants to try GNU/Linux and has asked me to help him switch. I use Arch and I figured it might be a bit too high maintenance for him, so I'm thinking of another distro to pick for him. My choices right now would be Ubuntu, Debian Stable with backports or OpenSUSE(maybe Tumbleweed? Idk); which one do you think is best? Also I'm not sure if KDE or Xfce would be better for the DE.

>> No.62580632

>>62580611
>>62580580
No work is required, Xubuntu will access all Windows files, as long as the Windows partition is mounted.

The inverse (Windows accessing Linux files) requires a bit more work though, and I'd advise against it for security reasons.

>> No.62580638

>>62580630
Fedora is pretty good too

>> No.62580646

>>62580630
It depends a lot on your father, but for first approach I'd say Kubuntu. But keep him informed there are other choices, so if he happens to prefer another DE or distro, he can inform you.

>> No.62580654

>>62580632
>Xubuntu will access all Windows files
Oh, that's useful. I remember having to set it up in fstab, but that was years ago.

>> No.62580694

>>62580630
You really can't go wrong with Xubuntu. I've been using it for months, it never failed me once. I've installed Xubuntu on all the computers at my school and all of my colleagues, even the oldest ones, learnt to use it after only a couple of accesses. It's very intuitive and user-friendly.

>>62580632
> partition is mounted
Can you explain please?

>> No.62580818

>>62580694
A partition is a "piece" of the hard disk where you can store data. For most part you'd rather have one partition for each hard disk, but since you're dual booting odds are you'll have two (one for Xubuntu's data, another for Windows' data).

However, to be used, a partition needs to be "mounted" first - it's like telling the system "hey, I'm allowing you to read and write data on this partition". For most part the systems do it automatically though and, when they don't, it's just a matter of changing a small file called /etc/fstab.

>> No.62580822

>>62580630
When choosing Linux distros for people you don't know well, ask these questions:

1) Do you imagine that they need bleeding edge or regularly updated stuff?

2) How much work with setting things up and fixing problems would be required?

*buntus aren't too bad, but Debian Stable might be better.

>> No.62580848

How to diagnose the problem of a not spinning fan?

>> No.62580865

>>62580818
Ok thanks

>> No.62580868

>>62580646
He is not good with computers so I want to install something that I can setup and then forget about. I'm inclined on picking Xubuntu 16.04 but I'm strongly considering Debian as well. OpenSUSE I'm considering it for Yast, but it's more of an afterthought. I like KDE(in fact I use it personally on my machine) but I don't feel it suits well this purpose and I heard the Ubuntu implementation isn't very good either.

>> No.62580869

>>62580848
First thing I personally would do, is open the machine, and check if there's something obstructing the fan.

>> No.62580871

>>62580822
GNU/Linux*

>> No.62580886

>>62580848
First clean the fan and directly connect it to 12v or 5v depending on how much it needs. If it doesn't spin up, it's not a software problem.

>> No.62580900

>>62580869
>>62580886
It worked on Windows, so I guess I'm missing a driver?

>> No.62580926

>>62580900
Yeah, the ACPI driver might not handling it. If nothing else works, set it to "always on" in BIOS.

>> No.62580933
File: 10 KB, 577x100, Screenshot_20170923_151843.png [View same] [iqdb] [saucenao] [google] [report]
62580933

>>62572746 update:
font config isn't as bad after restarting my computer, but it's still pretty terrible. Whatever their reason for not rendering fonts 3 times it's awful

>> No.62580939

>>62580926
Oh, didn't look in the BIOS, will check what's there, thanks.

>> No.62581108

>>62580933

Works on my machine. Let me guess, you applied Infinality shit or something similar which you don't even understand but you did it anyway to get placebo improvements other people told you is better.

>> No.62581173

>>62580933
https://www.reddit.com/r/archlinux/comments/71czls/psa_todays_firefox_nightly_fixes_the_font_issue/

>> No.62581212

Why is font rendering in Debian so fucking bad?
Xft.antialias: 1
Xft.autohint: 0
Xft.dpi: 96
Xft.hinting: 0
Xft.hintstyle: hintnone
Xft.lcdfilter: lcddefault
Xft.rgba: rgb
doesn't do shit.

>> No.62581235

>>62579916
I don't give a shit about my freedoms. In fact, I'm using a Hackintosh as my main OS. Windows just happens to be outright shitty OS.

>> No.62581286

>>62579916
dont care about the price
if it were open source/debotnetted, i would use it since it has more gaymen support

>> No.62581334

>>62581212
Why disable hinting? Also where are you putting all that and what do you expect it to affect?

>> No.62581356

>>62581212
works4me
sure your display isnt just garbage?

>> No.62581403
File: 25 KB, 480x480, 1500778241482.jpg [View same] [iqdb] [saucenao] [google] [report]
62581403

>>62579647
>tfw this accurately depicts my Ubuntu beard

>> No.62581497

>>62581334
Supposedly that config should make Debian font rendering look like Ubuntu's. I put all that stuff into ~/.xresources. With this file or lack thereof my fonts look like pretty much like this anon's: >>62580933

>> No.62581666

>>62581212
Those settings do nothing. Use gsettings.

>> No.62581809
File: 11 KB, 283x314, 1495830230677.jpg [View same] [iqdb] [saucenao] [google] [report]
62581809

>>62581403
>use Debian
>am clean-shaven

>> No.62581816

>>62581403
my beard has been in the pre-ubuntu stage for what seems for months now, the start of fall is a good excuse as any to chop it off.

>> No.62581925

Gonna do LFS this weekend. Wish me luck.

>> No.62581968

>>62581925
GNU be with you anon.

>> No.62581996

>>62580621
Yet, people here still can't manage that.

>> No.62582016

Skype For Linux Preview creates a directory in the home directory and it's not a hidden one. This would bother me a lot if I had to use it.

>> No.62582129

>>62582016
it has a dark theme though which none of my wincuck friends can find on theirs. Dunno why microsoft decided to do that

>> No.62582537

How can I make an "incomplete" alias?
I generally know how to make "aliases" but I wonder how I can make an incomplete command as alias where the user has to add something.

For example: alias='cd ~/Documents/userinput'?

I don't wanna scribe a script if possible.

>> No.62582604

>>62582537
You want to make a shell function, not an alias. Aliases can't take arguments and are literally just substitution.

>> No.62582606

>>62582537
use $1

>> No.62582625

>>62582604
>Aliases can't take arguments
Lies

>> No.62582699

>>62582625
[citation needed]

Bash (which is what basically everyone uses) doesn't allow aliases to take arguments.

>> No.62582718

>>62582699
alias m=mpv $1
m youtube.com/video/ahhhhhhhhhhhh
Yes it fucking does

>> No.62582738

>>62582606
Do you mean like that?
alias go='cd ~/Documents/$1

Then I could use this alias in the terminal by writing:
go directoyX

???

>> No.62582745

>>62582738
yes, what eve you pass after "go" would be the folder you want to do ti in "Documents"

>> No.62582759

>>62582745
>>62582606

thanks a lot!

>> No.62582767

>>62581497
Couple things:
You probably have to run "xrdb ~/.Xresources" after making a change.
You might have to restart currently running programs and/or use "sudo fc-cache -fv"
And finally I don't think .Xresources even effects most graphical applications.

What you want is to change your fontconfig settings.
https://wiki.archlinux.org/index.php/font_configuration#Fontconfig_configuration

>> No.62582774

>>62579647
How do I set up virtualization on linux?
I want to test some other versions of linux from inside linux.

>> No.62582778

>>62582718
The $1 is empty, the allowed is substituted for the n, you would get exactly the same behavior without it. Brainlet.

>>62582738
You don't need the $1

>> No.62582801

/fglt/ please tell me about slackware.

>> No.62582811

>>62582778
Nope
startu() { systemctl --user start $1.service; }

>> No.62582826

>>62582811
That's not an alias you moron.

>> No.62582828

>>62580045
Use trisquel, parabola, or deuvian

>> No.62582839

>>62582778
I tried it before like you said. But when I added this alias:
alias go='cd ~/Documents/'
I logically only changed the directory to Documents. That is not what I want. I am trying it with $1 right now.

>> No.62582848

>>62582774
Use VirtualBox. Free software, utilizes KVM, works bretty good, GUI based and sets up device redirection (like bridged ethernet) for itself so much less hassle than qemu for example

>> No.62582850

Reminder that mint is grossly untrustworthy

>> No.62582869

Arch is just a stepping stone.

>> No.62582878

>>62582869
To..?

>> No.62582889

>>62582878
making your own os

>> No.62582892

>>62582878
death

>> No.62582923

>>62582778
>>62582811
ok I did the following:

I added this alias to my list:
alias goto='cd ~/Documents/$1'
The outcome was indeed the same like without $1. I just switched to "Documents".
My goal is that I only need to type the alias and then the destination-directory. Is this possible without a script?

>> No.62582940

>>62582923
>goto
>instead of just cd
what kind of autismo is this?

>> No.62582956

>>62582940
I try to understand the technique. I obviously need it for a longer command.

>> No.62582980

>>62582718
holy shit you're dumb

The $1 in that example isn't needed. Try doing something a bit more complicated like, I don't know:
alias wri='vim $1.txt'

This should create a textfile where the filename is your input and the extension is made to be .txt. But it doesn't work.

Now let's see it as it should really work -- as a function:

wri() { vim $1.txt; }

This will do exactly what you'd expect it to.

>> No.62582998

>>62582980
Hi, I tried it and you seem to be right.

Would you mind to answer my question here in "beginner-language"?
>>62582923

>> No.62583031

>>62579647
Where is the Beard for Source Mage? Is probably close to LFS.

>> No.62583121

I'll be working from home for the next few months. I decided to only use Windows for work and when I have some free time I'll boot up Ubuntu. I could tinker with the settings and browse the net to relax and have to separate OS's to make it easier for me to focus on work.

Does an Ubuntu live dvd let you install the os on a usb stick? What I need to do is leave my windows copy alone (I need it for work and work only) on my hard drive and have an Ubuntu usb stick that would work *exactly* as if it was installed on the hard drive inside. So my files would be there on the stick, the programs, all my settings etc. would be saved on the stick and then I could simply turn the laptop off, unplug the usb stick and get to work after booting up windows.

Is this possible?

>> No.62583162

https://directory.fsf.org/wiki/Lebiniou
>displays images that evolve with sound
>Le Biniou works with music, voice, ambient sounds, whatever acoustic source you choose
Anyone use this?

>> No.62583298

>>62582923
You can put the function ~/.profile, and it will always be available when you log on.

>> No.62583305

>>62583298
Meant for >>62582998

>> No.62583388

>>62583305
what function?

>> No.62583442

>>62583388
You'd put

goto() { cd ~/Documents/$1; }

Into ~/.profile. Log out and log in, and "goto" should be available globally.

>> No.62583470

>>62579916
but windows is free

>> No.62583487

>>62583305
>>62583388
>>62583442
I see and thank you very much.

It worked:

goto ()
{
cd ~/Documents/$1
}


output:
> ~$ goto pandoc
> ~/Documents/pandoc$

>> No.62583674

is chrome os a botnet? should we at least be thankful it's increasing linux market share?

>> No.62583731

>>62583674
>an os that you can't do anything locally with
What do you think, anon?

>> No.62583818

>>62583487
$ help cd
The variable CDPATH defines the search path for the directory containing
DIR. Alternative directory names in CDPATH are separated by a colon (:).
A null directory name is the same as the current directory. If DIR begins
with a slash (/), then CDPATH is not used.

So really you could just set CDPATH=~/Documents and then have plain cd have almost the same behavior.

>> No.62583823

sup bros how does my code look im a brainlet so I dont know if this is a good code or not. its supposed to find the amount of fullly filled bags of apples and leftover apples (12 apples per full bag)



#include <stdio.h>
#include <stdlib.h>

int main(void)
{
int apples, bags, leftover; // defines variables
printf("Fully Filled Apple Bags And Leftovers Calculator\n\n");
printf("Enter the number of apples available=> ");
scanf("%d", &apples);
printf("You have %d apples\n", apples);
bags=( apples / 12 );
leftover=( apples - 12 * bags );
printf("You can produce %d full bags\n", bags);
printf("You have %d apples leftover", leftover);

return 0;
}



what would you guys do to make this better? thanks :3

>> No.62583839

What are the best ressources/books about ubuntu?
Unfortunately im a coplete noob regarding linux but I would really like to try it out

>> No.62583859
File: 94 KB, 428x432, 1497016874256.jpg [View same] [iqdb] [saucenao] [google] [report]
62583859

is Gummi worth it if I'm a brainlet? or should I just git gud?

>> No.62583865

>>62583839
you dont need to do research at all if you want ubuntu
as long as you know how to dual boot and fetch your graphics drivers, it wont require much from you at all

>> No.62583878
File: 272 KB, 1024x768, 1410133185056.jpg [View same] [iqdb] [saucenao] [google] [report]
62583878

>>62582738
$CDPATH exists for shit like this.

>> No.62583945

>>62583823
>leftover=( apples - 12 * bags );
Can't be bothered checking right now but I'm pretty sure C has the modulo arithmetic operato so you could replace the stuff in brackets with apples % 12

>> No.62584035

i didnt select to encrypt my partition during my install? how do i encrypt it after the fact?

>> No.62584045

>>62584035
You reinstall

>> No.62584141

>>62583945
thanks bro

>> No.62584147
File: 2.69 MB, 4000x4000, 1492022905438.jpg [View same] [iqdb] [saucenao] [google] [report]
62584147

>tfw compiling on an APU
FML

>> No.62584157

>>62579916
But Windows 10 is was """""""free"""""""

>> No.62584300

>>62583839
how about the Ubuntu manual?

>> No.62584309

What the hell am I reading ITT.

>>62583487
This is worse than using an alias since it will break with directories containing spaces.

Either use:
goto(){
cd "${HOME}/Documents/${*}"
}


or better:
alias goto='cd ~/Documents/'

>> No.62584329

>>62584309
The latter isn't what anon wants and the former is overly autistic.

>> No.62584359

>>62584329
Well, you're singly wrong.
Bot solutions do the same.

>> No.62584402

>>62584329
When you alias "goto" to "cd ~/Documents/", you can type "goto" and it will act like you have typed "cd ~/Documents", so theres not argument needed.

The former is more of a valid and secure function, what do you think is autistic here?

>> No.62584438

>>62583878
>CDPATH
Autocomplete to sub-directories which aren't really below the current directoy is pretty confusing tbqh.

>> No.62584447

>>62584359
$ gotof() { cd "${HOME}/Documents/${*}"; }
$ alias gotoa='cd ~/Documents/'
$ gotof butt\ magic
bash: cd: /home/user/Documents/butt magic: No such file or directory
$ gotoa butt\ magic
bash: cd: too many arguments[code]hmmm.....[/code]

>> No.62584471

>>62584447
>pretending to be retarded

>> No.62584491

>>62584309
>*
should be @

>> No.62584583

Hey look this framebuffer media player https://github.com/dimkr/fbff

>> No.62584728
File: 652 KB, 2175x1300, 1493511849586.jpg [View same] [iqdb] [saucenao] [google] [report]
62584728

>>62580458

>> No.62584738

I am running a Macbook Air, and have had an aweful time with my network card, tried both Debian and Ubuntu (havnt tried fedora or suse....yet) It just decides to stop working after a dozen or so reboots, on both systems, so Ive made a couple threads on reddit, but no one seems to be able to help me, so Im going through a trial and error type thing, now Im on try a OS without systemD

put Devuan on a usb, but the usb just dosnt recognize at all on the macbook (usb is good typing this on the devuan usb on a different laptop)

supergrub2 sees it but gave me some message about using bios mode or something, so next I tried refind, refind sees it too, but it gave me a message about legacy mode and to update firmware so I reinstalled mac osx updated everything, then reinstalled refind, and tried the usb again, same message

is it even possible to boot distros like this on a uefi?

>> No.62584777

>>62584471
They both literally do different things.

>> No.62585022

>>62584583
mplayer has been able to play to fbdev for a long time.

>> No.62585036

should I use alsa or pulseaudio

>> No.62585053

>>62585022
Thumbs up for MPlayer, works flawlessly.

>> No.62585066

>>62585053
mplayer was deprecated for mpv years ago when it stopped development.Mpv is superior

>> No.62585087

>>62585066
Here comes the fanboy, watch out, the internet tough guy.

>> No.62585095

>>62585087
When has stating facts become a fanboy?

>> No.62585099

>>62585066
No it wasn't.

>> No.62585110

>>62585099
mplayer and mplayer2 stopped development and mpv was forked from the last commit

>> No.62585118

>>62585095
MPlayer is not deprecated, mpv use their work but MPlayer never stopped.

>> No.62585125

>>62585118
It was, but devs came back to it later after mpv was already forked. They continued working on it instead of working with mpv

>> No.62585131

>>62585110
No, MPlayer continues development, get your facts straight.

>> No.62585144

>>62585125
First you say development stopped now you say is not. Get yourself together.

>> No.62585157

So I installed Firefox-esr on Alpine. Nothing shows up, yet I can apparently click and hover over the buttons, because I see my cursor changing over odd areas where there's nothing for the cursor to click on.

Anyone know how to fix?

>> No.62585161

>>62585131
But it stopped years ago same with mplayer2 the devs disappeared and mpv was forked and started moving forward . Some time later mplayer devs came back and started back up

>>62585144
If you would read, i said it stopped, mpv was forked then mplayer came back some time later after mpv already took over

>> No.62585162

I don't agree with calling it GNU/Linux.

>> No.62585171

>>62585162
sorry sweetie

>> No.62585180

>"mplyaer deprecated lul"
>"I dun liek gnu/linux"
coffee break until shitposting ends

>> No.62585334

>>62585171
A prominent reason behind the adoption of the name “Linux” is in accordance with the existence of non-GNU stuff (Display Server, Apache HTTP Server, GUI) present in a complete distribution crafted on top the Linux Kernel. “There are lots of people on this bus; I don’t hear a clamor of support that GNU is more essential than many of the other components; can’t take a wheel away, and end up with a functional vehicle, or an engine, or the seats. I recommend you be happy we have a bus,” - The founder of X Windows.

Calling it GNU/Linux implies that it's just GNU and Linux, which is not true. There's a whole collection of programs hard at work. That's why I like that analogy he made with the bus. Linux has come to incorrectly be known as a complete operating system. That's just the way it happened. If we want to correct that, we should either do it correctly and name every single vital component of the operating system, come up with a new and fair name, or we just leave it be. Your choice.

>> No.62585409

>>62585334
I agree. It should just be called Linux.

>> No.62585585
File: 60 KB, 600x600, 1484200292560.jpg [View same] [iqdb] [saucenao] [google] [report]
62585585

>>62585334
>If you don't use GNU, you don't use GNU.
Wow so clever!

>> No.62585602

Is it possible for a kernel module to delete stuff in the OS after a certain amount of time?

If not, how can I achieve this without using cron?

>> No.62585631
File: 91 KB, 241x234, 1491659795731.png [View same] [iqdb] [saucenao] [google] [report]
62585631

>>62585334
What we say is that you ought to give the system's principal developer a share of the credit. The principal developer is the GNU Project, and the system is basically GNU.

If you feel even more strongly about giving credit where it is due, you might feel that some secondary contributors also deserve credit in the system's name. If so, far be it from us to argue against it. If you feel that X11 deserves credit in the system's name, and you want to call the system GNU/X11/Linux, please do. If you feel that Perl simply cries out for mention, and you want to write GNU/Linux/Perl, go ahead.

Since a long name such as GNU/X11/Apache/Linux/TeX/Perl/Python/FreeCiv becomes absurd, at some point you will have to set a threshold and omit the names of the many other secondary contributions. There is no one obvious right place to set the threshold, so wherever you set it, we won't argue against it.

Different threshold levels would lead to different choices of name for the system. But one name that cannot result from concerns of fairness and giving credit, not for any possible threshold level, is “Linux”. It can't be fair to give all the credit to one secondary contribution (Linux) while omitting the principal contribution (GNU).

>> No.62585646

>>62579647
Why is debian rated so high on the beard-scale? Why is fedora lower?

>> No.62585650

>>62585602
Delete things in the filesystem or delete things from the kernel?

>> No.62585660

>>62585646
Fedora should actually be the same level like Ubuntu, Debian the same level like Arch.

>> No.62585661

>>62585099
Last mail to announce was Feb 2016 ...
http://lists.mplayerhq.hu/pipermail/mplayer-announce/

>> No.62585664

>>62585650
Filesystem, or whatever will make the OS unusable.

Trying to make a training vm that dies in 15 minutes to see how fast I get eventually,

>> No.62585669

>>62585660
>Debian the same level like Arch.
lolno

>> No.62585675

>>62585646
fuck you, that's why

>> No.62585684

>>62585669
Sorry that it hurts your elite-fee fees, but it's the truth.

>> No.62585694

>>62585684
Debian is trash, you have to enable 122352354235 different THIRD PARTY REPOS to even have a workable modern system.

>> No.62585698

>>62585631
t.butthurt he couldn't write a kernel

>> No.62585710

>>62585694
Retard.
>>62585698
Retard.

>> No.62585741

>>62585694
Ummm, I suppose that depends on what you mean by "workable modern system" but if you mean using a bunch of special snowflake alpha quality ricing scripts that aren't packaged in debian I believe you.

>> No.62585750

Feels very comfy when you get your config exactly how you planned.

When did you start using and understanding Linux?

I got debian on my desktop in december.

>> No.62585757
File: 128 KB, 602x402, 1476957969865.gif [View same] [iqdb] [saucenao] [google] [report]
62585757

>>62585698
t. butthurt he couldn't write a compiler

>> No.62585760

>>62585741
How bout nvidia

>> No.62585767

>>62585750
I started understanding more when Debian decided to limit me.

Moved to slackware and I configured it the way I want it to work like I did to vim.

Very /comfy/

>> No.62585770

Fuck off with this virtual rivalry, is GNU/Linux, Linus wouldn't complain if people start to call it just GNU.

>> No.62585771

>>62585694
flat out wrong

>> No.62585776

>>62585771
>>62585760

>> No.62585784

>>62585760
you mean apt install nvidia-driver which is a metapackage which handles doing the dkms build for you?

>> No.62585794

>>62585776
it comes with free drivers
all you have to do is add non-free to the repos and download the proprietary nvidia driver

>> No.62585801

>>62585650
>>62585664
I guess maybe have a file that has the time in seconds, and another script that looks into it every minute?

When it reaches zero, it runs rm -rf /? basically 3 files, 2 of them are scripts, one of them tells the time?

>> No.62585802

>>62585794
you dont even need the proprietary nvidia drivers if you dont want them either, but you will get better performance

>> No.62585803

>>62585757
somehow I doubt it

>> No.62585804

>>62585767
I finally configured my desktop the way I want and got Brave on here.

Using MATE.

very lightweight/core/

>> No.62585815

>>62585801
just call out to at when the vm starts.

>> No.62585821

>The first time I was introduced to this side of Unix was probably in 1991 or so when Lars Wirzenius dragged me along to an event at the Polytechnic University of Helsinki (which, as everybody knows, is not actually in Helsinki but right across the border in Espoo). They just want to be associated with the glamorous Helsinki even if only by name). The speaker was Richard Stallman.
>Richard Stallman is the God of Free Software. He started to work on an alternative to Unix in 1984, calling it the GNU system. GNU stands for “GNU is Not Unix,” being one of many recursive acronyms where one of the letters stands for the acronym itself—a kind of computer science in-joke that nobody else ever gets. Geeks—we’re just tons of fun to be around.
>More importantly, RMS, as he prefers to be called, also wrote the Free Software Manifesto, and the Free Software copyright license—the GPL (General Public License). Basically, he pioneered the notion of free source-code availability as something intentional, not just an accident, the way it happened with original Unix open development.
>I have to admit that I wasn’t much aware of the sociopolitical issues that were—and are—so dear to RMS. I was not really all that aware of the Free Software Foundation, which he founded, and all that it stood for. Judging from the fact that I don’t remember much about the talk back in 1991, it probably didn’t make a huge impact on my life at that point. I was interested in the technology, not the politics—I had had enough politics at home. But Lars was an ideologist, and I tagged along and listened.
>In Richard I saw, for the first time in my life, the stereotypical longhaired, bearded hacker type. We don’t much have them in Helsinki.
>I may not have seen the light, but I guess something from his speech must have sunk in. After all, I later ended up using the GPL for Linux. There I go, getting ahead of myself again.

>-- Linus Torvalds, Just for Fun, 2001.

>> No.62585832

>>62585631
>It can't be fair to give all the credit to one secondary contribution (Linux) while omitting the principal contribution (GNU).
>lines of code meme
The system is primarily Linux. Even if it wasn't, I think we should keep Stallman locked away forever. I picked Linux because I wanted a clean, hassle-free OS. The cleanly-shaven, trustworthy face of Linus Torvalds is what made me install Linux. If I saw that my only other alternative to Windows was a cohhmputer shishtem made by a hairy caveman who eats his literal foot that had a community full of computer communists, I would have just stuck with Windows. If you autists aren't careful, we might go back down to 2%.

>> No.62585837

>>62585815
What do you mean?

>> No.62585847

>>62585837
at "now + 15 minutes" <<< "rm /lib/ld-linux.so.2"

>> No.62585857

>>62585770
>Linus wouldn't complain if people start to call it just GNU
S-So? You cult of personality morons who can't think for yourselves are just the worst.

>> No.62585861

>>62585847
Oh damn nice, didn't know about that command.

I guess putting that into /etc/init.d/ as a script to start at boot would work as well?

I was wondering if VirtualBox or Vagrant had a way of doing it, since I've setup my environment in vagrant with a script.

>> No.62585867

>>62585832
There's no competition with other OS; marketshare doesn't matter if it's not for freedom. Do you want yet another botnet-normie friendly botnet OS?

>> No.62585877

>>62585821
Sadly he later turned into a Free Software hater.

>> No.62585886

>>62585770
>>62585857
>>62585857
>In some ways, Linux was the project that really made the split clear between what the FSF is pushing which is very different from what open source and Linux has always been about which is more of a technical superiority instead of a — this religious belief in freedom.

>There are 'extremists' in the free software world, but that's one major reason why I don't call what I do 'free software' any more. I don't want to be associated with the people for whom it's about exclusion and hatred.
>-- Linus Torvalds

>> No.62585893

>>62585861
>I guess putting that into /etc/init.d/
If you are going to use that exact command it won't because <<< is a bashism and (with sysvinit on debian at least) those scripts are run by dash. Have to echo through a pipe or something.

>> No.62585921

>>62585886
>install linux and you have freedom!
later that day
>fucking freetards, you ruin everything!

>> No.62585939

>>62585893
So the script would be like
#!/bin/bash
at "now + 15 minutes" | rm rm /lib/ld-linux.so.2
chattr +i /usr/bin/at
rm /etc/init.d/thisscript.sh
?

I was thinking maybe add some other stuff to remove like rm -rf /, but not sure if it would be useful.

>> No.62586008

>>62585832
One interesting thing about following Linux vs GNU/Linux discussions is that the pro-Linux side usually acts pretty childish (the commies, the jews, cuck, gas, LOL, toejam, etc) when faced with arguments, why is that?

>> No.62586012

>>62585939
uhh, wtf is that supposed to do? Whatever is I am fairly sure it doesn't do it. Are you trying to kill the VM while stopping anyone logged in from keeping it running? Does the logged in user have root? Why don't you just kill the VM from the host system?

>> No.62586037

>>62585939
#!/bin/sh

faster

>> No.62586042

>>62586008
Because the GNU side thinks that what they care about is more important than anything else and the Linux people disagree and think it is just nice to have. Both sides know this and are not going to change their position so any reasoned discussion is a waste of time because it would just go round in circles. Hence shitposting.
This is a very common occurance in discussions about all kind of topics. I know that might be surprising for high school students who are used to there being one single correct answer but there you go.

>> No.62586046

>>62586037
80% of distros link sh to bash

>> No.62586058

>>62586046
And your point is?

>> No.62586061

>>62586012
It's just a speedtest vm of how fast I can do certain things in it with root yes. I want to do it formally and a new way instead of timing myself physically.

>>62586037
Actually, when I put the <<< with #!/bin/bash, it accepted it.

>> No.62586063

>>62586058
You're literally running bash in both cases, nothing is faster

>> No.62586071

When the bash binary is called as "sh" it enters POSIX mode, which means it doesn't load all the bash extensions and acts like a simple shell, which makes it faster.

>> No.62586088

>>62586071
>>62586063
Top of the bash manpage.

>> No.62586090

>>62586063
except if you are running sh

>> No.62586093

>>62586046
>>62586058
>>62586063
>>62586071
Running it with #!/bin/sh doesn't run the actual script.

When I have it with #!/bin/bash, it does

Here are the outputs:
With sh
# /etc/init.d/test.sh
/etc/init.d/test.sh: 2: /etc/init.d/test.sh: Syntax error: redirection unexpected

With bash
# /etc/init.d/test.sh
warning: commands will be executed using /bin/sh
job 7 at Sun Sep 24 02:42:00 2017

>> No.62586106

>>62586093
And is >>62585939 the script you are running? Because the command you want at to run is supposed to go on the stdin of at.

>> No.62586139

>>62586093
#!/bin/sh
echo "rm /lib/ld-linux.so.2" | at "now + 15 minutes"
chattr +i /usr/bin/at
rm /etc/init.d/thisscript.sh

>> No.62586143

>>62586106
Nope, I changed it to $(at "now + 1 minute" <<< "rm /home/test/test")

>> No.62586152

>>62581108
nope, using stock freetype2, the dev just did a "minor housekeeping change" that also happened to totally switch how font is rendered

>>62581173
thanks, this fixed it!

>> No.62586164

>>62586139
Oh alright nice, I will do it this way just in-case it did not work.

>> No.62586203

>>62579647
Pic makes sense, because Ubuntu is the most usable and best looking.

>> No.62586208

>>62580630
Install him KDE neon or Manjaro.

>> No.62586214

>>62586203
if ur a beginner you cant customize

>> No.62586229

what's the best version of VNC these days? I don't care if it's Stallman approved if one of them is way better.

>> No.62586242

What's a good, script friendy utility for music tagging?

>> No.62586247

>>62579916
>what is picokms
I still prefer Linux for most things.

>> No.62586256

>>62586242
mutagen

>> No.62586269

>>62581497
Almost nothing obeys xresources anymore. Edit fonts.conf instead.

>> No.62586282

>>62586269
Cept thats a lie

>> No.62586358

Why isn't this working:
$ sudo iptables -F
$ sudo iptables -A INPUT -i enp0s3 -p udp --dport 53 -j ACCEPT
$ sudo iptables -A INPUT -i enp0s3 -p tcp --dport 53 -j ACCEPT
$ sudo iptables -A INPUT -i enp0s3 -j DROP
$ host google.com
;; connection timed out ; no servers could be reached


If replace the DROP command with
$ sudo iptables -A INPUT -i enp0s3 -j LOG --log-prefix "IPTABLES TEST: " --log-level 7

And check the logs, it does show packets being sent using port 53. What am I doing wrong?

>> No.62586367

>>62584147
It could be worse. It took me three days to rebuild the system from source running OpenBSD/sparc64 on a Sun Ultra 5.

>> No.62586368
File: 153 KB, 1918x855, Screenshot_20170923_200317.png [View same] [iqdb] [saucenao] [google] [report]
62586368

>>62579647
I have a problem

none of the kwin scripts I try to use will work
I can "install" them, but it's like my system refuses to otherwise recognize they exist; pic related

How do I even begin fixing this issue?

>> No.62586375

>>62584738
Broadcom wifi is utter garbage. Get a better laptop.

>> No.62586388

>>62586368
That means they're incompatible with your version of kwin. KDE is the all time champion of API churn.

>> No.62586447

>>62586358
>dport
>INPUT
are the response packets also going to port 53? AKA is the source port on your outgoing packets 53?

>> No.62586463

>>62586388
How do I find out what version of kwin I have, and what version of kwin they're designed for?

Not a single kwin script I've installed has actually shown up so I think my system might somehow be immensely out of date.

>> No.62586472

>>62586358
Also you could just use
iptables -A INPUT -m state --state ESTABLISHED -j ACCEPT
and not worry about having to filter that shit specifically. Pretty sure it works for UDP too.

>> No.62586484

>>62586463
Check your package manager. You might be up to date - Kwin scripting has been around for over a decade and almost none of them work on 5.10.

>> No.62586500

>>62586447
I'm controlling the server console directly in a virtual machine and I want to prevent the server from making requests to the outside world except ones I specify. I have much more complex rules in mind, but I want to try super basic shit before I do that.

>>62586472
Huh? How does that know I want to filter ports 53 UDP and TCP?

>> No.62586516

>>62586500
>I'm controlling the server console directly in a virtual machine and I want to prevent the server from making requests to the outside world
Then why aren't you filtering on the OUTPUT chain?

>> No.62586558

>>62586516
Thank you!! Switched to output and it works.

>> No.62586562

I've got linux mint 18.2 but I'm not sure I have all the repo's I should

Does anyone have a list of PPA's I should be using for 18.2?

>> No.62586584

I have been using debian for the longest time, and I sort of want to switch over to gentoo. I tried arch, i hated it because I could get the same effect without any hassle with debian minimale install. However, with gentoo you usually compile everything, so no binaries. this seems to give you the power of choice with literally everything, but I haven't actually tried gentoo. So, Is it worth it?

>> No.62586592

>>62586584
install gentoo

>> No.62586602

>>62586584
Gentoo is absolutely worth it if you're looking to rice every last package and binary. It won't get you a whole lot of performance improvements like it did in the Pentium 3 and 4 days, but it's satisfying.

>> No.62586666

>>62586484
Okay, I found some errors relating to it finally:

plasmapkg2 --type kwinscript -i kwin-quarter-tiling

Package type "KWin/Script" not found
kf5.kcoreaddons.desktopparser: Could not locate service type file kservicetypes5/kwin-script.desktop


I think I'm missing something here.

>> No.62586679

>>62586247
Linux is the desktop version of Android.

>> No.62586716
File: 168 KB, 420x561, 1501580485025.jpg [View same] [iqdb] [saucenao] [google] [report]
62586716

Now that I have your attention, what are some cool terminal commands?

>> No.62586722

>>62586716
hexdump -C /dev/urandom | lolcat -a -s 500

>> No.62586725

>>62586716
man touch

>> No.62586743

>>62586716
binwalk

>> No.62586747

>>62586725
jej

>> No.62586748

>>62586716
head -500 /dev/urandom > /etc/fstab && dd if=/dev/zero of=/dev/sda bs=1M count=128 && reboot

>> No.62586752

how would fsf feel about pirating non free games?

>> No.62586766

>>62586752
>pirating
that part of rms' no-no words along with open source and linux

>> No.62586793

>>62586748
don't do this u get banned

>> No.62586822

>>62586716
# Share current directory on port 8080.
python3 -m http.server 8080

>> No.62586823

im a dumbfuck who didnt encrypt my disk when i installed. is there a way i can backup all my configurations that i spent hours on and transfer them to a new install? my drivers too. i have an oddball nvidia optimus system so getting gpu drivers working is an extreme headache

>> No.62586892

>>62586822
but anon, sharing is theft

>> No.62586899

>>62586823
sure, just keep those files and then put them in the new install.
if you meant something automagically, then no
gets easier the second, third, ..., nth time though.

>> No.62586904

>>62586823
You can just rsync everything. Exclude /dev, /proc, /sys, /tmp, /run, and the destination directory.

>> No.62586907
File: 48 KB, 622x626, 1494189718528.png [View same] [iqdb] [saucenao] [google] [report]
62586907

>>62586892

>> No.62587006

>>62586716
echo "Hello World" >| echo "Me" > out.txt

>> No.62587077

>>62587006
???

>> No.62587155

>>62586716
curl cheat.sh/<COMMAND>
for example
curl cheat.sh/tar

>> No.62587164

>>62586716
curl -s -L https://raw.githubusercontent.com/keroserene/rickrollrc/master/roll.sh | bash

>> No.62587240

>>62586716
arch

>> No.62587524

Any sysadmin here has experience with daemontools? Can you tell its pros and cons? I am thinking on installing it to see how it does.

>> No.62587574

>>62579647
how to force install fedora 26 in bios legacy mode?
i cant change my bios setting priority to legacy (locked), and i want to dual boot with win7 (currently installed)
my best alternative now is reinstall win7 (uefi) then normally install fedora

>> No.62587580

>>62587524
covfefe

>> No.62587603

I have a CD with Arch on it but it's from 2016. Does it matter since everything will get updated during the install anyway?

>> No.62587811

>>62587603
Depends. If you actually install anything out of date then Arch will break. But if the live cd is network install then maybe it will be ok although with Arch you're better off just getting the latest.

>> No.62587845

>>62587574
never mind. i figured it out.

>> No.62587848

My manjaro openrc is deprecated and broke
ALREADY TRIED using Artix, Archbang, Devuan but THEY ARE ALL bugged shit
ANY OTHER non-systemd distro before I FINALLY surrencer to the systemd OVERLORDS?

>> No.62587857

>>62587848
bait

>> No.62587892

encrypting my partition during install. it says the DISK can have no additional changes to partitions after encryption
does this mean I can't resize my unencrypted windows partition without deleting the encrypted partition entirely?

>> No.62587918

>>62587848
install gentoo

>> No.62587927

>>62587857
not really
Downloading Void right now, its my last hope

>> No.62587937

>>62587918
Source based, and lengthy manual installation process, need a just werks distro

>> No.62587993

>>62587937
Try PCLinux

>> No.62588004

what distro does /fglt/ actually use?

>> No.62588014

>>62588004
debian
everything else is memes
arch users are fat losers so they dont count

>> No.62588019

>>62588004
Devuan and Source Mage over here, also armbian on my arm server

>> No.62588024

Ok, what gives here? I'm installing SMGL, and I'm now on the bootloader part. I'm going with the default lilo, and while lilo.conf exists, which I modified accordingly, when I go to run the command lilo -A /dev/sda 1]/code], I get lilo: command not found. the fuck?

>> No.62588035

>>62588024
goddamnit, fucked up the code tag.

>> No.62588046

>>62588024
Are you on the chroot and unpacked everything anon?

>> No.62588054

>>62588046
Obviously, else I wouldn't be on the bootloader part.

>> No.62588069

>>62587993
Not a bad choice
Not enough packages and shitty package manager though

>> No.62588086

>>62588014
what about fedora i was thinking about using that

can i use i3 with debian

>> No.62588093

>>62588004
ubuntu lts on a chinkpad, and vps
arch on my main rig
rasbpian on rpi
opensuse tumbleweed on a in-home server (old rig)

>> No.62588097

>>62588086
i use debian but i wasnt actually serious
do your research and use what suits you

>> No.62588113

>>62588054
Sorry, is you did all the steps correctly and edit /etc/lilo.conf I see no reason. Trace your steps and see what you did.

>> No.62588206

>>62580646
Kubuntu is a mess
Use KDE Neon

>> No.62588216

will ssh still work of one or both hard drives are encrypted?

>> No.62588223

>>62588113
I've done everything exactly by the documentation (minus the partitioning). This doesn't make any fucking sense.

>> No.62588231

>>62588216
What the fuck are you smoking? Hard drive encryption and SSH have nothing to do with each other.

>> No.62588234

>>62588216
Well the ssh daemon won't be executed if it isn't decrypted first.

>> No.62588242

>>62588223
Wait, is your partition mounted properly? Check if all the folders are not empty inside your chroot.

>> No.62588257
File: 56 KB, 645x773, 1503320277404.jpg [View same] [iqdb] [saucenao] [google] [report]
62588257

>>62588231
i dont know much about encryption
i thought it might show up as a bunch of gibberish or refuse to connect if it was encrypted but i guess everything is decrypted if the os is booted

>> No.62588260

>>62588242
Yes, obviously. I wouldn't have been able to do anything prior to get to this step if they weren't. I've been perusing through each directory manually since locate can't find anything related to lilo minus config files. All the stuff is there (well, obviously not, since I can't fucking find lilo)

>> No.62588273

>>62588004
void

>> No.62588319

>>62588004
Gentoo and NixOS

>> No.62588337

>>62588260
If you doubt the i age came with lilo download another chroot image but check your partitions, is easy to miss something and you could miss to mount properly, I know it happened to me when I though I did everything right but I unpacked the archive before mounting right.

>> No.62588344

>>62586748

How fucking new and retarded do you have to be that you think people will run that?
You have to be 18 to use this website, you fucking retard, stop posting before your mom sees you.

>> No.62588396

>>62588257
Are you serious?

>> No.62588400

>>62588337
Well I only created 2 partitions to keep it simple. /dev/sda1 as / and /dev/sda2 as /home.

These are my following steps (running from live Ubuntu):

mkdir /mnt/root
mount /dev/sda1 /mnt/root
mkdir /mnt/root/home
mount /dev/sda2 /mnt/root/home

cd /mnt/root
tar xvjf smgl-stable-0.60-10-basesystem-x86_64.tar.xz

mount --bind /dev/ /mnt/root/dev
mount --bind /sys/ /mnt/root/sys
mount -t proc none /mnt/root/proc
mount -t devpts none /mnt/root/dev/pts

chroot /mnt/root


And from there I proceeded along just fine, setting my basic configs and compiling the kernel. Then I go to install the bootloader, lilo just to keep it simple for the time being, and boom. No lilo found.

I think I'm going to say fuck it and do a workaround with grub2 instead, but given that grub/grub2 is ALSO not found on the system, I downloaded it manually. I'll see where this takes me.

>> No.62588408

>>62588400
Fug, typo on the tar. xvjf should be xvJf.

>> No.62588435

>>62588344
Ow, did you run a command from 4chan and break your pc?

>> No.62588448

>>62588435

Aww, did babby watch Mr Robot and thinks he's a hacker now for copy/pasting ridiculous one-liners that no normal person would run because it's obviously malicious?
Awww poor babby, don't you have to ask how to install Kali or why your Zsh config isn't loaded even though you triple-checked that you edited the .bashrc file?

>> No.62588480

/faglet/

>> No.62588676

make new_thread -j1

>> No.62588697

>>62588400
>>62588337
Ok, kewl. Grub worked, and I can actually boot into my system now, though the GRUB is kind of...basic right now. And the system seems a little buggy feeling. Oh, that's probably because I'm not connected to network.

How to connect to wifi in base install?

>> No.62588706

>>62588448
nigga, I don't need kali I rootkitted NSAs wire taps and bottnetted your backbone. I'm behind three dark fibers right now so you better stop talking smack or I'll blow your monitor up right in your greasy face.

>> No.62588707

I've been wanting to try i3 for a while now and have been wondering what graphical file manager and photo viewer would suit it best. Thunar and whatever Xfce uses for their viewer?

>> No.62588713

>>62588697
networkmanager and wicd both have cli clients.
Otherwise, you have to use wpa-supplicant which is not easy to use.

Whip out an ethernet cable and install some kind of network management.

>> No.62588725

>>62588713
None of those things are installed, and no network device but loopback is detected. Fuck.

Crawl out of one hole and into another. Is this a kernel thing?

>> No.62588735
File: 121 KB, 335x335, 1478877166460.png [View same] [iqdb] [saucenao] [google] [report]
62588735

What is the best, I mean the best, wireless adapter for linux distros in general? One that's plug and play.

>> No.62588946

>>62588735
just use wifi you filthy freetard

>> No.62588974

>>62588707
I've liked SpaceFM more than Thunar.

>> No.62589045

>>62588707

File managers and photo viewers are window manager independent, just like any other graphical program.

>> No.62589113

what the fuck did they mean by this?
https://www.youtube.com/watch?v=qHGTs1NSB1s
https://www.youtube.com/watch?v=umQL37AC_YM

>> No.62589128

>>62589113
They mean that they're too fucking busy lecturing people/managing retarded kernel devs to use a shitty installer and deal with all the idiosyncrasies and hiccups that come with the installation process.

>> No.62589175

>>62588946
...what?

>> No.62589214

>>62589113
It's absolutely true, though.

Most of the difficulty of the "advanced" operating systems (Arch, Debian, Gentoo, Source Mage, etc.) stems from the perceived difficulty of installation. Whether that difficulty is true or not, what's undoubtedly true is that daily usage of 99% of distros (including those advanced distros) is fairly straightforward.

It should also be noted that, although Stallman and Torvalds are major figures in the Linux community, their choices in distro/installation ease doesn't reflect every user. As can be seen in the case of the Linux Foundation idiots, the fact that RMS and Torvalds are *actually* devoted users of Linux is something to admire.

>inb4 *GNU/Linux

>> No.62589215

Is there a general guide to making Vim more useful? I'd like to autocomplete brackets, check spelling, some other basic things most IDEs already do.

>> No.62589225

Hi I made this simple function to google search from Linux and the command line:

# search google via terminal
google()
{
firefox -search "$1"
}



My issue is that only the first word is searched when I type several words. How do I solve it?

I also tried [email protected] insted of $1 but then the program opens two different browsers for the two different words.

>> No.62589241

>>62589225
better use searx, google is botnet

>> No.62589254

>>62589215

No, you're doing it wrong. You use Vim and then you add to it things, one by one as you start to need them.

Only idiots copy someone else's configuration files and addons, ending up with hundreds of useless things they don't even know they have.

>> No.62589255

>>62589225
Try "$*". Also this: >>62589241

>> No.62589259

new

>>62589256
>>62589256
>>62589256

>> No.62589284

>>62589255
"$*" really works, thank you anon! Couldn't solve it for an hour or more. Do you know how this kind of parameters are called?

>> No.62589348

>>62589284
The bash manpage explains everything.

>> No.62589358

>>62579916
It's free.
I think most of the GNU/Linux users, use a Windows Virtual Machine, to make tests on it.

>> No.62589425

>>62589358
>I think most of the GNU/Linux users, use a Windows Virtual Machine,
Nope. Just you.

>> No.62590149

>>62586716
set this script as the external browser in rss reader to directly launch mpv for youtube links
if [[ $1 == "https://www.youtube.com/watch?"* ]]; then
mpv $1 --ytdl-format mp4 &
else
xdg-open $1
fi
exit

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
reCAPTCHA
Action