Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

/vt/ is now archived.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 60 KB, 333x333, IMG_0107.png [View same] [iqdb] [saucenao] [google] [report]
62540644 No.62540644 [Reply] [Original] [archived.moe] [rbt]

Previous: >>62530518

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources:
Your friendly neighborhood search engine.

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux:
https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux

>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page

>What are some cool terminal commands?
http://www.commandlinefu.com/
http://bropages.org/

>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/

>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html

>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/t/'s GNU/Linux Games: >>>/t/769497 #

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

>> No.62540648

First

for

Reddit

spacing

and

pointless

arguments

>> No.62540677

what are arch users trying to compensate for?

>> No.62540687

>>62540677
Their father's affection

>> No.62540708

>>62540677
their inability to install gentoo

>> No.62540723

>>62540642
>>62540642
>>62540642
>>62540642

>> No.62540752

>>62540677
Lack of social life and small penis

>> No.62540837

>>62540677
they already have huge penises and active social lives, so they use a time-consuming distro as a break from the endless social gatherings and sexual conquests

>> No.62540923

Right now i have a minimalistic debian install with no de.
My goal is i3wm

What steps do i have to make to launch it on startup?
Not how, just what steps

>> No.62540956

>>62540923
Why not just read Arch wiki? Everything is still pretty much applicable to other distros.
To answer your question, add exec i3 in your ~/.xinitrc file and type startx in command line.

>> No.62541023

>>62540723
Have you tried reading the man page?

>> No.62541052

>>62541023
the what?

>> No.62541071

>>62541052
love it

>> No.62541086
File: 267 KB, 524x601, 1464730288921.png [View same] [iqdb] [saucenao] [google] [report]
62541086

>>62541071
what the fuck are you talking about

>> No.62541108

>>62541086
Did you even read the OP? It's there for a reason, you know? You keep all these stupid conky questions, and yet you aren't even putting up the effort to teach yourself?

>> No.62541130

>>62541108
ive been to fucking several links and it still comes out fucked up
ive been looking for answers the whole time, not twiddling my thumbs waiting for the thread to answer

>> No.62541245

>>62541130
Don't read links. Read the man page.

man conky (or whatever the command for it is)

>> No.62541248

>>62541130
use
man conky

my dude

>> No.62541282

>>62541130
how is it, that in all of your extensive research, you never even came across the concept of a man page?

>> No.62541353

>>62541282
because im just trying to get conky to work, not write a fucking book on linux

>> No.62541494

>>62541353
So, if you buy, say, a tent, do you throw away the manual and then tell the manufacturer that you can't be expected to assemble the tent because you're "not trying to write a fucking book on tents"?

>> No.62541512

>>62541353
I dont even understand why you didnt just google "man page linux" or something and just sat around here waiting for someone to explain it to you

>> No.62541560

>>62541494
well most people are neurotypical enough make things that dont really need a manual to use
a fucking desktop weather app and system monitor should not eat up hours of my time

>> No.62541593 [DELETED] 

>>62541560
Why are using conky?

>> No.62541601

>>62541560
Does sitting in this thread not count as time "eaten" up?

>> No.62541629
File: 107 KB, 523x428, tira10.png [View same] [iqdb] [saucenao] [google] [report]
62541629

What is THE BEST Emacs theme?

>> No.62541646

>>62541560
I just read the config and its dead fucking easy

You even have a graphical utility that changes your .conkyrc

>> No.62541655

>>62541601
no but that's how long it would take to configure it or alter other peoples configs to work on my system

>> No.62541724

>>62541646
are you talking about conky manager? i tried adding the repository for it
gave me a bunch of errors

>> No.62542130

>>62541646
>dead fucking easy
your mom is

>> No.62542472

>>62541629
Evil modo

>> No.62542874

Linux is the desktop version of Android.

>> No.62543102
File: 50 KB, 1200x800, 1493533891640.png [View same] [iqdb] [saucenao] [google] [report]
62543102

What are some cool terminal commands?

>> No.62543174
File: 665 KB, 1390x698, gnome-170.png [View same] [iqdb] [saucenao] [google] [report]
62543174

I just bought a nice Thinkpad for myself after my old PC died and I want to run exclusively GNU+Linux on it (I used to dual boot Mint and W10). I have my eye on Manjaro. I don't see a lot of talk about it even though it's like #3 on DistroWatch. What do you guys think of it?

>> No.62543505

Re-posting:

I'm in the process of choosing a distro. I'm taking my time because I really don't want to distro hop. Ideally I want something that will "just work" even if it takes a while to get everything to my liking.
I'll be keeping a windows install, but I'm really hoping that after everything is configured, I'll never need to boot that piece of shit again.
Devuan is a no-go, so I've resigned myself to systemd. Didn't want to, but whatever. Yet I'm not feeling Debian either, so I probably won't go with that.
I've settled on a DE, I'll be running KDE Plasma. I'm gonna try Neon on a vm soon, but I don't expect much from it.

My question is. Should I start seriously considering Arch? The thought has been crossing my mind lately.
Is it really that good if I dedicate myself? Is it really as well documented as people say? Is it worth it?

This will be on my only computer, so, my daily driver. It's an Asus laptop with dual-GPU (intel+Nvidia) and just 6 GB of RAM.
It will be used mainly for Web browsing, watching 1080p HEVC encoded videos through HDMI, some gaming, some image editing with GIMP, and hopefully some programming with C++/Qt. And torrenting 24/7.

Any thoughts and tips will be appreciated.

>> No.62543517

>>62543102
:(){ :|: & };:

>> No.62543544

>>62543517
>>>/redd.it

>> No.62543983

I'm installing arch and I'm having trouble with the bootloader part
I have confirmed I'm running in UEFI mode, but it doesn't like the EFI partition I made, even though it's 512MB, fat32 and marked as EFI System

>> No.62543998

>>62543983
nevermind I didn't mount the fucking thing

>> No.62544030

>>62543983
>>62543998
well fuck it's dropping me to the grub rescue shell thing

>> No.62544065

>>62544030
double check your fstab

>> No.62544090

>>62544065
all I've got is the root partition and swap
should the EFI partition be in fstab?

>> No.62544106

Where can I find a list of all multimedia keys like XF86AudioLowerVolume?

>> No.62544138

>>62544106
less /usr/include/X11/XF86keysym.h

>> No.62544172

>>62544138
lmao
#define XF86XK_LightBulb 0x1008FF35 /* Light bulb keys exist */
#define XF86XK_HotLinks 0x1008FF3A /* Show "hot" links */
#define XF86XK_BackForward 0x1008FF3F /* ??? */

>> No.62544219

>>62544138
Ty.

>> No.62545282

>ubuntu desktop system at my workplace, used for as desktop/office purposes
>every day after 9-10h of uptime desktop programs such as Dropbox client cannot access the internet and browsers cannot open certain websites
>ping from terminal works A-OK to anywere

What could cause this? This shit is driving me bonkers.

>> No.62545294

>>62545282
dns

>> No.62545312

>>62543505
why don't you try things out before you make up your mind anon

>> No.62545318

>>62545294
I edited the resolv.conf template to include the ISPs dns and opendns servers before it adds anything automatically. Is some shit ignoring this or resolvconf altogether?

>> No.62545340

>>62545318
>resolv.conf

stop living in the past you retarded babyduck
systemd, fucking use it

>> No.62545379

>>62545340
Please don't troll the newfriends.

>> No.62545595

>>62545340
thank you for your helpful and absolutely informative post. You can now go and fucking kill yourself, systemd nigger.

>> No.62545630

http://www.yak.net/carmen/unix_horror_stories

>> No.62545760

>>62545312
I've been trying them. That's how I've ruled out Devuan and also Debian.
I've always thought that when I finally made the switch to GNU/Linux, I'd run Debian, having run both it and Mint on VMs before. But now that I'm actually going to do it, I've changed my mind about it.
I'm considering just biting the bullet and installing *buntu (probably kubuntu, or maybe Neon for the maximum Plasma integration) for the "just werk" factor, but that would be as a last resort.

And then there's Arch. If it's wiki holds water to what it's advertised, that would be a great feature to have, instead of having to google and go through countless shady ubuntu forums trying to find a solution to some problem. The bleeding edge software would be just a very nice bonus.
However, it's clearly an intimidating distro to get into, and I was wondering /fglt/'s opinions about it.

>> No.62545917
File: 192 KB, 750x864, 1492217181571.jpg [View same] [iqdb] [saucenao] [google] [report]
62545917

>>62545630

>> No.62545956

>>62545318
IIRC, there's a bug with how systemd interacts with resolv.conf, in that it will just try to use what it perceives as the most stable DNS server instead of what you have listed first.

Pro-tip: use fewer servers (no more than 3, but preferably just 1-2). Don't use a "backup" server if you dislike systemd potentially trying to switch to it.

>> No.62545966

I dualboot windows 8 and debian. I've got an ssd with both OSs installed and an HDD. I made an NTFS partion on the HDD for files to be shared between both OSs, but linux does not see that partion, how do I fix this?

>> No.62546126

>>62545966
install ntfs-3g

>> No.62546175

>>62546126
I have it

>> No.62546216

>>62546175
it should work then. Do a

mount /dev/<your device> /somewhere -t ntfs-3g

and post the results. Replace dev and target with yours of course.

>> No.62546233 [DELETED] 

I need help.
I did CTRL+X some hours ago on my Debian PC, moving an important folder I had to a thumb drive, so I could put the files on another Debian PC I have.

But, when I inserted the thumb drive on the second PC, it was shown as blank. Inserting the drive on the first PC shows it as blank too. The space on the disk is certainly occupied, as I can see on properties, but I cannot see any file on graphical nor terminal, nor sudo, nor normal user.

I've been trying for some hours, and I don't have any clue about how to make the files appear again. Undeleting them on the PC was tried, without sucess. My thumb drive is partitioned as NTFS.

>>62537080
I said it is NTFS, right?
CTRL+X is a shortcut to CUT. https://en.wikipedia.org/wiki/Control-X So, the original files were deleted in the process.
I already tried testdisk. Don't know if there's something I did not tried correctly on testdisk...

>>62537153
Testdisk = already tried, as said above.
Can't use EXT4undelete because I'm not using EXT4. The thumb drive was formatted as NTFS.

>> No.62546268

>>62546233
>The thumb drive was formatted as NTFS.

Try GetBackDataNTFS. Its not free software, but included on Hirens Boot CD.

>> No.62546271
File: 89 KB, 426x640, rubbish-bin-364214_640.jpg [View same] [iqdb] [saucenao] [google] [report]
62546271

I need help.
I did CTRL+X some hours ago on my Debian PC, moving an important folder I had to a thumb drive, so I could put the files on another Debian PC I have.

But, when I inserted the thumb drive on the second PC, it was shown as blank. Inserting the drive on the first PC shows it as blank too. The space on the disk is certainly occupied, as I can see on properties, but I cannot see any file on graphical nor terminal, nor sudo, nor normal user.

I've been trying for some hours, and I don't have any clue about how to make the files appear again. Undeleting them on the PC was tried, without sucess. My thumb drive is partitioned as NTFS.

>>62537080
I said it is NTFS, right?
CTRL+X is a shortcut to CUT. https://en.wikipedia.org/wiki/Control-X So, the original files were deleted in the process.
I already tried testdisk. Don't know if there's something I did not tried correctly on testdisk...

>>62537153
Testdisk = already tried, as said above.
Can't use EXT4undelete because I'm not using EXT4. The thumb drive was formatted as NTFS.

>> No.62546316

>>62540644
As someone used to windows, whats a good way to understand the linux file structure?

For example, if I want to open a program but I dont know the CLI name for it, how do I find the folder that contains the ".exe" (how do I know its executable without a exe file end)?

Normally on windows of course, the file will be in the program files folder; but I dont know where package managers put programs.

Also, what about "portable programs" that exist in windows that dont use the registry; whats the equivalent in the linux world?

>> No.62546350

>>62546216
I get:
NTFS signature is missing.
Failed to mount '/dev/sdb3': Invalid argument
The device '/dev/sdb3' doesn't seem to have a valid NTFS.

Also instead of showing that one partion I made earliyer (and already dumped files onto) it shows 2 microsfot metadata partions and then the whole disk is 1 partion, is that normal?

>> No.62546368

>>62546316
most programs are put into /usr/bin or /usr/local/bin/ or something similar, running a command such as 'ping' will run the 'ping' program from /usr/bin. that meaning /unix system resources/binaries.

>> No.62546379

>>62546350
I never saw something like that.

Storing FS metadata/journal on a different partition is a thing (ext4 and reiserfs can do that too) but I never saw/heard ntfs doing it.

>> No.62546416
File: 19 KB, 500x390, 1497676174360.png [View same] [iqdb] [saucenao] [google] [report]
62546416

How do programs such as Scanmem & Cheat engine not segault on reading other processes' memory?

>> No.62546620

Friends, I'm going to be away from home for a while and I'll be using a Linux Live USB for my computing. Do all live systems run as root or is that just Kali? Would there be any security issues using a Live system that runs as root?

>> No.62546706

>>62543102
printf '\u2007\u25B2\n\u25B2\u0020\u25B2\n'

>> No.62546727

>>62546620
They either run straight from root or have password less sudo access for the user.

Your best bet is to use a live system with persistency, set up a root and a user acc/password, configure sudo then save your changes to the pers. file.

>> No.62546730

>>62546620
dont ever use root as dailer user, im sure you know why
just create a normal user
you'll probably wear out that flash disc really quickly...

>> No.62546751

>>62546730
>>62546727

Thanks chaps, I'll only be using it lightly for 2 weeks so I'm not too concerned with the health of the USB.

>> No.62546805
File: 38 KB, 300x300, brave_icon_shadow_300px.png [View same] [iqdb] [saucenao] [google] [report]
62546805

Has anyone manually compiled the Brave browser with chrome extensions, in Arch?

Apparently you can't do it in Arch since the kernel has userns disabled by default (whatever that is), and thus npm start throws a "No usable sandbox!" error.

Not sure what the best way to get around the user namespace thing is.

>> No.62546824

>>62546805
haha bleeding edge is good guys it just wurks :DD

>> No.62546855
File: 37 KB, 600x507, 1505542025782.jpg [View same] [iqdb] [saucenao] [google] [report]
62546855

>>62546824
Thanks

Now wanna help me out

>> No.62546868

>>62546855
no because arch is for faggots
why cant your autism club give you help

>> No.62546888

>>62545760
Arch is hard mode, if you enjoy a challenge and have the time for fiddling around with a distro go with Arch. If you just want stuff to work (mostly), go with *buntu. Both distros have their pros and cons but I think it really comes down to how much time you want to spend setting it up

>> No.62546934

>>62546805
>kernel by default doesnt support this
you're ment to be good at this shit to use arch. are you incapable of compiling a new kernel with that support in?

>> No.62546959

>>62546934
No I'm not. Am noob

Damn niggers, I thought /g/ loved arch

>> No.62546965

What's the difference between
U - final flag setting for installation

and
I - package is installed with flag

in the output of `equery uses ...`?

>> No.62546977

Is there anything like xbindkeys that doesn't have like half a second of latency?

>> No.62546988

>>62546959
Ah, yes, Mr. /g/, who lives next door and loves ricing Arch. I hear that he's actually out right now, buying groceries with his mother because she can't carry them all by herself. Don't worry, anon! He'll be back soon enough.

>> No.62547027

>>62546959
i dont know what /g/ you've been visiting but everyone here hates arch for being muh seekrit kloob and being a pile of trash

>> No.62547049

>>62546977
sxhkd

>> No.62547093

>>62546271
>CTRL+X is a shortcut to CUT. https://en.wikipedia.org/wiki/Control-X So, the original files were deleted in the process.
I fucking know what CTRL+X does, thank you very much. Say "cut and paste" or "moved" next time.
Why did you think that transferring from Debian to Debian with a NTFS thumb drive and without keeping a backup copy is beyond me.
>extundelete
that was 100% meant to suggest you to undelete on the original drive.
>tried
vague at best. If you want help you really should to improve your questions, and answers.
Did it find anything at all? What have you tried? Did you stumble upon https://www.cgsecurity.org/wiki/Undelete_files_from_NTFS_with_TestDisk ? Is a partition even there? What's fdisk output? Which are the "certain properties" you keep saying that you see even if it's "blank"?

>> No.62547170

>>62540644
Manjaro Xfce or KDE for ricing on older i7 and 8 gb ddr3 laptop?

>> No.62547182

>>62547170
you can run either.
It is when you have 512mb ram that you need to select a minimal desktop

>> No.62547208

>>62547170
At those specs, just install whatever you like. XFCE might be better for battery wise thou.

>> No.62547250

>>62546379
So uh should I just try making the partion agian?

>> No.62547308

>>62547250
Looks like its your only option. Save your data in windows then create a partition from gnu+linux using gparted. That should work fine with both windows and loonix.

>> No.62547319

>>62547049
Thanks! sxhkd seems to have zero latency unlike xbindkeys.

>> No.62547365

>>62547093
>TESTDISK
>found my thumb drive
>correctly shows 8005 MB / 7634 MiB , which means the files I recorded there are there, because the size difference is equivalent to the size of my files
>selected 'Intel/PC' partition table option
>Selected 'Analyze' and 'Quick search'
>Found the partition that is there on the drive
>Commanded to list the files
>Only lists a text file I deleted and is on the trash, doesn't list my other files

>> No.62547385

I installed Gentoo on my t420, but suspension when the lid closes doesn't work. I can manually suspend to ram, and I've even configured a keybind that works perfectly; however, I've been futzing around with APMD, but I can't seem to get my primary goal, suspension when the lid is closed, to work. Any anons had experience with this?

>> No.62547390

>>62547182
>>62547208
I've used ubuntu for 2 years now and I don't know if I want to abandon it fully. I kinda just want kubuntu.

>> No.62547462

>>62547365
Did you allegedly transfer a text file that should be there? If so, run `strings' on the entire thumb and grep for something that you know should be there. Did you safely removed the hard drive after you moved stuff on it? Di you issue `sync' or attempted to "safely remove" the USB?

>> No.62547507

>>62547365
>>62547462
>>62547365
>'Deeper search', then
>Bullshit alert about number of cylinders, fuck that shit
>Now it lists 2 partitions
>one is NTFS, blocksize=4096, 8004 MB / 7634 MiB
>other is NTFS found using backup sector, blocksize=4096, 8003 MB / 7633 MiB
>WTF man
>same shit on both, the deleted text file

>> No.62547539

>>62547507
>>62547462
>run `strings' on the entire thumb and grep for something that you know should be there
>>62547093
>https://www.cgsecurity.org/wiki/Undelete_files_from_NTFS_with_TestDisk
Follow the procedure detailed in the link carefully. If you don't see anything, try to check with strings and answer the questions.

>> No.62547550

>>62547462
I recorded a text file on the thumb drive after it blanked, just to test if it was a hardware failure. As I was able to record and delete it after, I concluded it probably isn't irreversible.

Running strings is really recommended in this case? The lost files were videos. I can't read 'video strings'.

I ejected the thumb drive after moving the videos, and turned the PC off. There's an eject button on the interface to unmont.

>> No.62547564

>>62547027
I think 90% of the arch hatred is just because people always say "btw I'm using arch" which they interpret as them being "proud" or smug and thinking arch is superior or something.

When in actuality it's probably just because when you go to get support for stuff people always tell you "always include what distro you're using to make it easier to help you". Arch users might have some more noobs who often go to those places and have learned to always say that they're using Arch.
It's not a big deal. Hating on Arch users probably makes you way more pretentious than they perceive the Arch users to be.

>> No.62547585

>>62547550
>I can't read 'video strings'.
You can read filenames.
>I ejected the thumb drive after moving the videos
>There's an eject button on the interface
Unclear, explain. Did you eject from Debian?

>> No.62547675

>>62547539
Oops, I almost forgot: I tried the 'undelete' option too on tesdisk. It seems very cool! It shows many files I deleted previously. But not the videos, because I had not deleted them.

>> No.62547692

>>62547308
Alright, I'll try that thanks anon.

>> No.62547703

>>62547093
>Why did you think that transferring from Debian to Debian with a NTFS thumb drive and without keeping a backup copy is beyond me.
How should I transfer my files? I always use thumb drives or external hard drives.

>> No.62547804

>>62547539
>>62547462
How to run strings on the whole drive, please?

>> No.62548178

>>62547804
presumably strings /dev/sdb if your disc is /dev/sdb, if not replace with something else like /dev/sdd

>> No.62548579
File: 11 KB, 300x300, 1504396300881.jpg [View same] [iqdb] [saucenao] [google] [report]
62548579

What is the most 1337 terminal font for truw hackers?

>> No.62548588

>>62548579
comic sans

>> No.62548591

>>62548579
* serif

>> No.62548595

>>62548579
GNU Unifont http://www.unifoundry.com/unifont.html

>> No.62548608

>>62548579
Monospace is my favorite.

>> No.62548622

>>62546368
I see, and if ping doesn't exist in /usr/bin, does it check elsewhere?

How do you tell that the file "ping" is an executable and not just an image without a file extension? Like ping.jpg without .jpg for some reason.

>> No.62548623

>>62547703
Assuming you have to use a USB drive and you really can't work it out differently in your LAN, anything formatted in any filesystem, except NTFS, will work. There are two concurrent and partially conflicting NTFS implementation and NTFS is a shit to begin with. Also, keep a backup.
A similar reasoning could be extended to HFS+ _with journaling_ if such drives were formatted by Apple software; such format will cause inconsistencies unless you first disable journaling.
For USB Flash drives, consider F2FS or just plain, simple FAT32 for maximum interoperability if you don't have to transfer single files >= 4 GiB (chances are you don't have such big ass files to transfer)

>>62547804
like >>62548178 suggested, grep the output

>>62547675
you didn't answer how you did eject, in detail. You mentioned that "there's an eject button on the interface" and I start to think that you didn't copy a thing. You may have issued the command and ejected the USB from the hardware itself rather than safely from inside the OS, and you removed it when the OS was still caching the data you wanted to move. Or, you "pasted" your files in a different directory in your file manager of choice.

>>62548579
Literally the hack font
https://sourcefoundry.org/hack/
Second place: terminus
Third place: adobe source code pro

>> No.62548647

>>62548622
>I see, and if ping doesn't exist in /usr/bin, does it check elsewhere
$ echo $PATH
>How do you tell that the file "ping" is an executable and not just an image without a file extension?
$ file -s $(which ping)

>> No.62548667
File: 54 KB, 1024x768, 1505158876999.jpg [View same] [iqdb] [saucenao] [google] [report]
62548667

Stupid questions:

Is dual boot secure? Can Windows destroy GRUB or fuck with my real system?

Can Windows break out of a VM?

What are some things to be aware of when using Windows in a VM?

>> No.62548680
File: 427 KB, 500x400, images.duckduckgo.com.png [View same] [iqdb] [saucenao] [google] [report]
62548680

>want to make a directory with another one inside of it
>most programs call that recursively
>mkdir -r
>invalid option
>mkdir -R
>invalid option
>mkdir
>check 'mkdir --help' for help
>mkdir --help
>it's a fucking -p
>for parents
logical or not this is fucking annoying

>> No.62548692

Why can I give a program root privs but can't for a shell script?

>> No.62548699

>>62548622
file extentions don't matter at all, only for what is the default program to open the file in. if the program isn't marked as executable or you try running something that isn't a program it just won't do anything. there's an environment variable in the terminals called the path, it will use these directories to search for executables. mine is: ~ echo $PATH
/usr/local/sbin /usr/local/bin /usr/sbin /usr/bin /sbin /bin /usr/games /usr/local/games
so the terminal will search all of these directories for the program you're trying to run, and you can add your own if you like - such as making a folder in your home directory to store some other programs, then running them just by typing the name of the program.
to run an executable that isn't in any of the path directories, you can do ./file_name - './' meaning 'current directory' and the filename being the program you want to run.

>> No.62548712

>>62548692
Because it would be retarded and insecure: the script is not the actual program; the interpreter defined in #! is which actually runs the script.

>> No.62548731 [DELETED] 

>>62548680
mkdir -p test/foo?

>> No.62548734

>>62548667
>Is dual boot secure? Can Windows destroy GRUB or fuck with my real system?
apparently it's broken GRUB in the past. I wouldn't put it past it. Just keep a USB around with an install medium.
>Can Windows break out of a VM?
it's not that smart of a program, and i think that's verifiable.
>What are some things to be aware of when using Windows in a VM?
performance may be worse.

>> No.62548735

>>62548667
>Is dual boot secure?
Detail a threat model.
>Can Windows destroy GRUB or fuck with my real system?
Sure it can. If you're talking about a baremetal install.
>Can Windows break out of a VM?
No, it shouldn't be able to do that, unless you're explicitly allowing it to break out of qemu and the like.
>What are some things to be aware of when using Windows in a VM?
Too vague.

>> No.62548749

which ping
>tells you path to binary
whereis ping
>path to binary, source and man page.
type ping
>tells you path to binary, or if alias, keyword, function, hashed...

>> No.62548786

>>62548699
Ah I see
>>62548647

My main issue is for example, when viewing a folder full of files, that pertains to program X, I know the extension doesn't "matter", but there are several extensionless files, so without using the CLI to test each of them to see which is executable... how do I know which is the executable? Is there a reason why the linux world just doesnt like to put .exe just for clarity?

>> No.62548787

>>62548667
>when your device is locked, the botnet still listens
Jesus, what a time to be alive.

>> No.62548790

>>62548680
sorry for that last post, anon; I didn't read it all the way. But, yeah, parent is actually a really common term. I'm surprised you've never heard it get thrown around before. I don't know how you could replace the term "parent directory" with something related to recursive-ness. Regardless, you ought to get used to it, because this won't be the last time you hear about it.

>> No.62548805

>>62548623
Could you please provide evidences that NTFS is shit? I'll judge what you have, so I can make my opinion.

>> No.62548838

>>62548749
alias t='type -a'
Think of
>t. program

All makes sense, everything is fine.
One of my most used aliases, since I often check defined aliases or functions (type prints them).

>> No.62548864

>>62548790
I had heard of it, it's just that for referencing multiple directories an R is usually used. I get it, but I don't have to like it.

>> No.62548895

>>62548786
>.exe just for clarity
".exe" aren't for clarity, at all. Besides, you may have different kind of executable: scripts in bash, perl, python.. all of them may be executable or not. I get that you aren't used to GNU/Linux, but graphical file managers will show you as well what kind of files you're dealing with and will identify executables, scripts and whatnot according the the magic numbers in the file and not on facetious suffixes. Maybe you have some issues with your graphical file manager?

>> No.62548922

>>62548786
you don't really ever see executable files in folders like you do in windows - you very rarely 'double click an exe' in linux systems, if ever. 99% of all executable things are just ran from the terminal without 'seeing' them, as most of them are in the /usr directory anyway.

>> No.62548929

Arch user here, can someone give me a quick rundown on void linux? thinking of switching

>> No.62548946

>>62548929
i use arch btw just so u ubuntu noobs know xD

>> No.62548967

Need a distro with a very wide selection of up to date packages.
Not Arch though. Is Gentoo what I'm looking at with these requirements?

>> No.62548969

>>62548805
>Could you please provide evidences that NTFS is shit
No, I'll just point you to your favorite search engine of choice, I'm not interested to discuss NTFS at all. Microsoft itself attempted to replace that old rusty behemoth so many times and on a search engine you'll hopefully learn about the concurrent, flaky implementations in GNU/Linux.

>> No.62548994

>>62548967
ubuntu...?

>> No.62549000

>>62548178
Thank you.

>> No.62549013

>>62548967
Any upstream will do.

>> No.62549021

>>62548967
it's not as up to date as arch as far as binaries, but you can build the newer ones yourself. fedora rawhide or any other rolling release distro will do you fine.

>> No.62549046

>>62548969
I had to bring some of those thumb drives to stores so they could print files for me. As they use Windows, I needed to format on a way the stupid Windows machines can read. I couldn't take an EXT4 thumb drive there, because their Windows XP can't read it.

>> No.62549062

>>62548838
# The following commands will report the location (filename and line number) of a function’s definition. Assuming a function named foo,

# Turn on extended shell debugging
shopt -s extdebug

# Display the function’s name, line number and fully qualified source file
declare -F foo

# Turn off extended shell debugging
shopt -u extdebug

For example, the output of these commands might be:

foo 32 /source/private/main/developer/cue.pub.sh

The above might work only in bash, and not in POSIX shells in general.

>> No.62549069

>>62549046
FAT32. It will work everywhere.

>> No.62549075

>>62548922
I guess its just odd to me, windows/mac you use your mouse lets say 80% of the time, with linux its more like 50%, which is a lot of wasted hand movement.

So now I feel like maybe I should use a tiling manager so I can use the mouse less; or try and set up shortcuts to rely in gui more.

>> No.62549082

Is Manjaro really that bad an option?

>> No.62549109

>>62549069
Dont macs not read fat32 now?

Also doesnt fat32 waste more file space over ntfs or ext4?

>> No.62549116

>>62548946
you gonna give me a quick rundown or are you going to be an asshole in the #friendly thread?

>> No.62549167

>>62549069
Isn't FAT32 even older and shittier than NTFS?

>> No.62549169

>>62549116
how about instead of asking for rundowns on distros you try them in a vm?

>> No.62549187
File: 316 KB, 425x450, 1488375748277.png [View same] [iqdb] [saucenao] [google] [report]
62549187

http://blog.ptsecurity.com/2017/08/disabling-intel-me.html

>> No.62549201

>>62549109
>Dont macs not read fat32 now?
FAT32 is used regularly to exchange file between mac users and windows users at work, so no, there's no issues.
>Also doesnt fat32 waste more file space over ntfs or ext4?
Actually the opposite, if you're weighting in metadata and journaling. FAT32 is more "raw".
>>62549167
It's older, yes. It's shittier.. not for your purposes. You're not going to run an OS on FAT32 like in ye olde Windows98 times.

>> No.62549203

>>62548994
>>62549013
>>62549021
Thanks I'll search through the package lists of a few distros.

>> No.62549257

>>62549021
>fedora rawhide
fedora user and admin here
no, don't suggest that, unless he's willing to be a tester. We don't run rawhide internally on baremetal. Packages and kernel in rawhide are unstable, untested and purposefully slower (every now and then a kernel without debug symbols is released, and a user can choose not to install debug kernels ever, but still..)
Opensuse tumbleweed may be a safer choice

>> No.62549351

>>62548579
Ignore these other jokers.
Terminus is the answer you're looking for

>> No.62549391

>>62549351
>>62549351
Pretty much. I tried so many fonts and always came back to Terminus. Even better with URxvt where you can set several fallback fonts (chinese moonrunes, icons, etc).

>> No.62549400

>>62549169
Oh okay, I was under the impression that this thread was for discussion, my bad! I'm guessing no one actually talks about linux here, everyone just tests everything themself when they have a minor curiosity

>> No.62549407

>>62549400
ok good im glad we sorted that

>> No.62549521

>>62547462
OK, I grepped the string that stringged the thug drive that blanked.

I could find many matches, but no evidence my videos are there. What I remember better are the directory names, and file extensions, not the video names. Also, there are chat logs and webpages previously on the drive, and they are showing up on the strings+grep commands, messing with the results.

>> No.62549569

>>62547093
>>extundelete
>that was 100% meant to suggest you to undelete on the original drive.
I can't run it on the original drive. I would need to unmount it, while I need it to use my PC.

Obviously, I'm not so dumb that I wouldn't unmount it to search for my precious files. It's that I already tried some programs on the original disk first, and it seems the original files are mostly lost. The only ones that appeared, where in such a bad status, and where so little in numbers, that I was more wanting to recover from the thug drive.

>> No.62549688

>>62548579
Fira code

>> No.62549725

>>62540644
Anyone else get a massive update recently for Gentoo? Currently updating 376 packages

>> No.62549747
File: 106 KB, 1366x768, 2017-09-21-212354_1366x768_scrot.png [View same] [iqdb] [saucenao] [google] [report]
62549747

why is the wide text not displayed correctly?

>> No.62549763

>>62549747
you don't have the font installed ?

>> No.62549765

>>62549569
>I can't run it on the original drive. I would need to unmount it, while I need it to use my PC.
A LiveUSB or similar was likely implied.
>>62549521
>no evidence my videos are there
consider this: >>62548623
>you didn't answer how you did eject, in detail. You mentioned that "there's an eject button on the interface" and I start to think that you didn't copy a thing. You may have issued the command and ejected the USB from the hardware itself rather than safely from inside the OS, and you removed it when the OS was still caching the data you wanted to move. Or, you "pasted" your files in a different directory in your file manager of choice.

>> No.62549773

I started to dual boot yesterday (Kubuntu) and downloaded a tiling script for KWin plus removed the window title bars and it is so comfy I felt in love with it but it's been kinda annoying I have to keep pushing hotkeys all the time to move, resize, minimize, maximize and close windows. does anybody have a list of good and comfy hotkeys I could use to manage my windows? which WM would you guys recommend to a beginner like?

>> No.62549788

I know that the whole Ubuntu/Amazon/Spyware thing was Unity only, but is there anything at all in the new Ubuntu (GNOME) that would be defined as invasive?

Does Ubuntu come with telemetry/spyware that (for example) Debian doesn't come with?

It's a shame Canonical had to ruin things for themselves, and it doesn't help that they are based in the UK. Are they just Microsoft tier at this point?

>> No.62549790

>>62549788
no of course not
it's over now anyway

>> No.62549803

im trying to install linux and when i enter the graphical install it looks completely scrambled
wat do

>> No.62549806

>>62548579
>>62549688
This, all others are cancer.

>> No.62549808

>>62549788
>>62549790
both debian and ubuntu come with the "popularity-contest" botnet

>> No.62549819

>>62549763
can you recommend me a good font for wide text?

>> No.62549832

>>62549803
Try a distribution instead.

>> No.62549834

>>62549803
use text-mode install
>>62549808
what is disabling it or removing popcorn package

>> No.62549838

>>62549819
use Noto for everything

>> No.62549855

>>62549838
>>62549688
>>62548623
>using ugly true trype fonts
bitmaps master race

>> No.62549859

>>62549834
im too retarded to install from a terminal

>> No.62549873

>>62549859
it's the exact same as graphical, but it's text mode buttons rather than clicky-buttons

>> No.62549904

>>62549819
https://en.wikipedia.org/wiki/Unicode_font#List_of_Unicode_fonts
noto and gnu unifont have good unicode coverage

>> No.62549911

>>62549873
will it still look scrambled when i boot into it after i install?

>> No.62549920

>>62549788
Ubuntu still has the MOTD advertisements baked into the base system, so even if you do minimal install it's still there and Canonical collects data on application usage which they apply to their OpenStack.

>> No.62549927

>>62549911
perhaps, perhaps not. did you boot into a liveCD or just an install disc?

>> No.62549936

>>62549788
Well they still have their contract with Amazon for a few more years so expect to see the Amazon stuff in the Ubuntu dash to dock side bar when the new releases come out

>> No.62549940

>>62543174
Use Arch Anywhere or at least Antergos

>> No.62549941

>>62549838
installed it, still not displayed correctly. what am i doing wrong?

>> No.62549956

>>62549941
did you make sure to restart X (by logging out and back in, if you don't use a display manager; or by restarting your PC if you do use one)?

>> No.62549958

>>62549940
>Arch Anywhere
dead

>> No.62549965

>>62549927
usb

>> No.62549976

>>62549965
what content was on the usb i mean?
was it an install image, or a live desktop one?
perhaps give me the filename that you downloaded?

>> No.62550003

>>62549976
just an install

>> No.62550021

>>62550003
try a liveCD image instead, see if it looks scrambled when you're on an actual desktop

>> No.62550058

>>62549956
>restarted X
>restarted laptop
still doesn't work...

>> No.62550082

>>62549803
It seems an issue with you GPU. Radeon? Nvidia? Append
nomodeset
to the arguments of your kernel. You should be able to do that stopping the GRUB countdown, selecting the kernel, moving to the line starting with "linux" or "linux16" or "linuxefi", add the argument there and boot the modified kernel (usually, F10 or ctrl+x)
Even better, choose "install in default video/fallback graphical mode" or similar, if such an option is available in your liveUSB.

>> No.62550085

>>62549958
It became Anarchy Linux, I think.

>> No.62550124

>>62550058
$ fc-match "lucida grande"

>> No.62550128
File: 72 KB, 1178x391, 1495412638504.png [View same] [iqdb] [saucenao] [google] [report]
62550128

>>62550085
yep

>> No.62550172

>>62550082
>Append nomodeset to the arguments of your kernel
if you cant tell, im a noob
how do i do that

>> No.62550179

>>62550128
Isn't "Linux" a trademark violation too? :^)

>> No.62550197

>>62550172
select kernel, press "e", edit, ctrl+X or F10. It would be nice to reply to >>62549976
>perhaps give me the filename that you downloaded?

>> No.62550205
File: 10 KB, 235x211, 1505225906472.jpg [View same] [iqdb] [saucenao] [google] [report]
62550205

>>62550128
>pointed out by the Arch Linux(TM) team
>pointed out

>> No.62550229

>>62549958
>>62549940
>Arch Anywhere
>>62550085
>Anarchy Linux

What's this?

>> No.62550231

>>62550124
nothing changed

>> No.62550255

>>62550231
you were supposed to paste the output of that command, you know. How the font Lucida Grande (used on that website) is mapped on your OS? fc-match provides an answer.

>> No.62550263

>>62550229
lurk moar

>> No.62550283

I would never install an disto so politically loaded just by looking at its name.

>> No.62550284
File: 487 KB, 608x653, 1491640648136.png [View same] [iqdb] [saucenao] [google] [report]
62550284

Stop lowercase posting.

>> No.62550285

>>62550263
Friendly thread.

>> No.62550352

>>62550255
oh ok^^
output:
DejaVuSans.ttf: "DejaVu Sans" "Book"

>> No.62550404

>>62550283
lmao nerd

It's a nice pun, tbqh. An Archy Linux, which is exactly what it is.

>> No.62550425
File: 73 KB, 1000x563, IMG_7408.jpg [View same] [iqdb] [saucenao] [google] [report]
62550425

>>62550205
Wtf I love Arch now

>> No.62550464

>>62549941
you have to set the font in your browser settings and make sure the settings override website settings

>> No.62550499

>>62550352
That's it. You don't have Lucida Grande and your fallback for sans is DejaVuSans. The other anon suggested you to set everything to Noto, you didn't do that or something in your font config is preventing to adopt it. I'd suggest you to install Lucida Grande and Arimo. DejaVu Sans can't display wide fonts.

>> No.62550507

>>62550425
dumb phoneposter

>> No.62550514

>>62550499
It's ALWAYS DejaVu

>> No.62550530

>>62550514
well, than that's it.

>> No.62550536

>>62550507
I always change filenames to ios looking names since it always triggers nighers

>> No.62550561

>>62550425
>>62550507
>>62550536
I didn't know that "IMG_$number.jpg" filenames were supposed to be phoneposters.
Well, time to adjust my filters

>> No.62550625

How do I become an awk/sed kung fu master?

>> No.62550632
File: 829 KB, 5616x3744, gg1500541158135.jpg [View same] [iqdb] [saucenao] [google] [report]
62550632

>>62550625

http://www.grymoire.com/Unix/

>> No.62550707

>>62546416
root.

>> No.62550809

Minecraft on Windows:
>video settings all set to minimal
>lags as shit with 19 fps
Minecraft on Linux:
>video settings all set to maximal
>no lags and more than 40fps

thank you /g/ for convincing me of installing linux it was a pleasure to me

>> No.62550852

>>62550625
https://www.gnu.org/software/sed/manual/
https://www.gnu.org/software/gawk/manual/
(the single page HTML versions are usually best for each)

>> No.62550931

>>62550809
GNU/Linux*

>> No.62551033

i'm trying to setup a chroot enviroment but even though i have bin/bash on the folder i'm trying to chroot in, it says
"chroot: failed to run command '/bin/bash': No such file or directory"

>> No.62551185

>>62551033
You better detail the whole procedure you're following and what you're trying to accomplish.

>> No.62551307
File: 2.74 MB, 1280x720, 1497162908487.webm [View same] [iqdb] [saucenao] [google] [report]
62551307

I need help with systemd timers gents.
I have a bash script that basically dumps some info about mem consumption of a process and kills it if it exceeds some value.
I used to use a cron entry under Ubuntu and it worked OK.
I now use Arch and there's no cron installed by default! I read Wiki and it tells me to use systemd timers. But the example they provide is shit and it only works with systemd services.

How the fuck do I run some bash script every 5 min under Arch without installing some shit cron replacement from AUR??

>> No.62551352

Does anyone here actually use gentoo?
---> >>62546965 ??

>> No.62551364

>>62551307
Uninstall systemd

>> No.62551383

>>62551352
Yes, you dip, lots of people do.
""install gentoo" is a meme" is a meme. It's a great distro

>> No.62551384

>>62551364
>>>/plebbit/
and stay there.

>> No.62551389

>>62551383
Answer my question then.

>> No.62551447

>>62551389
The actual output of equery has a legend that is more clear than what you wrote in that post.
U is as it is set in make.conf, I are flags that get some from some other means. In other words, I are not your explicitly declared use flags but are still enabled anyway

>> No.62551462

>>62551307
It's unclear if you created a systemd unit already. You obviously are supposed to.

>> No.62551493

>>62551384
no u

>> No.62551511

>>62551462
I don't have one. Can you show me an example of how to properly write one? I don't wanna fuck it up.

>> No.62551531

what is systemd and how to get rid of it?

>> No.62551540

>>62551531
Systemd is the kernel: the program in your system which allocates the machine's ressouces to the programs that you run.

>> No.62551575

>>62551531
>what is systemd
a plague
>how to get rid of it
install gentoo

>> No.62551589

why doesn't everyone just use gentoo

>> No.62551591

I have decided to switch distro. Antergos or Manjaro? which points should I consider to decide which one I want?

>> No.62551597

>>62551589
Waste of time.

>> No.62551611

>>62551591
Arch, Debian, Gentoo

Choose.

>> No.62551632

>>62551597
how?

>> No.62551642
File: 56 KB, 549x595, why.jpg [View same] [iqdb] [saucenao] [google] [report]
62551642

Any KDE users here know how to clear/purge this? none of those "terminal" files exist anymore, but still pop up when i search terminal.

>> No.62551647

>>62551611
>Arch, Debian, Gentoo
yes, Arch, as it is exactly what I asked.

>> No.62551650
File: 40 KB, 220x220, 1486578326424-1.gif [View same] [iqdb] [saucenao] [google] [report]
62551650

>>62551591
Source Mage GNU/Linux

>> No.62551666

>>62551531
rm -rf /lib/systemd

>> No.62551675

>>62551647
Arch is compromised.
Use Void.

>> No.62551681

>>62551647
No, you didn't.

>> No.62551682

Does XFCE still have screen tearing?

>> No.62551692

>>62551682
Of course it has. It doesn't come with a compositor. Why asking? Also it's called Xfce.

>> No.62551696

>>62551682
screen tearing is not xfce related nor is it xfce specific
stop using nvidia cards and start using wayland

>> No.62551706

>>62551696
t. tech illiterate

>> No.62551713

>>62551682
>what is compton

>> No.62551726

>>62551706
dumb frogposter

>> No.62551739

>>62551713
LMAO

I installed that shit and it made my DE have long animations.
Then when I tried to edit that file it started creating squares and distort programs.

It's shit.

>> No.62551751

>>62551739
>It's shit.
no, you're just dumb

>> No.62551761

>>62551751
>no, you're just dumb
Nah, you're just autistic.

>> No.62551776

I'm using Polybar with openbox and I want to stop using the system tray, but for some reason, networkManager is the only Network Manager that successfully connects. Is there a GUI front end for NetworkManager to connect to WiFi that doesn't involve clicking a tray icon?

Or is there a way I can open the NMapplet via a command or click?

>> No.62551799

>>62551776
you can use nmtui

>> No.62551800

>>62551739
You're just too stupid to use it.
When you install a program, you read the documentation in order to know how it works, then your activate the options you want and everything works fine. Try this with compton.

>> No.62551815

>>62551776
stop using NetworkManager
just use wpa_supplicant

>> No.62551823

>>62551511
https://wiki.archlinux.org/index.php/Systemd#Writing_unit_files
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System_Administrators_Guide/sect-Managing_Services_with_systemd-Unit_Files.html
For your purpose I guess you want to create a "oneshot" unit.

>> No.62551833

>>62551823
>redhat.com
ain't clickin' that shite, nigga

>> No.62551836

systemd is NOT okay

>> No.62551864

>>62551800
I tried doing all of that and it never worked the way I wanted it to.

Also, not everyone is a virgin neet like you who has so much time to read every single detail about a fucking operating system that is designed to FUCKING WORK.

>> No.62551866

>>62551307
You dont have to use systemd, you can use cronie

>> No.62551867
File: 48 KB, 1366x768, scrot.png [View same] [iqdb] [saucenao] [google] [report]
62551867

>>62551823
Informative.

>> No.62551877

>>62551864
>Also, not everyone is a virgin neet like you who has so much time to read every single detail about a fucking operating system that is designed to FUCKING WORK.
lol keep telling yourself that, dumbass

>> No.62551882

>>62551681
>Antergos and Manjaro aren't Arch
next you'll say ubuntu isn't debian, and mint isn't ubuntu, therefore, mint is debiant.

>> No.62551883

>>62551877
Kek did I trigger you, Reddit?

>> No.62551894

>>62551867
You're supposed to have javascript enabled in the html online version, you know. You can get the pdf or the epub if you prefer.
https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/7/pdf/System_Administrators_Guide/Red_Hat_Enterprise_Linux-7-System_Administrators_Guide-en-US.pdf
https://access.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Linux/7/epub/System_Administrators_Guide/Red_Hat_Enterprise_Linux-7-System_Administrators_Guide-en-US.epub

>> No.62551908

>>62551307
What is that fluffy creature called?

>> No.62551917

So running the ATA Secure Erase function with hdparm, is there any way at all, even a hacked up solution, to monitor the progress of the disk wiping? Or are we just SooL in that regard?

>> No.62551920

>>62551864
It was never designed to work.

>> No.62551933

>>62551883
>calls others reddit
>uses 'kek'
uh oh

>> No.62551935
File: 17 KB, 505x190, 1500310043411.png [View same] [iqdb] [saucenao] [google] [report]
62551935

>> No.62551939

>>62551908
rabbit.
>>62551917
No. By the way, it's a kinda over-rated procedure, and it can lead to bricked disks if performed on external HDDs (never perform it if you're connecting to your disk with USB)

>> No.62551952

Friends don't let friends use systemd

>> No.62551961

>>62551935
GNU/Linux*

>> No.62551970

>>62551952
this, arguments against systemd should be in the OP

>> No.62551971

How do I get drivers for my rx vega on debian? AMD's official page only offers for Ubuntu, Cent OS, and red hat

>> No.62551977

>>62551939
Yes, I'm aware of the potential problems by plugging drives in via non direct SATA controllers, but even still it's the best and only method for actually truly wiping SSD's as far as I know. The fact that HDD's can also do it seems to be a bonus.

But in any case, that's too bad. My autism flares up when I can't see and monitor the progress of something.

>> No.62551978

>>62551952
whats wrong with system D?

>> No.62551985

>>62551971
just include them in the kernel config

>> No.62551997

>>62551908
It's a Mountain Viscacha

>> No.62552003

How do I become better at gentoo?

>> No.62552009

Linux SUCKS. Why? Because:

1) Command lines/Lack of GUI's

Why the fvck would I want to use a command line? I have a modern computer, capable of displaying color and icons. Why should their be a command line? And further, why doesn't everything have a gui? Gui's are good, and easy, and don't require me to learn commands. Yey for Gui's.

2)Root/sudo is stupid.

Why on earth should I have to deal with either using sudo or running as root to actually use my programs? I still can't get a lot of programs to run because they keep whining about permissions. What ever happened to good old admin accounts? Why does sudo break everything?

3)Apt-get

Now this is just plane stupid. Why is it so damn hard to install anything? I have a desktop, why not do it the way it should be done? I get the installer icon, click on it, press forward a few times, wait, and have a nice icon on my desktop. Why isn't it done this way?

4)Compiling

Again, stupid. Just give me a fvcking installer program. None of this compiling sh1t.

Come on Linux. The rest of the world has moved beyond 1990. It's time for you to do so also. I'm giving up and installing windows.

>> No.62552034

62552009: try harder, be original and use your imagination

>> No.62552057

>>62552003
install gentoo

>> No.62552063

>>62551978
shitposter gonna shitpost, yet they infest the /fglt/ as well. Simply ignore them.
>>62551977
>truly wiping SSD
well yes, SSD are devilish.
>>62552003
Read man pages at length and join dedicated channels on IRC.
>>62551997
>not a rabbit but a chinchillas
well, fuck

>> No.62552073

>>62543174
I have manjaro. It's good for beginners.

>> No.62552078

>>62552009
Your epeen has just shrunk by 6 inches

>> No.62552087
File: 189 KB, 1600x1200, smgl-desktop-3d1.jpg [View same] [iqdb] [saucenao] [google] [report]
62552087

Wizards Assemble!

Advanced users of GNU/Linux (and I mean advanced), remember to try Source Mage GNU/Linux. True source-based distribution, and (in contrast with Gentoo and Arch) is:
Free from obfuscated and pre-configured code.
Fully committed to GPL, uses only free software (as in freedom) in their main package.
With even the documentation licensed as FDL.
Without 3rd party patches, sensible defaults or masked packages.
Doesn't need obfuscated python libraries, only bash.
No systemd (they've implemented their own init scripts system http://sourcemage.org/Init).
Uses clean dependencies as they came from upstream developers, which by the same provides instant updates.
Can heal broken installs.
Can also use flags.

Do you like Arch Linux's AUR? Do you like Gentoo's portage (or ports-like) package manager? With SMGL's "sorcery" you get all that. Making new spells (package build files) not found in the grimoire (repository of spells) is easy http://sourcemage.org/Spell/Book

Bash hackers welcome! Come and join http://sourcemage.org/

Installing SMGL is easy, here's the simplified process:
>boot a live Ubuntu (or whatever) USB drive
>go to SMGL website and download compressed archive of the base system
>partition and mount partition(s)
>extract the archive onto the new partition(s)
>chroot, set root passwd, hostname, configure network and locale, write fstab, install grub/lilo
>reboot
>compile a kernel (preferably the newest stable one from kernel.org)
>update sorcery, grimoires and the build toolchain
>rebuild the system (hold spells you've already built, so you don't build them twice)
The install guide will hold your hand through the whole process http://sourcemage.org/Install/Chroot
Do the chroot method, since the regular live ISO method guide is out of date currently.

Here's a list of common commands: https://pastebin.com/i4DALaNV

>> No.62552095

>>62552087
Best pasta.

>> No.62552101

>>62552087
It's a bit late to post this pasta, don't you think?

>> No.62552118

>>62552101
Better late than never.

>> No.62552124

>>62552087
Gonna do this over teh weekend. Can't be too hard...right? hehe...

>> No.62552129

>>62551823
thanks anon!

>> No.62552132

Just installed xubuntu and I can't see shit, how to make everything bigger?
On windows i use 150% scaling

>> No.62552154

>>62552132
did you try installing gentoo?

>> No.62552159

>>62552132
change ur resolution

>> No.62552180

>>62552124
You'll do alright.
Just follow the guidelines of the pasta.

>> No.62552199

>>62552132
change your font size in appearance or whatever

>> No.62552202

>>62552132
You mean text, or other UI elements?

>> No.62552210

>>62552180
Yeah I know. I'm just mememing. I've never done a build from scratch install before, but over the years I've amassed enough experience and knowledge to be able to follow along the instructions without going "huh?" every other word.

>> No.62552213

>>62552132
look closer

>> No.62552225

>/g/ - tech support

>> No.62552231

>>62551985
dont tell me how

>> No.62552238

>>62552225
200% better than /g/ - Consumer Electronics

>> No.62552244

>>62551815
I've tried WPA_supplicant, wifi radar, and wicd, and only could get Network Manager to work. Especially with University wireless which uses wpa2sk with protected PEAP. I'm not really bored on campus long enough to have time to fuck with it.

>> No.62552278

>>62552231
>download the latest kernel tarball from here https://www.kernel.org/
>make sure the source is clean
$ make clean && make mrproper
>configure (menuconfig is deprecated, use nconfig)
$ make nconfig
>make sure to check the amd drivers you need in the driver section
>compile (jobs is the number of cpu cores times the number of threads per cpu + 1)
$ make -j<jobs>
>install the kernel
# cp arch/x86_64/boot/bzImage /boot/vmlinuz-<append_whatever>
>install modules (modules are in /lib/modules/)
# make modules_install
>make your boot loader detect it
>done

>> No.62552305

>>62540644
Allowing companies to (((secretly))) vote DRM into the web standard was a mistake.

>> No.62552328

>>62552244
use wpa_supplicant stand-alone

>> No.62552343

>>62552305
the masses allow anything until they reach a breaking point
jews, pajeet jews and wannabee jew elites will always try to get their way unless you threaten them with violence

>> No.62552369
File: 38 KB, 490x290, 1482522365831.jpg [View same] [iqdb] [saucenao] [google] [report]
62552369

>>62552343
You have to go back.

>> No.62552383

>>62552278
Is this absolutely everything I need to do or are you assuming I'm familiar with steps you didnt mention?

>> No.62552415

>>62540644
I'm playing around with i3 in a virtual machine at the moment, and I just watched a tutorial where the guy installed i3 on ubuntu, and he could select which de/wm to use before logging in (https://youtu.be/j1I63wGcvU4?t=177 jump to 2:57 to see what I'm talking about). Is the same thing possible with Xfce? I guess I could just try it, but I figured I would ask, instead of spending another 20 minutes installing debian in a vm.

>> No.62552460

>>62552244
here's my peap entry if you need it btw
network={
ssid="Uni"
scan_ssid=1
key_mgmt=WPA-EAP
eap=PEAP
identity="user"
password="pass"
phase1="peaplabel=0"
phase2="auth=MSCHAPV2"
priority=3
}

look into wpa_supplicant.conf on the Debian and Arch wikis

>>62552383
it's literally everything you need besides a bit of common sense when configuring the kernel
the Gentoo wiki has some general guidelines about going about configuring the kernel, but it basically comes down to common sense
https://wiki.gentoo.org/wiki/Kernel/Gentoo_Kernel_Configuration_Guide

>> No.62552499

>>62552343
Bullshit. There's not going to be any fallout as a result of this, because outcry would ruin the services that most normal people enjoy most. But enjoy waxing poetically about this on the internet, like that makes a difference. And then, after this, you're going to sit down and watch some films on Netflix not realizing the bigger implication of your actions.

>> No.62552502

New: >>62552491

>> No.62552510

>>62552415
just use startx
and remember to put exec i3 into your ~/.xinitrc

>> No.62552535

New thread
>>62552338

>> No.62552556

>>62552535
you're late, delet it

>> No.62552567

>>62552510
I already got it to work, that's not my problem, I just want to know whether I can have xfce and i3 both installed and choose whether I want to use i3 or xfce on login.

>> No.62552581

>>62552556
>>62552535
>>62552502

It's fine. We need more good threads on /g/ anyway.

>> No.62552589

>>62552567
if you want to use xfce you can replace `exec i3` with `exec xfce-session` or whatever it's called
or just use LightDM

>> No.62552623

>>62552581
it's not fine because you'll split the anons and then mods will delete one thread anyway and before they delete it there will already be some good posts on there and that all will be lost

>> No.62552689

>>62552556
That thread was actually made before the other one

>> No.62552700

>>62552689
who cares, he posted the link later and the other one caught on

>> No.62552722

>>62552700
I know. I'm just stating for the record that the other anon probably should have refreshed the catalog before making that thread.

>> No.62552725

>>62552589
Oh shit I'm fucking retarded. I though the debian login screen was part of xfce, but turns out it's actually lightdm, so I installed i3 and everything just werked™.

>> No.62552735

>>62552722
yes and the first anon should've posted the link sooner

>> No.62552746

there's literally no reason to make new threads until this one reaches page 10

>> No.62552769

Whatever. It's not like the quality of /g/ went down when two more worthless generals were made. It just means that the rest of /g/ has a reason to hate us more, as if they didn't have enough reason.

>> No.62553023

>>62545630
That's nice, I didn't know ./. would include ./...

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action