Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

2017/01/28: An issue regarding the front page of /jp/ has been fixed. Also, thanks to all who contacted us about sponsorship.

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 91 KB, 800x577, 1484933058700.jpg [View same] [iqdb] [saucenao] [google] [report]
61691501 No.61691501 [Reply] [Original] [archived.moe] [rbt]

Previous thread: >>61662025

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources:
Your friendly neighborhood search engine.

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux:
https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux

>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page

>What are some cool terminal commands?
http://www.commandlinefu.com/
http://bropages.org/

>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/

>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html

>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/t/'s GNU/Linux Games: >>>/t/769497
/t/'s GNU/Linux Videos: >>>/t/713097

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

>> No.61692115

>>61662049

>> No.61692157

>>61692115
Bad post.

>> No.61692606

Fucking WOW someone deleted the older one.

Rude

>> No.61692848

How can I keep my PS1 when sshing to another machine?

>> No.61693469
File: 7 KB, 209x241, noidea.jpg [View same] [iqdb] [saucenao] [google] [report]
61693469

I have an Asus X552C laptop, with a Mediatek MTE730E WiFi+Bluetooth Combo that's giving me problems since forever (before with Windows, now with Ubuntu). My machine is double boot (Windows 8.1 and Ubuntu 16.04, I need both OS), so another /g/entooman here at /fglt/ told me that to replace it with a linux-compatible one I should get something Atheros. So, guys, what would be the best model for it? Something that's available on Amazon (so I'm sure I can get it in Italy), is compatible with the rest and doesn't cost too much, if possible.

>> No.61694315

hey /g/ee, I noticed some people post images that they think will help them get responses when they post their question. can some people dump some of those interesting and unique pictures for my future use? TIA

>> No.61694337
File: 60 KB, 640x480, 1475736770068.jpg [View same] [iqdb] [saucenao] [google] [report]
61694337

What are some cool terminal commands?

>> No.61694437

Any mpd users here?

I'm used to having all my songs in a single playlist that's usually on shuffle.
However, recently, mpd occasionally becomes unresponsive for 2-20 seconds, and occasionally halts the music for ~3 seconds before continuing.

The setup is an Odroid SBC with an external powered hard drive and the playlist contains about 28k songs.

What could be the cause for this?
The SBC is most certainly fast enough, and mpd is quite lightweight.

>> No.61694621

>>61692115
That's not /fglt/, anon. Stop shoving ignorant, anti-gnu propaganda bullshit down our throats.

>> No.61694665

>>61694315
"lurk moar, newfag"

>> No.61695168

>>61692115
>Creates his own containment board.
>Refuses to stay there.

>> No.61695190 [DELETED] 

>>61692848
.bash_aliases.
It's not just for aliases anymore.

>> No.61695273

>>61694337
zenity --warning --text "OP is a hedgehog."

>> No.61695350

how to install extreme minimal debian? assume I unmarked everything in tasksel
all I'll need is xorg, xfce4 (minimal), lightdm, python 3 most recent version, firefox, coreutils and a PDF reader

>> No.61695379

>>61695350
Grab the netinstall image.

>> No.61695397
File: 8 KB, 205x249, 1437215089149s.jpg [View same] [iqdb] [saucenao] [google] [report]
61695397

I tried to install nvidia drivers on debian 9. Followed this tutorial but ended up with a blackscreen after reboot. What did i miss ? I'm i'm grateful for any advice.
GPU: Nvidia GTX 1050 Ti
https://www.youtube.com/watch?v=_5RJzZxQ62U

>> No.61695584

>>61695379
I did and I installed debian already, here I have the command line window opened in virtualbox. I want to know the real necessary packages to have before I download xorg, xfce4 and what I need

>> No.61695856

>>61695397
>What did i miss
How on earth could anyone know what did you miss lol.
You definitely missed something though because from my experience Nvidia while completely disregarding the foss community doesn't have problems with providing good (as in installing, working and stable) drivers for their recent GPUs.

>> No.61695900
File: 166 KB, 720x1280, Screenshot_2017-08-02-14-14-12.png [View same] [iqdb] [saucenao] [google] [report]
61695900

>>61694665
pls

sorry for phonepost

>> No.61695905

>>61695584
nvm, I'm reinstalling it with everything I don't need

>> No.61696238

>>61695350
probably chroot install

>> No.61696562

>>61694621
That's /flt/, anon, Stop shoving ignorant,pro gnu region propaganda bullshit down our throats.

>> No.61696697

>>61696562
If it ain't GNU it's worthless.

>> No.61697163

>>61696562
This is the Friendly Grownups Linux Thread.
You're containment board is >>>/flt/

>> No.61697324

>>61691501
>use ristretto because it can display gifs
>use gpicview because it's default
>use geeqie because it can zoom in without aliasing

how to merge these 3 into 1?

>> No.61697455

>>61692115
/flt/ is the thread dedicated to discussion about the kernel known as Linux and not the operating system GNU/Linux, which it has been historically referred to as by its progenitors, regardless of technical distinctions.

>> No.61697476

>>61697455
/flt/ is thread about the Linux operating system. If you take my post for example: >>61697324, you can see that none of those are GNU software because GNU people don't know what a pixel is.

>> No.61697494

>>61697324
I think pornview supports gif's and zoom (although I don't know about antialiasing). It also supports certain video files.

>> No.61697533

>>61697476
/fglt/ is thread about the GNU/Linux operating system. If I take your post for example, >>61697324, you can see that none of those softwares are Linux, because Linux people don't know what a pixel is.

However, it is necessary to have some GNU utilities in order to use said software; whereas, it is not necessarily a requirement to have Linux in order to use such software.

>> No.61697558

>>61697324
>>use gpicview because it's default
Why is this an issue? Do you know what a mimetype is and how to configure associated files?

>> No.61697564
File: 53 KB, 286x846, IMG_20170802_215434.jpg [View same] [iqdb] [saucenao] [google] [report]
61697564

Conkybros, do you have any nice up/down arrows I can use instead of the letters? Preferably with the code to make them show up because I'm a conky newfag.

>> No.61697572

>>61697533
Linux is a kernel AND software written for the Linux kernel. GNU is just a tiny part of Linux ecosystem. The shit part.

clang > gcc
busybox, toolbox > gnu coreutils
dash > bash
c11 > GNU C
linux > hurd

>> No.61697625

>>61695397
>nvidia
Found your problem.

In all seriousness, never buy nvidia for GNU/Linux. I don't mean this in an antagonistic way or anything--I have no stake in the nvidea/radeon dichotomy (I don't even really know or care about the performance distinctions between the two)--but nvidia really, really hates Linux dev's, and they even go so far as to sometimes do some really petty things, to where it's hard to trace why they have such a deep grudge against anything not Windows. They just do.

>> No.61697632

>>61697572
GNU's coreutils are so awful that they're good. The code is so tediously micro-optimized that it significantly increases shell script speed.

>> No.61697653

>>61697572
/g/ was never good. But you're not helping matters.
Why not just fuck off?

>> No.61697689

>>61697572
You totally missed my point. You literally can't run GNU/Linux without some GNU software being involved. Even Alpine uses GCC to compile Linux. In contrast, it is feasible to run GNU without any Linux being involved. It is thus perfectly reasonable to distinguish GNU from Linux, because Linux is genuinely interchangeable.

Even if there was a true, pure way to use Linux entirely separate from GNU, you're still talking about distros that are using GNU. And for the Linux distros that have cleaned their hands of GNU--call them XYZ--then we should acknowledge that project and call them XYZ/Linux or whatever they would like to be called.

>> No.61697730

>>61697564
← ↑→↓↔

>> No.61697754

>>61697572
This anon is rekking shit

>> No.61697771

>You literally can't run GNU/Linux without some GNU software being involved.
100% false.

>uses GCC to compile Linux
It's their choice, not a necessity: http://llvm.linuxfoundation.org/index.php/Main_Page

> you're still talking about distros that are using GNU
The amount of GNU is less than 10%. The rest is libre soft. Also, many of those packages are unused and unknown by the vast majority of user (GNU hexdump).

It would make more sense to call it Mozzila/Linux or RedHat/Linux than GNU/Linux.

>> No.61697835

>>61697771
What I meant is that GNU/Linux, by definition, uses GNU, and it should be applied to the software that's applicable.

And you totally ignored my last post. All that software needs the GNU suite to work. Furthermore, most GNU/Linux software, including Linux, is licensed under GPL, a product of the FSF made for, but not limited to, GNU.

>> No.61697901

>>61697771
Also, I think it's clear that from "you're" (sic) post: >>61697572 this obsession with removing GNU from GNU/Linux is some kind of perverted ego thing. Why would you even involve the quality (or lack of thereof) of GNU software when the discussion isn't even about that? It's a total non sequitur.

What do you even gain from totally lobotomizing the ethical element that GNU introduces to the term "Linux" when you call it what it actually is: GNU/Linux.

>> No.61698265
File: 403 KB, 1600x900, Screenshot from 2017-08-02 15:58:09.png [View same] [iqdb] [saucenao] [google] [report]
61698265

Is this good advice?

>> No.61698333

>>61697901
>gnufag calls other people obsessive

>> No.61698366

>>61698265
Yes. Especially the last part. Research the hardware you're going to buy before buying.

I know I've been bitten by wifi adapters. I bought the Pau05 by Panda Wireless. I fucking hate those people. The description said it was compatible with a bunch of Ubuntu derivatives and Fedora and Suse. That should've been a red flag that their product needed proprietary firmware, but I just assumed they were pandering to idiots who couldn't into Linux firmware. I was mistaken. And they don't even supply the firmware themselves. I had to fucking hunt down the driver in the Debian repo, unpack it, and rebuild my Linux manually. It's feasible, but it's just such a fucking nuisance. Never buy Panda Wireless.

Generally Dell has good GNU/Linux support, though. They ship products with Ubuntu, although they also maintain their own repo for special firmware, so I'm not so sure how well Linux will work beyond the Ubuntu-compiled Linux.

>> No.61698384

>>61698333
I think anyone who posts anything on /g/ can be classified as obsessive in one way or another.

Nice trips, by the way.

>> No.61698561

Hello /g/uys
Not sure if this thread is the best place to ask but here is the thing:
I've grown tireod of win10 and I would like to use another OS.
Can any1 tell me what is the best OS to start as a newbie (Debian/Ubuntu/Mint/Manjaro/Slackware/OpenSUSE/etc)?
How much of a differences do they have?

>> No.61698586

>>61698265
All but the first one. Mayyybe it applies to laptops of a certain age, but otherwise it's just shillery.

>> No.61698600

>>61698561
It depends on you want to do. What do you want from an operating system? And then pick a distro that emphasizes those features.

You can do basically the same thing in all of them, though. After all, they're just respins of the same operating system, GNU/Linux.

>> No.61698764

>>61698600
it should be lightweight/fast. Literally the only thing that I would like to see
+ nice bonus would be lookin aesthetic (but i guess you can make any of them aesthetic by configurating desktop environment?)

>> No.61698805

When I tried to install ubuntu there were a bunch of missing letters, it didn't happen when trying to install it on my laptop. What the fuck? How do I fix this? I wanna join the linux master race guys come on give me a hand here

>> No.61698873

>>61698764
xubuntu

>> No.61698899

>>61698805
Your going to have to be me thorough then that. Were you just running the livecd? Was this after Ubuntu was installed? Was it just one application in which the font didn't render, or was it everything? And I mean everything.

>> No.61698970

>>61698899
I was using a flashdrive. I didn't install it, this was during the instalation screen. It was everything. Lots of blank letters which partially showed up when I put the cursor on top of them.

>> No.61698993
File: 236 KB, 766x758, Install+gentoo_9f19be_4815663.jpg [View same] [iqdb] [saucenao] [google] [report]
61698993

daily reminder

>> No.61699031
File: 211 KB, 679x652, 1497755847282.png [View same] [iqdb] [saucenao] [google] [report]
61699031

>> No.61699152

>>61698970
>>61698805
try installing a different flavor of ubuntu. or try installing from an earlier dot release and then upgrading post-install

>> No.61699191

>>61699152
What's something other than Ubuntu that's good for beginners?

>> No.61699239

>>61699191
Fedora, Suse, Debian.

>> No.61699835

How do I play .swf files on Ubuntu 16.04?
I tried using Firefox, but it doesn't do it, I tried Chromium, doesn't work too. I tried VLC and the standard Video player, but they all require some plugin or codec Which I cant find any info about. All the info that I can find online are either leading to dead/missing websites or require me to do some hacking type wizardry. I just wanna watch a freaking flash-video I have on my PC.

>> No.61699868

>>61699835
you need pepper flash for chromium.
also need to edit an xml file so it stops downloading the swf file instead of playing it.

>> No.61701051

>>61699835
Flash is literally dying/dead so what do you expect? Adobe announced that they'll completely drop all work and all support on flash altogether soon.

>> No.61701632

Good thread.

>> No.61701681

>>61698265
Doubtful.
If he actually knew anything about linux, he'd be using vim.

>> No.61701726
File: 14 KB, 259x224, Troubled.png [View same] [iqdb] [saucenao] [google] [report]
61701726

I finished my sysadmin degree a month ago. What should I start with to get some basic experience that would be useful in many workplaces?
Like setting up and maintaining a safe web server and what else? I live in the middle of Europe so my school was a shithole where we could do nothing, but I'd really like to know where should I start.

>> No.61701730

>>61701681
Sorry. I meant GNU/Linux.

>> No.61702210

>>61701681
Why do you have to be so elitist? Why are you so desperate to polarize something as arbitrary as text editors?

If you want to use emacs or some implementation of vi, that's your prerogative. Different strokes for different folks. Why do you need to bully them for no reason?

>> No.61702534

>>61702210
>as arbitrary as text editors
Well, if you spend most of every workday working with an application it shouldn't be an arbitrary choice which one you use.

>> No.61702587

Why don't people recommend Arch as a starter daily?

It's either that or Fedora for me. Planning on dual booting Linux + W10 on my home rig and my XPS 13.

>> No.61702930

>>61702587
What do you mean by starter daily?

>> No.61703012

>>61702930

My first Linux distro. And one that will be used on the daily.

>> No.61703286
File: 266 KB, 642x589, 1491628595884.jpg [View same] [iqdb] [saucenao] [google] [report]
61703286

>multimedia keys not working in my internet keyboard
>Only volume,sleep and prev/next track are working
>Unplug and plug the keyboard
>Play/pause, stop and eject are recognized now.
>mfw

I also have like 7 extra keys that wont even be recognized, i have tried checking the scancodes and they arent even registered.

What the FUCK can i do?.

ANd the piece of shit capslock delay is a stupid Cianigger cockshit

>> No.61703667

Anyone looking for any scripting help?

>> No.61703689

>>61703667
yeah, help me with a script that gets me a gf

>> No.61703698

>>61703689
sudo apt install love

>> No.61703881
File: 84 KB, 640x426, 1390077660103.jpg [View same] [iqdb] [saucenao] [google] [report]
61703881

>>61703689
The closest thing we have to a gf package for GNU/Linux is Virtual RMS

>> No.61704003

>>61703012
Well, if you don't need an installer and have the patience to read a manual and do a chroot install, then, by all means. Most people don't recommend Arch because many of the benefits it provides aren't useful in the context of normal users who just want to use their desktops to get work done and is more oriented towards involved users who want to validate themselves to a bunch of strangers on the internet.

>> No.61704019

>>61703286
What the hell is an internet keyboard?

Also, sauce?

>> No.61704109

swap encrypted but it doesn't get automatically mounted, manually mounting it fixes this, but i am reading and it says that the swap uuid get changed on boot, so there's no way to automatically mount it , is this true?

>> No.61704144

>>61691501
What's the best Linux music player?

I want something like MusicBee on Windows.

>> No.61704183

I'm convinced that the GTK-3 filepicker is a conspiracy. Developed by Windows/Mac fanboys determined to keep GNU/Linux down in the gutters by making their software as shitty and useless as possible

>> No.61704246

>>61696697
Fu
>>61697163
ck
>>61692157
off.

>> No.61704430

>>61704246
leave now, before i get unfriendly

>> No.61704460
File: 24 KB, 500x250, 4153brAirPL.jpg [View same] [iqdb] [saucenao] [google] [report]
61704460

>>61704019
>Pic related

http://imgur.com/a/YiyWb

>> No.61704540

>>61704183
I believe it.

>> No.61704858

>insurgent thread ded
fug them

>> No.61704940

>>61704460
Have you tried using APMD? Is it that the media keys literally do not send any input? Because it may be that things just aren't configured right. You should look up the model. Maybe you need to build special firmware in Linux.

>> No.61705023

>>61704940
They are dead in Linux

Windows had no problems with such keys but here they arent even registered.

Although the keyboard is quite old and i had to rewire several parts of the circuit plastic sheet to close the corroded parts, maybe all those 7 keys are fucking dead.

I might need to check it later, it still doesnt explain why i have to power-cycle the keyboard to make the other keys work

>> No.61705060

>>61704144
Nice dubs.

Also, what specifically in MusicBee did you like? If you want a more fully-featured music browser (e.g. social media integration, other superficial stuff), try Exaile or Clementine depending on which toolkit you prefer.

If you want a music player that handles large libraries, consider MPD. If you want a music player that is not only made for large libraries but is extremely extensible and has a lot of practical functionality for thing like sorting libraries, gMusicBrowser.

>> No.61705099

>>61705023
That's unfortunate, mang. Have you started xev to see if the inputs are working? Because, as I said, that may be your problem.

Worst case scenario, you just write a few keybinds to do the same thing.

>> No.61705144

>>61691501
https://youtu.be/C8voeJ9WgCw

>> No.61705154

>>61705099
running evtest
Scancodes arent registered.

The circuitry for these 7 keys might be fucked gonna run some tests tomorrow.

>> No.61705691

>be me
>had installed a few things from unstable branch of debian
>now everything's fucked up and I can't install shit without getting "this package needs so-and-so dependencies but they won't be installed" (FUCK YOU! Just install them anyway! They won't be installed... who do you think is in control, here?)
>"apt-get -f install" doesn't do anything

I'm really considering just wiping the slate clean and starting over. I think I fucked up by mixing and matching packages from stable and unstable.

>> No.61705773

>>61705691
open aptitude and look at it's suggestions. Follow the instructions down the bottom of the screen to view them and cycle through until you find one you are happy with.

>> No.61705832

>>61705691
>>be me
Who the hell else would you be?

>> No.61705859

>>61695397
Same happened to me a couple of days ago, using sddm + kde minimal, tried to troubleshoot a little, but i had no success. In every other distro I tried, it just worked perfectly, no issues ir whatsoever, I think is a problem with Debian itself.

>> No.61706226

>>61705859
>I think is a problem with Debian itself
I've been using frankendebian since 2011 and haven't managed to get the system in an unfixible state.

>> No.61706276

>>61695273
DOXXED!!

>> No.61706332

What distro are you using, anon? Why?

>> No.61706385

>>61705773
>>61705832
Well fuck I'm retarded. I just fucked shit up real bad.

I'm just going to do a fresh reinstall. I didn't have important stuff on that partition, anyway. The whole point was that I wanted to switch to GNOME.

>> No.61706395

>>61706385
Now I know to never try making Frankenstein's monster because I clearly have no idea what I'm doing.

>> No.61706524

>>61698993
>thinks RMS said that
>he uses Trisquel
>doesn't even promote gentoo on the FSF as an approved distro

>> No.61706623

>>61694437

>lightweight
There's that myth meme bullshit again.
Look at things like disk IO, maybe your drive is choking from where it's reading the music from.

>> No.61707039

I made bluetooth headset works using blueman+pulseaudio, but in pavucontrol i have only HSP/HFP profile and sound quality is awful (i read it's because of this profile). Wired set sounds fine and has plenty of profiles.
How can i make the sound quality better?

>> No.61707664

I love Cantata, but I hate how it looks. Any other player that has pretty much the same features along with its file format support?

>> No.61707762

Just wanted to report that after distro hopping for a considerable amount of time I decided to settle on Arch. Surprisingly Arch was the easiest to setup and make it work the way I wanted Linux to work.

>> No.61707807

What's the best way to make command "python" open Python3 instead of 2? I tried changing symbolic links but apparently it breaks all sorts of shit.

>> No.61707929

Im currently installing gentoo.

What use flags should i use?
desktop profile and im thinking of installing xfce

>> No.61707956

>>61707807
alias python=python3

>> No.61708073

>>61706524
it's a meme, you dip

>> No.61708084

>>61703286
>>61704460
Why would a robot need internal organs?

>> No.61708100

>>61707929
Emerge cpuid2cpuflags and ufed.

But only after you've set your profile and emerged your world and such. Certain flags can cause circular dependencies.

>> No.61708135

>>61707664
Support for filetypes doesn't really depend on the music player. In fact, isn't Cantata just an MPD frontend? Just use a different frontend, then. Or just look around. They all work pretty much the same.

>>61705691
>>61707762
nice blog

>> No.61708167

>>61706623
I do think lightweight is a reasonable criteria by which to judge a music player, only insofar as in terms of their responsiveness. And I don't mean in playing music. Mostly, I think it depends on how music players accommodate large libraries by use of caching. I've had music players freeze up because it keeps re indexing large libraries every time I interact with it. Obviously, it's feasible to change the behavior of some music players, but not all.

>> No.61708209

How do I make my terminal prompt just "~" or whatever instead of my computer name and username first?

>> No.61708236

>>61708209
Are you using bash?

>> No.61708255

>>61708236
Yup

>> No.61708266

>>61708209
It is defined in the environment variable PS1

>> No.61709048

Would any modern GNU/Linux distro be good for an htpc?

>> No.61709727

Incoming retarded question, I'm connected to my ubuntu server over SSH and I used sudo -i while I was building some stuff.

However whenever I run my application it creates its config and stuff inside /root/.Blah/blah.conf but I want it in /home/myuser/.Blah/blah.conf like when I run it without sudo privileges. IS there anyway to back out of the elevated privileges without re opening my session?

>> No.61709770

How do I select something in the terminal? shift+home doesnt work, shift+left doesnt work, shift+ctrl+left doesnt work. I just want to be able to edit text as efficiently as I would in any text box.
terms are xfce4-terminal and tilda

>> No.61710073
File: 78 KB, 562x362, a.webm [View same] [iqdb] [saucenao] [google] [report]
61710073

>>61709770
not really sure if you can do that in a plain terminal, but various multiplexers can do it (pictured: tmux)

>> No.61710287
File: 30 KB, 714x463, 2017-08-03-154647_1280x1024_scrot.png [View same] [iqdb] [saucenao] [google] [report]
61710287

>>61709770

Works for me in xfce4-terminal. You must be doing something wrong.

>> No.61710305
File: 151 KB, 562x362, a.webm [View same] [iqdb] [saucenao] [google] [report]
61710305

>>61710287
i figure he's after a keyboard method

>> No.61710367

>>61710073
tmux has different modes just like vim. I personally don't like that and I don't usually run tmux if I'm not ssh-ing. I thought there might be an easy solution to this using the terminal's config... oh well

>>61710287
You selected the text using the mouse, right? That's what I'm currently doing but it's very slow and cumbersome. I'm very used to (shift)(ctrl)(arrows|home|end) and the like.

>> No.61710456

>>61710367
i prefer to run long-running programs in tmux locally, for similar reasons to when using a remote machine
for example, what if i want to monitor it from another machine over ssh? my machine then becomes the "remote machine", and i can connect to it's tmux session
that and things like closing/restarting X won't affect things running under tmux, as they aren't parented by the graphical terminal itself

>> No.61710618
File: 120 KB, 280x291, 1501591339748.png [View same] [iqdb] [saucenao] [google] [report]
61710618

I need a distro that doesn't force the highest available resolution at the login screen. Every distro I tried (Ubuntu derivatives and Fedora) force the highest resolution of my monitor at start and my shitty GPU can't handle it so the screen turns black. I tried to circumvent it with scripts but all scripts are activated only after logging in, so that means I have to type in my password blindly and only then the script changes my resolution, and only then am I able to see anything.

>> No.61710699

>>61710618
use xorg.conf(.d)

>> No.61710730

Is it worth setting up a separate /home partition on my SSD so I can just reinstall an OS when it gets too clogged up with shit I have forgotten about it when I want to try a different distro?

Do any of you do this?
Also what filesystem is best for SSD if not ext4? Is btrfs worth keeping now that Redhat basically told it to gtfo? Anyone here use F2FS on their SSD with something like Ubuntu or Fedora?

>> No.61710799

>>61710730
I do this. I have a 256GB M.2 samsung SSD and I split it into /boot, swap, /home and /
Some people also have partitions for /var from what I've heard.
I use ext4 because I've always been using ext4 and it just werkz

>> No.61710843

>>61710618
Could be hard.
Is it a single user system?
Have you considered ditching the login screen all together and going for a tty login with a script that starts your environment automatically?

>> No.61710869

>>61710799
How much do you give to /?
Ubuntu usually takes about 4gb for itself, and I'm probably going to install Wine for vidya, and maybe a few other things like Docker and LXD (but that tends to save the images to /home anyway). So probably like 25gb for /

>> No.61710914
File: 28 KB, 696x693, 1501154624012.jpg [View same] [iqdb] [saucenao] [google] [report]
61710914

>ping 8.8.8.8 (not my dns, just a convenient ip address to ping)
>get packets
>ping my opennic dns server configured in resolve.conf
>get packets
>ping any url, like gnu.org or google.com
"Temporary failure in name resolution"
>use another device to sanity check
>phoneposting this from my wifi with no problems

Pic related

>> No.61711128

>>61710869
I went with 100GB for / because I store most of my user data on different drives anyway.

>> No.61711134

>>61710843
>>61710699
will look into these. or might as well buy a non 50$ GPU...

>> No.61711148

Covfefe

>> No.61711304

Unless you have an 8k screen, or your login manager renders a full 3D scene in realtime as the background, I don't see how a $50 GPU would struggle with that.

Unless it's like a 7 year old gpu that cost $50 back then (but I wouldn't call it a $50 gpu anymore, if that's the case).

>> No.61711320

>>61710914
are you using systemd?
/etc/resolv.conf?
is dnsmasq installed?

>> No.61711776

>>61711320
No
Yes
No

Some time ago I configured dhcpcd to not get dns configs, letting me manually add a server to resolv.conf, that's the extent of my configuration

>> No.61711808

Whenever Firefox is open, sublime text 3 is incredibly laggy and unresponsive. Once I close firefox, the lags and tearing are suddenly gone. I'm sporting a 600-series nvidia and the nouveau driver. Any idea what the cause is?

>> No.61711838
File: 23 KB, 420x460, dunce hat pepe.jpg [View same] [iqdb] [saucenao] [google] [report]
61711838

>>61691501
Alright freetards, I want a Libreboot laptop. Looking for something that's not x86 and that I can install Libreboot on without an external flasher.

According to the Libreboot website the ASUS Chromebook C201 is supported and I can flash it without full disassembly.

Will this work?

https://www.amazon.com/Chromebook-Rockchip-Pearl-White-Light/dp/B01EGBAQXY/ref=sr_1_3?ie=UTF8&qid=1501775121&sr=8-3&keywords=ASUS+Chromebook+C201

>> No.61711844

>>61710730

Copying my files cleanly is easier than dealing with leftover cache, config and temporary files.

>> No.61711847

>>61711808
>nouveau driver
lol
the cause is that you are too much of a faggot to tell stallman to go fuck himself and just install proprietary drivers like a sensible person

>> No.61711866

>>61711847
but I'm fairly sure the proprietary driver contains a backdoor. don't you think?

>> No.61711869

>>61711808

Ask on the forums for the proprietary software you're using. You paid for it, you should be able to use their support. Isn't that the big advantage of proprietary software?

>> No.61711877

>>61711869
I pirated it obviously. I'm not going to support closed-source software companies by buying their product. Unfortunately, visual studio code is a botnet and atom is even slower... so there's not much alternative to sublime from my perspective

>> No.61711902

>>61711877

>pirated
>botnet
>botnet
>botnet
>botnet
There is no point in helping idiots who are proud of their idiocy.

>> No.61711921

>>61711866
why the fuck would they do that? you could easily catch them out by inspecting traffic and seeing if anything goes to nvidia or any new site after a fresh install and then installing the proprietary driver.
see what a moron stallman has turned you into? you are scared of your own shadow.

>> No.61711935

>>61711877
the problem is likely with firefox rather than ST,but its worth checking their forum like the other anon said.

>> No.61711949

>>61711902
there are actually severe privacy issues regarding Visual studio code. I've researched this topic thoroughly because I need a good text editor. geany doesn't cut it in terms of customizability and plugins.
just one of the exhibits why VSC is bad:
https://stackoverflow.com/questions/40451596/visual-studio-code-still-accessing-internet-after-update-and-telemetry-was-disab

>> No.61711961

>>61711921
backdoor != spyware, fucker
next you're gonna tell me the intel ME and amd PSP aren't real? you're boarderline delusional

>> No.61711996

>>61711961
they're real you cunt, it's just i doubt they are sending anything to intel/amd, we can inspect outgoing traffic you stupid fuck.
what's the use of a backdoor if it doesn't send any useful data back home? what are you even worried about you fucking retard

>> No.61712064

>>61711996
that's not very friendly, anon. this is called the friendly gnu/linux thread for a reason.
furthermore, I've never said that the proprietary nvidia driver or intel ME are spyware that send data home; that's just your strawman. all I've said is that proprietary software may contain malicious code such as a backdoor. this is especially problematic with low-level software because the ME basically can inject any code at will and the nvidia drivers run in ring1. proprietary user space software is benign in comparison.

>> No.61712159

>>61711838
Yeah it will.
> flash it without full disassembly.
You have to dissemble and screw out the security screw

>> No.61712176

>>61712064
>backdoor != spyware, fucker
friendly
>cunt
not friendly

you really are a cunt, aren't you?

>> No.61712269

Is it possible to disable monitors when in working in command line interface? Clone view is annoying.

>> No.61712278

From https://www.debian.org/releases/stable/amd64/ch03s01.html.en:
>The installer is *not* designed to re-install over an existing system.

What the fuck does this mean? Is anything particularly bad going to happen if I try to reinstall? Or is there a better way to completely restore the system back to "factory defaults"?

>> No.61712386

>>61712278
They probably mean it's not going to magically repair your system.

If you have a basic understanding of partitions you don't need to worry about what they tell you, do what you want

>> No.61712417

>>41961180

>> No.61713090

I'm a linux newb, I'm running debian and I downloaded a program that only had a tarball available. How can I install this like a normal package and have it appear in my DE's menus? I'm currently using a Run Program command to the path in my ~/Downloads folder and I feel subhuman.

>> No.61713423

>>61713090
Sudo apt install /path/to/tarball

>> No.61713587
File: 201 KB, 532x532, help.png [View same] [iqdb] [saucenao] [google] [report]
61713587

Fuck, help me out here fglt, I'm going nuts. I've followed the furryguy's tutorial on Windows KVM w/ PCI passthrough step by step, upwards of 10-20 attempts but it all ends the same way.
As soon as everything is set up and I'm done with creating the VM in virt-manager I'm thrown into an UEFI shell where the input doesn't even work.
I'm using Linux Mint (it just works, so I would preferably stay there) with virt-manager 1.4.0.

>> No.61713698

>>61713423
>>61713423
Thanks for the tip, but it doesn't appear to be working. Here's the output:

E: Unsupported file /home/haws/Downloads/yakyak-1.4.4-linux-x64.tar.gz given on commandline

I could take this to google, but I will wait for you or another kind Anon :^)

>> No.61713701

I am trying to
gpg2 --full-gen-key
but i get
gpg: DBG: chan_4 <- ERR 16777397 Missing key <gcrypt>
gpg: agent_genkey failed: Missing key

I am trying to do this in CloverOS (Gentoo)
I think the problem is with libgcrypt but i don't know how to debug this further or solve it.

>> No.61714063
File: 60 KB, 1349x629, 1472759499436.png [View same] [iqdb] [saucenao] [google] [report]
61714063

>This site does use cookies not use cookies
Absolutely unacceptable!

>> No.61714548

>>61694337
sed, grep, lspci/lsblk/lsusb

>> No.61715267

>>61713698
that was a cruel joke.
Google how to install software from source. There will be README files after you extract the tarball.
When you get to the part that says "sudo make install" use "sudo checkinstall" instead.

>> No.61715329

>>61692848
You can't, you have to copy your config to the remote machine.

>> No.61715432

>>61715267
>>61715267
Thanks man, I'm glad you GNU enough to see through their deception. I ended up figuring it out... I ended up extracting the tar and creating a .desktop file as per the instructions. They had a couple of run-on sentences in their readme file which is why I kept missing the step to add a .desktop file.

>> No.61715473

>>61715329
ofc he can
>>61692848
set your PS1 as command when connecting, the trick is the correct escaping and combining it with a sleep so it's set AFTER the remote shellrc is loaded

>> No.61715693

Alright bois, I'm back into it. I had a thick hiatus where I tried to become a normie, but I realize now that /g/ wizardry is the life for me. I used to just use debian, sometimes hop to fedora, but all I did was write shitty programs and watch anime. Are there any new distros I should look into, or should I just go back to debian? Or maybe should I just go balls deep and install gentoo?

>> No.61715734

>>61715693
debian is still the only relevant distro, sadly. ubuntu if you want convenience and shiny. fuck timesinks like gentoo. if you actually want to get something done which it sounds like you do, then go with ubuntu.
if you want to experiment with some really cool and new shit, look into GuixSD and NixOS. soon all distros will be declarative.

>> No.61715754

>>61715693
Arch is the distribution you're looking for.

>> No.61715786

>>61699868
>uironically recommenting flash
>uironically recommenting chromium
wtf

>> No.61715824

After rebooting my system,it takes upwards of 2 minutes to be able to login(as root) from the tty.
When i was able to login,it then took 1-2 minutes for even dmesg or journalctl to process.In both there was nothing out of the ordinary.After about 30 minutes it goes back to normal and i was able to startx within seconds and Xorg popped up.
I checked all the ssd/hdd smart values and nothing shows up.I ran a short test on them all and nothing came up.
I ram memtest overnight(10 hours) and nothing popped up either.
What else could cause this?

>> No.61715860

>>61715824
systemd-analyze critical-chain

>> No.61715868

Hey guys. I successfully switched from Ubuntu to Debian 1 month ago and I'm pretty happy. I must say the "ancient packages" thing is a meme. I'm using the "Sid" repos and the packages are as bleeding edge as on Arch Linux.

Just saying hello to Debian folks and thanks for the cool support on the mailing lists.

>> No.61715909

whats the correct standard way to write a shell script which takes option flags like program -abc? anyone up for a quick tut for retards?
i just want to make it correctly, I'm currently using a while loop with shifting args but it feels just wrong

>> No.61715943

>>61715868
Welcome ~. That said, on stable, the packages are indeed old, but old also means rock solid, which is why stable is great for new users or servers. Its not always bad to have well tested, solid software. I personally use Debian stable with backports.

>> No.61715951

>>61715860
Nothing is out of the ordinary

>> No.61715970

>Xubuntu doesn't connect with wireless USB for some reason
It's grayed out for some reason.
It gave a terminal window once with a bunch of text once. (Nothing data, just the usual contract stuff) (Never got this window again)
I don't know what causes the problem

>> No.61715985

>>61715909
getopts

>> No.61715995

>>61715909
https://stackoverflow.com/a/21128172

>> No.61716031
File: 115 KB, 298x256, 1474387505445.png [View same] [iqdb] [saucenao] [google] [report]
61716031

>>61715995
>>61715985
ty anons, have this happy stallman in returm

>> No.61716038

>>61715943
http://jaqque.sbih.org/kplug/apt-pinning.html

>> No.61716061

>>61716031
>green_is_my_pepper.png

>> No.61716085

>>61715734
>really cool and new shit, look into GuixSD and NixOS
could you elaborate on that, anon?

>> No.61716114

>>61716085
The package manager style of guix and nix are the revolutin and I really hope that they'll be the future. Go to guixsd website and watch the demo video for a peek.

>> No.61716167

I LOVE GNU/Linux

>> No.61716177

>>61716167
me too brother

>> No.61716208

>>61716031
It's time to face the facts. Richard Stallman is nothing more than a whining, overly obese autistic manbaby who has not done anything beneficial for the computing OR technology world in the past 20 years. Seriously. Name something that RMS has done after 1995 besides bitching, crying, and moaning about bullshit that does not matter, or making some retarded, incomprehensible speech.

He demands that Linux be called GNU/Linux. That is fucking insane. The only reason GNU, GPL, and FSF are still a THING is because of Linus and the invention of Linux. If anything, Stallman should rename GNU to Linux/GNU, because without Linus, the GNU, GPL, and FSF would not be a thing anymore.

Stallman still has the fucking gonads to act like he's superior to everyone else. Saying shit such as "I'm not glad he's dead, but I'm glad he's gone" right after Steve Jobs' death. What an asshole. Stallman has not even programmed a single line of code since 2008, that was AFTER he essentially stopped in 1992.

He should be fucking grateful Linus stepped in to save his ass, and even allowing him to take partial credit for his achievements. If it wasn't for Linus, he would be nothing, he would probably be dead in a Burger King dumpster right now.

Besides, what has he ever even done? He claims to have written eMacs, but in reality he actually cloned gosmacs (the first eMacs that was made for UNIX). He didn't even write 50% of the code in eMacs.

You might say he wrote GCC and GDB, but the truth is that he initally wrote the C compiler, but now the vast majority for the same compiler is done by contributors.

He's a washed up, morbidly obese man who tries to stay relevant by having these retarded arguments that are similar to those found in the Soviet Union. Face it GNU/Freetards, Richard Stallman is a fat dickhead, and the only reason his name is still in the books is because of Linus's achievements.

>> No.61716290

>>61712269
xrandr --output themonitor --off
Or something like that.

>> No.61716303

>>61716208
He advocates free software, that's reason enough for me to like him

>> No.61716330

>>61716208
2/10 i replied

>> No.61716383
File: 159 KB, 1217x717, Untitled.png [View same] [iqdb] [saucenao] [google] [report]
61716383

>>61716208
You have a containment board.

>> No.61716525

>>61716383
fglt is the containment board friendo.
You faggots took over the thread last year,flt has been around for years ahead of your containment thread.

>> No.61716605
File: 51 KB, 320x449, 1501606797264.jpg [View same] [iqdb] [saucenao] [google] [report]
61716605

>>61716525
still here?

>> No.61716824

>>61716061
>fuck_the-green-pepper-is-starting-to-kick-in.jpg

>>61716383
>>61716525
>he's right you know

>> No.61716928

>>61716605
Don't call it GNU/Linux. It gives Stallsham undue credit. He's done nothing but take credit for the work of others and has the audacity to call himself a Doctor when he couldn't even finish his Masters.

wrote emacs
Contributed to guy steele's TECO macros, later cloned gosmacs, the actual first emacs for UNIX. If stallman wrote emacs, apple is the sole creator of webkit.
wrote gcc and gdb
He wrote the C compiler initially, but the vast majority of development for other compilers and the C compiler has came from non-stallman sources.

And he hasn't programmed in years. Stallman is washed up, and his justifications for copyleft are horribly invalid nonsense that would make more sense if they were actual thinly veiled communism instead of selfish ramblings and a desire for a world that catered to his specific social class.

>> No.61716939

>>61716824
>right
He's a fucking annoying shithead.

>> No.61716958

>>61716928
Go drink bleach.

>> No.61716965

>>61716958
>cognitive dissonance
I know its hard after drinking so much koolaid

>> No.61717151

If not for the GPL, linux would be as irrelevant as BSD.

>> No.61717175

>>61717151
Linus would have picked one of various other userlands at the time and we would be in the same place as we are now but without gnu.

>> No.61717220

>>61717175
Like fuck.

>> No.61717238

>>61717220
Read his quotes from interviews about the topic

>> No.61717255

Is this the ricing general?

>> No.61717360

>>61716525
THIS
/faglet/ should fuck off, I recommend red. it or 8 chins

>> No.61717384

>>61716939
He's still right
/flt/ was here years before this bullshit. don't try to act all innocent after you subverted OUR thread.
I only wish I could claim I was the guy who started /flt/ but unfortunately I'm only the anon who started /sqt/.

>> No.61717393

>>61717238
I already read a Torvalds interview where he stated precisely why he chose gplv2. Unfortunatly, it doesn't seem to have been archived anywhere that google can find it.
But, since I have in fact, read it, there's very little that any amount of retarded derp on your part will change my impression of Torvalds opinion on the matter.

>> No.61717397

My laptop's hdd has a myriad of pending sectors and is unusable.

I got an ssd and I've read about recovering my shit using a live usb ubuntu to make an image of the hdd with the recovery tools.

So, I'm reading about ddrescue and I'm lost, I can't understand shit. It's so frustrating. I found a gui version but I didn't even understand how the fuck to download it.

>> No.61717431

>>61717393
At the end he mentioned why he believed those who thought the GPL were socialist or communist weren't very bright.
"The cost of using GPL software is your contribution. The rest is legal fluff." was one part of it.

>> No.61717460

>>61717360
Don't let the door hit you in the ass on the way out.
Sorry it all turned sour for you.
Does sticking around and being an annoying and unrelenting piece of shit make you feel better?

>> No.61717490

>>61717393
>why he chose gplv2
If you are the person that said "If not for the GPL, linux would be as irrelevant as BSD." I don't see how Linus' reasons behind choosing the license supports that claim. You should instead be looking at the reasons behind the gain in market share.

>> No.61717550

>>61717490
>muh legal problums
What is microsoft patent trolling?
What is SCO.
GNU/Linux is where it is because the GPL promotes collaboration, and protects people's work from those who aren't interested in contributing.

>> No.61717565

>>61717460
But I'm staying until this is renamed back to /flt/. If I can be useful for one thing it will be that. We don't want the GNU shit here. Take it back to Israel or Auschwitz with you.

>> No.61717592

>>61717550
>protects people's work from those who aren't interested in contributing.
I fork your 5 million lines of code project
I apply a patch that many people like,but you dont want to adopt it for reasons(which you are strongly and censoriously vocal about because freetard)
I now copy verbatim your copy and just apply my patch to it every version bump.
I setup a donation page.
People donate to me.
People ignore you and you dont get donations

How that gpl for you now?

>> No.61717617

>>61717550
>What is SCO
Those cases were filed in 2004. And one was also filed against Novell.
>What is microsoft patent trolling?
If msft didn't write the gpl code then the patent grant clause of the gpl2 doesn't apply and it does literally nothing to defend against patent claims.
>GNU/Linux is where it is because the GPL ...
There you go, pulling claims out of your ass again.

>> No.61717623

>>61717592
People who violated the GPL have been successfully sued.
There are laws against murder. People still murder. How's that murder law for you? See how stupid that sounds?

>> No.61717651

>>61717623
I am not violating gpl in anyway
The source is available and open the entire time.
Im just applying a patch to it and maintaining the patch,which is public open source.

>> No.61717655

>>61717565
Are you the same guy, because that comment seemed extra stupid?

>> No.61717691

That's 2 threads turned into shit. This one, and /flt retarded-from-the-start fork.

>> No.61717693

>add common image editing features to krita
>gimp becomes obsolute

is this possible?

>> No.61717718

>>61717550
>GNU/Linux is where it is
Because at the time when people were looking for alternatives from commercial UNIX AT&T were in the process of suing the Berkeley for ownership of BSD and Linux was seen as a clean reimplemntation that ATT couldn't claim. Then after Berkeley won that case BSD fragmented into a bunch of different implementations. If the gpl encouriging contributions upstream incitied companies greed at the thought of getting their competitors work then that's great, but I doubt it was a major factor.

>> No.61717720

>>61717693
Thats not what krita aims to be.It is an image creator not editor

>> No.61717730

>>61717651
Nobody said you can't make money off FOSS.

>> No.61717759

>>61717730
But you as someone who has spent years on the code,by your self, you would be fine if i manage a patch and people liked it and paid me?
When all i do is pull your repo and apply the patch?
You would have no qualms with me just managing a single file patch on your years worth of work and making way more money then you have ever maid?

I know how you're going to answer(BUT MUH FREETARDISM) so i know you're full of shit

>> No.61717771

>>61717718
They called my bullshit, but if I just repeat it, it's true again.
Can't argue with that logic.
BSD is nowhere because nobody is required to collaborate.

>> No.61717795

>>61717759
You can go to distrowatch and buy installation cds.
Is that supposed to piss me off, too?

>> No.61717812

>>61717795
So you honestly telling me you worked for 5 years on your code,and some pissant comes around,forks it applies a patch and then gets money for it while you dont?

I knew you freetards were mentally unstable but holy fuck.
How much cum stained foot fungus have you eaten from your savior and lord stallman?

>> No.61717813

>>61717691
/fglt/ is the fork. Never forget that.

>> No.61717834

I have an idea, someone go to the archives, maybe warosu or anything else, find whichever variant came first and we go with what.

If /flt/ was first we use that. If /fglt/ was first we use that.

>> No.61717851

Netflix on Chromium, is it possible?
I know Stallman doesn't approve, I'll survive

>> No.61717872

>>61716208

Stallman is right, fuck your memes. You're just triggered because someone interjected you and now you're trying everything to find a reason to make "just Linux" a real thing. And while you're doing this, you're shitting on everything which made this community so great, which is Richard Stallman, copyleft, friendship, sharing and freedom - and the reason why threads like this exist. Ever seen a friendly Windows, sorry, NT or a macOs, sorry, Xnu thread? Guess why.

>> No.61717876

>>61717812
Consider the possibility for one second that somebody might create software because they want to use it, rather than sell it.
Now suppose there was this license called the GPL with millions of active projects, that contained stipulations about people being able to modify it, but required to share their improvements.
Can you get your pea sized brain around the idea that the GPL might seem attractive.
That right there, my dimwit friend, is why GNU/Linux has become so big.

>> No.61717881

>>61717771
What?! You can't back that claim up and are ignoring the actual reasons. Fuck off.

>> No.61717890

>>61708209
Zsh+ohmyzsh

>> No.61717895

>>61717851
Just use firefox and click allow drm when prompted.

>> No.61717901

>>https://warosu.org/g/thread/S49808959

>/flt/
July 2015

Mods take note. /flt/ was the original. /fglt/ have tried to infiltrate this thread and take it from us.

>> No.61717904

>>61717812
It's called competiton you rent-seeking moron. If you can't compete on marketing, brand and development speed then someone will come along and eat your lunch. That is a fact in all markets. You can't just expect to develop something nice and sit back, feel good about yourself, and expect the cash to roll in. If you aren't captilising on it then I bloody well hope someone else does.

>> No.61717912

>>61717876
You're completly ignoring the point(thrice now)
Common freetard tactic,completly overlook the point of the post and then spout off nonsense about MUH GNU MUH 4 FREEDUMBS/COMMANDMANTS.

>> No.61717928

>>61717901
alpha releases are know to be buggy

>> No.61717930

>>61717720
Fuck that shit, let's submit patches to give it image editor features

What are they going to do, turn down free features?

>> No.61717940

>>61717881
Poor BSD and legal problems.
Corporations using linux patent trolled for millions and SCO lawsuits irrelevant...OK kid.
Microsoft makes more money patent trolling android vendors than from windows phones btw.

>> No.61717948

>>61717928
Then you'll have no problem with another fork back to the original.

>> No.61717953

>>61717895
I've tried to switch to Firefox so many times, but it's just so much slower than chrome/chromium it's ridiculous

>> No.61717966

>>61717813
The good news is that /flt/ is back. Check the catalog. Bye now.

>> No.61718009

>>61717912
>ignoring the point
I'm still don't think you ever had a point.

>> No.61718081

>>61717393
Linus doesn't support the GPLv3 because he doesn't understand what the GPL is. He understand the GPL as a license which is about open development where "you get source code back", but the GPL is a copyleft license focussing on freedom. The GPLv3 got some updates to prevent circumventing the License with trickery (which the GPLv2 allowed), making sure that you always have the 4 freedoms. While RMS considers these updates as fixes, Linus considers them as "sneaking new rules into the License".
The interview you're referring to is from debconf 14.

>> No.61718142

>>61717966
>uironically riding the joke for a second day
>not even changing the ope pic
embrassing

>> No.61718160

>>61718081
>debconf 14
Actually it was a interview Q & A with a reporter I was referring to.

>> No.61718213

Anyway, I'm sure we can all agree it's nice /flt/ is back again. You can share your feelings with like minded idiots. I promise I won't go there and annoy you.

>> No.61718238

>>61718211
i love you

>> No.61718256
File: 210 KB, 1437x1210, 1488877267969.jpg [View same] [iqdb] [saucenao] [google] [report]
61718256

>>61718238

>> No.61718297

>>61715786
i missed the part where i was telling them to install it, just giving the knowledge out to the thread.
but i use both for some text games that are stuck in flash, sandboxed and all that.

>> No.61718409

>>61717953
I've heard that ublock origin doesn't slow chrome to half the speed of firefox the way adblock plus did. But i haven't tried it since. Except for netflix (with no extensions)

>> No.61718487
File: 58 KB, 722x349, 1462969085596.jpg [View same] [iqdb] [saucenao] [google] [report]
61718487

Xfwm with Nvidia is kind of a bitch regarding tearing.

I know nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }" is the solution, and I have that in my session rc after a delay, but sometimes it doesn't work and I have to manually enter it into terminal.

Is there a more proper way to configure nvidia-settings-rc it so it always forces the full composition pipeline? Scouring through and experimenting with the settings hadn't helped.

>> No.61718705

>>61693469
Why buy a new laptop?

Just replace the Mediatek NIC. It's probably just a mini PCI-E adapter. They're really easy to swap out.

I went over to newegg and they have about 15 different ones for sale, most of them are under $20. Just pick one and google around to see if it has linux drivers available before you buy it.

Or you could just try the mt76 drivers with the adapter you already have. https://github.com/openwrt/mt76

How did you identify it as "MTE730E". Did you probe it via software, or read the sticker, or read the writing on the actual chip?

>> No.61718795

>>61695350
Just find a super lightweight debian distro that's already gutted to the bare minimum and uses XFCE. Then install python 3, firefox, coreutils and a PDF reader.

>> No.61718937

>>61695397
Did you use the proprietary driver or the nouveau driver?

>ended up with a blackscreen after reboot

Boot from a live USB stick and dig around in /etc/default/grub

You should be able to set a command there to blacklist the currently broken driver or to tell xorg to reconfigure itself.

>> No.61718979

>>61697324
Just set ristretto as the default for gifs and geeqie for everything else.

>how to merge these 3 into 1?

Send in a feature request to one of the projects or code it yourself.

>> No.61719041

>>61697572
>GNU is just a tiny part of Linux ecosystem. The shit part.

>Thinks he can survive without it.

Good luck with that.

>> No.61719069

>>61697771
>The amount of GNU is less than 10%. The rest is libre soft.

GNU is libre software.

>> No.61719132

>>61701051
>Adobe announced that they'll completely drop all work and all support on flash altogether soon.

They're switching over to HTML5 and attempting to sell HTML5 animation creation software. They'll fuck it up somehow.

>> No.61719224

>>61701726
>Like setting up and maintaining a safe web server and what else?

Depends on where you want to work and what specifically you want to do. Most companies deal with way more than just a web server. Can you maintain a company wide network consisting of employees each with there own client system, a centralized server, an internal mail server, possibly databases for customer data shit, can you maintain backups for everything? Can you do it all securely with 100% uptime?

>> No.61719266

>>61703286
>wont even be recognized

USB or PS/2?

Either way you need to look at the raw data coming in.

>> No.61719327

>>61704109
>so there's no way to automatically mount it

if uuid = *any valid uuid*
then automount *every valid uuid*
else mount *everyfuckingthing*

>> No.61719455

>>61705691
>FUCK YOU! Just install them anyway!

You walk into a 7-11 and buy a car air freshener. The clerk asks where your car is. You say "Yeah I want to buy a car too". He says they don't sell cars... can you believe that shit?

It's the unstable branch, the packages are new and unstable. There is no guarantee the required dependencies are even in the repo.

If you do find packages without required dependencies in the repo make sure to yell at someone about it AFTER you find out where the dependencies are.

There is also a 100% chance that a package name changed and it does not know what the old/new dependency is named.

>> No.61719467

>>61719455
>Reddit spacing
I can't even be bothered reading that garbage.

>> No.61719472

>>61706385
>The whole point was that I wanted to switch to GNOME

That did not require switching to the unstable branch.

>> No.61719524

>>61706623
>>lightweight
>There's that myth meme bullshit again.

He's on a single board computer/embedded setup. Lightweight is a requirement at that point.

Is MPD actually lightweight? I don't know, I don't use it. But while you're here could you suggest a solution that's small and not resource intensive?

>> No.61719573

>>61709048
Kodi

>> No.61719662

>>61709770
>terms are xfce4-terminal and tilda

Find a new terminal that works how you want it to by default.

try xterm

>> No.61719739

>>61710618
>force the highest resolution of my monitor

It's probably just forcing the native resolution of your monitor...

>my shitty GPU can't handle it

I seriously doubt that. Sounds more like your monitor is not reporting it's capabilities correctly.

>> No.61719816

>>61710914
IPV4 or 6?

Did you try just letting the DHCP server handle everything?

>Some time ago I configured dhcpcd to not get dns configs, letting me manually add a server to resolv.conf, that's the extent of my configuration

So you manually added a DNS sever but not the client IP and default gateway? Why not just set a static IP along with the non-shitty DNS server?

>> No.61719940

>>61711847
>the cause is that you are too much of a faggot to tell stallman to go fuck himself and just install proprietary drivers like a sensible person

You know for some cards there is no proprietary version that works with current kernels. Sometimes the proprietary driver is not even available.

Most people use whatever works the best. Proprietary drivers always degrade, the code is just not available and AMD/Nvidia stop releasing Linux builds after a few years.

>> No.61720003
File: 1.93 MB, 2528x1278, GIMP.png [View same] [iqdb] [saucenao] [google] [report]
61720003

>>61714063
Where'd you get that screenshot 1995?

>> No.61720060
File: 170 KB, 959x1024, hot.png [View same] [iqdb] [saucenao] [google] [report]
61720060

Xscreensaver with two 4k monitors and the CPU hits 80 degrees.

>> No.61720074

>>61719524
>solution that's small and not resource intensive
MPD is about as small as you will get (it actually depends on quite a lot though) withought going to something like sox or ffplay that is much less convenient.

>> No.61720379
File: 7 KB, 834x600, 1501007947159.png [View same] [iqdb] [saucenao] [google] [report]
61720379

>>61720003

>> No.61720392

>>61720003
I don't want to call you a retard because I actually thought it said gimp for a minute too.

>> No.61720548

>>61720074
> MPD is about as small as you will get
Depends: adduser, lsb-base, init-system-helpers (>= 1.18~), libadplug-2.2.1-0 (>= 2.2.1-0), libao4 (>= 1.1.0), libasound2 (>= 1.0.18), libaudiofile1 (>= 0.3.6), libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libavcodec56 (>= 6:11~beta1) | libavcodec-extra-56 (>= 6:11), libavformat56 (>= 6:11~beta1), libavutil54 (>= 6:11~beta1), libbz2-1.0, libc6 (>= 2.17), libcdio-cdda1 (>= 0.83), libcdio-paranoia1 (>= 0.83), libcdio13 (>= 0.83), libcurl3-gnutls (>= 7.18.0), libdbus-1-3 (>= 1.0.2), libexpat1 (>= 2.0.1), libfaad2 (>= 2.7), libflac8 (>= 1.3.0), libfluidsynth1, libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.12.0), libgme0 (>= 0.5.5), libicu52 (>= 52~m1-1~), libid3tag0 (>= 0.15.1b), libiso9660-8 (>= 0.83), libjack-jackd2-0 (>= 1.9.5~dfsg-14) | libjack-0.116, libmad0 (>= 0.15.1b-3), libmikmod3 (>= 3.3.3), libmms0 (>= 0.4), libmodplug1, libmp3lame0, libmpcdec6 (>= 1:0.1~r435), libmpdclient2 (>= 2.9), libmpg123-0 (>= 1.13.7), libnfs4 (>= 1.9.3), libogg0 (>= 1.1.0), libopenal1 (>= 1.14), libopus0 (>= 1.1), libpulse0 (>= 0.99.1), libresid-builder0c2a, libroar2, libsamplerate0 (>= 0.1.7), libshout3, libsidplay2, libsidutils0, libsmbclient (>= 2:4.0.3+dfsg1), libsndfile1 (>= 1.0.20), libsoxr0 (>= 0.1.0), libsqlite3-0 (>= 3.5.9), libstdc++6 (>= 4.9), libsystemd0, libupnp6 (>= 1.4.3), libvorbis0a (>= 1.2.3), libvorbisenc2 (>= 1.1.2), libvorbisfile3 (>= 1.1.2), libwavpack1 (>= 4.40.0), libwildmidi1 (>= 0.2.3), libwrap0 (>= 7.6-4~), libyajl2 (>= 2.0.4), libzzip-0-13 (>= 0.13.56), zlib1g (>= 1:1.1.4)
Suggests: avahi-daemon, icecast2, mpd-client, pulseaudio

Phew. I realise that most of those are for file format support but libiso9660-8, libsmbclient?

>> No.61720690

>>61719739
I need to clarify: my GPU can handle it. the thing is it supports the max resolution of my monitor (1440p), but only on DVI. my monitor has no DVI support, so I have to use a DVI to HDMI cable which apparently can't handle 1440p? anyway I decided to just buy a new GPU...

>> No.61720769
File: 105 KB, 1000x639, 20151001104113_big[1].jpg [View same] [iqdb] [saucenao] [google] [report]
61720769

>in a thread, earlier today: "What's the programming equivalent of a deadlift?"
>one reply caught my eye: "Trying to install Wifi drivers in loonix."

Is that true? Is it really that much of a bitch? And if so why?

I specifically ordered pic related, a wifi(+bluetooth) PCI-E card yesterday so I could dual-boot Mint on my desktop. I have some shitty Chinese USB wifi dongle, with a MediaTek chip which has some really old Linux drivers developed for it, but after multiple full days of trying to make it work, I gave up. Shit was stubborn.

I'm just sick of windows and really wanted to give linux a try. Well now I guess I put down money for it so I'm invested. This shit better be worth it you weebs.

>> No.61720809

>>61720769
If no-one bothers supporting the chip in linux then you are going to have so trouble with it, of course. Stop complaining and thinking things will magically get better. Go buy something with an atheros chip in it.

>> No.61721278

>>61720809
That's what I did, hence the pic related.

>> No.61721301

Does anyone know what library might possibly not be loading right if a game can read keyboard input for things like movement, but can't seem to read keyboard input in text input boxes and chat boxes?

>> No.61722021

>>61720379
where can I download this

>> No.61722473

>>61722021
Right click -> Save as

>> No.61722549

>>61720769
>Is that true? Is it really that much of a bitch? And if so why?
Not really, if you've chosen compatible hardware. Fewer wifi adapters are supported on Linux than on Windows, however, so it creates a bad impression for some people who expect everything to just werk without checking first.

While Windows nominally has support for more wifi adapters than does Linux, honestly, the quality of a lot of those drivers is very poor. I've had a lot of trouble with wifi on Windows over the years.

>>61720809
This is the friendly thread. Be friendlier.

>> No.61722688
File: 41 KB, 1280x1483, brainguy.png [View same] [iqdb] [saucenao] [google] [report]
61722688

>>61722549
Yeah lol, when I bought the USB dongle I hadn't even thought about loonix, I just wanted a gaming computer. But now I'm graduated, looking for a serious job and want to see if I can move to linux full-time for 1. Freedom from Win doze 2. experience in Unix environments 3. Programming and better compatibility with Android for development, Python for machine learning, and basically everything else that's not lolgames or the M$ walled garden.

But I went all the way into the C files in the MediaTek drivers to try & see if I could fix the dependencies, got it working to the point where Network Manager would see nearby Wifi networks but all had a signal strength of 0% and would fail after several seconds of connecting. Was just trying to boost my ego by claiming that I almost accomplished a relatively hard task in the gnu/linux world.

>> No.61722707

>>61717834
are you too new to remember?

>> No.61722765

>>61716208
https://www.youtube.com/watch?v=jskq3-lpQnE

>> No.61722939

So... Windows 10 just updated and slit its own throat in a grand display, losing me all of my files.

2 questions. Are the Linux GPU drivers good enough for gaming yet, and what's the best standard Linux distribution to easily acclimatize myself to that won't rape me and sell my data to Mossad?

>> No.61723125

Guise, what's the best screenlocker for Xorg? Lightlocker that comes with Xfce is broken on my install, and xscreensaver is seriously ugly.

>> No.61723168

>>61722939
Drivers are your least concern. Only Windows can natively run DirectX, and Wine emulation causes unplayable input lag. Quit gayming anyway, switch to Debian for a stable classic Linux experience without selling your soul to Mossad (a.k.a. Jewbuntu)

>> No.61723174

Just got gentoo installed and even x is working.

What should i do next? Set my USE flags and emerge world?

>> No.61723185

>>61723125
slock

>> No.61723247

>>61723185
thx senpai

>> No.61723290

>>61723174
install gentoo

>> No.61723392
File: 81 KB, 1030x842, VMChromiumOS[1].png [View same] [iqdb] [saucenao] [google] [report]
61723392

My current laptop (Lenovo Flex 14) is really old Mbut still works like a champ. My roommate just got a Thinkpad Chromebook and it's pretty sweet. He likes the minimalism of it, and dual-runs Ubuntu with Crouton. Says he uses ChromeOS for pretty much everything unless he needs to code, at which point he just keyboard shortcuts over to Linux.

I searched and apparently ChromeOS isn't available to download in an ISO or anything, but ChromiumOS is basically the same thing.

If I wanted to ditch windows, is ChromiumOS legit and worth making your daily driver (primarily for muh minimalism)? Or should I just go full linux and use Chrome in that? I'm still not used to a linux-only environment and think the ChromeOS dual-wielding is pretty cool.

>> No.61723421

>>61723392
I don't know much about chromos (thinkpad chromebook ... wut) but you can the ISO in a VM and fullscreen that and try it out for a while before commiting.

>> No.61723468

Is there any real reason to not use deepin(distributive), besides >muh china >muh bloat?

>> No.61723641

Is there even one distro that will let me set up a system using F2FS in the installer? Fucking Ubuntu is too shitty to do this
I'll switch to it right now if you can recommend something that verifiably works with f2fs

>> No.61723861

>>61723641
Just use a live disk and format the partition yourself. Hell, dont installers let you drop down to a shell and do that shit yourself anyway?

>> No.61723910

>>61723861
You can't format a partition to f2fs with gparted. There are some people who have done it by installing with ext4 then moving the system over but I was wondering if someone has a better solution. It's retarded that a decent and useful fs isn't supported by the major distros. This is the 1st time in ages where I've wanted something that a major distro didn't have working out of the box or allow me to add easily post-install.

>> No.61724199
File: 29 KB, 650x344, a.png [View same] [iqdb] [saucenao] [google] [report]
61724199

>>61723910
>You can't format a partition to f2fs with gparted.
but that's wrong

>> No.61724244

>>61723168
I just did the Win10 LTSB thing. Unsure right now if I also have RAM failing or if it was just a memory page problem with the Firefox Nightly.

Tech issues come in waves.

>> No.61724250

>>61724199
what gparted version/distro

>> No.61724259

>>61724250
gparted 0.28.1, arch linux

>> No.61724291

>>61724259
even the arch wiki says grub doesn't support f2fs yet
also did you install your base os to f2fs, or is that post-install? because it works post-install on ubuntu also, but that's no use in installing the system to a f2fs partition

>> No.61724317

>>61724291
i'm only >>61724259 and >>61724199
all i'm saying is gparted supports f2fs
i don't even own any ssd's

>> No.61724342

>>61724317
>i don't even own any ssd's
you're missing out
sell whatever tech you need to sell to get the money to buy even a 32gb ssd. this shit FLIES even on ext4.

>> No.61724494

>>61720060

Stop using that shit. Stick to plain DPMS.

>> No.61724576

>>61720060
keep in mind screensavers were most popular back when there were no power saving features in the monitor or cpu
that is, software couldn't turn the monitor off, which is a better idea for both screen saving, and also power saving
and the cpu ran at full speed all the time, regardless of what was running, so running screensaver software wasn't a waste of resources or power (unless something else is also running, and the screensaver is taking away from that)

>> No.61724828

NEW THREAD

>>61711283
>>61711283
>>61711283

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
reCAPTCHA
Action