Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 428 KB, 640x480, Torvalds Linux.png [View same] [iqdb] [saucenao] [google] [report]
61522200 No.61522200 [Reply] [Original] [archived.moe] [rbt]

Previous thread: >>61503976

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Resources:
Your friendly neighborhood search engine.

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):
https://wiki.archlinux.org
https://wiki.gentoo.org

/g/'s Wiki on GNU/Linux:
https://wiki.installgentoo.com/index.php/Category:GNU/Linux

>What distro should I choose?
https://wiki.installgentoo.com/index.php/Babbies_First_Linux

>What are some cool programs?
https://wiki.archlinux.org/index.php/list_of_applications
https://directory.fsf.org/wiki/Main_Page

>What are some cool terminal commands?
http://www.commandlinefu.com/
http://bropages.org/

>Where can I learn the command line?
http://mywiki.wooledge.org/BashGuide
http://www.grymoire.com/Unix/

>Where can I learn more about Free Software?
https://www.gnu.org/philosophy/philosophy.html

>How to break out of the botnet?
https://prism-break.org/en/categories/gnu-linux

/t/'s GNU/Linux Games: >>>/t/769497
/t/'s GNU/Linux Videos: >>>/t/713097

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

>> No.61522291

>>61522200
>thread is 6 minutes old
>0 posts
this thread is doa

>> No.61522298

>>61522200
Good news, source mage just got added to screenfetch, update and check it out. With it in both screenfetch and neofetch, you can now use source mage in screenfetch/neofetch threads or any other GNU/Linux threads. FSF should be asked to to add source mage to their list of approved distros.

>> No.61522368
File: 32 KB, 602x500, devuan pepe tux.png [View same] [iqdb] [saucenao] [google] [report]
61522368

post tux pepes ITT, I only have a few

>> No.61522380
File: 26 KB, 602x500, 1490803760600.png [View same] [iqdb] [saucenao] [google] [report]
61522380

>>61522368

>> No.61522389
File: 26 KB, 602x500, 1490803494659.png [View same] [iqdb] [saucenao] [google] [report]
61522389

>>61522380

>> No.61522427
File: 27 KB, 602x500, 1500820892843.png [View same] [iqdb] [saucenao] [google] [report]
61522427

>>61522389

>> No.61522566

>>61522368
http://imgur.com/a/EHK9Z

>> No.61522609

Who arrived at the ultimate phase where everything just works for you, you settled for a distribution, the novelty is gone and you don't even notice you're using a Linux distribution any more?

Feels... average and unremarkable.

>> No.61522637

>>61522609
Install Debian.

>> No.61522653

Hi! I'm the anon who had issues with the bridges in the last thread. I've resolved it thanks to 2 anons (I believed) but as I'm a total uknknow in the topic, now some services are failing.

What are the matters I have to take in consideration after succesfully building the bridge? Now fail2ban thinks my SSH request are attacks, for example. What did I miss?

Thanks in advance guys.

>> No.61522731

>>61522609
Try Slackware. That's the final frontier.

>> No.61522778

>>61522731
Managing your own slackbuilds is fun!

>> No.61522801

>>61522731

There is no frontier, idiot.
Normal people (those that aren't idiots) realize what a distribution is early on and stick with it because it satisfies their needs. Only idiots like you perpetuate some myth of steps, levels and frontiers to inflate their intelligence which is obviously lacking.

>> No.61522841

>>61522801
FRIENDLY gnu linux thread

>> No.61522848

>>61522609
ArchLinux

>> No.61522892

>>61522801
Normal people are the wierdest sickos.

>> No.61522937
File: 191 KB, 1920x1080, 1489202439625.jpg [View same] [iqdb] [saucenao] [google] [report]
61522937

What are some efficient gui applications?

>> No.61523005

>>61522937
pavucontrol - all-in-one volume, input and output manager for memeaudio. It should be a default in every distro with pulse preinstalled/part of the desktop metapackage.

>> No.61523044

>>61522937
terminal emulator to access efficient CLI

>> No.61523056

>>61522937
Synaptic instead of Ubuntu's cucked "Software Center".

>> No.61523080

>>61522848
>>61522637
>>61522731

Why do you think I am not "satisfied" with my current distribution and way to use my computer?

>> No.61523095

>>61523005

It has flaws and no one is actively fixing it. I reported some usability concerns and they won't get fixed any time soon.

>> No.61523115

>>61523005
will it ever get an qualizer?

>> No.61523131

>>61523115
e+

>> No.61523156

>>61523080
>Feels... average and unremarkable.
This bit.
You gotta try new things man. Why settle for average when there might be something perfect just over the horizon.

>> No.61523201

>>61523156

I don't want my operating system to be exciting and new. I want it to be familiar and reliable. I actually use it, unlike some idiots that install different distributions to play with different desktop environments and themes, thinking that those things make up a distribution.

>> No.61523224

>>61523201
>I actually use it
I don't think you belong on this thread, man.

>> No.61523324

>>61522298
nice
>FSF should be asked to to add source mage to their list of approved distros
I don't think they'll do that, for the same reason they refused to add debian, since they offer a nonfree repo

>> No.61523325

>>61522298
Do you think the FSF will accept source mage?

>> No.61523345

>>61522298
compiling my kernel right now
I'll be uploading screenshots as soon as I rebuild the system and install xorg and a wm

>> No.61523389

>>61523324
It's less that they have a non free repo and more they make it too easy to find and install nonfree software.

>> No.61523474

>>61522653
Little bump for my issue, I'm a little lost.

Previous info >>61520042

>> No.61523587
File: 20 KB, 574x175, 0.gif [View same] [iqdb] [saucenao] [google] [report]
61523587

Daily reminder that these are things you can add to your Bash now (by putting them in ~/.inputrc):
>set colored-completion-prefix on
When pressing tab twice to list all possibilities the matched part is colored
>set editing-mode vi
Vim style command line editing (e.g. press escape and enter / to search history, or cw to change word, etc.)
>set show-mode-in-prompt on
For Vim command line mode adds an indicator to the start showing which mode you're in
>set vi-ins-mode-string "(ins)"
>set vi-cmd-mode-string "(cmd)"
In Vim command line mode sets how the indicator appears in either mode

Happy bashing!

>> No.61523610

!github 2hrs ago: added support for endless OS

>> No.61523656

>>61523587
Daily reminder there are many things in /etc/inputrc that are simply commented out.
Theirs you're template, boys.

>> No.61523661

>>61523610
What?

>> No.61523668

>>61522937
yad - it allows you to write little gui applications with shell scripting.

>> No.61523717

>>61522937
virt-manager
x2go
gparted

>> No.61523732

How do I copy a file into the same directory and give it a different filename, using command line?
inb4 rtfm, I read the man page for cp and can't find shit

>> No.61523774

>>61523732
cp oldname newdirectory/newname

>> No.61523802

>>61523732
>>61523774
if you want it to stay in the same directory just omit the newdirectory/

>> No.61523811
File: 208 KB, 807x935, 1496680579128.png [View same] [iqdb] [saucenao] [google] [report]
61523811

>>61523732
curl -# "file://my_file -o my_file_copy

>> No.61523829

>>61523811
Whoops, remove the ".

>> No.61523872
File: 18 KB, 180x200, image.jpg [View same] [iqdb] [saucenao] [google] [report]
61523872

>>61523774
>>61523802
>>61523811
>>61523829
thank (You) senpai's

>> No.61523882
File: 60 KB, 990x441, Screenshot from 2017-07-23 09-58-47.png [View same] [iqdb] [saucenao] [google] [report]
61523882

>>61523661
somebody was excited that sourcemage was just added to {neo,screen}fetch.

>> No.61523889

>>61523732
dd if=porn.mkv of=porn_copy.mkv

>> No.61523912

>>61523872
>image.jpg
>>>/r/eddit

>> No.61523924

>>61523912
>implying you don't phonepost

>> No.61523937

>>61523924
>owning a botnet listening device

>> No.61523983

cp oldname newname || cowsay fail

>> No.61523992

>>61523882
Dylanaraps updates fast, just a few hours after the screenfetch issue was opened he already had it implemented into neofetch and even used the logo in the request thread.

>> No.61523996

Do you guys think "unison" is stable enough to be run as root? There's some root owned directories I want to sync between two of my machines.

>> No.61524018

>>61523732
cat file > newfile

>> No.61524085

>>61522609
i am, but not feeling average. started learning more of bash scripting, vim using, and refining my loonix experience as a whole.

>> No.61524148
File: 3.30 MB, 1680x1050, Screenshot from 2017-07-23 10-17-22.png [View same] [iqdb] [saucenao] [google] [report]
61524148

>> No.61524152

>>61522609
There is no ultimate phase, you're always learning

>> No.61524166

>>61524148
wallpaper?

>> No.61524184 [DELETED] 
File: 88 KB, 500x441, 1390758939384.jpg [View same] [iqdb] [saucenao] [google] [report]
61524184

>>61522298
>tfw I made the ascii logo
Nice.

>> No.61524203

is it enough to just do
make defconfig

when compiling a kernel?
it'd be a pain in the ass to go through thousands of settings and figuring out which ones I need and which ones I don't
are the defaults sane?

>> No.61524217

>>61523983
>|| cowsay fail
Should be standard tbqh

>> No.61524244
File: 1.75 MB, 2560x1600, 1491761662828.jpg [View same] [iqdb] [saucenao] [google] [report]
61524244

>>61524166
I found it on 4chan/g :^)

>> No.61524248

>>61524203
if you have generic as fug hardware then it's enough. However at least look at the network card and storage controller sections (also enable nouveau/radeon/amdgpu as module so you aren't stuck with VESA console). If you have these 2 right then the kernel will be able to boot up and you can add everything else.

>> No.61524290

>>61524244
You mean that satire tech board?

>> No.61524303

>>61524248
>also enable nouveau/radeon/amdgpu as module
those are separate packages that don't come with the kernel, no?

also, do I need an initramfs image if I don't encrypt the root partition?

>> No.61524317

what are the first things you install after a fresh install?

>> No.61524322

>>61524244
thanks

>> No.61524328

What does "--release" do in i3 after "bindsym"

Apparently it's needed for taking a screenshot with the Print key, but I have no idea why

>> No.61524354

>>61524303
>those are separate packages that don't come with the kernel, no?
You are thinking of the drivers of x.org, yes those are in separate packages. They all require the kernel-level driver. If the kernel driver is present and operational you will get high resolution, widescreen tty.

If you don't encrypt your root and your disk drivers are included in the kernel (not as modules but built-in) then you don't need an initramfs.

>> No.61524395

What will happen when I write rubbish into /dev/mem? Will Linux get autism?

>> No.61524399

>>61524328
the command will run when you release the key rather than when you press it

>> No.61524426

>>61524354
thanks anon

>> No.61524429

>>61524395
you already write rubbish into 4chan/g/fglt/

>> No.61524432

>>61524395
if your kernel doesn't have the CONFIG_STRICT_DEVMEM option activated, you will get ~~~undefined behaviour~~~

>> No.61524575
File: 153 KB, 920x713, sick_burn.jpg [View same] [iqdb] [saucenao] [google] [report]
61524575

>>61524429

>> No.61524580

>>61524429
kek'd

>> No.61524629
File: 327 KB, 1920x1047, purism.jpg [View same] [iqdb] [saucenao] [google] [report]
61524629

>>61522200
https://www.youtube.com/watch?v=tz1ZAk02OVo

The future is here and respect your FREEDOMS!

>> No.61524696

>>61524629
>Computers that don't track you
>Built-in webcam
Hmmm...

>> No.61524716

>>61524696
Nice try Microsoft, but the webcam has a built in kill switch!

>> No.61524806

My Arch LARPtop became convinced that its mousepad does not have hardware buttons about an hour and a half ago. All the diagnostics say that this mousepad does not have hardware mouse buttons. It does. I've set up tap clicking as a stopgap measure, but this is really annoying. All the help threads I can find are about making your touchpad STOP thinking it has mouse buttons. Any advice?

>> No.61524832

>>61524806
Buy a better one https://puri.sm/

>> No.61524982

>>61524832
hahaha nice meem LEL

>> No.61525044

Is it possible to make a browser (or any other program) asking twice which file I want use to upload or sth? I'm looking for the browser or script language which allows that. I just want avoid missclicks and things like that.

>> No.61525065

>>61525044
it can be also plug-in to any browser, I just want this feature

>> No.61525113

>>61524629
hold ctrl and click on a second file

>> No.61525211

>>61522609
I have settled with arch for now, but every once in a while I bump into something I want to do that I have to learn.
There are a few things that I want to do which I do not understand but can live without.
For instance, having my VM automatically shutdown first when I send a signal to reboot/shutdown my host OS.
Another which should be easier to learn is scheduled S.M.A.R.T. HDD checkup, to at least give me some warning if one of my hard drives is about to fail.

I only backup absolute essentials, but would like to save what I can should that happen so I don't have to re-download as much media or waste money purchasing another huge NAS for redundancy.
That reminds me , I should write a script that grabs all folder names in my media folder and dumps the text into a text file with newline delimiters, far more compact way of backing up media which can be re downloaded.

>> No.61525354

>>61523474
So I ended up resolving it. For some reason now works, edited some things at /etc/interfaces as some anon told me to doo but with a minor change. Some things didn't work was a matter of configuration and now I have fully working bridge.

The only thing it last is if I want to set a manual lease on this bridge, I either give him the original MAC, as I have it in the router, or I give the router the bridge one. Someone would mind to point me what's the better solution?

>> No.61525510

Installed ubuntu for some reason and then uninstalled everything I didn't use which was a ton of shit, installed gnome and like 5 other pieces of software and the fucking thing still has almost 1800 packages. This installation is just used for web browsing, discord, spotify, and torrenting. Insane that 1800 packages are needed for that.
I guess it doesn't matter much because it is still running very well and not even using half of my available ram

>> No.61525540

>>61525510
Gnome alone is like 1 GB full of shit you wouldn't need, why would you clean your system and then ruin it by isntalling Gnome?

>> No.61525553

>>61525510
install xfeces

>> No.61525561

>>61525540
Idk I like it?
I think i3 is cool but Im not going to learn all those fucking keybinds

>> No.61525593

>>61525561
So, why didn't you just install Ubuntu Gnome then?

>> No.61525628

>>61525593
Fucked around with unity for a bit. Only took a minute or two to switch. I'm just surprised there are sooo many damn packages.
I'll do an arch install some time soon and install the same handful of applications to compare amount of packages. There was so much accessibility shit for like the fucking blind and spics, that was like 100 packages right there.

>> No.61525661

>>61525628
Arch splits its packages less, so it will have less packages for the same shit. Which doesn't say anything useful about your system anyway.

>> No.61526011

I have a shitty partition layout

>boot live disk
>mount all partitions and rsync entire / tree to another disk
>fix my shit
>rsync back and fix up fstab + any loose disk references
There's no reason this wouldn't work, right?

>> No.61526661

>>61523587

It won't look like that. Why do you never mention that?

>> No.61526763
File: 375 KB, 800x600, angry-guy.jpg [View same] [iqdb] [saucenao] [google] [report]
61526763

ok, I've been using linux for like 2 years now, BUT I CAN'T FIGURE OUT HOW TO ADJUST MY SATURATION. MY TN PANEL LOOKS LIKE SHIT, AND IN NO FORUM THERE'S AN ACTUAL ANSWER.

>> No.61526921
File: 22 KB, 453x294, Linus_Torvalds_Facepalm.jpg [View same] [iqdb] [saucenao] [google] [report]
61526921

>mfw i have been spending my time to compile the kernel everytime it got updated in debian to enable AMDGPU support for SI/CIK cards and i just realized that it seems to be enabled by default now
when the fuck did they do this change, have i been compiling kernels for no reason for a long time or what, the only small change i did is there by default now

>> No.61526985
File: 57 KB, 450x450, 1.jpg [View same] [iqdb] [saucenao] [google] [report]
61526985

I'm about to install Ubuntu but how they want to go back with Gnome desktop I have doubts about whether I should install.

I have always used the main version and just tried mate and lxde flavors for an old laptop so I do not know if I should start to get used to the new desktop by installing the gnome flavor or stick on the main distro until 17.10.

What do you recommend me to do?

>> No.61526994
File: 73 KB, 1085x374, 1475932364321.png [View same] [iqdb] [saucenao] [google] [report]
61526994

>>61526763
yes

>> No.61527017

>>61526985
>What do you recommend me to do?
to make up your mind

>> No.61527100

>>61526661
It might one day. Some of those features only work in the very latest versions of bash (4.4) so they're still new and subject to improvement or design changes.
I think the guy who posted that gif has patches that make it work like that and has submitted them, so you never know if they'll be accepted in a future release.

At least some of them will almost definitely be accepted, because the current way it works the indicator is slow as fuck to change but that guy has it changing instantly. Also being able to set the color will probably be adopted too, and I see no reason being able to set "\m" in the PS1 to decide where it goes wouldn't also be accepted

>> No.61527127

>>61526763
Isn't that usually something you adjust on the physical screen itself, your monitors settings, rather than in software?

>> No.61527390

>>61527127
You can't when you're using a laptop unfortunately.

>> No.61527544

>>61526994
aesthetic

>> No.61527565
File: 93 KB, 740x448, 1498596812443.jpg [View same] [iqdb] [saucenao] [google] [report]
61527565

Is thee any reason to login as root at all?

>> No.61527647

>>61527565
Yes, to do system administration.
That's entirely confined to CLI (and done through su) so if you were asking about graphical login then no, there's no reason to login as root into an X session.

>> No.61527931

What's the most stable KDE based distro? Is KDE Neon lts stable enough?

>> No.61528040

>>61527647
>using su
Every heared of "sudo"?

>> No.61528088

>>61527647
>Yes, to do system administration.
my question was if there is any reason to login as root

>> No.61528120

Hello /fglt/, what is the best distribution?

>> No.61528157

What exactly does Qt do (i.e. qt4 & qt5) and do I need it if I plan on only using a windows manager like i3 or bsp but no DE?

>> No.61528199
File: 20 KB, 360x480, IMG_20170129_140016_01.jpg [View same] [iqdb] [saucenao] [google] [report]
61528199

>>61524806
pssst....x86-input-synaptics.

>> No.61528296

>>61528040
Yes, and it's a fucking meme in 90% of cases.
sudo was introduced to run *certain commands* with root privileges, not to use it for everything as that is very insecure.
The idea is that if a user needs to run a few commands as root, you can configure sudo to only allow those commands. If you use a wildcard for all commands, then a potential attacker only needs to know your account password and he has access to the whole system.
With su, even if your password is stolen the attacker still needs the root password as well.
You can thank the retards at Ubuntu for this abuse of sudo and their constant disinformation about how "secure" it is.

>> No.61528342

>>61528296
The point of sudo is that you don't need the root password, therefore the root password doesn't have to be changed every time 1 guy leaves your company.

>> No.61528374

>>61526661
>>61527100
Actually you can make it do all of that stuff now except for changing the position the indicator show up at

>set keyseq-timeout 0
Gets rid of the annoying delay when switching modes

For colored prompt you can already do it in bash 4.4 but you have to surround the color codes with \1 and \2. For example:
>set vi-ins-mode-string "\1\e[1;34m(ins)\2"
>set vi-cmd-mode-string "\1\e[1;32m(cmd)\2"

You can also change the cursor itself to appear differently between the two modes, which I find extremely more intuitive:
>set vi-ins-mode-string "\1\e[1;34m\x1b[\x33 q\2(ins)"
>set vi-cmd-mode-string "\1\e[1;32m\x1b[\x32 q\2(cmd)"
This will make your cursor an underscore blinking line in input mode, and a solid block when you press escape

>> No.61528380

>>61528157
It's a gui framework, and it's not really related to your WM/DE unless they use QT themselves.
You need it if you use any software that needs it.

>> No.61528400

>>61528342
Also you can give different users different levels of elevated access, that would normally be all-or-nothing with su only.

sudo is only pointless next to su when thinking about single-user systems, which is pretty typical of your standard migrosert prisoner.

>> No.61528403

>>61524148
what an ugly wallpaper

>> No.61528406

>>61528040
You can't sudo cd into directories only root can enter.

>> No.61528493

>>61528406
why would you want to do this

>> No.61528534

>>61522937
Icecat

>> No.61528535

>>61528493
Why would you want to enter any directory? To do things inside it?

>> No.61528571

Whats a good cli music tagger?

>> No.61528575

>>61528406
Unless you think your working directory changing because your sudo session timed out is intuitive behaviour, that's just asking for trouble.

>> No.61528581

>>61528342
And changing passwords is a huge problem because Unix is known for absolutely no support for scripts or other kinds of automation, right?
That's completely ignoring that if you follow best security practices, there's absolutely no way he could ever get to the point of actually being able to utilize the root password.

>>61528400
Different levels of access is exactly the idea.
The problem is when you use sudo for everything and that happens on multi-user systems as well.

>> No.61528676

>>61528581
>changing passwords is a huge problem
That problem is on the user side, not the technical one.
>best security practices
Those certainly would tell you that using a password that got leaked to an outsider is not acceptable.

>> No.61528752

>>61528581
>Unix
You mean that proprietary OS from the 70s?

>> No.61528790

>>61522609
Debian for me (on my laptop)

>> No.61528821

>>61526921
There was a big bump in amd gfx around 4.6 i wanna say also 4.10
It helps if you read the changelog friendo

>> No.61528961
File: 2 KB, 33x35, banana.gif [View same] [iqdb] [saucenao] [google] [report]
61528961

What is the best Arch installer?

>> No.61528972

>>61528961
Reading the wiki and pasting 10 commands.

>> No.61529018
File: 40 KB, 550x366, 1494564818984.jpg [View same] [iqdb] [saucenao] [google] [report]
61529018

>>61528961
Back when this gif was a meme, the internet was a nice place.

>> No.61529042

>>61528961
>>61528972
This

>> No.61529070
File: 345 KB, 830x830, baka.jpg [View same] [iqdb] [saucenao] [google] [report]
61529070

I finally run 100% gnu+linux and it feels great.

>> No.61529132

>>61528961
https://github.com/is73/archlinux-quickinstall/blob/master/archlinux-quick-install.txt
Go here and download the zip. Good luck,Sir.

>> No.61529215

>>61529018
>nostalgia for the good old days
>posts a cancerous frog maymay

>> No.61529240

>>61529070
Welcome ~.

>> No.61529259
File: 2.19 MB, 500x500, 1451780930626.gif [View same] [iqdb] [saucenao] [google] [report]
61529259

>>61529070
Now become gnu free

>> No.61529268
File: 351 KB, 545x409, 1490485336487.gif [View same] [iqdb] [saucenao] [google] [report]
61529268

>>61529215
Welcome to the future.

>> No.61529299
File: 51 KB, 355x400, 1486479598123.jpg [View same] [iqdb] [saucenao] [google] [report]
61529299

>>61529259
Do I look like a cuck?

>> No.61529311

>>61529299
You're more of a cuck using gnu

>> No.61529314

>>61529268
those white edges make me feel uncomfortable
why can't people do shit correctly

>> No.61529321

>>61529070
congrats comrade

>> No.61529353

>>61528676
Indeed, but it's not as bad as someone actually getting to the point of using it because that means a huge architectural fuck up.

>>61528752
As in the whole OS family. I thought this was obvious from the context.

>> No.61529388
File: 55 KB, 557x605, 1480957862777.png [View same] [iqdb] [saucenao] [google] [report]
61529388

>>61529070
Nice.
>>61529259
What the hell kid.

>> No.61529424 [DELETED] 
File: 2.11 MB, 240x256, igotthewrongbottledwater.gif [View same] [iqdb] [saucenao] [google] [report]
61529424

>>61529388
I dont support software that was created by pedophile,bird masterbator and dirty foot skin eater.I dont support his autist(4 commandmants)
He is a lazy slob that wants everything to be given to him.

>> No.61529464
File: 43 KB, 480x320, 1493115900303.jpg [View same] [iqdb] [saucenao] [google] [report]
61529464

>>61529424
here's your (you)

>> No.61529502

>>61529464
Sad to see that you cant see what he really is.
He hasent contributed to the tech industry since '76.Yet he feels entitled to everyone else's work

>> No.61529559

>>61529502
Even on the i5 2500K's minimums are better than the other; it's just gigantic and not well thought out. I will be able to completely load down the product stack the WORSE it gets. The 1400 overclocks much worse than any other good online CS courses aside from CS50? Is there anyway to get something simple but something that can run a game optimized for PC.

>> No.61529591

Where is the startup log for openrc on Gentoo?

I'm reading the wiki entry, but I can't seem to find it.

>> No.61529616

>>61529591
dmesg

>> No.61529707

>>61529616
thanks, anon

>> No.61529716

>>61529707
You're welcome.

>> No.61529790

I was thinking of settling with Solus for a while. I'm going to need Linux for an upcoming job and Solus just looks nice. If I can open a terminal and use bash, I'm good to go. But is there any part of it that you would say is a downside?

>> No.61529828

>>61529790
isn't solus that "kevin net" backdoor distro made by a 4channer?

>> No.61529871

>>61528296
>a fucking meme
sudo is audited, commands are logged and who ran them. It is not just a replacement for su that uses a different password, it also works with pam.

>> No.61529889

>>61529828
>believing /g/

>> No.61529896

>>61528406
cd is a shell built-in, of course a separate binary can't run it.

>> No.61529922

>>61528571
eyeD3, what kind of interface are you looking for, one for batch jobs, single files?

>> No.61529933

>>61529424
Hello overzealous mod!!!
Here are some FACTS about richard stallman,since you seem to think FACTS are "Garbage outside of /b/".
Here is his admission of being a pedophile
https://stallman.org/archives/2003-may-aug.html
Here he admits he is in to bestiality
https://stallman.org/articles/extreme.html
And here is a picture taken of him in the act
https://stallman.org/parrot-love.jpg
Here is a video of him eating foot skin from his dirty feet at a conference
https://www.youtube.com/watch?v=I25UeVXrEHQ (1:55)

I know you might be suffering from cognitive dissonance right now,but in the future how about you kindly fuck off :)
Do your job better

>> No.61529985
File: 96 KB, 480x400, 1470595609730.jpg [View same] [iqdb] [saucenao] [google] [report]
61529985

@61529933

>> No.61529996

>>61529933
I was recently banned for posting a picture of an old man in a chair, with his dog at his feet. I'll never figure that one out.

>> No.61530006
File: 35 KB, 576x566, 1452211201957.jpg [View same] [iqdb] [saucenao] [google] [report]
61530006

>>61529985
>cares enough to tell you he dosent care

>> No.61530243
File: 50 KB, 974x724, picture.png [View same] [iqdb] [saucenao] [google] [report]
61530243

hi, I use GNOME 3 because I can't bother enough to do actual ricing and pretty stuff. But I was wondering if you guys have some sources of themes, except the official website (which is awful to browse).

current settings in the pic

>> No.61530258

>>61530243
also, any font recommendations? I'm currently using some variations of Roboto.

>> No.61530402

>>61526921
Subscribe to the appropriate debian mailing list to stay on the up-and-up

>> No.61530432

>use Windows 10 for 6 months
>No issues, crashes or lag
>Decide to switch to Kubuntu since I'll be using a lot more RHEL systems at work and want to be more familiar with Linux
>Nonstop lag and crash reports and graphical glitches on taskbar

Will trying out Xubuntu help since the system requirements are lower? I'm on an old business PC with a 2400-S bc I only ever just program and surf the web.

>> No.61530471

>>61528088
If your non-root user was not added to sudoers and you forgot his password (password in login manager may not always be password when logged in), logging in as root would be the first way I would attempt to change the above.

>> No.61530546

>>61530432
Absolutely fuckin 100% without a doubt. If you want ultimate stability and red hat bases system then install Centos 7 add the epel and yum groupinstall "MATE Desktop". You will not regret it. But if you can do without red hat based go with ubuntu mate 16.04. These are the most stable linux desktop setups you can possibly get. KDE is know for being a buggy mess.

>> No.61530631

>>61523717
gparted is indispensable, useful on a live-usb

>> No.61530675

How I configure mpv to switch to a default audio and subtitle channel? Wanna watch a dual audio anime by with in Japanese by default.

>> No.61530697

>>61530675
Check out the subtitle commands in the web manual

>> No.61530901

>>61530675
# Cycle through the available audio tracks.
j Cycle through the available subtitles.
--alang=jp,en
--slang=jp,en
Those last two can go in ~/mpv/config with the -- removed also.

>> No.61531373

Can someone explain to me what rxvt-unicode's blinking text feature does?

>> No.61531443

using opensuse tumbleweed. anytime I try to run a zypper update I get a message saying that PackageKit is blocking zypper. any idea of why this is happening?

>> No.61531566

>>61531373
I'm not seeing it desu.

>> No.61531687

Can anyone explain why like half the gnome extensions just don't work? It's a nice DE but christ it feels so hacked together

>> No.61531895

>>61522200

How come when I try to pirate Bitwig on my friend's computer it says he is on the wrong architecture?

A) bitwig is Java so it shouldn't matter
B) I'm running the same OS and using the same torrent and I was able to do it

>> No.61531955

filezilla doesn't want to launch filezilla: /usr/lib/gcc/x86_64-pc-linux-gnu/5.4.0/libstdc++.so.6: version `GLIBCXX_3.4.22' not found (required by /usr/lib64/libfilezilla.so.0)

and ncmpcpp is giving an "illegal hardware instruction". How do I fix this shit?

>> No.61532058

>>61531566
Gentoo allows for package specific use flags to be set, dictating how an individual package behaves. On the rxvt-unicode article (https://wiki.gentoo.org/wiki/Rxvt-unicode) one of the supported use flags is 'blink' which enables the blinking text feature. Not sure what it does though.

>> No.61532166

>>61531687
I don't know what you mean since I haven't used gnome in like 8yrs. But it's worth mentioning that the whole GNU/Linux ecosystem has been undergoing some major changes over the last few years with the whole systemd migration, getting things ready to ditch X for Wayland, and the release of a whole new graphics API (vulkan).

I wouldn't be surprised if all the major DE's had some things just not working right

>> No.61532360

Any idea why the fuck it's basically 50/50 now whether my laptop will even recover from suspend after I upgraded Fedora from 25 to 26?

>> No.61532380

>>61532360
Gnome 3 btw

>> No.61532488

Con someone tell what is the error here:
● rtorrent.service - rTorrent Loaded: loaded (/etc/systemd/system/rtorrent.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Sun 2017-07-23 22:23:02 IST; 36min ago Process: 630 ExecStop=/usr/bin/killall -w -s 2 /usr/bin/rtorrent (code=exited, status=1/FAILURE)
Process: 619 ExecStart=/usr/bin/screen -d -m -fa -S rtorrent /usr/bin/rtorrent (code=exited, status=0/SUCCESS) Process: 550 ExecStartPre=/bin/bash -c if test -e /home/pizero/torrent/.session/rtorrent.lock && test -z `pidof rtorrent`; then rm -f /home/pizero/torrent/.session/rtorrent.lock; fi (code=exited, status=0/SUCCESS)
Main PID: 622 (code=exited, status=0/SUCCESS)
Jul 23 22:23:00 orangepizero systemd[1]: Starting rTorrent...
Jul 23 22:23:02 orangepizero systemd[1]: Started rTorrent.
Jul 23 22:23:02 orangepizero systemd[1]: rtorrent.service: Control process exited, code=exited status=1
Jul 23 22:23:02 orangepizero systemd[1]: rtorrent.service: Unit entered failed state.
Jul 23 22:23:02 orangepizero systemd[1]: rtorrent.service: Failed with result 'exit-code'.

>> No.61532709

>>61530546

Thanks man. I got Xubuntu set up and Im enjoying it so far. I haven't used it since v12 or 13 but nothing seems to have really changed other than Numix theme being preinstalled.

>> No.61532849

>>61522200
What's the smallest Thinkpad I can get that doesn't have touch screen, bendy bullshit?

>> No.61534522

How do I deal with folders that have a & symbol in them? I'm trying to run a command on a folder that has & in the middle, but I'm not sure how I can get Linux to recognize it as a single folder

>> No.61534548

>>61534522
Escape it?

>> No.61534564

>>61534522
Escape sequences are pretty basic knowledge when it comes to computers and programming.
Most of the time the escape sequence is a simple backslash followed by the character, so:
>\&
You can also just wrap the whole filename in quotes and not use escapes

But also you should really learn how to use tab-completion too. If you're typing out a path or directory name on the command line you can press tab to auto-fill in the names to save time. If they contain special characters it automatically adds the escape sequences for you.

>> No.61534566

>>61534548
Ah right, thanks for that. Worked perfectly.

>> No.61534578

>>61534564
Yeah I'm aware of tab-completion, I use it constantly it's just that it was hitting a snag with the &. Escaping it worked perfectly.

>> No.61535222

>>61522609
Me, after about a year of using Xubuntu. Switching distros wouldn't make a huge difference I feel. I use CLI / TUI programs 90% of the time (the rest is web browsing and editing images and music) and I don't fuck around with packages often enough to warrant going for gentoo or something like that. If there's outdated software in the repos, I compile from source.

>> No.61535239

>>61530243

gnome look
deviantart

>> No.61535245

Any good free programs for creating music?

>> No.61535247

>>61532488

journalctl -u rtorrent

>> No.61535262

>>61523732
xxd oldfile | xxd -r > newfile

>> No.61535282

Slackware:Free of (((Systemd))), stable.

Tell me why you aren't using it

>> No.61535430

I have an inkling lightdm and its fancy graphical display manager stuff is giving me some issues. How would I go about getting the most minimal login screen possible? If possible, I'd like the same login screen as the ttys, except booting directly into the GUI. Just to load the smallest amount of stuff possible.

On xubuntu 17.04.

>> No.61535470

>>61535430
Install gentoo and avoid 8 moth support release distros

>> No.61535521

>>61535430

You're an idiot. Here's why.
1. you just assume LightDM is responsible for your problem (that you didn't even mention). You didn't verify it simply by using a different display manager or trying to start an X session in a different way.
2. you didn't bother typing that simple thing into a search engine and finding millions of results how to autostart X upon logging into a tty.

>> No.61535636

Is it rude to wget -r an open directory? Specifically archives.textfiles.com

I started and it's a lot bigger than I thought, 250mb after 13 files.

>> No.61535693

>>61535636
wget respects robots.txt by default and textfiles handle a lot of traffic so they probably wont care. There are mirrors if you want to spread the load.

>> No.61535856

>>61535636
Stuff is on the web so people can download it.

>> No.61535876

>>61535521
Gimme a break, I've been using linux for like a month. I don't know how to do most of this shit.

But thank you, I solved it with your help.


Just to log the problem and solution somewhere i'll expound on it here. I was having an apparently fairly common problem where, with nvidia drivers installed and enabled, resuming from suspend would freeze everything. More people with the problem: https://devtalk.nvidia.com/default/topic/962231/linux/resume-from-suspend-freezes-system-gtx-970-arch-linux-kernel-4-4-4-7-nvidia-370-/4

So on an intuition I figured it had something to do with display managers and disabled lightdm. Just by logging into the tty and manually doing startx the problem seems to be gone. I'd post it on that thread, but I can't be fucked registering.
Cheers.

>> No.61535913

>>61535636
This reminds me of a neat trick; textfiles has some old vt animations, but since modern terminals are too fast looks like trash, but you can slow it down with pv!
Example:
curl -sS artscene.textfiles.com/vt100/dirty.vt | pv -qL 960

>> No.61535940

>>61535913
http://artscene.textfiles.com/viewers/linux/slowcat.pl

>> No.61536244

>>61523656
>/etc/inputrc
It doesn't have enable-bracketed-paste mode in it on debian testing.

>> No.61536368
File: 21 KB, 1179x287, 2017-07-24-121832_1179x287_scrot.png [View same] [iqdb] [saucenao] [google] [report]
61536368

What if I have 4 two threaded cores?
Should I use
make -j9

?

>> No.61536453

>>61536368
https://blogs.gentoo.org/ago/2013/01/14/makeopts-jcore-1-is-not-the-best-optimization/

>> No.61536456

I sometimes can't copy-paste really large text. Any idea how to troubleshoot this problem?

>> No.61536487

>>61536453
thanks

>> No.61536754

>>61522841
>>61522801
can you even

>> No.61536756

>>61536456
You should be able to change the font size in the control panel.

>> No.61537484

I don't use youtube often but I'm shocked at how much of my CPU it is using. Watching one 1080p youtube video, with a secondary tab open in chromium and discord+spotify+htop in the background ontop of gnome is consuming damn near 40% of my [email protected]
Is youtube really that fucking demanding?
I thought my GPU(maxwell) had shit inside of it to accelerate the common codecs for video?
Just seems insane that it would take 40% of a highly overclocked modern quad core for a video

>> No.61537523

Senpai, how do I automate program startup and placement after login? Is there a better way than the i3 function because it seems to be really slow?

>> No.61537562

>>61537523
Have a script run on login with the programs you want to start and xdotool commands to put them where you want, maybe.

>> No.61537572

>>61537562
And put the script into xinitrc then?

>> No.61537628

>>61537572

How do you expect it to work when your window manager isn't started yet?

>average "i installed a tiling window manager because i think it's hacker and i think tiling window managers are special and i think i3 is an exclusive tiling window manager" user

>> No.61537712

>>61537628
>'Every ganoo / loonix user is ricing 24/7 and switches WMs every day lel!'
>'Why would anyone want to keep their system running and actually use it instead of constantly fiddling with it + memorizing unnecessary shit?'
Don't assume so much. Thanks for the initial answer

>> No.61537935
File: 2.91 MB, 3839x1079, b13614eccb1b92e1dafdb97fab6e77ec.png [View same] [iqdb] [saucenao] [google] [report]
61537935

>>61537712
It is pretty tempting to change WM/DE often because I always think something else might be better even though I've tried it a million times. Right now I'm on gnome and it's really very good for desktop. I think i3 is where it's at on most laptops though because it's easier to arrange windows with keybinds than using a shitty trackpad. Maybe on a mac I would use gnome because of how good the trackpads are but idk how much of that is macOS software fuckery vs just hardware

>> No.61538013

I'm getting the No command specified for SYSLINUX while installing antergos, any help?

>> No.61538139
File: 331 KB, 1327x773, gentoo install.png [View same] [iqdb] [saucenao] [google] [report]
61538139

It takes me 5 days..
I think I'm gonna cry..

>> No.61538222

>>61538139
5 days on a 6700hq? How? I've installed it over night on a pentium 4 at 2.4ghz

>> No.61538241

>>61538222

it's my first time. I've never try to install gentoo..

>> No.61539736
File: 2.71 MB, 1474x1600, 1470009532146.jpg [View same] [iqdb] [saucenao] [google] [report]
61539736

Back to page 1 with you.

>> No.61539740

How do i know if Vsync is enabled in UbuntuMATE ? Can i disable it permanently ? Also can i change the poll rate of my mouse from 125 Hz to 250 Hz or so ?

>> No.61539819

I have a new Debian install and when I boot it up and get to what should be the login screen it just shows my mouse cursor alternating between off and on every 5 seconds or so. I'm able to boot it into recovery mode and get the command line, fwiw

>> No.61539905
File: 24 KB, 393x317, pure.jpg [View same] [iqdb] [saucenao] [google] [report]
61539905

This bug is driving me mad. I'm running xubuntu on my laptop and every time I close and open the lid I get a black screen when I unlock the computer. I've tried like 4 different solutions and none of them work.

>> No.61540044

>>61539905

Disable actions upon lid close or solve your suspend issues.

>> No.61540513

>>61537484
vp9 isn't accelerated

>> No.61540557

Using this awk -F"[][]" '/dB/ { print $2 }' <(amixer sget Master) for volume. How to get rid of the printed % though?

>> No.61540630

>>61540557
I'm shit at awk so I'd suggest piping it into tr -d %

>> No.61540657

I asked this in a different thread, but I came to the conclusion that this is a better place for it. I jumped ship from systemd. I'm only missing one feature from it in OpenRC. systemctl status <service> displays the service's stdout nicely with timestamps and all, how can I replicate this with rc-service?

>> No.61540801

>>61540557
hacked
amixer get Master | awk -F'[][]' '/dB/ { print +$2 }'

>> No.61540836

>>61540557
nice
amixer get Master | awk -F'[][]' '/dB/ { printf "Removed the %% for you: %d.\n", $2 }'

>> No.61540866

>>61540557
actually getting rid of it
amixer get Master | awk -F'[][]' '/dB/ { sub(/%/, ""); print $2 }'

>> No.61540878

>>61537484
try using a different/more lightweight browser. maybe it's just that chromium is shit for handling videos. otherwise just reduce resolution and window resolution

>> No.61540888 [DELETED] 

>>61540557
bloat
amixer get Master | awk -F'[][]' '/dB/ { print $2 }' | tr -d '%'

>> No.61540942

What is currently the best distro for daily normie use?

>> No.61540964

>>61540942
The holy Debian.

>> No.61540985

>>61540942
install gentoo

>> No.61541043

why are you still using systemd?
https://www.theregister.co.uk/2017/07/24/underscore_domain_name_bug/

>> No.61541232

>>61541043

I use systemd, but not systemd-resolvd.

>> No.61541239
File: 754 KB, 436x432, 1436249212591.png [View same] [iqdb] [saucenao] [google] [report]
61541239

>>61540630
>>61540801
>>61540836
>>61540866
>>61540888
Thanks so sweet of you

>> No.61541905

>>61540942
Ubuntu is what you want.

>> No.61542072

I REALLY want to stop OpenGL games from stretching when i use a lower resolution.
Oddly, when i pick a lower resolution, the game goes to that resolution but the screen doesnt. How do i make it behave like in windows ?

>> No.61542183

Can anyone tell me how I can force Apache to run as root?

I'm trying to practice command injection via the DVWA, but every google search has resulted in the reverse query being answered

I obviously know its a retarded idea, but as I say, for testing purposes

>> No.61542323

How can I append text to the top of a file? (like >> but on the top instead of bottom)

>> No.61542397

>>61542323
https://superuser.com/questions/246837/how-do-i-add-text-to-the-beginning-of-a-file-in-bash

>> No.61542420

>>61542397
Looks like my search skills suck. Thank you.

>> No.61542467

Does anyone know of a terminal shmup game?

>> No.61542515

>>61540942
install openSUSE

>> No.61542580

>>61542183
>Apache
Please?

Changing the envvars file to root instead of www-data causes Apache not to run (presumably because on Raspberry Pi you can't specify a password for the root user)

>> No.61542724

>>61522200
sudo apt-get purge shit
cd ~/.config
if [ -d "shit" ]; then echo "Why is Linux so shit?" fi

>> No.61542873

>>61542724
>user does stupid things
>blames computer
10/10

>> No.61542913
File: 2.47 MB, 3072x2048, 1490827404459.jpg [View same] [iqdb] [saucenao] [google] [report]
61542913

>>61542724
I'd just like to interject for a moment. What you're referring to as Linux, is in fact, GNU/Linux, or as I've recently taken to calling it, GNU plus Linux. Linux is not an operating system unto itself, but rather another free component of a fully functioning GNU system made useful by the GNU corelibs, shell utilities and vital system components comprising a full OS as defined by POSIX.

Many computer users run a modified version of the GNU system every day, without realizing it. Through a peculiar turn of events, the version of GNU which is widely used today is often called "Linux", and many of its users are not aware that it is basically the GNU system, developed by the GNU Project.

There really is a Linux, and these people are using it, but it is just a part of the system they use. Linux is the kernel: the program in the system that allocates the machine's resources to the other programs that you run. The kernel is an essential part of an operating system, but useless by itself; it can only function in the context of a complete operating system. Linux is normally used in combination with the GNU operating system: the whole system is basically GNU with Linux added, or GNU/Linux. All the so-called "Linux" distributions are really distributions of GNU/Linux.

>> No.61542950

>>61542724
why do you expect apt to delete your personal files?

>> No.61543000

Why? www-data is part of the root group?

[email protected]:/etc/apache2# sudo -u www-data ping 192.168.1.1
ping: icmp open socket: Operation not permitted
[email protected]:/etc/apache2#

>> No.61543051

Man it's nice to switch from raspbian's prehistoric packages to fedora 26 server.

>> No.61543201

>>61543051
*tips red hat*

>> No.61543370

>>61543201
Thanks, I nearly forgot to. Come join us anon, our OS allows us to just werk.

>> No.61543393

>>61543051
literally nobody is using fedora

>> No.61543409

>>61538139
>6700HQ
>1280x768
>4 gig ram
what

>> No.61543410

The name "w3m" stands for "WWW wo miru (WWWを見る)", which is Japanese for "to see the WWW" where W3 is a numeronym of WWW.

>> No.61543449
File: 35 KB, 658x413, Screenshot from 2017-07-24 13-02-18.png [View same] [iqdb] [saucenao] [google] [report]
61543449

>>61542420
you could use echo -n if you don't want a newline.

>> No.61543518
File: 352 KB, 1024x768, 2-boot-ubuntu-live-media-100262999-orig.png [View same] [iqdb] [saucenao] [google] [report]
61543518

In a disaster situation (i.e. main machine dies) I'll be using a live distro from a flash drive to recover data from backups, for which I need a few packages.

Is it possible to add those packages to a live distro so that I won't have to download them whenever I boot it?

>> No.61543522

"When a glob is used to match filenames, the * and ? characters cannot match a slash (/) character. So, for instance, the glob */bin might match foo/bin but it cannot match /usr/local/bin. When globs match patterns, the / restriction is removed. "

Can someone spoonfeed me and explain this, I dont really get it, whats the difference between matching a glob and matching a filename in terms of what you actually type? */bin doesnt look like a filename to me..

>> No.61543608

>>61543522
It means it can't jump lower or higher in a directory tree.

Example:
/home/anon/*.mp4
will match
/home/anon/video.mp4
but won't match
/home/anon/.cache/kdenlive/cached_vid.mp4

To match that, you have to do something like:
/home/anon/*/*/*.mp4

Note: Some variations of matching allow you to use ** to match anything including /

>> No.61543623

>>61543518
install arch on flash drive

>> No.61543721

>>61543623
Hmm. That could work.

I'm not sure I can depend on Arch as my disaster-recovery OS (even though I run arch on all my computers), but I could just install Ubuntu on a flash drive and it'll be just as good (except I'll lose the convenience of never having to reinstall due to rolling release).

Thanks.

>> No.61543736

>>61543608
Thank you anon.

>> No.61543741

>>61543623
>arch
>as rescure os
lmao, he maight need ubuntu to rescure arch instead

>> No.61543981

>>61543000
Help

>> No.61544067

>>61522200
Anyone using Ardour could tell me if in the most recent version you can still choose colors for the boxes of the sound clips in the editor view?
I've seen a bunch of screenshots looking like that, but I don't know if they're old or what, because I can't find where I can select that option in version 5.
Checked the manual, and it mentions options that are no more there. Did they change where you select this option, or got rid of it altogether?

>> No.61544251
File: 118 KB, 404x404, desudesu.png [View same] [iqdb] [saucenao] [google] [report]
61544251

Is a bad idea encode media on a luks partition?

>> No.61544269

>>61544251
Please try again in English

>> No.61544271

>>61544067
I mean choosing different colors according to track, not just select the generic color.
Worded that like a bitch

>> No.61544344

>>61544269
stupid entitled monolingual cunt, people spend at least 4 years of their life learning english and then go off to learn even more english and visit english websites for years, use google translate, look up their doubts on english, and you stupid fuck that couldnt even learn a second language complain about a phrase like that ? you stupid fuck wouldnt learn a second language even if you got paid for it. would take you 1 year to memorize "hello" and "goodbye" plus a few numbers you dumbfuck monolingual retard.

>> No.61544457

>>61544344
Did you just assumed my language?

>> No.61544500

>>61544269
newfag

>> No.61544618

why is busybox gpl'd?

>> No.61544634

>>61544251
No. What exactly are you afraid of?

It's just writing the same 1s and 0s to the disk, but it's encrypting them at 3GB/s (if you're using AES encryption underneath, which should be default, and if your CPU supports AES-NI, most 2010+ ones do) so there's almost no difference compared to writing to a regular partition.

>> No.61544644

The web is so bloated that avoiding X11 in some form is impossible.

>> No.61544735

>>61544618
To protect your freedoms.

>> No.61544747

>>61540657
grep syslog

>> No.61544814

The CIA is trying to take over my computer you guys, what should I do?

>> No.61544865

>>61544634
I'm worried that encode time will increase a lot

I'm on i7 3gen so there will not be any drastic performace drop?

>> No.61544895

What reason is there for me to "PRISM Break" today?

I've entertained the idea of moving permanently to Linux and changing my compute habits for years. They already have everything though, they have my google history, all my worst porn searches, over a decade of completely not giving a fuck what I put on the net or my compromised PC.

I'm not being a smartass I just feel so deep in the shit it almost doesn't feel worth the energy to get out.

I've been ruthless on my computers over the years, I've searched anything that interests me without the slightest fuck given to legality or ethics because I figured if I have no interest in actually doing anything with the knowledge there was no harm in me learning about it, for instance learning how to make certain drugs, weapons, or whatever.

>> No.61545047

>>61544895
The bad side effect of giving in is that it also means approving; it says that the current state of spying on everyone is acceptable.

When I block web-bugs or use a different search engine, I do it because I don't support that trash.

>> No.61545065

>>61545047
>irony
You're using google botnet captcha to post this message.
You're also creating a profile for gook to sell to his top seller with your posts

>> No.61545082

>>61545065
>>>/r/eddit

>> No.61545115

>>61545065
Are you sure that I really do?

>> No.61545148
File: 1.02 MB, 1402x3892, gookspy.jpg [View same] [iqdb] [saucenao] [google] [report]
61545148

>>61545082
Mad facts are being dropped?

>>61545115
Well you arent a passfag, so yes, yes you do

>> No.61545172

>>61545148
why are you posting on 4chan?

>> No.61545176

>>61544895
>I know the arguments, convince me anyway
>anon tries to offer argument
>Hurr durr irony
Fuck off shitposter. That ain't an argument, learn to compartmentalize. Don't let the perfect be the enemy of the good, you filthy absolutist. If everyone thought like you no-one would ever try to improve.

>> No.61545202

>>61545172
Why are you posting on 4chan?

>> No.61545227

>>61539819
Update to this: when I boot it normally I still get a blank screen with a mouse cursor but I can bring up a terminal but the keyboard only works for second every 20th second. It seems like it's switching between mouse and keyboard input but I can't get it to actually do anything.

>> No.61545355

>>61545227
See if you can switch to another tty (ctrl+alt+f2f) and check syslog and xorg log, If you have another computer you can try SSHing in from there and doing the same.

>> No.61545399

My aunt is computer inept, what distrib for her?

>> No.61545432

>>61545399
windows xp

>> No.61545514

>>61545432
In her words "i want oupennesourse OS"

>> No.61545653

Does anyone have or have taken the exam to LPI Linux Essentials?

Is it hard?

What is something you should absolutely know like the back of your hand for that test?

Are LPI tests like "It's not hard, but we throw shit in there you weren't expecting to know so you would fail" Microsoft style or how would you describe their tests?

>> No.61545817

>>61545355
I'm currently trying this but I can only type one letter every 10 seconds or so. I did install it to a netbook, so I wonder if it's working normally but my hardware is so slow that it seems like a bug.

>> No.61545860

>>61545817
Additionally: I can still use the recovery boot option (boots to root terminal) normally.

>> No.61545973

>>61545860
Fuck it. Does anyone know a really light-weight distro that would run relatively well on a netbook? I had debian 7 on it a few years ago but stopped using it. All I really want is to be able to compile C++17 without screwing around with my main desktop, which won't update GCC past 5.9.2.

Additionally, I have the books The Linux Bible and How Linux Works and neither really gets down to how Linux works (heh) at a fundamental level. Is there a good resource that explains what it's doing from the time I boot it until the CLI starts running? I'm getting tired of having to look up every error message I get instead of being able to diagnose problems myself.

>> No.61545982

>>61545973
Arch

>> No.61546183

>>61545982
meme

>> No.61546188

For ranger, I'm trying to set gnash to run swf files, but what is a swf file? Doing it like this won't work.

mime ^image/swf, has gnash, X, flag f = gnash -- "[email protected]"

I know it's a flash object, but what should I put there?

>> No.61546194

>>61546183
"Arch is a meme" is a meme. Arch in of its self, is not.

>> No.61546199

>>61545982
Hmm, that's probably what I'll do. Thanks anon.

>> No.61546220

>>61546188
Nevermind, this worked:

ext swf, has gnash, X, flag f = gnash -- "[email protected]"

>> No.61546600
File: 240 KB, 1677x1012, Screenshot_20170724_185526.png [View same] [iqdb] [saucenao] [google] [report]
61546600

So, I installed openSUSE Tumbleweed, but font rendering blows. I feel like I'm on fucking Arch again. Is there a way to fix this, or should I go back to Neon?

>> No.61546611

What is the best window manager and why?

>> No.61546633

>>61546611
Fluxbox
No retarded,recompile to make 1 character change
No having to learn a scripting language to make basic configuration changes

>> No.61546713
File: 164 KB, 1280x738, 1481231973843.jpg [View same] [iqdb] [saucenao] [google] [report]
61546713

My power went out today some time in the middle of running pacman -Syu. My system boots fine, but some things are acting a bit odd (pacman can't access the internet, the ping command does literally nothing, X locks up after 5 minutes, etc.) What's the most efficient way I can repair the system using a live USB?

>> No.61547256

>>61546713
Read your pacman.log and see what was updated and when it was interuppted.Reinstall those packages.
Although you're just naming generic problems that wouldnt happen after a -Syu..........

>> No.61547272
File: 54 KB, 639x648, 1500478506906.jpg [View same] [iqdb] [saucenao] [google] [report]
61547272

How do I remap Super_L + Left to home using XKB

>> No.61547316

>>61547272
This is a blue board you idiot.

>> No.61547319

>>61547272
You read how to make it and then you write it in your config and then you enjoy using it

>> No.61547339

>>61547316
There is nothing nsfw about that image

>>61547319
Please just tell a brainlet how I spent 20 minutes on https://wiki.archlinux.org/index.php/X_KeyBoard_extension and I'm still confused

>> No.61547361

>>61547339
https://wiki.archlinux.org/index.php/X_KeyBoard_extension#Simple_key_assignment
Literally copy and paste and edit

>> No.61547478

aegisubs seems to crash on Fedora 26 (Gnome under Wayland), is it the program's fault or wayland's? usually there's not problem since xwayland exists

>> No.61547533

>>61547361
I'm still clueless. Whatever, I'll try looking at it again tomorrow

>> No.61547537

>>61547339
>There is nothing nsfw about that image
maybe you don't know what nsfw means.

>> No.61547559

>>61547537
Literally no thread on this site is sfw if we're going to use you're autistic definition. There's no nips or genitals shown, therefore it's 4chan sfw

>> No.61547597

>>61547533
I think I understand it a little more now actually. I thought I'd just be able to put one line like Super_L+Left=Home, but I think I have to globally define Super_L as a Level? modifier. That's more work than I thought it'd be. I'll do it tomorrow

>> No.61547605

>>61547597
just use xbindkeys

>> No.61547697

>>61547605
Thanks anon
I had to install xvkbd and map Super_L+Left to xvkbd -xsendevent -text '\[Home]' to get it to work, but that's a lot easier to get working. I'll still probably try to get XKB working tomorrow though because it's cleaner

>> No.61548029

>>61547697
$ sudo du -hs /lost+found/
11G /lost+found/

Does anyone else have issues with filesystem corruption on ext4? I also suspend the PC at night and it is running on an mdadm raid10.

>> No.61548116

>>61548108
>>61548108
>>61548108

>> No.61548192

>>61548029
>does anyone else
Nope.Not even once
>raid 10
baaaaahahahahahah

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action