[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology

View post   

[ Toggle deleted replies ]
File: 986 KB, 1024x671, 1492724019721.jpg [View same] [iqdb] [saucenao] [google] [report]
60910160 No.60910160 [Reply] [Original] [archived.moe] [rbt]

Previous thread: >>60897655

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Your friendly neighborhood search engine.

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):

/g/'s Wiki on GNU/Linux:

>What distro should I choose?

>What are some cool programs?

>What are some cool terminal commands?

>Where can I learn the command line?

>Where can I learn more about Free Software?

>How to break out of the botnet?

/t/'s GNU/Linux Games: >>>/t/769497
/t/'s GNU/Linux Videos: >>>/t/713097

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

>> No.60910177

reminder wayland is the future and all wm are now obsolete

>> No.60910189

Reminder that rampant shitposting like this is the reason why no one should take /g/ seriously without doing their own research

>> No.60910193

sorry you can't handle the truth

>> No.60910324

call me when it can handle input devices LOL

>> No.60910348

works fine

>> No.60910355

It's not wayland, it's your wm LOL

>> No.60910364

systemctl rupeed --deposit 10 --with-extra-(you) -p 60910177

>> No.60910387

This derailed quickly.

>> No.60910439

redhat's inhouse version probably has this feature lol

>> No.60910483

Reminder that wayland is a window system, not a window manager.

>> No.60910518

wayland is a protocol.

>> No.60910623
File: 78 KB, 661x811, 1496700486357.jpg [View same] [iqdb] [saucenao] [google] [report]

What are some cool terminal commands?

>> No.60910660

Why the hell do you ask this every thread?

>> No.60910666

you need to go back to rabbit, my son

>> No.60910703

howdoi is pretty cool, it searches stackoverflow (or a different api) and prints the first useful result

>$ howdoi extract tar.gz
>tar zxvf <yourfile>.tar.gz -C /usr/src/

>$ howdoi grep numbers
>echo "99%" |grep -o '[0-9]*'

>> No.60910747

Does feeebsd not support wifi? I want to give it a shot but heard it has some problems with wifi

>> No.60910764

depends, what wifi card you have?

>> No.60910781

freebsd has some compatibility layer that allows it to use linux driver modules. I've heard it's sometimes janky but otherwise works.

>> No.60910796


>> No.60910819

this is a blue board, no nudity or gore is permitted.

>> No.60910832

I don't know, the laptop is acer aspire e15

>> No.60910849

Whats the best way to check for internet connection within a shell script? I gues pinging google 24/7 isn't the best idea.

>> No.60910855

You probably shouldn't try FreeBSD if you don't know how to lookup which wifi card you have

>> No.60910870

How else would you check for internet connection?

>> No.60910877

I forgot to write i can look it up, but i actually meant even if i know my WiFi card where can i look for driver and stuff

>> No.60910891


>> No.60910907

why do you need to know 24/7 if you have a connection?

doesn't support my laptops' internal cards, but works fine with all the external USB ones i have.

>> No.60910920

I think i should think again before jumping to the BSD train

>> No.60910928

Has pinging google ever been a good idea? Last time I tried, a good half of their servers didn't answer to ping at all, so it was unreliable as fuck. I've been using gnu.org for years myself.

>> No.60910937
File: 7 KB, 228x221, download_1497520017596.jpg [View same] [iqdb] [saucenao] [google] [report]

So I just downloaded ElementaryOs. This is first Linux I am using. What are the things that I have to download first. What is the best browser? Can I install Microsoft Office, if not can I use some alternative and open microsoft office documents? I newfag to linux, go easy on me please.

>> No.60910956

you can live boot the BSDs. just make a boot drive, boot your PC with it and try things out.

libreoffice is similar to MS Office, and can save and read MS Office formats

>> No.60910965

you can use libreoffice.
just use firefox or chrome, whtvr you prefer.
also the online version of microsoft office is ok.

>> No.60911055

just don't reply, he's here everyday

>> No.60911188
File: 21 KB, 600x450, 1474718232445.jpg [View same] [iqdb] [saucenao] [google] [report]

I'd just like to interject for a moment. What you're referring to as Linux, is in fact, GNU/Linux, or as I've recently taken to calling it, GNU plus Linux. Linux is not an operating system unto itself, but rather another free component of a fully functioning GNU system made useful by the GNU corelibs, shell utilities and vital system components comprising a full OS as defined by POSIX.

Many computer users run a modified version of the GNU system every day, without realizing it. Through a peculiar turn of events, the version of GNU which is widely used today is often called "Linux", and many of its users are not aware that it is basically the GNU system, developed by the GNU Project.

There really is a Linux, and these people are using it, but it is just a part of the system they use. Linux is the kernel: the program in the system that allocates the machine's resources to the other programs that you run. The kernel is an essential part of an operating system, but useless by itself; it can only function in the context of a complete operating system. Linux is normally used in combination with the GNU operating system: the whole system is basically GNU with Linux added, or GNU/Linux. All the so-called "Linux" distributions are really distributions of GNU/Linux.

>> No.60911224

Install Firefox, Libreoffice and then Gentoo.

>> No.60911245

why does he like birbs so much

>> No.60911340

Whats a nice 1337 terminal torrent client?

>> No.60911377

Pair it with GNU screen for maximum usability.

screen -D -R -S rtorrentd rtorrent
It opens a screen session called rtorrentd, and if the session already exist it reconnects to the existing one.

>> No.60911388


>> No.60911405

emerge dick --keep-going

>> No.60911411

you exit the session by Ctrl-A followed by "d"

>> No.60911415

are you a clown irl too?

>> No.60911433

Just noticed some strange behaviour when scrolling with the mouse in vim (vimx actually). Sometimes it takes a second to render each line in the correct place so you may get a block of code popping in or jumping up a few lines into it's correct place. I haven't noticed this before and can only attribute it to upgrading to Fedora 25 recently. Nothing to do with Wayland as I use i3 and it doesn't seem to be present outside of vim. Anyone had this before?

>> No.60911507
File: 177 KB, 450x450, confused_looking_anime_girls_with_question_marks_on_their_head_050.jpg [View same] [iqdb] [saucenao] [google] [report]

What's a tiling manager and why should I take one over whatever window manager Ubuntu has (Nautilus?)? Or can you have both?

The copypasta collection in the OP (https://p.teknik.io/wJ9Zy) recommends pytyle3, but I've went through all the links and nowhere does it even say what it is.

I've also been told Nautilus sucks and want to replace it, but with what? One of the links in the OP (https://github.com/aleksandar-todorovic/awesome-linux#x-windows-managers) has a list of "X Windows Managers". Are those special windows managers or, hence the "X", or are those normal ones I can use?

>> No.60911542

Keep using whatever you're using now.

>> No.60911607


You how it really sucks to position your windows manually? A tiling VM automates it and lets you organize everything using keyboard shortcuts.
Personally i'd reccomend i3 (i3gaps if you want it to look pretty).

here's a neat 3 part video series that should get you started.

>> No.60911671

what's the answer to `howdoi shotweb`

>> No.60911699

$ howdoi shotweb
@media print {
html, body {
display: none; /* hide whole page */

>> No.60911723

howdoi install gentoo?

>> No.60911757

curl cheat.sh/tar

replace tar with whatever command you're intersted in.

>> No.60911772

man <program>

replace <program> with whatever command you're intersted in.

>> No.60911786


>> No.60911792

What's does the /g/ think about Chrome OS?

>> No.60911802


>> No.60911810

your >>>/r/eddit is showing

>> No.60911811

man is for reference, not for "how do I do this thing"
compare man qemu with https://wiki.archlinux.org/index.php/QEMU

the wiki goes straight to the point.

>> No.60911861
File: 19 KB, 300x278, shotweb.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.60911872

will systemd stay or disappear?

>> No.60911909

it will stay even after everyone leaves

>> No.60911993
File: 32 KB, 1280x413, RedHat.svg.png [View same] [iqdb] [saucenao] [google] [report]

It's there to stay. RedMumbai made sure it latches onto everything it has and won't let go.

>> No.60912063
File: 1.95 MB, 352x218, 1496478063687.gif [View same] [iqdb] [saucenao] [google] [report]

really gore on fglt? you should feel ashamed op!

>> No.60912191


>> No.60912210

I'm going to fix it even further. Just need to figure out what font they used.

>> No.60912523


>> No.60913052
File: 503 KB, 750x1066, 1475094570548.jpg [View same] [iqdb] [saucenao] [google] [report]

Is /fglt/ communism?

>> No.60913064


>> No.60913174

>Isn't it ironic that the proprietary software developers call us communists? We are the ones who have provided for a free market, where they allow only monopoly. If the users chooses this proprietary software package, he then falls into this monopoly for support. The only way to escape from monopoly is to escape from proprietary software, and that is what the free software movement is all about. We want you to escape and our work is to help you escape. We hope you will escape to the free world. The free world is the new continent in cyberspace that we have built so we can live here in freedom. It's impossible to live in freedom in the old world of cyberspace, where every program has its feudal lord that bullies and mistreats the users. So, to live in freedom we have to build a new continent. Because this is a virtual continent, it has room for everyone, and there are no immigration restrictions. And because there were never indigenous peoples in cyberspace, there is also no issue of taking away their land. So everyone is welcome in the free world, come to the free world, live with us in freedom. The free software movement aims for the liberation of cyberspace and everyone in it.

>> No.60913189

Are there any text VIEWERS?
I want an application that doesn't edit text files just opens up a new window and displays it

>> No.60913203
File: 94 KB, 640x480, cat.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.60913241

Was Ubuntu Mate a good choice as my first (non-virtual) distro?

>> No.60913251

it's a concatenating tool.

I also forgot to write "graphical"

>> No.60913274

Why do you seek approval for your own decisions?
Use it and see for yourself, don't sheep yourself.

>> No.60913297

vim doesn't edit by default.

>> No.60913328

will linux stay or disappear?

>> No.60913329

A little advice friend, if you have nothing to say, why waste time on typing a post?

>> No.60913332

What do you need graphical for if you want to view plaintext?
cat is a tool to view plaintext.
You could run nano (or any other text editor) in read-only mode or revoke write permissions to the file for the duration of your looking at it.

>> No.60913359

it is likely that in the future it will be replaced by a microkernel architecture similar to Hurd.

>> No.60913410

microkernels are a fraud.

>> No.60913420

I ALWAYS just ping google.

>> No.60913445

>using GNU screen

>> No.60913449

They are superior in every way to monolithic and the only reason they weren't chosen as the go-to kernel type is because performance of the old hardware was massively limited and swiitching modes added a lot of overhead.

The concept of Hurd is absolutely fucking flawless.

>> No.60913465
File: 2.09 MB, 580x433, 1497459321851.gif [View same] [iqdb] [saucenao] [google] [report]

lol so funneh he uses software he needs LOL XDDDD

>> No.60913479

>he felt for the modern hardware is too fast meme.

>> No.60913487


>> No.60913497

Were you dropped as a child?
>opens up a new window

>> No.60913525

Experience has proven otherwise. Hurd is only even bootable because of a sympathy project.

>> No.60913538

What the fuck are you even saying? Less is literally made for viewing files you piece of shit.

>> No.60913544

Learn to read friend.

>> No.60913562

That's why I said concept. It's obvious that Hurd was deemed to be failure the second everyone jumped on Linux.

Christ it's like you people actually don't understand what you're reading.

>> No.60913598

Learn to think dipshit. Multiple people have given you multiple options but you're clinically retarded and can't comprehend how to open something in a new window.

What a shitty thread.

>> No.60913599

xmessage "$(screenfetch -N)"

>> No.60913608

screen is gnu software, use tmux instead

>> No.60913614

>tfw haven't updated gentoo in 5 months
i... i'm scared guys

>> No.60913635

Please leave the gene pool.

>> No.60913636

Yeah, that's obviously what I said.
God you're so fucking stupid.

I asked for a VERY specific thing but as usual all you can do is ask "why". I don't want a bunch of manchildren explaining me that any old text editor does it. I fucking know it. I want a text viewer.

>What a shitty thread.
Thanks you to most probably.

>> No.60913643

ok, i just opened my laptop and looked it up, i have a atheros qca9377 does freebsd support it?

>> No.60913653

So you want to view some text. People told you the correct answer inclusive alternatives. Case closed, you can leave now.

>> No.60913659

Concepts are useless if they don't prove to be true in reality, mongoloid. Microkernels were a CS wet dream, but the reality is they're horseshit and not a single one has been successful without implementing monolithic characteristics. Take your shitty kernel design dream and fuck off.

>> No.60913672

>People told you the correct answer inclusive alternatives.
Not a single one so far.

>> No.60913694

Stop replying to him already, is it not obvious he's just baiting?

>> No.60913709

wtf, this is neat

>> No.60913742

>wet dream
even NT (hybrid) borrowed the concept

>> No.60913762

curl, httpie or wget?

>> No.60913770


Told you, don't have an answer - don't reply.
You're just a bunch of retards that can't read but always ready to give clueless opinions on everything.

>> No.60913779


>> No.60913808

Can wget even curl wttr.in? AFAIK wget is a downloader.

>> No.60913822

He had sex with one before.

>> No.60913837

wget -qO- wttr.in

Comfy alias:
alias wcat='wget -qO-'

>> No.60913877

is this some new meme of the month?

>> No.60914022


>> No.60914098

how do i update all the packages for gentoo

>> No.60914148

sudo apt-get install gentoo

>> No.60914160

Too many funny people ITT.

>> No.60914177

What do I need to google/man -k to read about the terminals Ctrl keybindings (etc. Ctrl c)?

sudo emerge -uavDN @world

>> No.60914240

scape code

>> No.60914263



>> No.60914302

cheers bud

>> No.60914364

How to contact the master control program?

>> No.60914617

For lazier input
echo 'cheat(){ curl "cheat.sh/$1"; }' >> ~/.bashrc && source ~/.bashrc

or even
echo 'c(){ curl "cheat.sh/$1"; }' >> ~/.bashrc && source ~/.bashrc

>> No.60914692

I'm setting up a personal portfolio/CV website on a cheap VPS. Should I set up Apache or Ngnix?

>> No.60914711

Both: https://vestacp.com/install/

But if you have < 512MB RAM just setup nginx + php-fpm

>> No.60914904

nginx, I don't think there's a good reason to install apache unless you know that you need apache specifically

>> No.60915057

$ time for i in {0..100}; do curl wttr.in &>/dev/null; done
$ time for i in {0..100}; do http wttr.in &>/dev/null; done
$ time for i in {0..100}; do wget -qO- wttr.in &>/dev/null; done

Not sure if I'm missing something but httpie looks pretty slow (maybe b/c python).

>> No.60915127

but then the nsa knows that your computer is turned on

>> No.60915144

Can tell you that nginx just werks, haven't used apache.

>> No.60915175

curl $API | jq is comfy.

>> No.60915186

It's definitely because python.

>> No.60915218

Python isn't that slow though.

>> No.60915292

starting the vm every time is

>> No.60915309

I installed pulseaudio and pulseaudio-alsa on arch, did cp /etc/pulse/client.conf ~/.config/pulse/client.conf, added pulseaudio --start to .xinitrc and now I have no sound, send help

>> No.60915311

Who is into gaming here? Just discovered this http://www.mgba.io/

>> No.60915319

Arch is for advanced users only.

>> No.60915349

fuck you

>> No.60915357

friendly thread

>> No.60915377

I want to try GuixSD but all I have is a 1GB flash drive and the USB image is just a little over that. Is there a way to compress it?

>> No.60915389

All Arch users deserve to be hanged for the neets that they are

>> No.60915434

Anyone here do mathematical modeling on Linux? I've been use GNU Octave, C, and gnuplot for all my modeling and computation. I'm curious if there are any math/numerics people in /fglt/

I always have used mednafen. Works well enough, very easy to set up gamepads, and I never experience anything terribly different from my actual gba.

mednafen has worked great on all the hardware I've used it on (going back ~9 years now). It also supports a ton of consoles, not just gba.

>> No.60915460

Yeah its pretty ok. I use it on my laptop because it is low-resource and high compatibility. What are you planning to use it for though?

>> No.60915565
File: 40 KB, 900x900, iu[2].jpg [View same] [iqdb] [saucenao] [google] [report]

Everytime I try the Ubuntu DVD it says that there is an internal error, how the fuck do I fix it?

>> No.60915613

You might have issues with boot priority

look at your bios, you might learn something.

failing that, try a USB install.

>> No.60915708

How do I look at my bois?

>> No.60915760

google the key combo for your make of laptop.

you hold a key combo when you boot up and then there will be a screen that shows you all the plugged/mounted boot devices.

>> No.60915768
File: 183 KB, 650x510, dragon3.gif [View same] [iqdb] [saucenao] [google] [report]

is mednafen the systemd of emulators? why normies want to centralize everything?

>> No.60915788

And then what am I supposed to do?

>> No.60915836

idk about it being systemd. i feel like you can make a bigger argument about core software like that. games should be easy to play though, and mednafen does that.

pick the device you want to boot and boot it. also good to see if other people with your same laptop have had similar issues.

>> No.60915855

I meant:
google to see if other people had the same issue

>> No.60916080
File: 1.14 MB, 1411x923, 1497554515.png [View same] [iqdb] [saucenao] [google] [report]

>tfw fedora users are human platypuses that use filthy thinkpads warping in 4d space

>> No.60916115

So I got it working now, but I have another problem: The HDMI cable I'm using is in 1080p and my TV is in a lower resolution, on windows 10 I just adjust the resolution using Nvidia Control Panel, is there any way of doing this in ubuntu?

>> No.60916119

What's the consensus behind Linux/IT-themed magazines? Are there any that I shouldn't buy or listen to?

>> No.60916133

yes, should be an application called "displays" installed by default.

>> No.60916162

With a cold one, ready to be cracked open.

>> No.60916174

I'm using arch on my Dell Latitude e7470. audio is fine through the speakers, but I get nothing at all through headphones when I plug them in. When I run amixer, I get this:

Simple mixer control 'Master',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Front Left: Playback 35702 [54%] [on]
Front Right: Playback 35702 [54%] [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 0 [0%] [off]
Front Right: Capture 0 [0%] [off]

I'm under the impression that I'm supposed to be seeing a section for headphones as well right? Am I missing something here?

>> No.60916195

a bunch of people who are paid to have an opinion. maybe they are valid opinions and worth reading, but take it with a grain of salt.

distrowatch is a pretty good gauge for popularity of an OS. don't think I have advice other than that.

>> No.60916244

You're welcome for the help btw.

friendly linux.

>> No.60916261

I mean actually being able to make your own resolution instead of selecting one.

>> No.60916302

Ah, yeah there's a config file somewhere. Don't remember exactly. you can definitely do arbitrary resolutions, I've just never had to. "Look it up" is crappy advice, but that is my advice, sorry.

>> No.60916452

Arch is for advanced users only.

>> No.60916495

How do I make my wi-fi drivers persistent?
It breaks after every kernel upgrade and I have to re-install broadcom-wl from AUR. What should I do?

>> No.60916497

Then feel free to impress me with how advanced you are by helping me out

>> No.60916527

Install oh-my-wifi-git from the AUR.

>> No.60916541


>> No.60916557

what was the OP pic?

>> No.60916567

No such package in AUR

>> No.60916674

Is there not a net install image?

>> No.60916710

Does Ubuntu's implementation of XFCE provide rock solid stability?
I'm using Gnome and Cinnamon right now, and they crash too often. This isn't acceptable if I'm doing something like recording video.

>> No.60916716

Anyone else leaving Debian behind even with the new release?

Just moved to Devuan last week and it is quite fantastic, I was looking forward to the Stretch release this weekend, not realising how much I'd enjoy this.

>> No.60916738

How do I set an unavailable resolution?

>> No.60916741

Yes xubuntu is pretty solid, Xfce is reliable no matter what distribution.

>> No.60916756

Been on Devuan since 1.0 release, pretty comfy

>> No.60916775

already moved pham, if you want me to contribute to your cirklejerk.

>> No.60916786


devuan is bestuan

>> No.60916861

>crash too often
The heck are you doing that makes you DE crash buddy?

>> No.60916896

maybe its gaymes

>> No.60916899 [DELETED] 

Will this work on ubuntu?

>> No.60916984

probably. try it out and tell us if it breaks

>> No.60916992

It didn't work.

>> No.60917195
File: 71 KB, 761x636, snapshot1.png [View same] [iqdb] [saucenao] [google] [report]

holy shit is slackware for real. So if I want to install ffmpeg from slackbuilds, I have to first go through and manually install all these other packages from slackbuilds if I want ffmpeg to build with those options. Holy fucking shit.

>> No.60917229
File: 2.24 MB, 480x270, 1494008121080.gif [View same] [iqdb] [saucenao] [google] [report]

the answer is obvious!

>> No.60917360

Trying to use a Linux distro for (approximately) the first time here and I'm already lost. I installed the most recent Lubuntu on an old Athlon XP machine I have here, and Firefox gives me an immediate crash on startup (presumably because versions above 48 don't run on SSE-only processors, and the one that comes by default in there is 50), nearly every other browser I tried installing via the software center also doesn't work (QupZilla works for a little while and then it crashes too), and even the SSE build of Pale Moon crashes upon trying to open any site, outputting "Illegal instruction (core dumped)" to the terminal.
Well then what the fuck can I still do? The earliest version of Firefox that shows up on Synaptic is 50, and as I just said it doesn't work.

>> No.60917458

Try an older distribution.
You can still download debian oldstable (wheezy).
It ships with some ancient verison of firefox-ESR.

I'm 100% it will work, but try a liveCd before nonetheless.


>> No.60917618


You will learn a lot using Arch Linux.

I'm still not sure about if an average newbie can use Arch Linux properly, but I think that a really curious newbie with perseverance and patience can use Arch Linux and love it.

>> No.60917693


>> No.60917734

I can only seem to boot into gdm on my arch install.
I'm trying to switch to either lightdm or lxdm but I don't want to remove gdm atm, just disable it.
How can I ensure that gdm is not interfering with the other display managers?

>> No.60917825

>You will learn a lot using Arch Linux.
top meme, I laughed

>> No.60917828
File: 1.38 MB, 1013x1433, 1493905577763.png [View same] [iqdb] [saucenao] [google] [report]

My father wants to install linux to get away from OSX, which he's been using for the last 15 years. He's not the most tech savvy person but is super intelligent and willing to learn, which distro would be best for him?

I was thinking Antergos for the simplified install and pacman, but Debian sounds nice as well

>> No.60917836

Install Trisquel.

>> No.60917871

Mainline Linux just werks.

>> No.60917877
File: 520 KB, 768x1024, 1477236370247.jpg [View same] [iqdb] [saucenao] [google] [report]

If he is super intelligent, like myself, he should be using Arch Linux, which is the Linux distribution (or distro, for short) which I am expertly using due to my high level of intelligence.

>> No.60917907
File: 2.71 MB, 1474x1600, 1496855897345.jpg [View same] [iqdb] [saucenao] [google] [report]

I'd just like to interject for a moment. What you're referring to as Linux, is in fact, GNU/Linux, or as I've recently taken to calling it, GNU plus Linux. Linux is not an operating system unto itself, but rather another free component of a fully functioning GNU system made useful by the GNU corelibs, shell utilities and vital system components comprising a full OS as defined by POSIX.

Many computer users run a modified version of the GNU system every day, without realizing it. Through a peculiar turn of events, the version of GNU which is widely used today is often called "Linux", and many of its users are not aware that it is basically the GNU system, developed by the GNU Project.

There really is a Linux, and these people are using it, but it is just a part of the system they use. Linux is the kernel: the program in the system that allocates the machine's resources to the other programs that you run. The kernel is an essential part of an operating system, but useless by itself; it can only function in the context of a complete operating system. Linux is normally used in combination with the GNU operating system: the whole system is basically GNU with Linux added, or GNU/Linux. All the so-called "Linux" distributions are really distributions of GNU/Linux.

>> No.60917932
File: 289 KB, 1200x2362, 1473076331273.png [View same] [iqdb] [saucenao] [google] [report]


>> No.60917948

Hey guys, I'm looking to try out an open source OS like Linux since I feel that the most recent updates to Windows 10 are really detracting from my user experience. I consider myself somewhat of a Linux expert already since I'm an advanced Android Linux user (I even figured out how to install .apks from anywhere, not just the Play Store!) so if you could please direct me to an advanced Linux OS, please?

>> No.60917956

install gentoo

>> No.60917958

>He's not the most tech savvy person but is super intelligent and willing to learn, which distro would be best for him?
An easy fucking distribution that he will be able to fix with the help of google. Ie. Ubuntu or Mint.

>> No.60917973

>recommending mint
please leave

>> No.60917989

Does anyone know what the Linux equivalent of the program Honeyview is? I just want a good image viewer for reading manga that can read .cbz, .cbr, and all that.

>> No.60917996

install gentoo

>> No.60918035

They're just archives like zip, rar etc. Unpack them, view them with any image viewer. You could also try and see if your pdf viewer can directly open the archives.

>> No.60918078

I know they're just archives, but on Windows I can just open them without unpacking.

>> No.60918087

wtf I love Windows now

>> No.60918092

Like I said, first try to open them with a regular pdf viewer like evince. If that doesn't work, and you don't want to manually unpack them, just write a script that unpacks them into /tmp, opens an image viewer at that location, and deletes the temp files again after closing the viewer (optional).

>> No.60918109

Oh and also learn to search your package manager.
$ apt search comic viewer
Sorting... Done
Full Text Search... Done
cbrpager/trusty 0.9.22-1 amd64
viewer for CBR, CBZ and CB7 (comic book archive) files

comix/trusty 4.0.4-1 all
GTK Comic Book Viewer

mcomix/trusty 1.00-1 all
GTK+ image viewer for comic books

okular/trusty-updates 4:4.13.3-0ubuntu0.1 amd64
universal document viewer

plasma-widgets-addons/trusty-updates 4:4.13.3-0ubuntu0.1 amd64
additional widgets for Plasma

qcomicbook/trusty 0.8.2-1build1 amd64
qt viewer for comic book archives (cbr/cbz/cba/cbg/cbb)

zathura-cb/trusty 0.1.2-5 amd64
comic book archive support for zathura

>> No.60918132


>> No.60918185

Ubuntu LTS. Let him try live CDs with different desktops. Avoid Unity, since it's dead. If he wants a toy OS like anything Arch based, just point him in the direction of TempleOS, at least that's a fun toy.

>> No.60918207

can we agree that systemd saved gnu linux? since systemd has been adopted,the major distrubutions have suddenly become usable: ubuntu, fedora, suse, mint, debian, manjaro, magaia, ...

you can verify yourself, all of those become usable at the exact moment they adopted systemd.

>> No.60918334

I want to build a small linux machine to use as a server and back up system. I don't want to exceed 500€ What kind of CPU should I look at ? I want something a minimum good since I'll have to compile a few things manually and want something that last a few years.

>> No.60918357

they were already usuable
Ubuntu wasn't, isn't and won't be usable anytime soon

>> No.60918369

t. big boy Arch user

>> No.60918464

If I want to reinstall my OS is there a way to easily restore my packages, development environments etc?

>> No.60918551

save your home folder

>> No.60918554

Backup all config files. That mostly means all dot-files and dot-directories in ~/ and maybe some stuff in /usr/etc/. Get a list of your installed packages with cat <<< $(apt list --installed | grep -oE "[-a-zA-Z0-9]+/" | sed 's#/# #g') >> /tmp/tmpfile. You can then install all of them at once on the new system by copying that file (obviously) and doing sudo apt install $(cat /tmp/tmpfile)

>> No.60918688

point of the cat?

>> No.60918739


>> No.60918759

How bad is vivaldi?

>> No.60918767

Proprietary garbage. Do not use.

>> No.60918801

>Windows machine breaks (work machine)
>Give up and join Loonix since I don't use C#/ASP.NET anymore so there is no reason to keep using Windows

Started using Kubuntu, finally got most of my work environment going.

I'm enjoying apt-get too much.

>> No.60918807

I need screenshot app
it need to have option where i can select part of screen with mouse and save it
it cant be screencloud
it cant be shutter

>> No.60918827

kek, touché.

Anyway, why not

apt list --installed | grep -oE "[-a-zA-Z0-9]+/" | sed 's#/# #g' > /tmp/tmpfile
sudo apt-install "$(<file)"

import screenshot.png

>> No.60918850

for your phone?

>> No.60918868

What are the best lanix alternatives to IrfanView and foobar2000, preferably with as many features as them as possible?

>> No.60918902

Wired way to spell GNU.

Look into deadbeef or discover the joys of mpd/ncmpcpp.

>> No.60918919

just use mpv

>> No.60918935

scrot -s

>> No.60918953

Why is everyone and his grandmother using scrot when there are so many ways to take a screenshot using programs which usually are already installed?

>> No.60918969

im trying to remove the second protective partition created by GPT

how would i do this?

im aware of how to remove MBR + part
dd if=zeros of=/dev/sdx bs=443/512 count=1

i heard its located in the last 34 blocks? not sure if thats accurate and how would i target that

>> No.60918971

I like it

>> No.60919248

Just installed gentoo, wat do now?

>> No.60919289

install gentoo

>> No.60919303

I've just did it

>> No.60919392


>> No.60919414


>> No.60919460

In fact, fug dis, downloading void rite nao

>> No.60919499
File: 37 KB, 570x420, 03-doge_01.jpg [View same] [iqdb] [saucenao] [google] [report]

/g/ is making a web browser that can work in the terminal (without Xorg) and still browse and post on 4chan >>60885202

There is a contact mail for developers >>60919191

>> No.60919791

what's the best distro for steam? ubuntu or debian?

>> No.60919858

Ubuntu is the "officially" supported one, but steam runs decently well on most distros.

>> No.60919879

isn't the supported ubuntu version from 12.04 or some old one?

>> No.60919945

windows 10

>> No.60919961

>Error: Our system thinks your post is spam. Please reformat and try again.
link to source removed because the spamsystem is a piece of shit
>Currently, Steam for Linux is only supported on Ubuntu 12.04 LTS and newer with the Unity, Gnome, or KDE desktop

>> No.60920007
File: 41 KB, 815x683, Untitled.png [View same] [iqdb] [saucenao] [google] [report]

Windows host, with a lubuntu VM. I just installed it, and it asked to be restarted, clicked ok, and now I'm stuck at this screen.
What do?

>> No.60920049

Uninstall Windows.

>> No.60920079

I've been using Arch for a while but for some reason I can't shake the feeling that I've got it set up "wrong" just because it wasn't already configured OOB for me. Has anyone else experienced this? I don't even know what I should do to try and rectify it. It's almost like because there isn't a base framework like I'm used to on OS X or Windows I feel like everything I do is wrong.

>> No.60920082

It doesn't really matter. As long as you are okay with compiles taking a little longer anything recent is good. I put a modern Pentium in my last one.

>> No.60920121

I thought steamos switched to a debian base?

>> No.60920152

Just restart the vm program, that shouldn't break anything any further

>> No.60920167

If you are still looking fur an answer you should be configuring pulse, not alsa.

>> No.60920169

what is the best proprietary program for linux?

>> No.60920211

iwlwifi (ucode)

>> No.60920229


>> No.60920256


>> No.60920273


stop this insanity

>> No.60920490
File: 78 KB, 600x450, 1476482561400.jpg [View same] [iqdb] [saucenao] [google] [report]


>> No.60921059

I'll be slowly switching from windows to GNU/Linux, what would be a good distro to start in GNU/Linux between Debian and Mint? truth be told I'm leaning towards Debian + XFCE

something I always wondered, excuse me in advance if it's too stupid: is there a way to install a GNU/Linux distro in a flash drive and save changes everytime you done using it?

thx in advance

>> No.60921077


>> No.60921254

Using a non-rolling release distro on a single user desktop PC is a fucking waste of time.

>> No.60921569

just select the flash drive during install and boot it

>> No.60921593


>> No.60921601

I fucked up and installed CloverOS as my first distro. >>60896540

From what I found it's based on gentoo and I want to install flash but I have no idea how to go about it.


>> No.60921669

the fuck

>> No.60921699

I know but I need it for a site I own. I just need to know how to install packages a tutorial would be great I can't find any good ones.

>> No.60921720

DDGing for live USB persistence should point you in the right direction for the flash drive stuff you want to do, but do note that OS updates will eat into your persistent storage.

>> No.60921729

um first result in google

>> No.60921750

That's what I linked already. I'm just unsure on how to install this


>> No.60921804 [DELETED] 

I decided I'll go with Manjaro because rolling release also I'll create a partition in VirtualBox rather than install the OS in a flash drive. thx /g/entlemen!

>> No.60921821

I decided I'll go with a Manjaro rolling release also I'll create a partition in VirtualBox rather than install the OS in a flash drive, that's kinda stupid. thx /g/entlemen!

>> No.60921930

I am running Xubuntu 16.04 and have two monitors on my GTX 770, can I use my intel CPU to plug in a 3rd vga monitor at the same time?

>> No.60921945

probably not.

>> No.60923025

Because I like using cat.

>> No.60923214

i use it because its called scrot and i'm a manchild

>> No.60923734

sudo emerge adobe-flash

read https://github.com/chiru-no/cloveros

>> No.60923936
File: 2.32 MB, 3264x2448, DSC_0002.jpg [View same] [iqdb] [saucenao] [google] [report]

On shitbuntu and stuck here. Any ideas on what the fuck is going on?

>> No.60924147
File: 75 KB, 512x1024, 1483235522340.jpg_(JPEG_Image,_512 × 1024_pixels)1483235522340.jpg [View same] [iqdb] [saucenao] [google] [report]

When using WINE, should you use 64 bit prefix or 32 bit prefix?

>> No.60924184

How dank is this formatting

#!/usr/bin/env bash

--textcolor=ffffff00 \
--insidecolor=faddc500 \ # inside of circle while typing/idle
--ringcolor=fafafa00 \ # outer ring while typing/idle
--linecolor=2d283e00 \ # ring delimiter lines
--keyhlcolor=fabb5caa \ # keypress ring color
--ringvercolor=fadd5caa \ # outer ring while
--insidevercolor=fadd5c00 \ # inner ring while password is being verified
--ringwrongcolor=f13459aa \ # incorrect password ring color
--insidewrongcolor=f1345900 \ # inside incorrect color

-loglevel quiet \
-y \
-s 2560x1440 \
-f x11grab \
-vframes 1 \
-vf "boxblur=luma_radius=4" \

"$image" \
$HOME/local/lockoverlay.png \
-gravity center \
-composite \

i3lock "${lockparams[@]}" -i "$image"

>> No.60924198

1. reboot
2. select the ubuntu line in grub, press e to edit it
3. find the line starting with linux
4. in that line delete "silent" and "splash" and add "verbose" and "nosplash"
5. press F10 to boot. Things should be quite verbose this time so you can see where memed is stuck.

>> No.60924206

32bit for 32bit only programs
64bit for 64bit programs and in cases where for example a game comes with a launcher but while the game has a 64bit exe the launcher is 32bit only

>> No.60924220

1. go to adobe.com/go/getflashplayer
2. download the tar.gz
3. copy the library file (.so) to ~/.mozilla/firefox/your_profile/plugins (create the plugins directory if it doesn't exist)

fuck installing flash via package managers

>> No.60924224

What would happen if I use 64 bit prefix for 32 bit application?

>> No.60924227

guess it would run in a similar manner as opening it in 64bit windows (in a 32bit subsystem).

>> No.60924259

Eventually "the system is running on low graphics mode" error popped up so i figured I'd try nomodeset instead of what you suggested. Booted but still wouldn't let me into Unity. Let's me into i3 though. Tried upgrading and restarting but it wasn't fixed. Gonna try to reinstall gpu drivers next I suppose.

>> No.60924270

I didn't suggest nomodeset exactly for that reason. It disables graphic acceleration, so no wide resolutions and no modern DEs. However if you system only boots with nomodeset, then that's a problem. You will need a newer kernel from backports or proprietary crapware drivers.

>> No.60924289

man -i touch cp cd --help

>> No.60924329

It's not that it wouldn't boot using anything else, it's just that i personally immediately opted for nomodeset. Anyways, was able to get into i3, updated the gpu drivers just now and the problem is fixed. Thanks for your time anyways man.

>> No.60924342

Oops, replied to myself by accident, meant to reply to you. God damn phoneposting, how do these bastard phoneposters do it..

>> No.60924350

Better dead than red.

>> No.60924358

Well I'm asking because I was trying to run a game, but the input wasn't being recognized until I switched to 64-bit prefix.
So I thought maybe some of the applications that I didn't manage to get it to work was caused by running it in 32 bit prefix instead of 64 bit prefix.

>> No.60924425

Enjoy and don't get too frustrated when something doesn't go your way. It will inevitably happen sooner or later, consider it a part of learning experience.

>> No.60924438

I don't think you have to use bash for that. Consider a POSIX shell (sh, dash, mksh, whatever your distribution uses)

>> No.60924544



>> No.60924678

>that garbage at the end

I hope that's an "attempt to quit vim"

>> No.60924698

ed actually.

>> No.60924755

Nice outrun style glitch art, saved.

>> No.60924813

You forgot to quote $HOME and $DISPLAY. Also why not centering the overlay with ffmpeg too? Nice formatting, btw.

>> No.60925032
File: 133 KB, 500x633, 1478930942067.png [View same] [iqdb] [saucenao] [google] [report]

What are some cool gui programs?

>> No.60925163
File: 320 KB, 1152x2048, russian intellectual asking the real questions.jpg [View same] [iqdb] [saucenao] [google] [report]


Recommend me an NSA-safe OS, that I can run in a virtual machine.

>> No.60925191

QubesOS is probably the safest you can run

>> No.60925207

I heard so too, but apparently it can't run in a VM.

>> No.60925214


>> No.60925217

Stop being a dumb cunt and use your brain
If your host is compromised how on earth do you want to secure the guest OS?

>> No.60925221

If the host OS isn't NSA safe you're wasting your time.
Not to mention hardware backdoors

>> No.60925223

I want to try it out before switching over. Nigger.

>> No.60925225

run it as a livecd

>> No.60925278

It woun't help you in a VM.
It woun't help you with newer CPUs.
The only way to be secure is using pre 2006 hardware on a librebooted and free (as in freedom) GNU/Linux distro.

>> No.60925294

>newer CPUs
>pre 2006 hardware
What happened?

>> No.60925309


tl;dr cpus running proprietary engines with full ring -9000 system/network access

>> No.60925330

Why on earth does a CPU need network access?

>> No.60925344

ask hardware manufacturers collaborating with their government intelligence agencies.

>> No.60925348

Remote maintenance for instance.

>> No.60925350

>pre 2006
Slightly newer friend.

my T7100 is sometihng like Q3 2007 and doesn't have these botnet features yet.

>> No.60925443

What are some of the proportional san serif fonts?

>> No.60925444

>not adding that to your .bashrc so you can add it to your .bashrc whenever you want

echo 'echo "cheat(){ curl \"cheat.sh/\$1\"; }" >> ~/.bashrc && source ~/.bashrc' >> ~/.bashrc && . ~/.bashrc

>> No.60925747

Just upgraded my first machine from Debian to Devuan.

The only thing that I ultimately had to let go were desktop icons for removable devices. By using spacefm instead of thunar, I can mount and unmount from my file manager without privileges and with dynamic mount points, with no systemd dependencies. Having that functionality in thunar requires gvfs, which drags libsystemd0 but nothing else from systemd, so it's not a terrible option either.

During the upgrade itself, though, I accidentally answered Y to apt-get and uninstalled xfce and my current display manager. This, of course, dropped me back to text mode. Fortunately I was running my commands from a screen session. That should be avoidable by marking packages as manually installed, but I hear some of the metapackages involved have systemd dependencies and do need to go. I'll see if I can do a less aggressive upgrade next time.

One important bit: the official way to upgrade is to replace the repositories, install the signing key without verifying it and then upgrade. I find this silly, because the key can be obtained by less insecure means. I did this:

gpg --keyserver hkp://keys.gnupg.net --search-keys [email protected]
gpg --export Devuan\ Repository\ \(Primary\ Devuan\ signing\ key\)| sudo apt-key add -

It sure beats a one-off unauthenticated HTTP download, I think. At least you can use different servers and check that the key matches.

>> No.60925789

New -> >>60925780

>> No.60925804


Name (leave empty)
Comment (leave empty)
Password [?]Password used for file deletion.