[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology

View post   

[ Toggle deleted replies ]
File: 99 KB, 721x972, gnutux.png [View same] [iqdb] [saucenao] [google] [report]
60610333 No.60610333 [Reply] [Original] [archived.moe] [rbt]

Previous thread: >>60602218

Welcome to /fglt/ - Friendly GNU/Linux Thread.

Users of all levels are welcome to ask questions about GNU/Linux and share their experiences.

*** Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread ***

Before asking for help, please check our list of resources.

If you would like to try out GNU/Linux you can do one of the following:
0) Install a GNU/Linux distribution of your choice in a Virtual Machine.
1) Use a live image and to boot directly into the GNU/Linux distribution without installing anything.
2) Dual boot the GNU/Linux distribution of your choice along with Windows or macOS.
3) Go balls deep and replace everything with GNU/Linux.

Your friendly neighborhood search engine.

$ man %command%
$ info %command%
$ help %command%
$ %command% -h
$ %command% --help

Don't know what to look for?
$ apropos %something%

Check the Wikis (most troubleshoots work for all distros):

/g/'s Wiki on GNU/Linux:

>What distro should I choose?

>What are some cool programs?

>What are some cool terminal commands?

>Where can I learn the command line?

>Where can I learn more about Free Software?

>How to break out of the botnet?

/t/'s GNU/Linux Games: >>>/t/769497
/t/'s GNU/Linux Videos: >>>/t/713097

/fglt/'s website and copypasta collection:
http://fglt.nl && https://p.teknik.io/wJ9Zy

>> No.60610352
File: 16 KB, 312x402, smgl-tux.jpg [View same] [iqdb] [saucenao] [google] [report]

install SourceMage

>> No.60610355

First for install devuan.

>> No.60610362

Hello, my friends.

Is there any point to using a Linux operating system as your home desktop when pretty much any and all programs today, such as video games, cater exclusively to Windows?

Not trolling; sincere question for someone who has nothing but a shitty laptop the military forced on me, is saving up to build a gaming PC, but would really love to learn to use a Linux operating system soon.

>> No.60610368

Vanilla linux contains propierary code doesnt it? so how can you use it for secure systems like tails?

>> No.60610373
File: 49 KB, 700x508, 1483587797250.jpg [View same] [iqdb] [saucenao] [google] [report]

I'd just like to interject for a moment. What you're referring to as Linux, is in fact, GNU/Linux, or as I've recently taken to calling it, GNU plus Linux. Linux is not an operating system unto itself, but rather another free component of a fully functioning GNU system made useful by the GNU corelibs, shell utilities and vital system components comprising a full OS as defined by POSIX.

Many computer users run a modified version of the GNU system every day, without realizing it. Through a peculiar turn of events, the version of GNU which is widely used today is often called "Linux", and many of its users are not aware that it is basically the GNU system, developed by the GNU Project.

There really is a Linux, and these people are using it, but it is just a part of the system they use. Linux is the kernel: the program in the system that allocates the machine's resources to the other programs that you run. The kernel is an essential part of an operating system, but useless by itself; it can only function in the context of a complete operating system. Linux is normally used in combination with the GNU operating system: the whole system is basically GNU with Linux added, or GNU/Linux. All the so-called "Linux" distributions are really distributions of GNU/Linux.

>> No.60610387
File: 223 KB, 1920x1080, fuckingCortana.jpg [View same] [iqdb] [saucenao] [google] [report]

>cater exclusively to Windows

>> No.60610397

If you play only games that have a native gnu+linux port (especially those available from stem) it's better to use gnu+linux to avoid the annoyances of windows like ransomware, forced upgrades etc.

>> No.60610399


>> No.60610422
File: 24 KB, 505x405, 0c8.jpg [View same] [iqdb] [saucenao] [google] [report]

Remember kids, never trust proprietary AI https://www.youtube.com/watch?v=PaxZgsdh-ac

>> No.60610424

Again, not trolling.

It's a legitimate question - I've seen this thread multiple times, but not even the OP that serves as a FAQ answers the "why for your main desktop?"

>> No.60610455

Should I install 32 bit or 64 bit?

>> No.60610472

if you can 64 definitely go for it, assuming you did check your computer supports it

>> No.60610502

for your persistance
1) the ONLY thing windows has the edge on is specific applications. Games run under wine decently for the most part, not all ill say.
2)freedom. I can do whatever i want with my machine, on windows you cant. Thats more than just being open source and not spying but also encouraging the user to do what they want.
3. Its actually free. Yes i have a windows licence, but i prefer to do everything i want on my gnu linux install. Its that i can do stuff way faster with the cli than i can on windows.
4. rice. Honestly windows looks so average after using cinnamon with my theme for a few days.
5. Productivity isnt hindered. I can do everything i could on windows (code and draw) rather the same if not better (a free drawing programme is actually better than photoshop / illustrator imo). and i can use atom just the same. Then you have stuff like emacs and vim which im pretty sure run on windows anyway.
Why wouldnt you use gnu linux is the better question. I dont game, so theres no reason for me. I have windows left over only for incase i ever do need it. Probably the only complaint i have is that theres no decent dac. but every other program is there. Oh and also the installation is faster, easier and more secure than windows anyway

my personal opinions anyway

>> No.60610519


>> No.60610558

bumping from previous thread

>> No.60610560

I uninstalled eclipse but it left behind "open jdk monitoring and management" so i think ill uninstall it even thoguh yum didnt (even with autoremove) but that leaves me questioning, what else could it have left behind and what can i do to keep my system clean from stuff i dont need?

>> No.60610576

Hi there!

You seem to have made a bit of a mis take in your post. Luckily, the users of 4chan are always willing to help you clear this problem right up! You appear to have used a tripcode when posting, but your identity has nothing at all to do with the conversation! Whoops! You should always remember to stop using your tripcode when the thread it was used for is gone, unless another one is started! Posting with a tripcode when it isn't necessary is poor form. You should always try to post anonymously, unless your identity is absolutely vital to the post that you're making!

Now, there's no need to thank me - I'm just doing my bit to help you get used to the anonymous image-board culture!

>> No.60610591

Is reducing the role of systemd to that of a udev providor as good as just deleting it entireley?

>> No.60610669
File: 25 KB, 621x142, Screenshot from 2017-05-28 02-07-02.png [View same] [iqdb] [saucenao] [google] [report]

in fact, to add to this i just checked my history list and it seems that certain uninstalled software isnt even removing everything.

>> No.60610674

found your problem

>> No.60610676

I appreciate this. Like you alluded to, gaming is the biggest draw for people like me still being on Windows.

>> No.60610738

You could just install a distro alongside windows or find an old hard drive and install it on that. Not to bash you but gaming in general is in such a crap state right now that its not even worth following anything, and also any multiplayer game either runs natively (dota2, csgo, tf2) or runs well in wine (lol, bf1, overwatch (i believe)). Plus gnu/ linux has exclusives of its own like tux racer extreme

>> No.60610749

what should i use over yum, its deprecated to dnf or something isnt it? why is it still included then?

>> No.60610762

never worked for me for stuff like exactly what you find, good luck though, hope you find a solution

>> No.60610951 [DELETED] 
File: 9 KB, 251x251, 1436538131057.jpg [View same] [iqdb] [saucenao] [google] [report]

>install linux
>no games
>no software
>he shills it for free
>Is a cuck

>> No.60610995

That's why you should install GNU.

>> No.60611004
File: 91 KB, 1200x1125, win.png [View same] [iqdb] [saucenao] [google] [report]

>lying about having no games
>lying about having no software
fucking telemarketers, microsoft must pay good money to shitpost on /g/

>> No.60611032

Why do you reply? Are you braindead?

>> No.60611060

What is a good music player for the GNU+Linux distribution called "Xubuntu", which is a variant of the GNU+Linux distribution called "Ubuntu" with the DE (Desktop environment) "XFCE"?

>> No.60611108 [DELETED] 
File: 40 KB, 467x433, 1444171687158.jpg [View same] [iqdb] [saucenao] [google] [report]

Keep getting cucked by alpha windows users who have games to play.

>> No.60611153

lollypop or gnome music since youre using a joke distro

>> No.60611155

>muh videogames!
This phrase indicates the windows users' confusion. When met with something they can't understand they shout "Muh vidya" or "Muh working OS muthaucka"
This is followed by getting 200 viruses and their data stolen.

>> No.60611158

deadbeef comes close to foobar2k
beginner friendly: moc
advanced cool guy: mpd+ncmpcpp
quantum gallium hacker: urandom/aplay
idgaf: mpv

>> No.60611176

can't get my dell dw1510 working on tahrpup, any help?

>> No.60611181

It's not a joke distro if you have a toaster

>> No.60611188

enjoy ur ransomware

>> No.60611219

Is there any way to delet botnetd without fucking up everything on xubuntu?

>> No.60611227

yes it is, compare xfce's system resource usage to cinnamon for example. LXDE is the true lightweight DE. furthermore using something like i3 or openbox would be way more lightweight

>> No.60611243

vrms -s | xargs sudo apt-get purge

>> No.60611264

adding even further, i cant even find a package name for this, and nothing shows up with yum extender.

>> No.60611282

trying too hard to fit in anon.

>> No.60611296
File: 3.03 MB, 2560x2880, 1457053379245.jpg [View same] [iqdb] [saucenao] [google] [report]

Enjoy 1% market share, cuck.

>> No.60611422

How am i supposed to open moc?

>> No.60611451
File: 65 KB, 712x415, Screenshot from 2017-05-28 02-50-02.png [View same] [iqdb] [saucenao] [google] [report]

ok i found the package by going back through the menu shortcuts. Its java-1.8.0-openjdk- but specifically jconsole i think. I tried removing it but the amount of dependants it has is actually quite high, i wonder why this is happening, that eclipse installs some random thing that it doesnt remove and it seems to intergrate itself.

>> No.60611455

type in terminal mopc
inside the terminal type "?" to see a list of commands

>> No.60611506

This was surprisingly convoluted.
So it's an inside-the-terminal software, sorta like aptitude.
Figured that much when I couldn't find an icon for it.
But I couldn't for the life of me figure out what should I type in.

>> No.60611554

trust me after that is more than easy, type the question mark for the list and see for yourself

>> No.60611593

I use this command in a function to check what's eating storage.

How do I modify du to show only files? No directories.

# Lists the $1 heavier files and directories and stores them in a file. Takes two arguments. How many entries are listed and the block size. Second argument can be ommited.
heavy() {
du -ah --block-size=$2M . | sort -n -r | head -n $1 > HeavyFiles.txt &

If I remove "a", it shows only directories. Any way of making it show only files?
du -ah

>> No.60611597 [DELETED] 

Halp me boys, what do i do? After update i started getting this error
[quote]ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld.sock' (2 "No such file or directory")

>> No.60611600

By the way, where it says "detach from the server" means you can keep the music running in the background without having open the terminal, i like what mpd+ncppmmpmpn does without the fuckery of configuration.

>> No.60611648

Im impressed with gnu/ linux, its the only thing thats ever confirmed my gpu. Windows says HD7900 series, speccy says hd7900 series, the cooler on the gpu says hd7900 series. But gnu/ linux says hd7970/8970/280x. Only time ive ever known (and known i wasnt swindled). Good job linus

>> No.60611684

Halp me boys, what do i do? After update i started getting this error
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/run/mysqld/mysqld.sock' (2 "No such file or directory")

>> No.60611713

df -h

I bet your root has 0 bytes of free space

>> No.60611721

Anyone know how it looks with ARM?
>1% market share, cuck.
so what?
>microsoft must pay good money to shitpost on /g/
i hope its just goims...

>> No.60611730


>> No.60611740

use find -type d instead of the dot

>> No.60611768
File: 4 KB, 674x34, ss_016.png [View same] [iqdb] [saucenao] [google] [report]


>> No.60611799

What did he mean by this?

>> No.60611810

He ask for df -h, why that screenshot? Are you trolling?

>> No.60611868

What's the best way to read the man pages?

I think there was some sort of website with no nonsense that improved the comprehension greatly. Was it a dream?

>> No.60611879
File: 17 KB, 584x156, ss_017.png [View same] [iqdb] [saucenao] [google] [report]

that is root, if you look it has 10% free
there is no difference between that and df

>> No.60611998

cool, OPEN/GNU propaganda.
shit next goim.....

>> No.60612030

the issue with linux is that the user has too much choice and software is too splintered. Do you really need 100 media player variants? no. you need one. This is where windows will always be better; it guides the user and gives them the definitive software they need. You dont need 100 DE, you need one. Imagine if everybodies computer ran custom i3 or openbox; it would be a catastrophy changin from one pc to the other, the workflow would be nonexsistant.

>> No.60612065

did you hear about Ubuntu|SUSE?
gentoo is not only distribution.

>> No.60612066

Ok. I got it. Thanks.

# Finds and sorts by size the $1 heavier files.
find . -type f -exec du -ah --block-size=1M {} + | sort -n -r | head -n $1 > HeavyFiles.txt &

# Finds and sorts by size the $1 heavier directories and files.
find . -type d -exec du -ah --block-size=1M {} + | sort -n -r | head -n $1 > HeavyFiles.txt &

Where $1 is a integer (say, 50).

>> No.60612070

a big part of linux is the customisation, so it suits everyone. 1 DE would not suit all - some are designed for low end PCs, others full of nice graphics and animations, which would be unsuitable for low end hardware. it's all about choice and doing things how you like it, so it cannot be one size fits all.

>> No.60612082

I need one DE only. One that Microsoft never touched.

>> No.60612115

>Linux as a personal Operating System

JESUS CHRIST. You might as well use DOS. Linux is good for servers and nothing else.

>> No.60612123

>tfw I just backup my files and install a new version of my OS instead of upgrading through the OS so I don't end up with a fucked up upgrade

Am I just being paranoid?

>> No.60612141

or make it so animations can be turned off.

>> No.60612147

>backup files
>doesnt work? reinstall with that backup

>> No.60612201

Is there a button in KDE plasma that says: "I'm fuck done customizing stop showing me al these goddamn options everywhere"

>> No.60612210

What is the best way to setup volume keys with i3 window manager? I tried something with xbindkeys but it allowed going above 100% which triggers my OCD

>> No.60612226
File: 10 KB, 209x250, 1494558755931.jpg [View same] [iqdb] [saucenao] [google] [report]

>as well use DOS
DOS is proprietary so.... no.
>and nothing else.
thats why android exist.

if you are too dumb to switch you could just live your live, not spamming 4chanEliteBread

>> No.60612243

what do you mean? post print screen

>> No.60612359

>new version of my OS
>not using rolling distro
you mean ''lock widgets'?
right-click on desktop if so

>> No.60612435

I don't want to miss on a not-so-obvious problem after upgrading. At least with a straight-up new install, I don't need to worry about it.

I don't care about having the absolute most current versions of software.

>> No.60612440

What do you need that linux doesn't have.
It's perfectly fine if you don't need extravagant shit. But if you do need that, you can afford windows and all the software you need.

>> No.60612454


>> No.60612459

I'm using xbindkeys like so: "amixer set Master 1024+ unmute". Doesn't go over 100% in i3wm for me.

>> No.60612616

install ncdu
quote ur variables

>> No.60612642

What is ncdu and why should I use it?

>> No.60612751

he mean Gentoo.
Gentoo is systemD-free&&source&&Community-based GNU/Linux distribution that give to User full Choice||Freedom

>> No.60612933


>deadbeef comes close to foobar
No, it doesn't you retard. At least inform yourself about the software you recommend before doing so, instead of just parroting what you hear.
Deadbeef doesn't even have a library feature.

>> No.60612949


There are more media player variants for Windows than for Linux distributions.

>> No.60612971


Linux is a kernel and it doesn't care if it runs on a "server". "Server" is a buzzword which doesn't mean anything. If I run an FTP server on my laptop it's suddenly a server.

>> No.60613000


That has nothing to do with your window manager or xbindkeys. One managers windows, the other keybinds.
What changed your volume and made it go above 100% (which is apparently not clearly defined and doesn't mean anything) is what you should look into. You most likely used the Pulseaudio CLI, pactl.
Solutions are described all over the internet, but someone else spoonfed you already and wasted precious internet kilobytes in this thread.

>> No.60613061

So i was trying to install a wine game
but got a weird nvidea bug
so i searched for the fix and found only this

The fix:
FPUCW 0A7F -> FPUCW 027F during first call to IDirect3DDevice::SetFVF(), resetting the rounding mode to default, when the relevant context is created. Or the entire code block that is called at th123_102.41DAD7 can also be wrappered by this.
The fix in the DLL is incomplete at this time, it'll still freeze sometimes. Need to put a wrapper on a lot more d3d calls/threads than I have at this time. (I would just find and kill the 0A7F completely, except netplay synchronization is an issue.)

I don't understand a fucking word

>> No.60613117

its ment for devs to read not end users. you can't do anything about it

>> No.60613139

Installed Gentoo, neofetch doesn't show the ASCII, what do?


>> No.60613165

It's under the «Resolved bugs» header

>> No.60613271

install gentoo

>> No.60613287


>> No.60613367

i also hate the term server because i can even run my 3ds as a server (albeit a pretty shit one).

i usually dont side with spamposters but this guy >>60613287 is right. neofetch is shit bloat for people who do nothing.

>> No.60613379

What's a lightweight and good compositor I can use for openbox? I plan to gayme on this PC as well with the AMD drivers

>> No.60613380

What is screenfetch god for?
I use it to check the ram, but does it have other uses?
(Besides showing off the cool specs and shit)

>> No.60613420

what a pointless question. it does one thing so why ask whats its good for. most distros have a built in speccy anyway. i know ubuntu and fedora do anyway

>> No.60613455

i need help about terminal text colorization. is there a standard way?

>> No.60613486
File: 2.98 MB, 1474x1600, 1468290986788.jpg [View same] [iqdb] [saucenao] [google] [report]


Fuck off shill. Install Hyperbola (when it's ready)

>> No.60613537


>> No.60613548


>> No.60613563

zsh + oh my zsh

>> No.60613571

i mean colorization through printf, for example.

>> No.60613655

is there a comparison of all terminal emulators on how they handle color codes?

>> No.60613662

No,its standardized

>> No.60613698

I installed Arch a few days ago and I really like it. However, I don't wanna have to fight with it every time I install it somewhere, and archiso seems like a pain in the ass and it doesn't even have an install option, just live cd.

My question is, how good are Manjaro and Antergos? They seem to be stable enough and you can use the AUR, which fucking rules, but obviously it's not the same as installing Arch on yourself. Can anyone who uses them help me decide?

>> No.60613716

Antergos is basically arch with a actual setup, you can choose a DE or just "base" which is pure arch, has a partition GUI and everything. I'm installing it right now, posting from live USB kek

>> No.60613718

Bash is the best shell and all terminal emulators are the same

>> No.60613743

>fight with it
Meaning what exactly.Its very straight foreward..
>dosent have an install option
You boot the liveusb and then setup the install.

>how good are downstream distros
They are shit and you should never use downstream distros.Just use arch.

Use Arch

>> No.60613745

yes but there are multiple standards :3

>> No.60613760
File: 2.94 MB, 3359x2178, IMG_20170527_170828.jpg [View same] [iqdb] [saucenao] [google] [report]

I'm trying to install linux for the first time on my t530 but when I boot up my system with my live antergos USB it just goes to windows. Secure boot is off and my boot order looks like this. What am I doing wrong?

>> No.60613766

PS1 and .Xdefaults are fucking standard between all of them.Thats why its a fucking standard

>> No.60613786

Im assuming you want to use option 7

>> No.60613790
File: 43 KB, 758x120, Screenshot from 2017-05-27 18-09-53.png [View same] [iqdb] [saucenao] [google] [report]

What is the actual reasoning behind HJKL?

>> No.60613801

why the fuck are you even talking about PS1? how is this relevant to color escape codes at all?

i found this which is quite informative


>> No.60613808

Second player users hjkl

>> No.60613814

Im fucking retarded, didn't even see that. Thanks.

>> No.60613823

printf -- '\e[31mRed\e[m\n'
printf -- '\033[31mRed\033[m\n'
31-37 normal colors
41-47 bold colors

256(2) colors
printf -- '\033[38;5;197mMagenta\033[m\n'
38: foreground
48: background

truecolor (2):
printf -- '\033[38;2;255;0;0mRED\033[m\n'

[00m or just [m (shortcut) disables colors

>> No.60613826

Can't you just change it so it becomes pure arch?

>> No.60613839

>41-47 bold colors

>> No.60613852


>> No.60613860

Why? where can I learn more about that, upstream downstream and shit

>> No.60613864

Please let me know how it feels, maybe a screenfetch
Well fuck me but I like being able to just conne wifi when I first log in without having to download all the tools and setting the systemd service to run and all that shit. Since I'm building a new desktop after the summer I'll probably install actual Arch in there, but for now there's no point.
I didn't know you can install from the archiso, I was searching online and it seemed like you can't just install everything as you have it (configurations for de, wm etc)>>60613743
Manjaro is downstream and I guess you have a point, but Antergos uses the Arch repositories.

>> No.60613924
File: 323 KB, 1360x768, Screenshot from 2017-05-27 18-15-39.png [View same] [iqdb] [saucenao] [google] [report]


>> No.60613933
File: 443 KB, 2676x2370, 1466872078861.jpg [View same] [iqdb] [saucenao] [google] [report]

Back in the days we were too poor for arrow keys, so we used hjkl instead.

>> No.60613949
File: 25 KB, 931x301, ADM3A Terminal Keyboard.png [View same] [iqdb] [saucenao] [google] [report]


>> No.60614004

does only vim use hjkl? my fingers always feel like shit when using vim after doing only a little navigation

you cant just migrate systems bit by bit. even if you tried the amount of stuff that will go wrong

the terms tell you everything you need to know.

>> No.60614025

Interesting. Thank you.

>> No.60614107

Isn't the data collection talking about their website and forum tho?

>> No.60614170

keeps hands on the home row

>> No.60614175

Most roguelikes use hjkl movement.

>> No.60614245

>remove shitty webcam bloat
>gnome loses system settings and contacts
Why is this shit so widely used again?

>> No.60614249


>> No.60614269

What's the point of having your settings and contacts hard depend on a fucking webcam app? I don't even have a webcam.

>> No.60614284

So what are the essentials to download on a fresh linux install? If possible commands for install would be cool.

>> No.60614286

So, finally installed Gentoo. Already compiled X.org, MATE and Firefox. I switch my sound devices often and Pulseaudio requires systemd, what should I install instead?

Btw, compile times are a dumb meme.

>> No.60614291

With gnome,you have to have EVERY GNOME PACKAGE for the FULL EXPERIANCE. You are breaking the law and not installing ALL THE GNOME PACKAGES

>> No.60614298

use gnome 2 or kde or xfce or bspwm or awesome or openbox or i3 or literally anything other than gnome 3 and unity.
>implying gnome 2 doesn't look way better anyway

>> No.60614320

compile gcc or a browser and come back saying that

Use alsa retard

>> No.60614323

do you have a sysV replacement installed? cause use that.

>> No.60614523

I have a huge problem of being a noob!
I have the asus router with padavan OS on it, which work on busybox and entware-ng, my problem is that I dont know how to configure openVPN client, not server, on it, or any other free vpn service. Recommend me some

>> No.60614582

So I finished my install and after I remove my USB and reboot my computer goes to boot agent and I get media boot failure. What do?

>> No.60614682

Fuck I'm getting worried. Any help?

>> No.60614726

Did you remember to install a bootloader? What does your boot order look like?

>> No.60614727

Is there an official/recommended C++ IDE for Debian? Preferably something I can

su apt-get install X

after which point it just werks™. I've spent about a week trying to get CodeBlocks installed and I'm fed up of running into error messages.

>> No.60614753

I decided to restart my whole installation to see if it works this time but isn't antergos supposed to download grub2 automatically?

>> No.60614816


Anyways, alsa is not working with all my devices. Refuses to put the USB mic on and change output to my sound card. Is there nothing like pulseaudio without systemd?

>> No.60614846

>is there nothing like pulseaudio without systemd
Yes,fucking alsa.Take 1 fucking minute and configure it properly

>> No.60614877

I use Atom which is developed by GitHub and is designed to be customizable af with community packages etc. You can put a C language package and a gcc one and boom best IDE ever. Also Visual Studio is now available for Linux.

>> No.60614927

damn. I'm the anon who was waiting for your results and screenfetch. Did you get any option to install grub or something during the install?

>> No.60615033

So here I was during my second install thinking of how I partitioned it wring and needed to do it a third time to get grub working, and I reinstall and this time just werks. Will edit some things then screenfetch for you.

>> No.60615215
File: 384 KB, 1920x1080, Screenshot_20170527_224329.png [View same] [iqdb] [saucenao] [google] [report]

Success! Recommendations on themes and programs are welcome.

>> No.60615292

I've installed Antergos several times, each time choosing to format my HDD completely with the LVM option to use LUKS.

My LUKS password stops being accepted after 2-4 weeks. This is the third time it has happened and I don't understand why or how.

I'm going to just reformat (again) and go without the added security, but I'm really curious what sort of process is going on behind the curtains.

No special characters. I don't use any alternative keyboard layouts. My pws were all just strings of 8 lowercase characters and numbers. Anyone have a clue?

>> No.60615303

I've taken a whole while and I can't get it to work the way I want to. Fuck it, back to systemd.

>> No.60615309

Your drive is dying. That's on disk bit rot.

>> No.60615400

What's the best, and most user-friendly i686 distribution there is?
I need something that has support for Intel wifi cards though, since I'm too much of a poorfag to afford anything else.

>> No.60615403
File: 61 KB, 1024x869, x1.jpg [View same] [iqdb] [saucenao] [google] [report]

is there any benefit to running Linux on a thinkpad?

>> No.60615428


Main benefit is you're not running Windows

>> No.60615449

>AUR support
Wat? Nothing is needed to support the AUR, or does it mean it installs some tool like pacaur or yaourt or whatever?

>> No.60615509

How passwords in UNIX work is:
1) when you create user or change password, it takes a 56bit version of your password
2) it takes a 12bit version of the current system time
3) encrypts them together
4) when you enter your password again it encrypts it anew with the 12 bits which are saved with your user account
5) it checks encrypted password against encrypted password, and if they match it let's you log in.

So, either:
a) your login manager gets fucked (try another one, there's gdm (gnome) sddm (kde) lightdm (universal) and others
b) this >>60615309

If it is a), then you're lucky. When you get to the log in screen, press CTRL+ALT+F2, log in as root, use the command
systemctl disable <login manager you're using>
apt-get install or pacman -S or w/e <other login manager>
systemctl enable <other login manager>
systemctl start <other login manager>

This is if your distro uses systemd.

>> No.60615553

you might need to
cd /etc/systemd/system
and then
rm <the file about login managers>

>> No.60615619

Should I install arch or freebsd on my x220? Currently have mint on there but i want something kewler

>> No.60615678

Jesus Christ these text interfaces are great.
So much easier to use these than fucking around with the mouse.
God bless GNU+Linux!

>> No.60615688

Devuanfag here

I have a Panda wireless USB adapter. It shows up in lsusb, but in wicd, no wireless networks are detected. Using iwlist, etc, wlan0 shows up, but is stated to be down and not having scan ability.

On other distros this USB usually just werks, and it worked in Devuan in a live image. Am I missing something obvious? I've tried the command to make it "up" but it still won't work

>> No.60615800

That's interesting, thanks for the explanation. I might be wrong, but I don't think the login manager would change anything in regards to the LUKS password entry? That password prompt occurs before the disk can be mounted and accessed.

I hope not

>> No.60616068

I've had problems with login managers before in Arch linux, nowhere else though. It wouldn't change the password entry, but it might be doing a different encryprion or it might be looking in the wrong place for the username-password combination.
What I ended up doing in Arch was after I saw that different login managers worked, I uninstalled and then reinstalled the one I had (sddm - the kde one) and it works from then.

>> No.60616233
File: 57 KB, 640x479, interested linux frog.jpg [View same] [iqdb] [saucenao] [google] [report]

Is it worth putting Linux proficiency on my resume even though I'm not in the CS/IT field?

You know, like how everyone puts in that they're good at Excel even if they're barely going to use it (or just use basic functions) on the job.

>> No.60616394

There is zero need for a login manager

>> No.60616433

Display Managers are a pointless attack surface, why would anyone need one?

>> No.60616442

Okay, I'll try a different login manager this next time I reformat, maybe it'll work
Thanks for the suggestion

>> No.60616527

I really don't see how mentioning you have skills with linux and system administration would hurt you.

>> No.60616541

Hey guys how can I use the "padoka ppa" or whatever the equivalent is on arch? is the padoka thing for ubuntu only? what about the DRI3 thing does it come with it? thanks in advance

>> No.60616551

Anyone with a Thinkpad updated Intel ME?

>> No.60616570

How would you guys break up the filesystem for installing Linux? For example, I have a 120GB SSD, a 60GB SSD, 1TB HDD, 200GB HDD(2x), and a 500GB HDD.

How should I partition across multiple drives? root on the 120GB SSD, home on the 60GB SSD, the rest just for holding various media?

If you're applying somewhere it's used it might not be a bad idea. I did a science-related internship in college, and all the computers were running RHEL/Fedora. I had to know a little bit about SSH, basic commands for file navigation, and at least a degree of competence in a text editor. Actually, most of the data reduction we did was using custom scripts in a Linux terminal, but a lot of the other interns had never used Linux before in their lives. So I think depending on the circumstance, including it isn't a bad idea.

>> No.60616679
File: 21 KB, 445x334, 1301374205435.jpg [View same] [iqdb] [saucenao] [google] [report]

I know there's the "install gentoo" meme in regards for people trying to get more accustomed to learning linux, but once it's actually installed, how is it as daily use OS?

I'm not super experienced with Linux, but I've used Ubuntu a decent bit, can navigate command line, and can do basic network and package troubleshooting.

>> No.60617150

I actually managed to install Gentoo today (first try!). Honestly, it seems great. The compile times are a meme. I compiled everything quickly (Firefox, DE, xorg). I have too much weird hardware to configure (soundstuff, screens etc.), so its a bit tedious and I'll just go back to Debian.

I wasted the whole day with Gentoo and don't regret a bit. The installation was surpisingly easy. Might go back some day.

>> No.60617505

Some applications are refusing to start citing oom.But i have 10gb free,but its cached.
I have swappiness at 90 and vfs_cache_pressure at 50.

Why is it not pushing shit out of cache and allocating the new ram?

>> No.60617532

I'm a linux noob but what if you run something like top, what does your RAM usage look like?

>> No.60617552

Its 5.5gb ram used
10.5gb cached

>> No.60617743

You have 16gb total? Yeah that's odd, I'm assuming the cached memory is memory that is technically available. If you run swapon --show does it show that swap space is set?

>> No.60617757

I dont have swap

>> No.60617812
File: 87 KB, 1366x768, file.png [View same] [iqdb] [saucenao] [google] [report]

I did the Chicago95 theming junk but I can't get the start button to appear unfucked like pic related. What do?

>> No.60617834

Oh okay. I'm not sure what the issue could be besides you actually running out of memory, but those programs wouldn't normally use 10gb or RAM right? Maybe there's some infinite loop allocating memory or something?

>> No.60617863

Its 10gb of cached ram though,which is what is expected.I can manually kill the cache with a mem dump but i shouldnt have too

>> No.60617872

Yeah you shouldn't have to, what distro are you on? Maybe check out the links in here, it could be a bug:

>> No.60617873

>some infinite loop allocating memory or something
Memory leak

>> No.60618075
File: 87 KB, 1366x768, file.png [View same] [iqdb] [saucenao] [google] [report]

Nevermind. I'm going with this instead.


>> No.60618193

Arch-4.11.2,that link is the OOM manager is killing processes despite there being ample ram to support it

>> No.60618237

>that link is the OOM manager is killing processes despite there being ample ram to support it
Is that not what's happening to you?

>> No.60618290

The programs fail to start,they pop up and then disappear,or in cli, state no room left on device and then exit properly.There is no OOM entry and no other processes are killed in its place,it just refuses to launch because its not pushing room in to the cache

>> No.60618454

Weird. I'm about to fall asleep but I hope you figure it out. What programs btw? and yku're running them in normal circumstances (like not under another less priviledged user or something)?

>> No.60619712
File: 45 KB, 1360x768, 2017-05-28-005437_1360x768_scrot.png [View same] [iqdb] [saucenao] [google] [report]

>tfw finally install arch

>> No.60619730

>not using -ck patchset

>> No.60619735

What do you mean by that

>> No.60619746

You are currently not using the linux-ck kernel patchset

>> No.60619766

Does it make a big difference

>> No.60619770


>> No.60619814

why even use arch id you dont know what it does?

>> No.60619817

fug... h---here we go

>> No.60620058
File: 238 KB, 550x440, rt.jpg [View same] [iqdb] [saucenao] [google] [report]

Messing around with github for the first time.

I'm trying to "update submodules". I've got the gitmodules file, with seemingly appropriate links. I run the command, it makes some folders, and does absolutely nothing. What's going on? It just kind of stops.

>> No.60620216

git clone noose

>> No.60621083

Looking to customize my new ubuntu desktop, going for a 90s windows look. What are some good window manager fonts? I don't even know where to look. What fonts do you all use?

>> No.60621285
File: 38 KB, 680x793, 064.jpg [View same] [iqdb] [saucenao] [google] [report]

>server has transmission client on it
>last night went through my currently airing shows and added all the episodes to get me current
>about 60 episodes of lots of shows and I was at different stages of the shows each
>update my txt file that shows where I was up to
>this morning
>some glitch with the torrents caused the temporary names to not be overwritten
>episodes all named 1~73490edv or whatever
>no idea what episodes are what
>or where I was original with the shows

>> No.60621303

How can I force emerge to install firefox without unmasking adwaita-icon-theme? I know I could just unmask adwaita, install firefox and mask adwaita again but I'd rather not.

>> No.60621374
File: 55 KB, 723x170, Screenshot from 2017-05-28 16-22-20.png [View same] [iqdb] [saucenao] [google] [report]

I'm running Elementary OS andI keep getting this weird error:
>E: Package '___' has no installation candidate

It's not just GIMP like in the photo, tons of different things that definitely exist. Any clue whats going on? It's really fucking annoying

>> No.60621451

Did you sudo apt-get update before?

>> No.60621458
File: 1.25 MB, 1366x768, 2017-05-28-072348_1366x768_scrot.png [View same] [iqdb] [saucenao] [google] [report]

Just wanted to say a quick thank you to you guys, I had an old Lenovo Ideapad S205 that was pretty much unusable. I hadn't really used any other OS other than Windows and someone a few threads ago coached me through how install a lightweight Linux distro (Lubuntu) on it to give it new life.

It's like a new computer. I'm so happy. Thank you guys so much. I'm still learning, but it's really a pleasure to use.

Thanks again, you guys are great.

>> No.60621478
File: 133 KB, 264x338, 1482107187737.png [View same] [iqdb] [saucenao] [google] [report]

I'd just like to interject for a moment. What you're referring to as Linux, is in fact, GNU/Linux, or as I've recently taken to calling it, GNU plus Linux. Linux is not an operating system unto itself, but rather another free component of a fully functioning GNU system made useful by the GNU corelibs, shell utilities and vital system components comprising a full OS as defined by POSIX.

Many computer users run a modified version of the GNU system every day, without realizing it. Through a peculiar turn of events, the version of GNU which is widely used today is often called "Linux", and many of its users are not aware that it is basically the GNU system, developed by the GNU Project.

There really is a Linux, and these people are using it, but it is just a part of the system they use. Linux is the kernel: the program in the system that allocates the machine's resources to the other programs that you run. The kernel is an essential part of an operating system, but useless by itself; it can only function in the context of a complete operating system. Linux is normally used in combination with the GNU operating system: the whole system is basically GNU with Linux added, or GNU/Linux. All the so-called "Linux" distributions are really distributions of GNU/Linux.

>> No.60621538

Yep done apt-get update and apt-get upgrade

No good

>> No.60621850

Anyone using Ubuntu Budgie?
Seems like the panel only ever works on the top. If I move it to the bottom it spazzes out. The menu appears at the top for a split second and sometimes it just crashes and disappears.

Other than that it seems alright. I was using Openbox and tint2 before so I kind of miss the customization though.

>> No.60621865

It safe browsing Tor pages in a virtual machine using Devuan?

>> No.60622054


Git is not Github.

>> No.60622079

I need a distro that does the following:
- Binary (so no gentoo)
- Lets me install kernel sources from package manager for easy upgrades
- Has up to dates packages (thus no Debian, even Sid took two years to get neovim)
- Won't break if I spend three months without updating (thus no Arch)

Does such a distro exists?

>> No.60622111


>> No.60622154
File: 23 KB, 771x318, screenshot_2017-05-28-09:34:23.png [View same] [iqdb] [saucenao] [google] [report]

Thanks for the recommendation anon but I think I'll pass...

>> No.60622161

Relax, it's still a work in progress

>> No.60622178

Apparently they're still shipping iceweasel even though debian decided to kill the project. I'm really not sure the devs of this distro can be trusted.

>> No.60622309

r u stupid

>> No.60622313

Did you install the 32-bit driver? Honestly, you should be using PlayonLinux for Wine as it makes things so much easier

>> No.60622315

No but you must be for recommending a shit distro.

>> No.60622344

hello friends I am new to linux. I had a windows install, then I installed debian, but I don't like how all the packages are outdated. Should I remove debian completely before installing something else, or should I overwrite it? How would I go about removing grub and debian? I still want to boot into windows

>> No.60622349

Just get Archbang/Arch anywhere, manjaro/antergos are bloated as fuck

>> No.60622360

>FOSS distribution endorsed by fsf
try again

>> No.60622366

>Devs can't even get their https certs right
>Doesn't do anything new
>Somehow the distro isn't shit

>> No.60622373

is sudo a security concern? ive always just used su and kept my sudoers list empty

>> No.60622459

stop using su

>> No.60622470

Is grub the best bootloader?

>> No.60622471

>new to linux
> but I don't like how all the packages are outdated.
simply upgrade

>> No.60622489

install gentoo

>> No.60622491

I think you misunderstand. I am very familiar with GNU. I am just new to the Linux kernel

>> No.60622515
File: 53 KB, 620x521, 1490426576593.jpg [View same] [iqdb] [saucenao] [google] [report]

The expression “the Linux kernel” can easily be misunderstood as meaning “the kernel of Linux” and implying that Linux must be more than a kernel. You can avoid the possibility of this misunderstanding by saying or writing “the kernel, Linux” or “Linux, the kernel”.

>> No.60622522

gentoo is a meme

>> No.60622537

>everything is a meme

>> No.60622549

>I have never installed ganoo srash lincucks
>when I need gan ew slash linukks installed I just ask somebody else to install it for me

Where can I find somebody else to install ganoo slash linus for me?

>> No.60622551

how to pronounce systemd?

>> No.60622563

For security reasons preferable silent.

>> No.60622571

Memetato is ameme

>> No.60622576

nice meme

>> No.60622583


>> No.60622586

its a meme

>> No.60622608

Is void a meme?

>> No.60622637

>ffmpeg output now clears itself and only occupies one line, instead of printing it continuously


>> No.60622905

>Lets me install kernel sources
So what now, binary or source-based?

>Has up to dates packages
>spend three months without updating
So what now, do you care about up to date packages or not?

Make up your mind about what you really want first.

>> No.60622913

>binary or source-based?
wat, what do you think a binary made of?

>> No.60622937

>So what now, binary or source-based?
Both. You know that's possible, right? Gentoo is mostly source based but offers a few precompiled binaries. Debian is mostly binary but you can choose to install from source too.

>So what now, do you care about up to date packages or not?
I care about both. I'm currently running gentoo and I can spend months without updating. Then I do an emerge --update and everything is pulled directly from upstream without breaking.

>> No.60622946

They should leave it broken to filter out more retards like you.

>> No.60622958

>Devs litterally can't into https subdomains
>Somehow I'm the retard

>> No.60622960

It always did for me, until I accidentally resized the window too narrow to contain the line

>> No.60622993

I've seen no distro that does both well though.
And no, you don't care about being up to date if you only update once in 3 months.

>> No.60623019

>I've seen no distro that does both well though.
Me neither, that's why I'm asking if I missed somemthing.

>you don't care about being up to date if you only update once in 3 months
Yes I do. For example when Neovim was created I cared about running Neovim and Debian took a long ass time to add it to their repos. When neovim got lua integration I cared about having it right away too.

>> No.60623052

Trying GNU/Linux for the first time (on vm).

Feels good :')

>> No.60623060

How do I write my own kernel? I want to replace linux

>> No.60623065

A'ight, I'm on Ubuntu and just about to kill myself. I just got through waiting for the power to come back after a two hour power outage and as soon as I got back on my PC there was no sound. Yes, everything is unmuted on Alsamixer and Auto-Mute is disabled. Tried to hop on a DE as opposed to my autistic WM to see if any GUI settings menu there could be of any help. Sound appears to be muted and can't be un-muted while my DAC isn't even detected. Fuck my ass.. Any ideas?

>> No.60623073


You can install a program without using the repos.

>> No.60623077

And then I have to keep track of it separately. It's better if my package manager takes care of every single package of my system for me. Like it's supposed to.

>> No.60623078

psst, Anon, that was our little secret

>> No.60623092

thats retarded and you should feel retarded.

>> No.60623095

Commit Sudoku

>> No.60623105

The most important part is to give it a cool name, like "Linux", just that this one is already taken so you'd need an even better one.
Good luck with that.

>> No.60623106

Learn ASM then head to http://wiki.osdev.org/Main_Page

>> No.60623120

By this point I might as well to be perfectly honest with you.

>> No.60623227

>should feel retarded

I already know I'm retarded, anon. Should you be telling others what they 'should' feel? Do you have such authority?

>> No.60623238

fuck you I'm programming my kernel in Java and you can't stop me
assembly is for losers

>> No.60623254

You won't be the first https://en.wikipedia.org/wiki/Phantom_OS

>> No.60623285

I'm trying to follow this guide:


But when I enter

vi /etc/apt/sources.list

I just get a long list of tildes. What gives?

>> No.60623307

I can't figure out NetworkManager. wifi-menu worked perfectly fine before but then I enabled NetworkManager and now it won't connect to the internet. Any help?

>> No.60623313

Are there any non drm games that are 3d and have decent graphics and are actually good? all i can think of is the witcher

>> No.60623315

I'll make the logo

>> No.60623337


>> No.60623338


Oooh, so that's why.

>> No.60623342

can linux run a 8k display?

>> No.60623343

>I just get a long list of tildes.
That's just what vi would do if you passed it an empty or non-existent file. Are you sure the file exists?

>> No.60623362

doesn't windows?

>> No.60623365

looks alright, how dead are the servers? seems like quake arena

>> No.60623373

Instead of blindly following some guide which is probably outdated anyway understand what they told you to change and adapt that to your system.

>> No.60623383

yeah but does that really answer my question

>> No.60623395

I just don't see why you don't think linux could handle 8k. But yes. it does.

>> No.60623404

beacuse of drivers and shit. even on windows, only a very limited GPUs support it

>> No.60623414


>> No.60623420

yeah i get games pretty often when i want. its completely free so download it and try it out

>> No.60623462

how up-to-date are ubuntus packages?

>> No.60623478

~5 years ago

>> No.60623499

ubuntu is based on debian, which is well known for outdated packages

>> No.60623500

In which case fuck it, I'm switching back to Windows. Screw getting buried under 5 layers of error messages every time you want to install a program.

>> No.60623509

enjoy ur botnet

>> No.60623527

Using Windows is an error itself.

>> No.60623617

Going from GNOME to KDE.

Which KDE should I get? Plasma or Neon.

Gonna do WEB DEV if that matters.

>> No.60623641

install arch with i3

>> No.60623644

>Gonna do WEB DEV if that matters.
Yes, that obviously totally matters.

>> No.60623664

this desu.

>> No.60623675

Plasma vs. Neon guy here.

Looking for the simplest, most efficient choice.

>> No.60623689
File: 514 KB, 1300x1000, wacom.jpg [View same] [iqdb] [saucenao] [google] [report]

Im using a wacom tablet for art, it has 4 buttons on it (2 top l, 2 top r). It works surprising well without any propietary drivers, even the pressure on the pen works, but i cant figure outt how to get the bottons working. Anyone know how without any propietary drivers?

>> No.60623713

arch + i3

>> No.60623725

both are useless.why these specific ones?

>> No.60623733

why do you need those goddamn buttons? theyre in the most awkward spot for either hand, dont you just put your other hand on your keyboard?

>> No.60623761

See if by any chance they send keyboard or mouse events. Run "xev", make sure to keep focus on the little window that pops up, and press those buttons. In the terminal you should see any such events showing up - take your time and press keyboard keys and mouse buttons (inside the window) to get used to the expected output.

If events show up, it shouldn't be hard to map them to whatever actions you fancy. If xev remains silent, though, that simply means X isn't seeing anything, but maybe your kernel does and they can still be used without any further drivers.

>> No.60623763

What are they even supposed to do?
Something on the system - See in you can bind the keycodes to whatever functionality you want.
Something on the tablet itself - Probably won't work without driver support.

>> No.60623778

It looks very interesting and cool desu, but customizing it would take a lot of time and effort.

I like its style.
I promise to try it when I finally have time.

Now plasma or neon?

>> No.60623918

KDE Plasma is the full name of the DE.
Neon is a distro, it's Ubuntu LTS with the latest KDE packages slapped on.

>> No.60623928

no, i place my tablet where my keyboard would go, theyre fast from new layers and editing (undo, redo, switch to pen

nothing unfortunately.

theyre usually binds

>> No.60624027

better thread quality pls

>> No.60624044

this never helps.

>> No.60624053

fglt really has become another shitposting general, nearing sc2 levels. I blame the inane speed of the board for the reason. It used to go ages without posts but now it needs shitposts to survive

>> No.60624059

Install Arch and i3 my son.

>> No.60624090

what is the best gentoo? gentoo or funtoo?

>> No.60624118

Gentoo is fun, too.

>> No.60624154

I have no idea what funtoo is. What exactly is the different?

>> No.60624169

>nothing unfortunately.
You're not completely out of luck yet. Try showkey -k or showkey -s - you will most likely need to run these in text mode, read up on how to switch to a virtual terminal (and how to come back). If something shows up, you can use setkeycodes to map them to something useful. This is a rather confusing area for me, but back when I was new myself I managed to make enough sense of it to map my laptop's special keys, so be confident and read the manpages.

If nothing shows up with those commands either, which I think is the most likely scenario, your next hope is that someone has already done the dirty work for you. I see that tablet is wireless, but does it have its own USB receiver? If so, run lsusb to find its unique device identifier (in the format "dead:beef"), then use that identifier to search the tubes. Maybe someone has figured out how to make it work or even written a driver.

If it's bluetooth or something, I don't know how to obtain a similar identifier, so just search whatever.

>> No.60624175

new thread when? :3

>> No.60624179

after meme limit

>> No.60624190

What's the best DE to use with i3wm?

>> No.60624214

Maybe some GNU/Linux guy can answer my question.

>I'm a first time Linux user
>I installed Ubuntu 16.04.2 LTS

When I place a file on my Unity desktop it won't show up.
Howewer the file is present in the Dektop folder.
How can I fix that?

>> No.60624218

>with i3wm

>> No.60624229

Sometimes I like to look at a desktop background that isn't solid black

>> No.60624244

pretty sure you can still have wallpapers in i3

>> No.60624255

i actually dont have the wireless module for it so i run it off a usb (wacom charge something like $50 for the wireless "kit"). Looking into showkey now

de;s are designed to have interchangale components so it is possible

none, just build your own de.

>> No.60624299

-> >>60624294

>> No.60624348

thank you

>> No.60626368

You should use Drivedroid android app and prioritize USB FDD. Press F12 to force the boot manager to show the ISO as some lenovos have broken boot order (that resets after shutdown).

Secureboot must be disabled.
Don't use Legacy boot.
UEFI boot should be preferred these days because most distros come with Grub efi.

Idk about antergos though. I think it came with gummiboot before and it's not recommended and slow as fuck. Go full arch or use the revenge/architect installer.

Name (leave empty)
Comment (leave empty)
Password [?]Password used for file deletion.