Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

2017/01/28: An issue regarding the front page of /jp/ has been fixed. Also, thanks to all who contacted us about sponsorship.

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 833 KB, 731x512, 1464568324574.png [View same] [iqdb] [saucenao] [google] [report]
55007807 No.55007807 [Reply] [Original] [archived.moe] [rbt]

Previously on: >>54991636

Welcome to /fglt/. We are always open to users of all levels, including absolute beginners.

There are four ways to try GNU/Linux, you can:

0) Install a GNU/Linux OS on a VM (Virtual Machine/VirtualBox) for "safety purposes"
1) Use the Live ISO directly without installing anything, that way, you can get a "full GNU/Linux experience".
2) Dual-boot GNU/Linux with Windows/Mac (recommended if you want to learn more about GNU/Linux)
3) Go balls deep and overwrite everything with GNU/Linux

Before asking, please search for answers to your questions in resources.

Please be civil, notice the "Friendly" in every Friendly GNU/Linux Thread.

Understand that much of your software from Windows will be unavailable, although maybe WINE can make up for it.

IRC connection details:
Server: chat.freenode.net:6667 (no SSL, 6697 for SSL) - Channel: #flt
If you don't have an IRC client (which you should), go to https://kiwiirc.com/client/irc.freenode.net/flt to use IRC on a web client.

Visit the Friendly GNU/Linux Thread/Website:
http://fglt.nl/

Resources:
man <insert command here>
Your friendly neighborhood search engine (searx.me, ixquick, whatever)
https://wiki.archlinux.org/ (Most of the configurations and troubleshoots will work on various distros, including Debian)
https://wiki.installgentoo.com/index.php/Category:GNU/Linux
https://wiki.installgentoo.com/index.php/Babbies_First_Linux
https://prism-break.org/en/categories/gnu-linux/
http://linuxcommand.org/tlcl.php
https://www.gnu.org/

>> No.55007822
File: 282 KB, 731x512, 1.png [View same] [iqdb] [saucenao] [google] [report]
55007822

>>55007807
your .png is now optimized

>> No.55007824

>unironically using Linux
ISHYGDDT

>> No.55007842
File: 427 KB, 1250x802, 1461386631319.jpg [View same] [iqdb] [saucenao] [google] [report]
55007842

Original here: http://www.gnu.org/graphics/gnulove.en.html

>> No.55007861

>>55007824
>unironically not using Linux
ISHYGDDT

>> No.55007870

>>55007824
why not? it just works, it's nice.

>> No.55007883

http://www.openbsd.org/lyrics.html#43

>In 1998 when a United Airlines plane was waiting in the queue at Washington Dulles International Airport for take-off to New Orleans (where a Usenix conference was taking place), one man stood up from his seat, demanded that they stop waiting in the queue and be permitted to deplane. Even after orders from the crew and a pilot from the cockpit he refused to sit down. The plane exited the queue and returned to the airport gangway. Security personnel ran onto the plane and removed this man, Richard Stallman, from the plane. After Richard was removed from the plane, everyone else stayed onboard and continued their journey to New Orleans. A few OpenBSD developers were on that same plane, seated very closeby, so we have an accurate story of the events.

How does /fglt/ feel about this?

>> No.55007920

>>55007883
>http://www.openbsd.org/lyrics.html#43
what is this? autism central?

>> No.55007965

>>55007920
They always do a song for fun each release and usually include some commentary.

>> No.55008036
File: 15 KB, 480x360, LinusTor.jpg [View same] [iqdb] [saucenao] [google] [report]
55008036

>>55007883
>>55007920
>>55007965
based, only unironic communists shill for Stallman

>> No.55008038

>>55007965
I am talking about the comics and the stuff they assume. rms is an atheist or at least agnostic, so no "god given role", they quote the four freedoms in a wrong way to push their agenda, they also said nothing about the context of this incident in 1998 (assuming that it actually happened). they also say he lies to the public without any sort of proof.
now move to some other thread and try "trolling" there, this just doesn't belong here.

>> No.55008075

>>55008038
I only asked what /fglt/ thought of it because it directly relates to stallman.

>> No.55008102

>>55007883
Today's BSD community should be thankful. Without RMS beeing annoying back in the 80s, BSD would still be proprietary trash. BSD and GNU were friends and worked together at the beginning. You can see this in many referenced code and programs on todays's GNU/Linux systems. I don't understand how the BSD community converted into such a bunch of butthurt people.

>> No.55008122

>>55008036
>media getting shit wrong
what about alan cox? what about everyone who contributed to Linux? what about the people who contributed to GTK, Qt, GNU, X...?
calling Linus torvalds the creator of the "Linux operating system" is like calling Steve jobs the creator of BSD.

>> No.55008141

>>55008122
Do you want me to make a collage?

>> No.55008144

>>55008102
>I don't understand how the BSD community converted into such a bunch of butthurt people.
it's the same everytime
people can't stand critics, they take critic as insults and need to "fight back"
same with people who call it "linux" instead of "gnu/linux", they feel insulted and start hating rms for he is the root of the word

>> No.55008156
File: 122 KB, 625x626, bait4.png [View same] [iqdb] [saucenao] [google] [report]
55008156

>>55008122

>> No.55008185

>>55008156
>can't argue
>better call it b8

>> No.55008275

"It doesn't really _matter_ what people call Linux, as long as credit is
given where credit is due.
Personally, I'll very much
continue to call it "Linux"
-- Linus, while fapping in 1996

>> No.55008345

So I gotta ask because I put Xubuntu on a system with a haswell processor which has integrated intel 4600 hd graphics.

Is this iGPU so shit it can't do 1080p at 60fps on youtube or am I doing something wrong? I'm using compton as a compositor because otherwise, tearing and shit.

>> No.55008355

>>55008275
>Guy creates linux kernel, the "key stone" of the new operating system, tying together all other parts
>Distributions are created, all referring to the OS by what most deem the most important part, "linux"
>RMS feels upset, brings about a campaign to get all distros to change names to "GNU/Linux" as it is more correct
>Not only does he want them to change the names though, he also wants them to pretend like they have always been called "GNU/Linux" since day one

I don't mind the official naming being changed to suit his autism, but the requirement that everyone pretend that it's the *only* name and has always been that way is off the spectrum.
People are going to continue referring to it colloquially as "Linux" until the heat death of the universe, deal with it.

>> No.55008373

>>55008355
where did he say that? please provide context.

>> No.55008390
File: 184 KB, 650x700, 1442532417928.png [View same] [iqdb] [saucenao] [google] [report]
55008390

>>55008355
>Guy creates linux kernel, the "key stone"
OK, kid.

>> No.55008455
File: 50 KB, 960x540, 12670803.jpg [View same] [iqdb] [saucenao] [google] [report]
55008455

Newfag here.
How can I make my home folder accessible in the home network?

>> No.55008492

>>55008390
A chair without legs is no more a chair than a pile of bricks is a house.
FSF wanted to make their own complete OS, saw that Linux made the kernel quite quickly and thought "well shit, it can't be that difficult, let's just finish it".

They then realised that they were too stupid to finish their own kernel, got upset, and wanted to plaster their name over a project they were literally unable to finish.

>>55008373
http://www.oreilly.com/openbook/freedom/ch10.html
https://lkml.org/lkml/2003/1/12/55

Is that enough to satisfy you, my good man?
RMS didn't go after the name until linux blew GNU out of the water, and their own attempts failed hilariously.

The FSF is no better than patent trolls.

>> No.55008588

kek:
>Everybody loves freedom, and GPL is freedom so everybody loves GPL. In recent years there has been a disturbing trend of typos in software license headers, people accidently write BSD or MIT or even Apache (the letters are like right next to eachother). Since we know they are reasonable individuals who love freedom just like us, we know they will love our help in fixing their accidental typos with this shiny new script.
https://github.com/cjdelisle/fixlicense

>>55008492
go home bait

>> No.55008602

>>55008390
Linux is widely used without GNU.

>> No.55008608

>>55008355
RMS was swagging the tech when Linus was still shitting in his pants, bro.

>> No.55008625
File: 208 KB, 630x421, 1446507316903.jpg [View same] [iqdb] [saucenao] [google] [report]
55008625

>>55008602
Embedden in toasters and dishwashers, yes.

>> No.55008636

>>55008492
>I think we started in 1994 (although mostly privately until 1996).
>While some viewed descriptions of Linux as a "variant" of the GNU Project as politically grasping, Murdock, already sympathetic to the free software cause, saw Stallman's request to call Debian's version GNU/Linux as reasonable. "It was more for unity than for credit," he says.
next time use a source that supports your claim
>it turned out that debugging these asynchronous multithreaded programs was really hard.
kek

>> No.55008647

>It's the Linus vs RMS time of the day.
Stop being retarded faggots, if you're insecure, read about the history of GNU and Linux and educate yourself. "Hurr durrr you're wrong." leads to nothing.

>> No.55008667

>>55008455
Bump

>> No.55008685

>>55008667
which OS needs to access it? if it should be compatible, use samba.

>> No.55008702

>>55008685
Linux to Linux. What I want is something like windows' network drive embedded into my thunar

>> No.55008713

>>55008647
>Stop being retarded faggots, if you're insecure, read about the history of GNU and Linux and educate yourself.
Agreed.
>"Hurr durrr you're wrong." leads to nothing.
Well, it's important. Most people think their OS was made by a student just for fun, while historically it was made by RMS so people can have a free operating system. Both, Linus and the GNU project made an incomplete OS, thrown together it's GNU/Linux, the perfect ground for political discussions, but it simply isn't Linux, since Linux is just a part of the OS.

>> No.55008720

>>55008702
>Thunar
surely you mean pcmanfm senpai

>> No.55008741
File: 144 KB, 268x336, CMON.png [View same] [iqdb] [saucenao] [google] [report]
55008741

>>55008720
>mfw it replace f a m with dweebshit
ok that's it im quitting posting on 4bongz

>> No.55008785

Should I replace XFCE with KDE.

It just seems like a way more complete/professional experience than all the other options. I hated how it looked in the past, but the newest version looks slick as fuck. I know it has a reputation for being bloated, but does that really matter anymore in >CURRENT_YEAR ?

>> No.55008786
File: 1.42 MB, 2311x1730, 1462584742355.jpg [View same] [iqdb] [saucenao] [google] [report]
55008786

>>55008720
>>55008702
>using a graphical file manager

>> No.55008802

>>55008786
Fuck off

>> No.55008809

>>55008785
straight sway cunts use unity

>> No.55008829

>>55008809
>straight sway
wot m8

>> No.55008832

>>55008785
KDE is better only if you are using their latest releases.

KDE is the fucking best

>> No.55008846

>>55008713
Is it important how distros label things, and the nomenclature used by technical documentation?
Yes, of course.

Is it important how people informally refer to the operating system?
No, not at all, yet this is what seems to rustle your jimmies so hard.

Nobody runs around screaming
>You can't call it just windows, it's Microsoft™ Windows
>Calling it windows is confusing because windows is already a term for applications are displayed graphically

Everyone manages to get around that "confusing" matter just fine, so when someone calls it Linux and the context makes it 100% clear that they mean an OS and not a kernel, you have no reason to complain.

The interjections are a meme, but they're also not, a lot of FSF followers really are that autistic, and we're not going to pander to their requirements.

>> No.55008857

>>55008785
GNOME>KDE imo. xfce only makes sense if you pair it with a tiling WM or if you got a shitty computer and can't handle anything more minimal.

>> No.55008871

>>55008785
kde is the best desktop environment with version 5.6.4. Stable, fast and feauture rich. There also is the papirus suite which makes it look really good.I for one use gnome since I gotten used to it and I like the headerbars and modern feel to it. On my desktop I've gotten rid of gtk2 and 3 and only use qt since it's a beast of a toolkit.

>> No.55008877

>>55008846
>we're
fuck off to reddit

>> No.55008895

>>55008857
I use gnome on my laptop. I dont understand the hate it gets. It uses minimum config files and looks modern as fuck and can be extended with extensions. It also has the best integration with owncloud and dav. I use gnome-calendar/contacts/todo with geary mail and feedreader.

>> No.55008904
File: 95 KB, 1366x545, 1460774047779.png [View same] [iqdb] [saucenao] [google] [report]
55008904

>>55008857
>>55008895

>> No.55008924

>>55008895
i use a lot of gnome software myself even if i am on dwm, there is some really good stuff in gnome, i just don't need most of it.
>>55008904
what are you trying to say?

>> No.55008925

>>55008871
>papirus suite
Tell me more

>> No.55008926

>>55008846
>100% clear that they mean an OS and not a kernel,
You think that the Linux OS and the Linux kernel are two different things? But that's wrong! A kernel is an operating system; if you refer to Linux, you're always referring to the kernel. The problem is that people don't use the kernel alone, since it's only a part of GNU/Linux. The other parts come from the GNU project, which itself is also an operating system and actually the root of everything, with Linux (or any other kernel) on top of it. Also, naming like Windows or OS X doesn't work with free software, where many people put together their projects to create something complete: You can't tell a Debian GNU/kFreeBSD user that he is using "Linux".

>> No.55008935

>>55008924
Saying that GNOME has no features even though it is the heaviest gtk DE

>> No.55008938

>>55008925
https://github.com/PapirusDevelopmentTeam
Theme for everything in plasma. I use it on my desktop and it looks pretty good.

>> No.55008956
File: 45 KB, 640x960, qt66.jpg [View same] [iqdb] [saucenao] [google] [report]
55008956

>>55008829
http://www.urbandictionary.com/define.php?term=Sway
http://www.urbandictionary.com/define.php?term=Straight

keep it 100 lad

>> No.55008990

>>55007474
There are trams everywhere at any time you almost don't need a car.
I come from Portugal

>> No.55008993

>>55008857
DELETE THIS

>> No.55009007

>>55008877
Nice quad-dubs.

Also, if my usage of "we're" is the only thing you can point out, the rest of my argument must have been pretty solid, thanks for acknowledging it.

I know not everyone agrees with the sentiment, but it's a lot more than just me, so I used a plural term.
This is a perfect example of informalities rustling FSF jimmies on a daily basis, because of pure autism.

Don't expect the world to change for your convenience, you must change for it, or face ridicule.
Your freedom of speech is not more important than my freedom to laugh at you in return.

>>55008926
Your reading comprehension is poor. If someone uses a term in place of another, it doesn't mean they think those things are identical.
Nobody is advocating for formal names or documentation to refer to the OS as "Linux", some of us would just like to use the term informally without getting you autists assblasted every 5 minutes.

My point is, if someone says "linux" but it is clear from the context they mean "GNU/Linux", there is no problem.

Much like how Americans refer to their favourite sport as "football" even though the game has very little to do with feet compared to hands, and is played with an ovoid shaped object distinct from a classically defined ball.

You're allowed to be pedantic when it matters, but not when it doesn't, unless you don't mind being frequently laughed at for being "that guy".

>> No.55009028

>Thread spammed by anti-GNU cuckolds

If you don't like it go fucking make your own thread you pieces of shit

>> No.55009045

>>55009028
This

>> No.55009117

>>55009028
>Just make your own thread :^)
>GNUtards totally wont come in and shit the place up with links to the __real__ GNU/Linux thread every 5 fucking minutes, and report it for being off-topic

We've played this game before.
Reminder that the /flt/ thread was a linux thread until you autists made your own site, and then demanded that everyone else jump ship rather than just leaving the old one how it was in peace.

There are faggots on both sides of the argument, don't try to pretend your hands are clean.

>> No.55009132

>>55009117
I was here before /flt/ was a thing you fucking dipshit. Don't like it? Make a fucking /flt/ and fuck off

>> No.55009135

>>55009117
Upgrades usually come with bugfixes.

>> No.55009171

>>55009135
>My way is the right way because I say it is :^)

I like my freedom to not come with a dose of dictatorship, thanks.

>>55009132
See: >>55009117

Considering that RMS is such a grammatical pedant, you followers sure have terrible reading comprehension.

>> No.55009201

>>55009171
The one without reading comprehension is apparently you. What part of "fuck off" is hard to understand?

>> No.55009213

>>55009201
See: >>55009117

If anyone is going anywhere, it's (You).

>> No.55009235

what is the open source alternative for Guitar Pro?
and how bad/good is the spotify build for Debian

>> No.55009237

>>55009213
You are really trying hard to fit in, aren't you? Quoting self won't save you from your embarrassment.

>> No.55009258
File: 45 KB, 816x3242, 1448785124571.png [View same] [iqdb] [saucenao] [google] [report]
55009258

>>55008355
>Guy creates linux kernel, the "key stone"
Aight.

>> No.55009339

>>55009237
You really are trying hard to have the last word when you actually have nothing useful to add to the conversation :^)

There have been /flt/ threads in parallel with /fglt/ in the past, and they were shitposted out of existence by freetards.
Forgive me for not putting my hopes into your community having matured at all in the last 3 months.

>>55009258
RMS didn't work on GNU alone, there were hundreds on contributors. However, the amount of code that Linus himself is responsible for is enormous in comparison.
I'm not saying that automatically means it should be called one thing instead of another, but it should mean that Linus gets more say in the matter, as he is the one individual to have personally contributed the most out of anyone.

Things might be a little different if RMS wasn't so stubborn, and apparently allergic to other people's opinions.

If RMS truly cared about freedom, he'd let you call things whatever the fuck you want to, not what he tells you.

>> No.55009407

>>55008702
The linux way to do it (or maybe it is the unix way) is to use NFS (thats network file system) exports. Check man exports for details but is basically a list of /dir user(options for that user) where the user is an ip adress, range or machine name. NFS can be a cunt if you server is not going to be up the whole time then. The other way (apart from sshfs) is to use samba which generally "just works" better than NFS and also works natively with windows (with some occaisonal difficulties due to assumptions about authentication).

>> No.55009413

>>55008141
Yep

>> No.55009444

>>55009339
Linus didn't work on Linux alone either. His code makes up something like 3% of the kernel nowadays.

>> No.55009493

>>55009444
It's still the largest individual contribution, and by a long stretch.

Again, that doesn't give him automatic rights of any sort, but still, if you wanted a single person to represent GNU/Linux, it should be Linus and not Stallman.

Unless of course you would prefer a less than democratic system in place, like many freetards would prefer.

>> No.55009503

>>55009493
I don't want a single person to represent GNU/Linux. I just want GNU to get some credit too, instead of constantly being swept under the rug.

>> No.55009522

>>55008741
Off yourself instead

>> No.55009526

>>55009339
>nothing useful to add to the conversation
I am here with a question and because of your spamming it is pretty much unresolved. Please get out, I don't care what you think is true or false. Go make a thread about it as >>55009028 indirectly suggested

>> No.55009537

>>55008741
new? casual? summer?

>> No.55009621

>>55009526
>If I keep repeating "lel just make a gnew thread", it'll become a viable option

See: >>55009117 and >>55009339
Why do you believe that you are allowed to be stubborn and not accept that your idea is not going to work, but I must listen to your request?

Exactly the kind of mindset that makes people cringe when they think of the FSF, and exactly why Linus recommends the EFF instead.

>>55009503
Why do you care if normies don't know 100% of the back story about GNU/Linux? How does that affect you personally?
Why are you not also concerned with making sure that people thrown under the rug at Microsoft and Apple also get their recognition?

>> No.55009646

>>55009526
Which one are you?
>>55009621
Just.Get.The.Fuck.Out, Spammerfaggot

>> No.55009658

>install arch with architect
>install i3
>install chromium
>cursor is hueg when outside chromium window, while normal size inside it
what's going on?

>> No.55009675

>>55009658
Get a proper DE

>> No.55009691

>>55009675
why?

>> No.55009699

>>55009646
>My shitposting isn't spamming because I say it's not :^)

Your hypocrisy is ripe. You don't get to silence people because they disagree with you, this isn't reddit friendo.

>> No.55009726
File: 258 KB, 860x640, setting.gif [View same] [iqdb] [saucenao] [google] [report]
55009726

>>55009691
Because it has proper controls

>> No.55009735

>>55009658
Sounds like DPI fuckery because of a >1080p monitor or something.

>> No.55009767

>>55009699
>Disagree
Yeah you are the one who got his SJW syndrome triggered to see GNU in this thread. Mad that /fglt/ caught on?

>> No.55009833
File: 2.79 MB, 300x252, bait.gif [View same] [iqdb] [saucenao] [google] [report]
55009833

>>55009767
>Shitpost other threads until they no longer exist
>Call other people SJWs

Pandering to autists will do this board no good, just because it's not your problem yet doesn't mean it wont be later.

>> No.55009863

>>55009833
>Shitpost other threads until they no longer exist
Yeah you are trying that as well.

The only difference is you are not being taken seriously. Stay salty, SJW cuck

>> No.55009877

When I press backspace Firefox does not return to the last page. Has anyone encounter this before? I am on Xubuntu 16.04.

>> No.55009889

>>55009877
set browser.backspace_action to 0

>> No.55009978

Love the OP pic.

I just installed Debian Jessie in a laptop with W8.1, UEFI and all that crap. When I was changing the boot order so it would boot the LiveUSB, the USB showed as two: one of them preceded by "UEFI", but I went with the other option.

Quick question: should I reinstall with the other option? Will it work then? Or I would waste my time and some later tweaking is needed. Fuck M$.

>> No.55009980
File: 44 KB, 720x599, Triggered.jpg [View same] [iqdb] [saucenao] [google] [report]
55009980

>>55009863
There is no alternative thread, I am not directing anyone to anywhere.
And so far, either nobody has reported me or the mods don't seem to consider my posts as "shitposting" any more than yours are.

You can try telling the boogeyman to leave the room, but you might just have to hide under the blankets until morning when he doesn't listen.

If I had it my way, people would get their posts removed for trying to tell anyone how they should refer to the OS, whether that is "Linux" or "GNU/Linux".
The point is it should be the user's choice, not the FSFs choice forced onto them pretending to be any sort of freedom™.

>> No.55009994
File: 60 KB, 500x500, 1464036169213.jpg [View same] [iqdb] [saucenao] [google] [report]
55009994

>>55009999
>>55010000

>> No.55010111

>>55009978
You should install with UEFI if you intend to use UEFI-only features like quick booting, etc.

>> No.55010115

>>55009980
The users have spoken. It's /fglt/ and that's why there is no alternative thread (since they get deleted)

>> No.55010157

>>55010111
I don't care about it. I just want to get the grub prompt instead of booting directly to windows.

Reinstalling won't solve that problem then?

>> No.55010175

>>55010115
That's the great thing about imageboards, the userbase is changing all the time :^)

That's why it's important to not make the mistake of assuming that every new user has the same braindead cult mindset as yourself.

Indoctrination is the job of the Catholic church, let's leave it to the professionals bud.

>> No.55010233

>>55009980
>The point is it should be the user's choice, not the FSFs choice forced onto them pretending to be any sort of freedom™.

You still don't get it: Feel free to call actual dogshit horseshit instead, but don't get mad when people interject you and tell you that you're wrong. dogshit is dogshit and it doesn't matter if you don't like the word. You could even call dogshit "double whopper", but don't be mad when people are laugthing at you.

>> No.55010269

>>55010233
>Don't laugh when the autists demand you dance like a monkey

But I can't help it.

>> No.55010278

>>55010157
it depends on whether you installed grub or grub2

if you installed grub2 it should be able to boot windows, but my guess is that your distro installed grub by default when it was booted via mbr

>> No.55010291
File: 197 KB, 3000x1688, maxresdefault.jpg [View same] [iqdb] [saucenao] [google] [report]
55010291

>>55010175

>> No.55010313

I'm using a PNY USB 3.0 128 GB stick to try and maanufacture a bootable USB key.
However, I can get it to boot once, after which the GRUB goes missing and I get an alert to insert a bootable media.

I've tried with Debian, Ubuntu, and Knoppix, using Unetbootin, live disc to install, desktop install, and YUMI.

When i try to partition from USB FDD to Multi USB HDD, I get an error when writing to volume, "write protected" poking through the command line does not help, I can take disk control, but not volume.

Attempts to partition in installation fail, and SATA internal over USB 3.0 has taken an excess of 24 hours for a debian install.

Are PNY sticks boot locked and for storage only?

I was reading a notice that said bootable media is locked to 32 Gigs or less.
Testing with PNY USB 2.0 8 gig sticks works fine, but results in frequent hangups due to the much smaller data pipe.

>> No.55010381
File: 69 KB, 1000x576, keyboard-9647.jpg [View same] [iqdb] [saucenao] [google] [report]
55010381

Remapping keys in X is quite painless with the help of xmodmap, I set up my caps lock key to behave as a hyper modifier key and it feels liberating to have a modifer+key combo that's essentially guaranteed not to be used already.

However I would like to take it a step further and fiddle directly with lower level systems, to have the caps lock interpreted directly as a hyper key, so that I could have it in the tty for example. What would it take, /fglt/? How far down do I have to go?

>> No.55010478

>>55009980
Well yes, let's pretend it's "Just Linux", Linus' succsessful "Open Source" hobby project, which aims for market share world domination by taking over Microsoft. kek

>>55009978
>Love the OP pic.
This. We need to calm down and accept that GNU/Linux is a project made by different people with different views, but all these people are working together to create something amazing.

In my opinion, GNU/Linux is a neutral name, which is (technically) more correct than "Linux" or "GNU" anyway.

>> No.55010489

>>55010157
What is the problem exactly? Also I am quite sure it is possible to convert a mbr partition table to gpt and do anything else that is required (re install grub in UEFI config?) without having to re-install your distro.

>> No.55010500

>>55010115
>The mods have spoken. It's /fglt/ and that's why there is no alternative thread.
FTFY

>> No.55010516

>>55010478
Since this is 4chan, I guess those just-linux people are just trolling/baiting out of boredom.

>> No.55010546

>>55010313
>I was reading a notice that said bootable media is locked to 32 Gigs or less.
I have no idea but seeing as you said it worked once already that doesn't sound likely. You could always try partitioning the usb drive. Also, maybe you bios is fucked.

>> No.55010558

>>55010516
confirmed

just check out that "pedophile neckbeard" pasta that appears every other thread

>> No.55010578

>>55010558
>anons, rms isn't even a real DR.!!!

>> No.55010625

I need help please. I have a folder containing over 10,000 files and i want to move all the files to folders grouping the files into folders holding 100 files each. How can i accomplish this using the terminal with bash shell or is there some software that would do this for me etc. Please help anons

>> No.55010737

>>55010546
Multiple computers were tried, UEFI and normal, it would boot once and then hang loading gnome or xserver.

Attempts to partition with bootice and the installation menu resulted in failures and unrecognized partition tables.


Closest I can figure is the firmware is disabling repartition permission in the stick proper, but that doesn't work since I can still get the one boot on a separate computer before fuckup.

>> No.55010772

>>55010278
It's Debian Stable (Jessie), so I don't know. How do I install grub2?

>>55010489
>What is the problem exactly?
The installation process went fine, but when it rebooted it booted directly to windows. No grub boot screen whatsoever. I don't mind reinstalling (it took me 20 minutes even with my dog distracting me), but I'd like to avoid messing with the partition table.

How do I solve this?

>> No.55010779

>>55010381
On debian there is the kbd package that provides an init script which runs

dumpkeys < /dev/tty1 | sed -f /etc/kbd/remap | loadkeys
I am using thes to remap control to compose on the text console. Here is the contents of my remap file:
# This sed script is run across the dumpkeys output to remap keys on the console
s/keycode 58 = Caps_Lock/keycode 58 = Compose/;

Don't know if you can map to a modifier there but it could be somewhere to start.

>> No.55010797

>>55010291
>Having irrational beliefs is fedora.
A meme born from the lack of a proper rebuttal. I love it.

>> No.55010817

>>55010797
My bad.
>Not giving credit to irrational beliefs is fedora*

>> No.55010841

>>55010772
If you have changed the boot order in the bios to point to the usb drive (or whever grub is supposed to be) then it sure shouldn't be going to windows. Try both options (UEFI and legacy) in the bios and if neither of them work ... reinsall I guess. Or go ahead and just install grub on the windows drive too.

>> No.55010877

I'm learning how to use here documents at the moment... Seems cool, but am I going to have to learn 'ed' commands?

I was trying to send commands to vim but it kept giving input errors.

>> No.55010880

>>55010625
Maybe not the best way, but try this:
Create a directory called "part_1/" inside the directory where your 10,000 files are in.

>10000files/part_1/

move into 10000files

run this:
for i in $(find . -type f | head -n 100); do mv "$i" "part_1/"; done

Then create part_2 and run the command again, repeat 10 times.

Replace "mv" with "echo" to preview what would happen.

>> No.55010901

>>55010817
>>55010797

is summer over

>> No.55010966

>>55010381
xev,xmodmap,xbindkeys

>> No.55010987

>>55010880
Or even more comfy (untested):

for d in {1..10}; do
mkdir "$d"
for f in $(find . -type f | head -n 100); do
mv "$f" "$d"
done
done

>> No.55010988

>>55010880
Thank you so much anon i really appreciate the help. Works like a charm

>> No.55011029

>>55010987
Whoa, yes this is so much better. Thank you, works really well its almost done

>> No.55011070

>>55010841
Sorry. I expressed myself poorly. I modified te bios to point to the LiveUSB for installing Debian. It's there that the two options (uefi and standard) showed up. I booted the regular one, installed correctly, put grub in the only hard drive and rebooted.

But then it went directly to windows. My initial question was: Should I reinstall Debian with the 'uefi' option of the LiveUSB?

And, important. It seems that the Linux OS isn't even showing in the bios, though I'm going to recheck that right away.

If somebody has some ideas, throw them at me. I don't know what to try.

>> No.55011140

Who here is arch linux master race?

>> No.55011186

>>55011070
Yes. Confirmed. No Linux whatsoever in the bios boot options. I should try and reinstall with the 'uefi' option then?

>> No.55011188

>>55010381
>>55010779
>>55010966
Hello friendos. I've been having a problem related to this. I have swapped my caps lock and escape keys, yet, periodically something is resetting the keyboard layout and I have to swap them again. Any idea what might be causing this?

>> No.55011234

>>55011070
>>55011186
I'm googling properly now. Sorry for bothering you, pals. I'll report back whether I succeed or not.

>> No.55011286

>>55010877
>am I going to have to learn 'ed' commands?
Haha no, ed is obselete.
>I was trying to send commands to vim but it kept giving input errors.
Like what?

>> No.55011319

>>55010966
they said lower level than X...

>> No.55011341
File: 27 KB, 300x313, 1440994275361.jpg [View same] [iqdb] [saucenao] [google] [report]
55011341

should I install arch linux?

>> No.55011351

I want to use Linux for web dev. Which OS should I try?

>> No.55011366
File: 134 KB, 499x499, 1451607536886.jpg [View same] [iqdb] [saucenao] [google] [report]
55011366

>>55011234
Please avoid using the term “google” as a verb, meaning to search for something on the internet. “Google” is just the name of one particular search engine among others. We suggest to use the term “search the web” or (in some contexts) just “search”.

>> No.55011378

>>55011286
For ex.
#!/bin/bash

vim $1 <<!HERE!
G
o
- Tommy
:wq
!HERE!

exit 0


This gives me a warning that it's not from terminal then exits with an input error.

>> No.55011401

>>55011378
>!
found your problem

>> No.55011417
File: 154 KB, 556x5537, 1455085548653.png [View same] [iqdb] [saucenao] [google] [report]
55011417

>>55011286
>ed is obselete
ed is the standard text editor

>> No.55011459
File: 234 KB, 605x6812, 1441699546991.png [View same] [iqdb] [saucenao] [google] [report]
55011459

>>55011417
sed is the standard stream text editor

>> No.55011463

>>55011401
It's not an issue. The text (Beginning Linux Programming) I'm reading suggested doing that to avoid confusion. Removing them gives me the same errors.

>> No.55011473

>>55011351
debian

>> No.55011494

>>55011351
But the web is online anon.

>> No.55011497

>>55011366
But google is a word in the English language that means "to search for something using a search engine"

>> No.55011519

>>55011497
Gno.

>> No.55011583

I have a weird problem with Chromium on Arch Linux.

Any time an emoji or a japanese/chinese/korean glyph appears somewhere everything slows way the fuck down on my pretty powerful computer.

Examples of situations when browser freezes for a few seconds:
1) A tab with an emoji in its name makes ALL browser interactions lag like hell (opening/closing tabs, opening windows, etc.)
2) Omnibar suggestion with an emoji in it.
3) If a "recent tabs" list has an entry with an emoji in the title.

It's incredibly annoying.
Is there a fix for this issue?

>> No.55011601

>>55011519
Relax man, ill go get you a Kleenex and a Coke.
*brings you an off-brand cola and off-brand tissues*

>> No.55011612

>>55009621
FSF and EFF serve different purposes

>> No.55011691

>>55011612
Of course they do, that's why one of them has a real future, and the other will die off as soon as Stallman does.

Just imagine the day when some skiddie from Intel makes the same comment about Stallman's death that he made about Steve Jobs.

Many giggles will be had, and it will be a good day indeed.

>> No.55011711

>>55011583
Holy shit it gets worse with the number of emojis.
Test URL that slows even clean Chrome down: https://twitter.com/steveluscher/status/741089564329054208

It has emoji in the tab name so it even slows down tab switching. It takes my computer about ten seconds to load it as an omnibar suggestion.

>> No.55011792

>>55011497
your choice of wording strengthens a monopoly that lives of innocent peoples data. i hope you understand this.

>> No.55011808

>>55011583
does it work with firefox?

>> No.55011825
File: 60 KB, 600x526, 1458133479868.png [View same] [iqdb] [saucenao] [google] [report]
55011825

>>55011691
>it will be a good day indeed.

>> No.55011829

>>55011808
I don't have firefox, but I have no lags in luakit while displaying that page.
I'll test firefox and midori right away.

>> No.55011843

>>55011829
you could also test it in surf.

>> No.55011861

>>55010381
How do you map f13-f24 to ouse buttons.
I tried adding them in to open keycodes, but it isnt binding for some reason.

>> No.55011877

>>55011825
Now would you say the same about your cult leader, or would you let your biases cloud your judgement?

>Suppressing freedom is okay if Stallman says it's okay :^)

>> No.55011886

>>55011808
>>55011829
>>55011843
Midori lagged a bit, but I'm not really sure.
Firefox didn't appear to lag at all.

>> No.55011898

>>55011886
looks like it is a webkit issue then, you could report it or switch to firefox/icecat.

>> No.55011907

What group of packages do I need to install to build stuff from source in Fedora?

>> No.55011920

>>55011877
>using that smiley with a carat nose outside of [s4s] or google/NSA presentations

>> No.55011939

>>55011898
Eeeh, both sound like a lot of work. I was hoping it'd just be an issue in my configs somewhere. I'm still holding out hope.

>> No.55011941

>>55011378
Is calling vim with commands on stdin even a thing? Maybe you could try with -s scriptfile (or even -s - (for stdin))

>> No.55011999

>>55011941
pretty sure switching should be easy since they allow you to import bookmarks and stuff.
do you have custom settings in chromium? maybe you could reset it.

>> No.55012004

>>55011861
Are you using xbindkeys? What have you tried so far? You should be able to do something like:"xdotool click 2"
F12

>> No.55012064

>>55012004
Currently the mouse is using the home row numbers. I need to rebind them to f13-f24 because i need the numpad to be avalible at the same time.So i wanted to bind f13-24.

I've added
keycode 93 = f13
To the .Xmodmap. Where 93 is an open keycode via xmodmap -pke.
Xbindkeys is working fine, with all my other keybinds via media keys and launching other programs via keyboard binds. but it is picking up the buttons as mod2+ 1-9 and then the plus,end ,etc when i press the buttons on the mouse without any config.

>> No.55012081

>>55011941
googling it I found a source which mentions that vim has problems with terminal interaction.

http://www.tldp.org/LDP/abs/html/here-docs.html

I might be able to get away with using vi though.

>> No.55012102

>>55008345

You're a fool for going with Compton first, without doing minor research and trying the TearFree driver option.

>> No.55012186

>>55011366
Sorry, I was using Google, as much as it pains me. I'd like to use other search engine, but duck duck go couldn't even find a 4chan board even if I wrote "4chan g", so I couldn't use it for finding anything.

>> No.55012190
File: 14 KB, 1023x96, virtualization_extensions.png [View same] [iqdb] [saucenao] [google] [report]
55012190

I received this error when trying to virtualize in Gnome Boxes v 3.18, Ubuntu 16.04 running on a Thinkpad X220.

Has anyone encountered this? What bios settings must I change?

>> No.55012228

>>55012186
try searx

>> No.55012291
File: 48 KB, 1167x649, V8.png [View same] [iqdb] [saucenao] [google] [report]
55012291

>>55012228
Thanks for the suggestion anyway. I'm open to more of them.

>> No.55012295

>>55009235

TuxGuitar, I guess. No realistic sounds though, I think it only does MIDI synths.

>> No.55012300

>>55008832
>>55008871
Would you recommend a distro that ships with KDE? Or should I just stick with Arch?

>> No.55012366

>>55012190

Enable Intel's VT-d in your BIOS/UEFI.

>> No.55012382

>>55012190
>>55012366

>vt-d
I meant vt-x.

>> No.55012401

>>55012300

>apparently is using arch and has enough "experience" to know the answer to his stupid question
>still asking it

Something is telling me you're not really using Arch or any distribution. Booting into it once every fortnight to run "ls -l" doesn't count as using.

>> No.55012409

Why does parole player play music louder than on clementine? Is it because of plugins?

>> No.55012426

>>55012401
Don't forget what the 'f' stands for, anon.

>> No.55012434

>>55012426

The F is tongue-in-cheek.

>> No.55012458

>>55012401
I've been using it every day for a year or two now. That doesn't mean I can be bothered to try out all the distros that ship with a particular DE to see if they're worth using.

>> No.55012484

I get a black box filling up the whisker menu in Xubuntu. Is this a common bug?

>> No.55012485

>>55012434
I must dissent.

>> No.55012500

>>55012186
Use SPage

>> No.55012508

What do you guys consider to be the best GUI file manager? Bonus points if it doesn't leave .directory files everywhere, or anything like that.

>> No.55012582

>>55012508
Nemo.

Functional enough to do what you want, simple enough to not be bloated.
Can maybe get away with stock nautilus if your distro isn't run by retards who wont apply the patches the gnome team refuses to apply themselves to make nautilus actually usable.

>> No.55012583

>>55012458

>That doesn't mean I can be bothered to try out all the distros that ship with a particular DE to see if they're worth using.

After two years you still haven't realized switching distributions just for a desktop environment is retarded? A normal person should have realized that the valid reasons for switching between distributions are:

>package manager
>release model
>package policy

Switching distributions only because of its looks is something a person new to Linux distributions does. Not something a person which has apparently been using it for two years (using an "advanced" distribution).

>> No.55012716

>>55012582
So in your opinion Ubuntu's Nautilus would be superior to Fedora's? Interesting.

>> No.55012724
File: 42 KB, 700x500, 1422045090603.jpg [View same] [iqdb] [saucenao] [google] [report]
55012724

>4000 aeons since the fall of Tooomh
>still no modular file picker

>> No.55012796

>>55012724

How do you envision a file-dialog to be modular? It's tied to the GUI toolkit the program is written in. Do you want software to depend on multiple GUI toolkits or somehow make GTK and Qt (KDE) disregard their own implementations and settle for a 3rd party option?

>> No.55012802

>>55012716
Well it's not superior exactly, just certain (completely necessary) options have been disabled by the gnome team because they are braindead, and most distros have reenabled them in their own packages so as to to not fuck over end users.

Debian at least keeps playing the "it's not our job to fix it" card, so the only usable gnome-based file manager is nemo. It's old as fuck but it works, unlike debian nautilus.

>> No.55012823

>>55012802

>gnome-based
You mean GTK based?

> It's old as fuck but it works
Version 3.0.5 was released a couple of weeks ago.

>> No.55012899

>>55012823
>You mean GTK based?
No, I mean gnome based. It is based on the stock gnome file manager

>Version 3.0.5 was released a couple of weeks ago.
It's still based on gnome2, regardless of when the last patch was made.

>> No.55012960

>>55012899

>It's still based on gnome2, regardless of when the last patch was made.
Are you sure? Isn't Mate the GNOME 2 fork and Cinnamon a GNOME 3 "fork"?

>> No.55013016

>obese cow with neckbeard being humped by a manlet.

seems accurate m8.

>> No.55013026

>>55012960
"Based on" in a design sense, rather than the underlying libraries, which is why I steered away from saying what version of GTK it was based on.
At one point it was referred to as gnome 2.5, since it's using gnome 3 but has been modified to look and act more like gnome 2.

It's old in both appearance (which is good) and updates (which is not great), but that's more to do with mint being shit.

>> No.55013262

>>55007807
Whats the Linux equivalent to dxdiag? I need support for a game but I need that.

>> No.55013358

>>55013262
sudo lshw > file.txt

lscpu and lspci are also good when you want stuff about your cpu and your gpu/display

>> No.55013395
File: 162 KB, 749x972, whatdo.png [View same] [iqdb] [saucenao] [google] [report]
55013395

So I mounted a hard drive, and the name is wayyy too long for me to access through terminal:
[email protected]:~$ cd /mnt/d1b2aa11-a3e4-434b-b71c-47a8ac23ac23/
[email protected]:/mnt/d1b2aa11-a3e4-434b-b71c-47a8ac23ac23$


Guy on stackoverflow tells me to unmount, do this (I named it "volume"):
sudo e2label /dev/sda2 volume[code]then mount it again. I do that, perfect. Restart my computer, and now it's back to the long name, but the label still exists.

What to do?[/code]

>> No.55013421

>>55013358
bash: lshw: command not found
The other two workerd though.

>> No.55013426

>>55013395
Crap, forgot to close the code brackets.
I named it this:
sudo e2label /dev/sda2 volume

and remounted.
Which worked, but when I restarted my computer, it was back to the long name. The label still exists, though.

>> No.55013448

>>55013421
sudo apt-get install lshw

or

sudo dnf install lshw

>> No.55013650

>>55009726
it happens whether I'm using i3, awesome, gnome3 or kde plasma

>> No.55013653

>>55013426
you could add an entry to /etc/fstab
If you don't want it to be mounted on bootup you'll have to specify that tho iirc

>> No.55013678
File: 6 KB, 496x277, [email protected]:~_002.png [View same] [iqdb] [saucenao] [google] [report]
55013678

>>55009735
maybe

>> No.55013888

>>55013421
as said, you can just install it, and it will be actually like a dxdiag unlike the other two that provide information about specific stuff of your computer.

>> No.55013914

>>55012796
It could just call a command and expect a path on stdout. It isn't complicated. Infact you may even be able to do just that with a LD_PRELOADED library ...

>> No.55013994

>>55009978
>>55010111
>>55010157
>>55010278
>>55010489
>>55010772
>>55010841
>>55011070
>>55011186
>>55011234
I'm the guy who couldn't install Debian Jessie on W8.1. The literal first hit from Google has the answer. Sorry for bothering you. I guess I simply wanted to post.

http://superuser.com/questions/714856/trying-to-dual-boot-windows-8-1-and-debian-jessie

To sum up:
Disable Fast Boot, Secure Boot. Boot the LiveUSB with the 'uefi' option (the only one that appears in the bios once you've disabled FB and SB).
Install normally.


>>55012500
Link it. I couldn't fin anything but katakana moonrunes.

>> No.55014031

>>55013994
>Disable SecureBoot
wew lad
that's kind of a big security flaw right there
you're vulnerable to malware that can infect the BIOS / boot sector

>> No.55014045

hey guys, how can I change Trash size in debian? and can I remove it completly?

>> No.55014088

>>55014045
Trash is DE thing, not a debian thing. If you press shift+delete on a file, it'll delete it instantly without going to the trash, exactly the same as if you removed the file from the terminal.

>> No.55014119

>>55014088
then cinnamon

>> No.55014137

>>55014031
I'm guessing it can be enabled after the install? Is it really that relevant?

>> No.55014140

>>55014031
Malware that can effect the BIOS is very very rare and can be fixed by re-flashing the BIOS. Boot-Sector malware is also very rare.

I've only heard of such malware in cryptolocker clones. Either way, make sure you get a distro which supports UEFI and secureboot.

>> No.55014150

>>55014119
just remap delete key to delete and not "move to trash"

less risky than ripping a component out of the DE

>> No.55014173

>>55014150
well, sounds like a plan. thanks anon.

>> No.55014178

>>55014140
I'm using Debian. I'll see if I can reenable it in the BIOS and grub still loads properly. Thanks for the heads up.

>> No.55014306

No seriously, why is the font rendering so shit in every distro except umbango?

>> No.55014404
File: 436 KB, 1883x966, 2016-06-10-15:33:31.png [View same] [iqdb] [saucenao] [google] [report]
55014404

>>55014306
because you're a moron that can't understand that fontconfig and font rendering are independent of the distro

>fedora 23

>> No.55014476

I tried to visit my website today only to find that I couldn't connect to it. I decided to check out my web server to see if I could fix the issue, but I don't 100% know what I'm doing and am a bit stuck.

I updated files on my server and apache seems to be running fine. I can connect to the internet and my files seem to be in tact but...when I attempt to connect to my site, I get the error 'The website at (my IP address) )seems to be unavailable. The precise error was:

Could not connect: No route to host."

Anybody know what's going on, or where a good starting point could be?

>> No.55014608
File: 41 KB, 637x364, Screenshot_2016-06-10_15-40-43.png [View same] [iqdb] [saucenao] [google] [report]
55014608

just installed xubuntu on my new thinkpad x240 and i'm having a weird wireless problem. when start up the computer it automatically connects to my wifi network but doesnt show any wireless networks in the network manager. the network manager icon also displays the 2 arrows pointing up and down like i'm connected by ethernet rather than showing the wifi symbol. all this shit worked fine when i was in the "try xubuntu" shit during installation. anyone encountered this? the wireless card is an intel 7260.

>> No.55014629
File: 209 KB, 600x847, 1463375183398.jpg [View same] [iqdb] [saucenao] [google] [report]
55014629

Guys, I have a question

Using Debian, you know how aptitude sometimes when you're upgrading or installing something, it sometimes tells you that certain packages are recommended but will not be installed by default?

How does this work? Why is it recommending these packages? Optional features that weren't deemed worthy enough to be dependencies? What's the command to install recommended packages when you're upgrading/installing on aptitude?

>> No.55014701

>>55014629
It's not like the manpage would make a secret about how it works.

>> No.55014713

>>55014608
I heard Ubuntu's having problem's with wireless support this last release, so your problem might fall under this

>> No.55014812

>>55014713
there's a process called gvfs-smb-browser that's using a constant 25% of my cpu too. works fine on my other thinkpads though. guess i'll just try out fedora or something

>> No.55014852

>>55014812
Or Debian Sid

>> No.55015028

>>55014852

>debian sid

versus

>fedora

kek. Fedora is light years better than sid

>> No.55015116

Let the shitposting begin

>> No.55015188

>>55015116
So, recently I was on reddit (I know, I'll kill myself later) and I came across an interesting argument in a linux thread. I cant find the thread anymore, but I copypastad the argument becasue I dont really understand internal kernal functions that well. My question is, is this guy a windows shill, or does he have any valid arguments:

"In Windows, any I/O operation including to file handles, sockets, or certain other system objects can be made "overlapped", or asynchronous. The OS will start the async I/O operation and update the status in a user-space OVERLAPPED structure accordingly. In addition to this, system I/O objects such as file handles and sockets may be assigned to another kind of object called an I/O completion port, which enqueues notifications that I/O operations on its associated file handles have completed, and their status. Multiple threads can share an I/O completion port and wait for their scheduled I/O operations to complete in a thread-safe manner.

In Linux, by contrast, there is no standard, generally accepted way to do true async I/O, so I/O is done using the standard POSIX calls such as read(2) and write(2). These are always synchronous -- even on O_NONBLOCK fds -- but you can get pretend asynchronicity by setting them O_NONBLOCK and buzzing in a select or epoll loop, interleaving I/O with other processing. Alternatively you can spawn one thread per request but neither give you the flexibility that Win32 gives you.

Just try writing a server with thread-pool allocation in Linux. You can't use the one-thread-per-request method because your worker threads are limited in number. So you will have to use some sort of select/epoll loop and manage all the synchronization yourself." continued...

>> No.55015203

>>55015188
"An I/O completion port would do all this for you and save you CPU time (and hence battery life on portable devices) by putting any thread waiting for its I/O requests to complete to sleep, rather than requiring them to buzz in a loop asking the fds "are you ready yet? are you ready yet? are you ready yet?"

Also, again -- all I/O calls are synchronous. Unix I/O has a notion of "fast" and "slow" devices that has nothing to do with speed; the difference is that I/O on "fast" devices never returns EAGAIN or EWOULDBLOCK; the process goes into uninterruptible sleep (D state in ps) until the entire I/O operation either completes or errors out. I/O to the file system is considered "fast" -- meaning that processes doing file I/O become stuck until the I/O finishes or errors out, which can be a real bummer if your disks are slow (e.g., VMs), flaky, or if you're talking to an NFS server that's gotten wedged.

Later versions of the POSIX standard provide the POSIX aio API, but the most common implementation of that fakes asynchronous I/O by doing synchronous I/O in a subprocess. It's better than the select loop, I guess, but why not save the process-table entry slots by providing real aio primitives in the kernel -- the way Windows does?

This Does Not Happen under Windows because Windows provides real async I/O primitives.

Structured Exception Handling lets you respond to OS-initiated exceptional events (segmentation faults, division by zero, invalid instruction, etc.) with a try/catch mechanism similar to C++ exceptions. It relies on Microsoft-proprietary C++ extensions to operate, however -- but it's still lightyears ahead of the janky signal mechanism used by Unix (and hence Linux)."

>> No.55015376

>>55015188
>>55015203
http://stackoverflow.com/questions/87892/what-is-the-status-of-posix-asynchronous-i-o-aio/5307557#5307557

>> No.55015408

How do I make my music player play music louder? The video player has the right volume but not Clementine or gmusicbrowser.

>> No.55015414
File: 24 KB, 181x121, 1457820064399.gif [View same] [iqdb] [saucenao] [google] [report]
55015414

>>55015203
>>55015188

>> No.55015452

>>55015116
It's just Linux. GNU is a cult.
http://gng.z505.com/cult.htm

>> No.55015983

Does Antergos use a different repo then Arch by default? Or what is the extra repo used for? If you install via pacman on Antergos is it coming from the Arch core? I can't seem to find much info on it.

>> No.55016019

>>55014476
>Anybody know what's going on, or where a good starting point could be?
A good starting point would be to ensure you have a route to the remote host...
But seriously, run ip route get <server-ip> and see what is says.

>> No.55016068

Trying to do minimal install of xubuntu, everything works great until its time to boot into the new system, and then I only get a black screen. Any ideas? Everything in the installer seemed straightforward enough, and I even tried again just to make sure I didn't fuck anything up and I still get nothing but black screen. Thinkpad T410 is machine btw.

>> No.55016093

>>55016068
you need to look at the logs/journal

there's literally nothing to go on here to help you

>> No.55016113

>>55014629
That packages are required, recommended or suggested are specified by the package maintainer when the make the package. Required ones are required for the thing to run and to use all functionality of it. Recommended packages are usually things like docs and plugin packages, optional is more of the same I suppose...
Recommends are installed by default and for suggests you can use the command line option --install-suggests or add APT::Install-Suggests "true"; in /etc/apt/apt.conf

>> No.55016138

How to make apt not spamming my terminal when I update?

>> No.55016207

>>55007807
Absolute newfag here.

How do I compile MPC-Qt (>>55015833 )in Ubuntu?

I don't understand this:
>You need the Qt5 sdk installed and a recent edition of libmpv. On ubuntu you can usually install the Qt5 sdk with the ubuntu-sdk or qtcreator packages. You will need to compile libmpv from git head or at least version 0.17.0 with the --enable-libmpv-shared option. Make sure ldconfig is run after compiling libmpv, or you may end up with linker errors.

>> No.55016225

>>55016138
pacman is your answer

>> No.55016270

>>55016138
man apt-get

>-q, --quiet Quiet. Produces output suitable for logging, omitting progress indicators. More q's will produce more quiet up to a maximum of two. You can also use -q=# to set the quiet level, overriding the configuration file. Note that quiet level 2 implies -y, you should never use -qq without a no-action modifier such as -d, --print-uris or -s as APT may decided to do something you did not expect.

>> No.55016286

>>55016225
Why must Arch users always act like edgy asses?

>> No.55016308

>>55016270
Thank you.

>> No.55016349

>>55016286
their whole community is cancer

they are like mormons that won't ever leave you alone

>> No.55016405
File: 5 KB, 401x400, 1416071278008.png [View same] [iqdb] [saucenao] [google] [report]
55016405

Friends, need some help with resolution settings on Ubuntu 16.04 using the open source driver.
When I used Ubuntu 15.10 I always used the proprietary graphics and everything was fine, my resolution was detected as 2560x1080 60Hz. When I updated to 16.04, knowing that I would have to use the open source driver, I noticed that my resolution options were capped on 1920x1080 60 Hz. I ran some the xrandr commands to force my resolution into 2560x1080 60 Hz, as it was before, but the screen started to blink and I couldn't use the PC. I tried with 2560x1080 40 Hz and it worked fine.
Why does this happen? Has anyone experienced the same? How can I fix it?
I don't really want to roll back to 15.10 please help.

>> No.55016447

>>55016286
>>55016349
It's not really much different clean now, is it?
sudo apt-get install vlc -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
vlc
0 to upgrade, 1 to newly install, 0 to remove and 0 not to upgrade.
Need to get 0 B/1,508 kB of archives.
After this operation, 4,972 kB of additional disk space will be used.
Selecting previously unselected package vlc.
(Reading database ... 220245 files and directories currently installed.)
Preparing to unpack .../archives/vlc_2.2.2-5_amd64.deb ...
Unpacking vlc (2.2.2-5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for vlc-nox (2.2.2-5) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up vlc (2.2.2-5) ...

>> No.55016500
File: 11 KB, 160x160, 1434260286035.jpg [View same] [iqdb] [saucenao] [google] [report]
55016500

>>55014404
>calls me a moron
>posts pic of disgusting font rendering
You can fontconfig until the cows come home, it never looks as good as Ubuntu.

>> No.55016533

>>55014306
Lmao Fedora actually has shit font rendering.
Ubuntu being a newbie distro has this fixed ootb, with glitches of course

>> No.55016535
File: 156 KB, 688x1430, 1456366628617.png [View same] [iqdb] [saucenao] [google] [report]
55016535

>>55016349
>>55016286

The only cancer is the constant bitching about arch, when no one who is using arch is involved in the conversation. Its the neo/g/'s only meme that brings them together,in an otherwise too complex field to be part of

>> No.55016579

>>55016447
what are you trying to say here?

>> No.55016586

Cannonical does not care anymore.

They are MS sellouts. The 16.04 LTS is HORRIBLE with broken gtk.

Kubuntu gives you a general idea of how shit it is with the cropped out widget in the Live ISO.

FUCK Cannonical and Ubuntu

>> No.55016602

>>55016579
He means apt-get is still too verbose and the output structure is garbage.

>> No.55016617

>>55016602
>>55016447

you didn't even pass a quiet flag

>> No.55016619

>>55016586
Debian's where it's at, boyo

Ubuntu is its bastard child that deserves to be disowned

>> No.55016629

>>55016447
>sudo apt-get -qq install vlc

>> No.55016631

>>55016617
I'm not the one who asked the question but -y means quiet level 2

>> No.55016654

>>55016619
Unfortunately,

1. The only branch with security updates only provide ancient packages
2. No PPA

>> No.55016656

>>55016631
no it doesn't, I literally just posted the man page:

>>55016270

-qq implies -y, not the other way around

>> No.55016674

>>55016654
>implying

Stable has security updates
Testing has delayed security updates
Sid has security updates right out of the oven bundled into the main repo

You can add additional repositories if you feel it's necessary, that's your PPA right there.

>> No.55016687

>>55016629
That's worse you dumb faggot

>> No.55016718

>>55016447 Here

So how do I combine -y --purge and --autoremove together?

>>55016207
Bump

>> No.55016757

>>55016687
wtf are you talking about

>> No.55016768

>>55016718
&&

>> No.55016801

>>55016687
>>55016631
>>55016602
>>55016447
>>55016138

>summer

>> No.55016816

>>55016757
It's fuckton more spammy than simply passing -y
>>55016768
Thanks for stating the obvious.

It appears I have to manually type autoremove everytime

>>55016801
Can't handle truth?

>> No.55016871

>>55016405
Pls respond.

>> No.55016887

>>55016816
>It's fuckton more spammy than simply passing -y

>-qq No output except for errors

You are an absolute moron. Pipe it to /dev/null if you somehow can't figure out how to run the most simple command on earth, jesus christ

>It appears I have to manually type autoremove everytime

>believing this


Just state for the record you have no idea what you are doing and I will help you.

sudo apt-get -qq update && sudo apt-get -qq dist-upgrade && sudo apt-get -qq autoremove

and fuck, I haven't even used a debian-based OS in 10 years

>> No.55017064

>>55016887
>qq No output except for errors

udo apt-get -qq install vlc | wc -l
Extracting templates from packages: 100%
257


2 5 7
5
7

Also,
>sudo apt-get -qq update && sudo apt-get -qq dist-upgrade && sudo apt-get -qq autoremove
Do you seriously write that shit?

>> No.55017073

So I am trying to split an album given a .cue file and gCue2tracks, but whenever I run it with the flac option, it says

Codec
/usr/bin/flac
missing

I installed ffmpeg and it still isn't working. What am I doing wrong?

>> No.55017432

so, whats the /g/ opinion on
Manjaro with Deepin?

should I make the switch from Debian to Manjaro?

>> No.55017453

>>55017432
manjaro dev team isn't competent enough to keep a current security certificate, go antergos if you're doing arch easymodo

>> No.55017603

>>55009658
It's the difference in your gtkrc files.

>> No.55017664

>>55016718
>>So how do I combine -y --purge and --autoremove together?
apt-get autoremove --purge -y <pkg>
But seriously, don't use -y.

>> No.55017695

What happens when I run:
sudo apt-get install -y *?

>> No.55017732

>>55017453
>t. meme master

>> No.55017873

>>55017732
that a meme? antergos?

>> No.55017892

>>55017432
i dunno. I just know the common opinion on tripfags.

>> No.55017976
File: 1.88 MB, 320x180, 1453825578738.gif [View same] [iqdb] [saucenao] [google] [report]
55017976

moot2 fix your shit

>> No.55017993

Could someone explain to me what this sed command does:

sed '/^\ *$/d' filename

>> No.55018094

>>55017993
"Show him how to fish..."
man sed

>> No.55018107

>>55017993
deletes lines that contain nothing but spaces
>>55018094
c'mon nigger

>> No.55018111
File: 100 KB, 284x200, 1420187871705.png [View same] [iqdb] [saucenao] [google] [report]
55018111

I only know Windows administration and Linux as an end user. What are the best resources for learning enterprise system and application deployment, or just administration in general?

What virtualization technologies are available? Analogues to MED-V and APP-V? Anything similar to group policy based application deployment? How would I go about doing ZTI?

>> No.55018134

>>55018111
What the fuck am I reading?

>> No.55018222

>>55018107
Thanks for not being a nigger.

>> No.55018242
File: 1.99 MB, 5760x1080, Screenshot_2016-06-11_03-47-18.png [View same] [iqdb] [saucenao] [google] [report]
55018242

tfw playing EROTIC GAMES while enjoying freedom

Occasionally after awakening from sleep my internet fails to connect, using ethernet.

Using arch+xfce if it matters. I also seem to sometimes get a start job running after rebooting on my ethernet interface, e3p0 or whatever. (rebooting fixes it)

>> No.55018294

Why is it called freetards instead of freefags?

>> No.55018304

>>55018134
How can I host a virtual desktop on a server that can be accessed by multiple users?(Microsoft enterprise desktop virtualization) How can I have an application installed on a server accessed by remote users? How can I completely automate the Linux installation to systems over a LAN for large scale deployment?(zero touch installation)

>> No.55018338

>>55018222
Check out >>55011459

>> No.55018378
File: 132 KB, 600x1050, 1446296501925.jpg [View same] [iqdb] [saucenao] [google] [report]
55018378

I'm just leaving this here.
http://registry.gimp.org/files/gimp_instagram_effects.zip

>> No.55018403

>>55018338
Thanks -- that is very useful for what i'm working on

>> No.55018851

>>55007807
Forgive me for my stupidity.
On my last laptop I had a shortcut for KDE so that it hides the border if I press Ctrl+F11. I put Manjaro KDE on my new laptop, but I appear to have completely forgotten how to bind a keyboard shortcut to that action. Can anyone help me out?

>> No.55018925

I got a spare l420 thinkpad lenovo and i want to install linux on it.

I only want to use it for work, study, sometimes watch movies but i don't want to play videogames on it.

Any recommendations? I am a complete beginner on this, but i am tired of windows 10 bullshit.

I only want to study/work on this laptop, i dont need thousands of updates to make my laptop useless every god damn time.

>> No.55019124

>>55018925
Ubuntu or Mint.

>> No.55019271

>>55017064
>--auto-remove
Configuration Item: APT::Get::AutomaticRemove
>--purge
Configuration Item: APT::Get::Purge
etcetera, once again directly from the man page.

>> No.55019296

Just updated my laptop running antergos after a month of not using it. Now I get awful screen flickering that persists through fallback mode, and changing display managers. What could be possible causes of this?

>> No.55019320

>>55018304
>blah blah sharing shit
xrdp is probably the easiest solution actually...
>deployment
Their are lots an lots of solutions. From seeding installers to install on local disks (each distro pretty much has their own solution to that) to BOOTP/PXE to loading half the system over NFS.

>> No.55019356

>>55019124
Is mint safe? apparently they fucked up privacy

>> No.55019434

>>55019356
No, they fucked up their security and got hacked once.

>> No.55019448

>>55018294
Because freetard is a portmanteau, and freefag is not.

>> No.55019497

>>55018925
i used a x220 fwhich has similar specs or a while and i hopped from distro to distro

i liked xubuntu quite a lot but kept getting errors, normal ubuntu has a really annoying gui imo, mint was nice but the bulgarian botnet fiasco scared me

i ended up using fedora the most because it gave me the fewest probelms utlimately

>> No.55019718

Trying out debian testing in a vm.

I'm trying to use openbox with a barebones no DE install. Tried to do it the same way as in Arch but I didn't realize I wouldn't be able to run X rootless.

Is there a better way to accomplish this than doing a bunch of obnoxious shit to try and get X to run without root?

>> No.55019825

>>55019497
Alright senpai, i was about to go for ubuntu but i'll follow your adivce.

Any advice? it will be my first time

>> No.55020205

>>55019825
Linux Mint.

>> No.55020285

>>55019434
And continually fuck up security by refusing to ever push security updates through and having an outdated, insecure kernel.

>> No.55020300

>>55018925
Just try out a couple different distros and see what you like; everyone's preferences are different. I run Manjaro XFCE but all that really matters is that you like it in the end.

>> No.55020335

>>55020300
I dont wan't to sound like a normie but i don't feel like using Libreoffice, mainly because of the compatibility. Sometimes i have to do powerpoint presentations and give them to my classmates.

I'm on fedora right now though, it feels really refreshing,, it started so fast.

>> No.55020356

>>55020335
people will hate me saying this, but you're better off using googlenet docs.

worked the few times i've had to do slides with others. and you can just use it on the browser.

>> No.55020521

I have to code a sed script that will read in several similarly named files (i.e project1, project2) apply changes and have them saved as assign1, assign2 etc. This part I have go a handle on but for each file I create I also have to create file that notes the lines which are being changed prior to the changes -- Im not sure how to accomplish this.

Anyone have some wisdom on this one?

>> No.55020587

>>55018111
There is a whole thread on /t/

>> No.55020598

I know there's several flash implementations for Linux but I don't really know anything about their quality. Is there a decent up to date desktop client .swf player that is not a buggy security liability like the official windows client?

>> No.55020599

Im currently using awesome WM and trying to change the default font.

I understand that I need to change "theme.font" in my theme file, but im not sure how it will know where the font I want to use is.

Basicly, I dont know how to install the font so that it will be able to be recognised in the theme file

also, if my font has spaces in it, do I replace those with underscores? does the font install with a different name to its file name? is it case sensitive?

please helpx thanks
Extra Info: Linux mint

>> No.55020622

>>55020335
libreoffice has pretty good compatibility. ever tried 5+?

>> No.55020639

>>55019718
Xinit/startx

>> No.55020657

>>55020598
Don't use flash.
Try gnash but stay away from any kind of flash. Let it die.
>>55020599
Lxapperance and man awesome

>> No.55020697

>>55020657
>Lxapperance and man awesome
I-I dont understand?
Im using Awesome WM and Lxapperance seems to be for another WM.
As for man awesome I dont know what that means

>> No.55020735

>>55020657
I know it's shit, needed for the occasional thing though. How does Lightspark compare to Gnash?

>> No.55020738

>>55020697
Lxapperance works for most WMs. Man awesome is a command. It shows you a manual.

>> No.55020826

>>55020735
I literally haven't used it in years. What are you doing that's so special?

>> No.55020847

>>55020826
not him, but i need it for some lewd games.

>> No.55020868

>>55020587
Thank you.

Is Linux viable in an enterprise environment where you have a large number of users? I just don't see it being able to do alot of what ms server is capable of for desktop clients

>> No.55020878

>>55020639
That's what I'm trying to do but it won't let me run it as a normal user.

>> No.55021135

>>55020868
where do you think GNU/Linux is mostly used?
of course it is viable, it is a multiuser system by default, you could try test it.

>> No.55021144

>>55021135
You should have just used task-desktop.

>> No.55021202

>>55019825
for fedora? i would install the free and nonfree rpmfusion packages and install mpv (set it to default media player) and install chrome and whatever other programs you need, and you're pretty much good to go

fedora is the distro that gave me the fewest problems, but for some reason people love mint idk why

even if you get a hankering for vidya, playonlinux/WINE runs fine on fedora, in fact i'm pretty sure steamOS is based on fedora

there's a software store like ubuntu's, where you can find pretty much anything you need, i use simple scan for my old hp printer/scanner and it works great. fedora also doesn't come with a lot of bloat.

the installation process can be kind of confusing, and getting a liveusb on fedora is a little bit more complicated than ubuntu in my experience, and the install wizard is a bit more complex too but it's a very stable and secure OS, both ubuntu and fedora are stable and easy to use and secure but my preference is fedora (security is why i shied away from mint even though i probably like it more than fedora)

>> No.55021333

>>55021202
if you need to install community packages your distro isn't very good.

>> No.55021410
File: 4 KB, 1315x92, sedsdeadbb.png [View same] [iqdb] [saucenao] [google] [report]
55021410

I have to have sed take in many like named files (e.g project1, project2, project3) perform changes and then output them under new names (assign1, assign2, assign3) -- Im stuck here. I tried piping the output to assign* but then it puts it all into one big file named assign*.

I will admit I am a complete retard at scripting and Linux in general -- please help.

>> No.55021441

>>55021410
assign[1..3] maybe?

>> No.55021471

>>55021441
trying this now, thanks

>> No.55021516

>>55021471
It just put everything into one big file again -- this time named assign[1..7] hnnghhh

>> No.55021537

>>55021516
my bad. use curly braces and it might work

>> No.55021569

>>55021537
I ran into the same problem. Maybe I have to use some kind of array variable to accomplish it I'm not sure. Thanks for helping me try to figure this out though

>> No.55021841
File: 835 KB, 1176x1000, 1415930882451.png [View same] [iqdb] [saucenao] [google] [report]
55021841

>>55018851
A-anyone?

>> No.55021944
File: 2.57 MB, 220x212, 1464362221869.gif [View same] [iqdb] [saucenao] [google] [report]
55021944

>get the urge to play Fallout
>the VM gets errors and doesn't run it
>wine runs it just fine
Would someone mind explaining why this is the case?

>> No.55021975

>>55021944
If I were to guess, probably graphics driver related. What are the errors?

>> No.55022024

how do I install this on debian? https://packages.debian.org/sid/pocketsphinx

I've tried
apt-get install pocketsphinx


but got Unable to late package pocketsphinx in return.

>> No.55022037

>>55021975
Initially I think that was the problem, but after fixing it the mouse was either moving about 80 pixels at a time or unbearably slow.

>> No.55022040

>>55020738
>>55020697

Lxappearance has nothing to do with window managers. It sets the theme for GTK programs, icon themes and cursor themes along with some other GTK options.

>using an "advanced " window manager but doesn't even know what man pages are

How to spot a pathetic ricer.

>> No.55022210

new thread when

>> No.55022633

Could anyone recommend a way to extract DLLs in Linux?
Also, how do I optimize my Linux problem solving when Google isn't helping and I know I shouldn't come here to ask every stupid question I can't solve on my own?

>inb4 git gud
nice meme, u titty
how though?

>> No.55022695

>>55022633
>how do I optimize my Linux problem solving

I'm sorry, but when you ask a question as vague as that the only answer anyone can give you is literally "get good".
Get more Linux experience. You can binge and do LFS, or just use Linux non-stop for years and it will all come to you over time.

>> No.55022878

>>55022695
It was a vague question because I'm talking about vague minor Linux issues.
Installgentoo and the Linuxwikia have like 300 articles each, so I'm going to assume that's not the go-to for when you want to solve problems. I hear you though and I'll rephrase the question:

Are there any particularly helpful pages out there for working with Linux? Google feels clumsy when asking very simple questions, so I'm looking for a collection of Linux subjects (where ideally you could filter distros as well).

>> No.55023009

>>55022878
>I'm talking about vague minor Linux issues.

And to fix them, like I said, you need experience. Enough experience either to google stuff more precisely or to even fix stuff by yourself.
There's no guide "How to Linux", as there is no guide "How to life". There's too much to cover and a much greater variety of issues than any guide or wiki can contain.

>installgentoo and linuxwikia have 300 articles each
And Arch Wiki has 4000. It's one of the greatest Linux resources and is mostly distro agnostic. It's the closest thing to what you want.

>> No.55023042

>>55021569
Pretty sure bash doesn't have multi-target redirection ... or whatever. Do something like:
for d in project*;do sed ... "$d" > "assign${d#project}";done
If you didn't know alread that ${var#pat} is a variable substitution (look in man bash for more) that strips pat from the start of var.

>> No.55023142

>>55023009
Alright, thanks anyway.

>> No.55023145

>>55021333

are you such an autist that you're wiling to shittalk one of the most secure and depdendable distros out there, that linus himself uses and advocates others to use, because it doesn't meet your arbitrary standards?

>> No.55023563

is there an easy way to transfer files trough lan cable from windows pc to linux(arch) ?

>> No.55023607

>>55023563
FTP?
UUCP?
SMB?
NFS?
It's a solved problem.

>> No.55023643

>>55023607
im soo noob, what i have no idea what those letters mean :/

>> No.55023669

>>55023643
and how to use em

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
reCAPTCHA
Action