Quantcast
[ 3 / biz / cgl / ck / diy / fa / g / ic / jp / lit / sci / tg / vr / vt ] [ index / top / reports / report a bug ] [ 4plebs / archived.moe / rbt ]

Due to resource constraints, /g/ and /tg/ will no longer be archived or available. Other archivers continue to archive these boards.Become a Patron!

/g/ - Technology


View post   

[ Toggle deleted replies ]
File: 49 KB, 400x341, linus.jpg [View same] [iqdb] [saucenao] [google] [report]
50295686 No.50295686 [Reply] [Original] [archived.moe] [rbt]

Previous thread : >>50272773
no copy pasta edition.

Talk about Linux and ask your questions in this thread.

Don't forget to search before asking anything and to read the wiki (the /g/ wiki and the wiki of your distribution)

>> No.50295705

>>50295686
Linus is CUTE! CUTE!

>> No.50295761
File: 56 KB, 523x523, 213548456315.jpg [View same] [iqdb] [saucenao] [google] [report]
50295761

>>50295705
if only Tove wasn't a karate champion...

>> No.50295860

RTFM<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Installing Linux and Ricing, Linux Distributions (Beginners to Servers to Advanced)
>Introductory Guide To Linux V0.4
http://pastebin.com/ut77Ma1t

Tools for Webdev, Infosec/Hacking, IDE's, Using Windows Software, Videogames, Steam, Emulators
>Software For Linux V0.3
http://pastebin.com/Eie7rBJ0

Learning the Shell, Scripting, Customizing the CLI, System Programming
>Becoming A Linux Wizard V0.3
http://pastebin.com/gitkAT2y

>> No.50295869

>>50295686
I wil literally fap to this picture, thanks OP

>> No.50295970

>>50295686
>daily reminder FCC says linux is illegal

>> No.50295985
File: 294 KB, 1366x768, Screenshot from 2015-09-15 15-29-36.png [View same] [iqdb] [saucenao] [google] [report]
50295985

Help me to keep friendly status with linux..
I am gnomefag , upgraded recently to 3.16.
Still having the same issue like with previous version .

How in the name of everything ever do I turn off fucking notifications about everything that happens on my machine?

There are notifications (now in calendar section , before it was in bottom sensitive area (jesus fuck)) about everything , when my dota match is ready , when I open new tab of browser while he is not focused (For example when I open html from Sublime-text it just notifies me that "chromioum is ready" and it doesnt even focus the browser until i click the notification popup or browser itself),when skype is "ready"/new chat , i mean there are notifications about everything .

Things I tried are simply with gui clicking OFF on every notification and with dconf inside of notifiaction dir but the system simply doesnt acknowledge anything i change .

Why the fuck do they even make gui settings if they doesnt work? I was faced with this problem even on debian , mint , fedora...
I am using Oobuntu GNOME 15.04.

>> No.50296000

>>50295860
What is the connection between the Source Mage distro in your guide and the real dead Sourcemage GNU/Linux?

>> No.50296021

>>50295985
Try deleting your GNOME configuration directories and start over.

>> No.50296024

Why is it that in every distribution of Ubuntu, Bluetooth won't work OOTB with speakers/headsets?

>> No.50296049

Anyone know how to disable middle-click pasting without disabling the middle mouse button entirely on Xubuntu? It's getting kind of annoying accidentally pasting things everywhere when I try to scroll on my Thinkpad.

>> No.50296102
File: 16 KB, 327x192, logo_black_slogan_border.png [View same] [iqdb] [saucenao] [google] [report]
50296102

>>50296000
Apparently the original developer make it closed source (some say by kind invitation from the NSA).

Other people rescued the project to form SMGL (Source Mage Gnu/Linux).

Is a very attractive distro I should say.
http://beta.sourcemage.ru/Intro

>> No.50296126

Is it possible to be hacked while using SSH into a server?

>> No.50296158

I'm on Windows 8.1 and know NOTHING about Linux, How do I go about using Linux Mint, I'm scared in case I mess my laptop up.

>> No.50296164

>>50296102
>Is a very attractive distro I should say.
Sounds like a load of FSF hyperbole to me.

>> No.50296177

>>50295686
Who is this penis praiser?

>> No.50296198

>>50296164
i run a virtualbox on win 8.1
got the iso of mint 64bit from their webpage.

theres always a black screen when the installation image should pop up.

i enabled pae/nx but its still not working.

anybody a clue?

>> No.50296224

GoldenDict or StarDict?
Or something entirely different, mayhap?

>> No.50296248

>>50296021
If I delete them are they generated again by the system or do I need to reinstal DE again?

>> No.50296253

>>50296158
install it on a VM to try it first and see how is the install process.
when you'll install it, reduce your windows partition from windows (they got a tool for that). That way you'll not be able to make a mistake since you'll just have to install it on the free space of your disk.

>>50296177
see the file name

>> No.50296325

>>50296248
Question: If you add a new user, do you have to reinstall your DE?
The answer is "no".

>> No.50296373

>>50296325
it happens to me too often that i speak before thinking

>> No.50296476

>>50296373
Oh and before I forget: Don't just delete anything called .gnome* in your home directory if you use stuff like Evolution. GNOME's a bit special like this...

>> No.50296882

Daily reminder to PLEASE try this. It is a script for n00bs to ease the transition from Windows to GNU/Linux. It is designed for Debian stable. Please bug test it. Through the small number of bug testers I have, I have found a large number of bugs, none of which appeared in my own terminal. Test this out, please. It is for the n00bs!

https://github.com/Chocolate-Chip-Computing/DebianNewbieScript

>> No.50297648

So i'm trying to boot arch linux and it gives me the error of
Waiting 30 seconds for device /dev/disk/by-label/ ...
ERROR: '/dev/disk/by-label/' device did not show up after 30 seconds...

i checked the ls of my by-label, and there isn't a folder called ARCH_201509
yet my CD is named that way when i check on my windows pc.

>> No.50297708

>>50297648
If you can't solve such simple errors then Arch isn't for you.

>> No.50297719

>>50296882
Thanks for the botnet invitation!

>> No.50297722

>>50295686
http://www.youtube.com/watch?v=6G3kQyqMFpQ
this should be in EVERY IT/programming/... thread

>> No.50297729

>>50295970
Bullshit, source?

>> No.50297737

>>50297708
Thanks for the help anon

>> No.50297755

How do I replicate windows mouse movement? I already ued xset command and it is a lot more accurate, but it just doesn't feel as good as windows.

>> No.50297775

>>50297755
Install windows

>> No.50297802

>>50297775
Yeah I was afraid of that. Oh well I guess I'll get used to it.

>> No.50297806

Let's say I installed Xubuntu and now I decided to switch to Cinnamon.

How should I remove XFCE without fucking anything up?

>> No.50297843

>>50297755
what xset command?
I'm using xset m 0 and it works like windows with 6/11
Maybe you are used to the enhance pointer precision option?

>> No.50297884

>>50295970
nice citation you got there faggot

>> No.50297899

>>50296882
>remove all desktop enviorments, and add a light-weight one called LXDE
I'm surprised you didn't try and force dwm on anyone.
>implying any of your beta testers are even remotely "newbies"

>> No.50297913

>>50297843
>Maybe you are used to the enhance pointer precision option?

Yeah that's probably what makes the mouse movement so nice. I don't remember what xset I used but I followed an indepth guide and can't find it now.

>> No.50297980

>>50295970
linux is in almost every single router out there, you fucking retard. they want to make it illegal for router vendors to install your own distro in their routers, which is a completely different topic

>> No.50297999

>>50296224
isn't goldendict the successor of stardict? I find it a bit better, but it has some annoying behavior sometimes

>> No.50298060
File: 106 KB, 546x360, 32.jpg [View same] [iqdb] [saucenao] [google] [report]
50298060

Does anyone know what the problem is?

>> No.50298063

>>50297648
Try dd to usp

>> No.50298216

Are there any noob friendly tutorials how to rice linux? Something more descriptive than z3bra's or /g/-wiki's:
1) Do fresh install with X.org
2) Install WM
3) Customize it to your liking
4) Done

I'm probably retarded but on z3bra's "guide" my desired effect is the screen right after the first step 'install WM'.

>> No.50298305
File: 41 KB, 550x512, 1442104128043.jpg [View same] [iqdb] [saucenao] [google] [report]
50298305

>>50296882
># Desktop background #
>https://choco.neocities.org/Pics/background8.jpeg
>wget http://www.pokehidden.net/banned_from_equestria_daily/wallpaper.jpg -O "$HOME/Pictures/.wallpaper/Clip Clop.jpg"

How about you get rid of these 'bugs' first and then ill consider running it.

>> No.50298320

>>50295761
This made me laugh way to muh, is it True?

>> No.50298424

>>50296882
kill yourself

>> No.50298587

>>50298305
Jesus, I didn't know there was all that pony shite in there. Fucking trash.

>> No.50298683

Ok I posted yesterday about how I'm running Mint 17.2 with a 4.2 kernel so my wifi drivers work. I need to get my GPU working, right now its only listed as a 3D controller when I run lspci and installing drivers does nothing. I checked the terminal and I get
>Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
when it tries to setup nvidia-352(the driver I'm trying to install)

Which is why I'm assuming it doesn't work. I've googled the issue but the solutions involve things like linux-source but since I'm on 4.2 I don't think that will work.

Any ideas?

>> No.50298700
File: 1.48 MB, 9000x5988, maximum_trolling_2_by_rober_raik-d4cxndc.png [View same] [iqdb] [saucenao] [google] [report]
50298700

>>50296882
Make a manual on how to modify your script to install a custom setup, or you will face the wrath of trolls.

>> No.50298701

>>50298683
Forgot to mention its a 960m and it has that hybrid thing with integrated graphics and what not.

>> No.50298734

>>50298683
How did you install the kernel? It can't find the source so I assume you don't have it the kernel source in /usr/src/linux? Or is it looking somewhere else?

>> No.50298841
File: 61 KB, 642x312, Screenshot from 2015-09-15 13:16:35.png [View same] [iqdb] [saucenao] [google] [report]
50298841

>>50298734
Well I compiled it from source because I needed ath10k using these instructions

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1383184/comments/190

And the source is linked there. I'm pretty new to this so is it possible to fix if I have the source?

Here's what it gives when I install nvidia-352. It still acts like its installed, I can purge it whenever but obviously it doesn't work.

>> No.50298926

>>50296882
>https://github.com/Chocolate-Chip-Computing/DebianNewbieScript
haha holy fucking shit

>> No.50298952

>>50298841
Those instructions are fairly vague. Post the output of 'ls -la /usr/src'.

>> No.50298988
File: 16 KB, 610x171, Screenshot from 2015-09-15 13:25:29.png [View same] [iqdb] [saucenao] [google] [report]
50298988

>>50298952
is this an issue

>> No.50299015

>>50298988
set up a symlink from the kernel source to /usr/src/linux

Should look like this:
drwxr-xr-x 20 root root 4096 11.09.2015 07:11 linux-4.2.0-gentoo-r1/
lrwxrwxrwx 1 root root 15 10.09.2015 10:38 linux -> linux-4.1.6-pf1

>> No.50299037

>>50299015
Oops, except that it should link to the right one :D

drwxr-xr-x 20 root root 4096 11.09.2015 07:11 linux-4.2.0-gentoo-r1/
lrwxrwxrwx 1 root root 15 10.09.2015 10:38 linux -> linux-4.2.0-gentoo-r1/

>> No.50299071
File: 8 KB, 800x800, ansible_logo_black_square.png [View same] [iqdb] [saucenao] [google] [report]
50299071

Do you /g/entoomen use Ansible for configuration management on your servers? If not, what do you use and why?

>> No.50299127

>>50298988
Your source doesn't have to be in /usr/src but you need to create the link to /usr/src/linux

Sorry, was a bit vague.

>> No.50299171

>>50298060

Yes, it appears you're using Elementary Os (or at least their desktop environment). Don't and your problems will be solved.

>> No.50299238

>>50299127
Thanks I'll give it a go soon. Right now I'm checking if there's an alternative to stay on 3.16 and still have wifi working.

>> No.50299409
File: 5 KB, 231x43, logo.png [View same] [iqdb] [saucenao] [google] [report]
50299409

Does somebody tried the Solus distro ?

>> No.50299430

>>50299409
no

>> No.50299440
File: 172 KB, 416x445, 1323721215208.png [View same] [iqdb] [saucenao] [google] [report]
50299440

Can somebody recommend me a stable and noob friendly distro without systemd?

I heard someone blasting it the other day, and now I kinda wanna switch.

>> No.50299461

>>50299440
>noob friendly distro
Do you even know what systemd is

>> No.50299475

>>50299409
I'd like to know this as well.

>> No.50299480

>>50299440
Go for funtoo, it's fairly involved but still quite simple. Or lubuntu I think, void, alpine.

>> No.50299530

>>50299480
Or puppy linux, proteus

>> No.50299545

>>50299530
>proteus
porteus I mean

>> No.50299578

>>50295686
I'm trying to boot LiveCD from a memory stick so I can wipe my old (and now corrupt) windows installation and format the drive for my new Linux OS.

I'm using that Rufus tool, however, whenever I boot it it gives me some error essentially saying the BIOS doesn't recognize what the livecd is trying to do.

Anyone have some advice? Is there a better way to do it?

>> No.50299586

>>50299461
I did some research, so yeah, I have got the gist of it I think.
>>50299480
>>50299530
Thanks i'll look those up

>> No.50299707

>>50299475
I'll try it in live CD, it's fucking slow in QEMU

>> No.50299810

>>50299440
ubuntu 14.04 doesn't use systemd

>> No.50299847

>>50299440
Linux Mint 17.2.

>> No.50299857
File: 56 KB, 750x501, pukenao3.jpg [View same] [iqdb] [saucenao] [google] [report]
50299857

>>50299810
>>50299847

>> No.50299868

>>50299440
Windows

>> No.50299892
File: 522 KB, 460x276, chocked in the eye1.gif [View same] [iqdb] [saucenao] [google] [report]
50299892

>>50299868

>> No.50299900
File: 53 KB, 430x307, angrygates.jpg [View same] [iqdb] [saucenao] [google] [report]
50299900

>>50299857
He was asking for noob friendly, you fat dumb archbeard.

>> No.50299942
File: 74 KB, 655x657, 1434527115791.png [View same] [iqdb] [saucenao] [google] [report]
50299942

Do you have to be leet to use Arch and does it break a lot or is it just a meme? I'm using Fedora at the moment and I like it but having more up to date packages and rolling release is appealing.

>> No.50299952

>>50299942
it does break and yes it is a meme

>> No.50299971

Never had linux, but want to try it for side-by-PC laptop. Is it user unfriendly that I should avoid it and what disadvantages would that have over win7?

>> No.50299983

>>50299857
what's the difference between ubuntu, arch, gentoo, etc? tell us, please

>> No.50299985

>>50299952
stop lying if you can't use it properly. it used to break 5 years ago, now it's flawless.

>> No.50299999

what's the go-to distro for people who do actual work on their computers? fedora with gnome?

neet animefags need not reply.

>> No.50300011

>>50299985
of course anon

>> No.50300016

>>50299942
Let's just say there's a reason they call it timesink OS. Stick to Fedora, most packages are updated enough there.

>> No.50300040

>>50299942
you don't have to be leet, there are a lot of great guides on arch wiki.

you still need to do every single thing yourself though, so unless you have a lot of free time, I suggest you stick with fedora.

>> No.50300052

>>50299942
Hasn't broken in years for me, bleeding edge packages don't get you much and yes it is a meme. AUR gets my dick hard though

>> No.50300056

>>502960
Have you installed the package pulseaudio-bluetooth? It allows you to assign programs for playback over Bluetooth.

>> No.50300059

>>50299999
CHECK EM

>> No.50300061

>>50299942
>I'm using Fedora at the moment and I like it but having more up to date packages and rolling release is appealing.

You're on Fedora, not Debian, calm your tits

>> No.50300089

>>50300040
>you still need to do every single thing yourself though
That's just installing though isn't it? Once you have it set up don't you just update everything with pacman -Syu?

>> No.50300131

>>50300089
https://github.com/helmuthdu/aui
script isn't really maintained but takes the tedium out of installing it for the umpteenth time, all you really need to do is manually partition your drive during install

>> No.50300139

>>50299983
ubuntu is fine if you're new to linux or just need it to browse web, watch videos, listen to music, write documents. I would recommend fedora tho
arch and gentoo are great ir you're already familiar with linux. you'll customize the operating system to your needs.

>> No.50300150

>>50300089
well, sure, you can update easily, but try configuring the packages you installed, and you'll have to spend an unnecessary amount of time reading the wiki.

>> No.50300164
File: 868 KB, 500x500, 1426050097282.gif [View same] [iqdb] [saucenao] [google] [report]
50300164

>>50299999
Here's your free loli, sir.

>> No.50300178

>>50300139
>ubuntu is fine if you're new to linux or just need it to browse web, watch videos, listen to music, write documents. I would recommend fedora tho
>arch and gentoo are great ir you're already familiar with linux. you'll customize the operating system to your needs.
you are fucking retarded if you really believe this, all distros are more or less the same thing. stop spreading bullshit, you stupid elitist fuck.

>> No.50300181

>>50300150
Same on any package based distro. If you don't want what standards the maintainer of the package did set, you're in a world of pain.

>> No.50300268

>>50300178
sure thing they're more or less the same thing, but if you install ubuntu, mint or fedora, it comes already with a lot of packages you'll never need. if you don't give a shit about it, I respect.

>> No.50300307
File: 225 KB, 460x276, chockedforever.webm [View same] [iqdb] [saucenao] [google] [report]
50300307

>>50300178
lol it's this guy again

>> No.50300336

>>50297980
>implying you cannot tinker with your wifi card on linux which is a fcc violation

>> No.50300377

>>50298216
which wm/de do you use? i like Numix

>> No.50300385

>>50300336
that's not the point, they apparently want to make routers more "secure", i.e., some android-like security, in which you are left with old, vulnerable software, and no way of fixing them by yourself...

>> No.50300440

>>50299971
linux mint cinnamon or LMDE2 are what you want, it's extremely user friendly if you don't expect it to be windows. it's more like android with a keyboard. you can't gaym much (some games work great though. witcher 2 for example). just try it in a live disk and decide if you want to dual boot or go full freedom.

>> No.50300479

>>50300440
>linux mint
>full freedom
oh boy

http://www.gnu.org/distros/common-distros.html

>> No.50300538

>>50299440
I'm going to recommend gentoo to you and I'm being completely serious. comes with openrc by default and you can choose if you want a fully libre system or not by using the license groups. you can get it setup in an afternoon.

>> No.50300545

>>50300440
Why do people say the witcher 2 port on linux works great? It's atrocious in terms of performance in comparison. A 45 FPS difference is no joke.

>> No.50300566

>>50300538
Is gentoo really noob friendly?

I remember it being this "harder than arch" distro that took between 1 and 2 days to install because you had the option to compile everything.

>> No.50300587

>>50300545
It's not even a port, it runs trough a shitty wineskin ripoff, in which case you'd get much much better performance running the fucker trough wine.

>> No.50300590
File: 330 KB, 806x938, shut_up_stallman.jpg [View same] [iqdb] [saucenao] [google] [report]
50300590

>>50300479

>> No.50300595

>>50300566
it's really not that hard. first install is just a matter of being able to read the manual. it gets challenging once you've done with your base install and want to setup a WM and xorg and what not, but you have an IRC that's very friendly if you have any problems.

>> No.50300615

>>50300595
>noobs
>being able to read the manual

>> No.50300643

>>50299999
debian stable with xfce? nice quints m9.

>> No.50300674

>>50299545
>porteus
A very underrated distro. http://build.porteus.org/ is awesome.
>>50299707
Use VirtualBox.

>> No.50300692

>>50299999
Fedora with MATE for me.

>> No.50300720

>>50300590
I haven't seen this before. When was this posted? Link please?

>> No.50300731

what is linux and what is gnu?

>> No.50300737

>>50300674
Indeed, it's so handy to be able to create a custom build with applications you need. I've only used it on a usb stick though, not sure what it would be like as a proper desktop install.

>> No.50300782

How do I copy the last 10 modified files to another dir? I tried doing a=`ls -t1 | head -n 10` but I can't seem to make $a work as an argument for scp neither can I write a proper cycle to iterate through $a.

>> No.50300799

>>50300737
It's not really for desktop installs, I think.

>> No.50300822

>>50300731
linux is an open source kernel and the biggest collaborative project in the history of mankind.
Gnu is some faggots that took the kernel, added some replaceable shit on it and called it Gnu system or Gnu/linux. you'll soon find only retards and underaged people call it like that

>> No.50300824

>>50300385
YOU CANNOT MESS WITH YOUR WIFI CARDS! ANON WE ARE THE FCC THIS FOR YOUR HEALTH AND WELL BEING STOP JAMMING OTHER PEOPLES SIGNALS!

>> No.50300890

>>50296882
So I guess I'm confused.
A while ago everyone was supporting this script, and now a bunch of autists are complaining about it?
Are we invaded by newfags?
It's only gotten better.

>> No.50300900

>>50300674
It doesn't boot on my usb stick.

I don't want to try hard tonight

>> No.50300924

>>50300782
ls -t1 | head -10 | while read line; do cp "$line" dir; done

>> No.50300933

>>50299892
Kill yourself.

>> No.50300934

>>50300900
VM it.

>> No.50300947

>>50300822
the GNU OS has been in development since the mid 80s. they were nearly done, they just needed the kernel.

>> No.50300954

>>50299952
Liar.

>> No.50300960
File: 57 KB, 620x387, confused chock.jpg [View same] [iqdb] [saucenao] [google] [report]
50300960

>>50300933
>not liking chock
Get out.

>> No.50300973

>>50300924
Thanks a bunch anon.

>> No.50301002

>>50300307
Kill yourself and take your gay forced meme with you.

>> No.50301028

>>50300782
It's a string variable, not an array, so if you want to loop, you need to split it, think how you store it in the first place as in what is your delimiter.

You should read about IFS, since it's an internal delimeter that you can utilize ie.
var="first;second;third"
tmpIFS=$IFS
IFS=";"
for str in $var; do
echo $str
done
IFS=$tmpIFS


Nevertheless I wouldn't bother in your case, since you can do things like this.
for f in $(ls -t1 | head -n 10); do
scp $f [email protected]:/some/directory
done


I haven't played with Bash in while, but I hope that helps.

>> No.50301058
File: 38 KB, 595x419, rly.jpg [View same] [iqdb] [saucenao] [google] [report]
50301058

>>50301002
Epic bro

>> No.50301095

>>50301028
That makes a lot of sense, thanks. Also, does $IFS reset itself when I start a new shell or restart my PC or will it always stay the same after I modify it?

>> No.50301114

I have Mathematica for students that will expire in 2016. How can I use LD_PRELOAD to rewrite the function that it uses to get the current date to stop it from expiring?

>> No.50301275

>>50300822
https://en.wikipedia.org/wiki/List_of_GNU_packages this is GNU and the kernel is linux.

>> No.50301302

So I have linux mint 17.2 for couple hours now.
I just installed teamspeak and HOLY SHIT IT'S SO FUCKING SLOW.

Like I cannot do shit. It is so heavy. What the fuck do I do. Also how do I delete programms?

And can anyone tell me why do I have mouse acceleration? Its disabled in the option but I still got it ffs.

>> No.50301339

>>50301302
Forgot to mention. ItÅ› only when I launch teamspeak. Not after I close it.

>> No.50301342

My PC doesn't recognise USB on boot. How do I force it?

>> No.50301404

>>50301302
which DE do you use? being slow is weird. are you running it from a live medium or did you do a proper install?
for uninstalling programs, you can use the ui options to install/uninstall software but you can also open a terminal and type: sudo apt-get remove <package name>
and then sudo apt-get update
and sudo apt-get autoremove

>> No.50301417

>>50301342
tell us more

>> No.50301433

>>50301342
press f12 or whatever it tells you while it loads the BIOS?

>> No.50301484

FLT, I'd like to remove the Xubuntu install I have living alongside Windows 10. Now obviously I can simply format & remove the Linux partition and extend the Win10 partition in its place, but that'll fuck the boot loader.

I'm not sure how I'd go about replacing GRUB with the default Win10 loader. Any thoughts?

>> No.50301516

>>50301484
google
windows bootloader fix

>> No.50301524

>>50301417
Total noob who used windows all his life is trying to get linux to revive dying laptop to be useful.
Got cinammon mint, burnt it to usb, trying to install it.
>>50301433
Ok, got into BIOS, it don't seem to have an option to enable USB boot, only CD, floppy and internal/network adapter boot.

>> No.50301529

Sup /g/ question for ya. So I got an old desktop that I wanted to put linux on to fuck around with because the windows OS on it already was really fucked up. So I made an Ubuntu Bootable USB. I couldn't get the boot menu to come up so I changed the boot order to make removable devices first but that didn't work either so I went into windows and opened the installer on the USB from there. I was able to install Linux and I wanted to wipe the drive and install Ubuntu which was an option. And now when I start it it's just a black screen with a flashing cursor that I can't do anything with. It's not recognizing the USB, what should I do?

tl;dr Trying to install Linux on a blank drive but it isn't recognizing the USB is bootable.

>> No.50301530

Which linux mint DE is best for laptops? I kinda want something that can be customized moderately at least - so it'd have an aero-ish look.

The laptop in question is a lenovo g500, so it isn't terribly old or fast...just average.

>> No.50301539

How would I go about getting started contributing to Linux-related FOSS? Is it as easy as making pull requests to random Linux repos on GitHub, or is there some sort of approval process?

I have ~7 years of professional C/C++ experience if that means anything at all.

>> No.50301546

>>50301516
Eh. Most seem to assume you're using Win7 and can run /fixmbr from the install media - kind of difficult if Win10 was upgraded from Win7. (It doesn't work, for the record.)

Still searching though, but as usual I'm wondering if anyone else had gone through this before.

>> No.50301558

>>50297722
Do people actually need this to be said.
You just make a CV and send it to everyone.
How hard is it.

>> No.50301570

>>50301524
oh the laptop is this old, i would recommend you to use a cd/dvd then, sorry.

>> No.50301589

>>50301530
xfce all the way

>> No.50301602

>>50301570
I wouldn't say it's too old, was told it was bought around 4 years ago and it has win7 sticker on it. Model is HP G62 notebook PC.

>> No.50301612

>>50301524
Check if it thinks your USB is a HDD

>> No.50301633

>>50301404
Thanks,

I use cinnamon.

>> No.50301667

>>50301539
just ask rms.
everyone always loves it when people reverse engineer stuff to make drivers.
>>50301602
so you got in the BIOS and saw the part where you could select devices to boot from? and your usb isn't there? then it's either not written on there correctly or it's recognized as something else.
>>50301633
did you install it to your hdd or is it running from the usb-drive? moar info pls.

>> No.50301676

>>50301612
>>50301570
Another thing, should there be some kind of exe in the usb after burn like with windows(which I could not find) or it has to be specifically booted during computer boot?

>> No.50301684

>>50301539
oh and yes, it's that easy, happy hacking.

>> No.50301708

>>50301676
there will be no .exe on there. https://www.linux.com/community/blogs/127-personal/812379-how-to-burn-iso-to-usb-drive have you followed this or some other guide?

>> No.50301763

>>50301708
Thanks.
Just tested that usb with my main PC, seems to work fine. Gonna get myself a CD tommorow.

Is linux already too hard for me if I'm struggling this hard to even install it?

>> No.50301771

>>50299942

i don't want to read guides. installed Fedora and i had problems with video hardware acceleration and HDMI audio. installed Antergos and it just werks.

>> No.50301812

>>50301667
Are you saying I should literally email rms?
Also, mind elaborating on the reverse engineering bit?

>> No.50301931

>>50301667
I installed it on my /home partition on my hdd.
I have made enough space for the /, /swap and /home. That shouldn't be a problem.

I updated everything and it still goes crazy when I launch it. Do you know what the best way is to install teamspeak? I followed some video.

>> No.50301991

>>50301763
Installing is the hardest part. But installing windows is also difficult nowadays. GNU/Linux will be easier than you think. Give it some time.

>> No.50302057

>>50301812
Gettung involved in any free project is good but if you want to know what's the best way to help at the moment then I would recommend you to literally email rms.

>> No.50302061

>new user, only a week in Ubuntu
>try to install an IDE
>feeling good, putting all the packages together
>the very last package doesn't work, has dependencies that don't exist
>nothing helpful on google
>have a worthless almost-IDE

How do I fight the urge to give up and go back to Windows? I just want my thing to just werk.

>> No.50302079

>>50301763
no, you're trying and learning, that's literally all you need.

>> No.50302140

>>50302061
You need to find the dependencies somewhere, google their name. Could you give some info on what you need?

>> No.50302304

>>50297648
Mount the disk where it wants and log out of the terminal>>50297899
But anon DWM is great.

>> No.50302395

>>50302061
>No specifics

It's almost like you don't want your system to work so you can cry about it on 4chan. Seriously, give a few details (which IDE? Did you install it from the official repositories? Which package doesn't work? Which dependencies does it need?) and there is a very good chance the thread can help you fix it.

That you said you were "putting all the packages together" instead of just telling apt what you want to install and letting it handle everything tells me that you're trying to install your IDE by hand. That is a bad idea until you get more used to how Linux works.

>> No.50302415

Hello /flt/, I have a problem with my Kubuntu 14.04, some days ago there were some updates including kernel updates, I installed them and didn't reboot and continued using the system, some days later there were some more updates, so I finally decided to reboot and then install the new updates. After reboot the notification for new updates didn't show up, so I decided to open Muon updater from the menu.
When I clicked the icon the system completely froze, didn't respond to ctrl+alt+f1, ctr+alt+backspace, not even to magic SysRq.
I turned off and on again the pc withe the power button and at the login screen I pressed ctrl+alt+f1 and logged in the console. From there I did sudo apt-get update and sudo apt-get upgrade and it installed the updated packages. After rebooting I logged normally to X, opened a terminal windows and wrote sudo apt-get update, after inputting the password it showed the message "0% processing" (or something like that, it's in my language) and completely freezes again. Now I tried to uninstall vlc from the console because I tought it could be a problem because I installed it after the kernel updates and before the reboot, after uninstalling I rebooted to X, opened a terminal and I tried apt-cache search vlc and it worked, then I tried again sudo apt-get update and it completely froze again. So on tty1 everything works, on X even the same commands in a terminal that on tty1 work freeze completely the system. Is there something I can do to fix it?

>> No.50302443

>>50300590
Well, I think all of us know that in reality, Stallman is an idiot and kind of a person that appropriates someone's else achievements.

He serves well as a meme, though.

>> No.50302464

>>50302140
>>50302395
Sorry, I'm too tired to troubleshoot any more today, I'm gonna pass out soon. I've been working on it all day. I was mostly just bitching, you're right, maybe after some sleep I'll ask the thread for help.

For the record it was Monodevelop, and I was usting apt-get instead of using individual packages. There is a main monodevelop program and a bunch of addons, one for testing, one for databases, that kind of thing. The database one wouldn't install properly. Lots of people online had the problem but I never found a solution that worked for me. Tomorrow I'll ask for more help, I just wanted to vent a little.

>> No.50302477

>>50301589
well I just tried xfce on a live usb... it's not very customizable..

>> No.50302479
File: 13 KB, 217x307, 1441809883140.jpg [View same] [iqdb] [saucenao] [google] [report]
50302479

>>50296882
>Chocolate Chip Computing

>> No.50302563
File: 35 KB, 600x600, cool shibe.jpg [View same] [iqdb] [saucenao] [google] [report]
50302563

>>50302479
hi newfag

>> No.50302586
File: 34 KB, 615x409, chked.jpg [View same] [iqdb] [saucenao] [google] [report]
50302586

>>50302563

>> No.50302609

>>50302563
Hello oldfriend, explain to me then pls? (:

>> No.50302657
File: 3.07 MB, 2560x1920, 20150916_001743.jpg [View same] [iqdb] [saucenao] [google] [report]
50302657

>>50302415
So I had a nice idea, that is to log in to X, and then go back to tty1 and do sudo apt-get update, the system froze and this is the output.

>> No.50302725

>>50302657
Fuck, it looked more readable on the phone screen, there are two messages that caught my attention. At the 3rd row:
BUG: unable to handle kernel paging request at 0000000000001000
and a the 3rd from the bottom:
BUG: unable to handle kernell NULL pointer deference at 0000000000000018

>> No.50302785

>>50302725
I'd like to add that I tested both the RAM with memtest86+ and the HDD with fsck and badblocks and they don't have problems.

>> No.50303379

What's the best non-botnet browser, I'm thinking of moving to loonix and I want to be rid of the botnet. While i'm talking about it, what are some of the best loonix c++ IDE's? Or just other useful apps?

>> No.50303426

>>50302657
coglione

>> No.50303453

>>50303426
Installa gentoo

>> No.50303462
File: 75 KB, 897x714, snapshot3.png [View same] [iqdb] [saucenao] [google] [report]
50303462

brightness doesnt change back after unplugging the power cord. How do I fix that? I'm runnng Arc. It was the same on Kubuntu

>> No.50303475

>>50303453
'n gul a mammt

>> No.50303513
File: 81 KB, 600x534, hitler_looks.jpg [View same] [iqdb] [saucenao] [google] [report]
50303513

>>50295686
Ver das ist kinky kernel kopf

>> No.50303562

>>50303475
Fuck off african kid

>> No.50303598
File: 51 KB, 620x485, jim.jpg [View same] [iqdb] [saucenao] [google] [report]
50303598

>>50300307
>lol it's this guy again
Now then, now then...

>> No.50303673

>>50303598
>proper chocked

He fixed it for me.

>> No.50303712

>>50302657
Very impressive and no VLC is not the cause of that mess.
You could try to manually clear your cache,
sudo rm /var/cache/apt/*.bin

then update/upgrade.

Also if your system says to reboot after upgrade, please do so, because there might be tasks related to the upgrades which only trigger after a reboot.

>> No.50303779

>>50303475
'mba d'unni si?

Anyone experiencing libreoffice crashing like a bitch? I had a friend ask help for his thesis, libreoffice is completely stable on his PC, on mine it crashes MOSTLY when fucking around with a document's index table, non-standard glyphs and I think that's it.

I'm interested to know if there's a way to debug it. outputting stderr and/or watching the output in the terminal didn't really help me nail down the problem, but I'm under the impression that it's caused by java.

>> No.50303835
File: 292 KB, 460x276, fully chocked.png [View same] [iqdb] [saucenao] [google] [report]
50303835

>>50302479
>>50302609
he's a ponyfag and his OC is named chocolate chip

>> No.50304186

>buy thinkpad
>install kali linux

a-am i mr. robot now, /g/?

but no, is it wurf installing kali linux going in mostly blind? i've used linux before, but literally none of the tools that kali comes with.

>> No.50304326

Would running a Windows 10 VM inside a Linux distro (most likely Elementary or Mint) on a T60 be slow as fuck, or would it actually be feasible? Just for light gaming for Windows-only games.

I haven't properly used VM software in a few years, I just remember it being unbearably slow.

>> No.50304370

AND THEY SAID LINUX DOESN'T HAVE QT

#rekd

>> No.50304438
File: 52 KB, 447x342, woowoo2.webm [View same] [iqdb] [saucenao] [google] [report]
50304438

>>50304370
Did they really?

>> No.50304560

>>50304186
What would you even want to do with it?`

>> No.50304903

>>50304560
Probably find + patch holes with my network/desktop.

I'm not really savvy enough to get a ton of use out of Kali, probably, as cool as all of it's tools seem.

>> No.50304930

>>50304903
Well as long as you're willing to read documentation on the tools and have a purpose for doing it I don't see why not
knock yourself out

>> No.50305030

Installation get stuck during formatting /boot partition: tried Debian and Ubuntu.
"Creating ext4 file system for /boot in partition #3 of SCSI1 (0,0,0) (sda)..."

What do?

>> No.50305138

>>50299892
>>50300307
>>50300960
>>50301058
>>50302586
>>50303598
>>50303835
>>50304438
What's the obsession with this ugly old fag? Explain the joke please.

>> No.50305259

>>50305138
He's hot

>> No.50305287

>>50299440
No trolling here, at your user level systemd should be a non-concern.

Ubuntu and Linux Mint 17.2 are your best bet for ease of use. Most beginner tutorials will be for Ubuntu.

>> No.50305304

>>50305030
Uh, some more details needed, are you dual booting, is the HD going to be dedicated to Ubuntu?
What's your setup essentially.

>> No.50305346

>>50305304
I used to have 900 GB Windows partition. Recently I've come to use Windows very sparingly so I decided to resize the partition down to 100 GB, knowing there's about 50GB space used.
So now I wanted to install Ubuntu along the now 100GB Windows partition.

>> No.50305376

>>50305287
troll

>> No.50305403

>>50305259
Oh, I thought he may have been a programmer.

>> No.50305418

>>50305403
hahaa

nope. He is the Casy Kasem of the UK.

>> No.50305430

>>50299578
Is your machine using Secure Boot?

>> No.50305439
File: 172 KB, 500x285, how do you do fellow kids.png [View same] [iqdb] [saucenao] [google] [report]
50305439

I'm on debian jessie, anyone got a good guide on how do I make install like a non-retard? Apparently it breaks the system and makes it impossible to uninstall later.

>> No.50305469

>>50305403
>>50305418
https://en.wikipedia.org/wiki/Jimmy_Savile_sexual_abuse_scandal

>> No.50305471

>>50305418
>UK
Oh, that explains a lot. Thanks.

>> No.50305557
File: 40 KB, 615x409, Jimmy Saville.jpe.jpg [View same] [iqdb] [saucenao] [google] [report]
50305557

>>50305469

>> No.50305769

So I started out on Slackware ages ago, and used to really dig deep into my system. Recently I've been running Ubuntu out of convenience, but the freeze dates in the six month cycle now seems badly out of step with important projects. Gnome and Mesa in particular always seem like they're badly out of date and I have no interest in Mir or Unity. I mainly just use Ubuntu because of the amount of software support it gets.

Should I try Arch? It seems like the setup process is needlessly complicated even compared to Slackware, but it seems to have good documentation for everything. Is it worth the hassle? Am I going to break my machine worse than I used to occasionally with Slack?

>> No.50306521

How can I change the default terminal size? It bothers me it doesn't remember the size when I picked it in the Terminal drop-down menu.

>> No.50306583

>>50305769
Arch is easy. It can take a little bit to set up, but really not too much. And, unlike Ubuntu and many distros, once it is up, it generally can be up to date indefinitly, no need to get the next version every so often.

I never did slackware, so I cannot compare directly, but if you follow the beginner's guide you can get it going easily in less than an evening, generally.

>> No.50306613

>>50306521
Depends on the terminal emulator you're using, but in Gnome's Terminal its under preferences->profiles->edit
Then you'll have a pair of number spinners under 'initial terminal size'

>> No.50306661

>>50295686
damn, those are some American football shoulders

>> No.50306818

>>50306613
Thanks. Can't believe I missed that. I've just spent hours fiddling with the font and colors there.

>> No.50306883

>>50306583
How well does Steam work on Arch? Will the need to remove bits of the Steam Platform libs to play nice with Mesa RadeonSI cause more problems on it with the more up to date nature of the OS?

>> No.50306912

>>50305471
>>UK
>Oh, that explains a lot. Thanks.
merifag detected.

>> No.50306942

>>50305439
If you could not talk like some mexican on weed then we might be able to understand what you need.

>> No.50306950

Is there a way how to create an user without password. Not blank password, just without password. I do not wish to be asked for user password anywhere.
Security is naturally of no concern here.

>> No.50306959

>>50306950
No need for a new user, just edit visudo

>> No.50307006

>>50305439
We need a lot more clarification. What are you trying to do, exactly?

>>50306883
I sadly have no experience with steam on Arch or elsewhere.

>> No.50307302

How do you add space between newly created terminal windows in GNOME Shell? I do not want to install new WM for this single feature.

>> No.50307328

>>50306666

>> No.50307613

How can i run a watch command via SSH and be able to close the SSH connection, but have the script still running on my Pi?

>> No.50307792

>>50307613
screen

>> No.50307817

>>50307792
i did and when i closed my SSH connection is said screen is terminating.

>> No.50307835
File: 14 KB, 200x200, A14965461098200973A.jpg [View same] [iqdb] [saucenao] [google] [report]
50307835

>>50307328
Epic

>> No.50307951
File: 516 KB, 1024x1400, 1442153142422.jpg [View same] [iqdb] [saucenao] [google] [report]
50307951

>> No.50307977

>>50307817
Log back in and try screen -R

>> No.50308010

>>50307977
>>50307817
No wait, you have to detach screen so you can close your connection. So run screen, run your command, then press Ctrl+A, D (that is first Ctrl+A first, then D alone) to detach it. You can then exit ssh if you want and run screen -R to reattach it.

>> No.50308032

>>50307977
Error Unknown option -n

>> No.50308070

>>50308010
so i run screen straight with nothing behind it? like just "screen" or "screen -D"

>> No.50308175
File: 61 KB, 480x480, 1428131056436.png [View same] [iqdb] [saucenao] [google] [report]
50308175

>>50308010
YESSSSSSSSSSSS IT WORKED!!!!!!!!!!!!! THANK YOU

>> No.50308277

i'm booting lubuntu from a usb and trying to run a program that i have in another usb drive. i can get the source file to compile, and get the executable, but when i try to run in from terminal, i get a message that says
>bash : permission denied
not sure how to get past this. tried a few chmod commands that didn't work. anyone know why permission would be denied though?

>> No.50308436

Is F2FS still being developed?

>> No.50308534

>>50308277
You are able to compile but not able to read the permissions?

>> No.50308584

>>50298320
yeah she was 6 time champion in Finland.
and she did the first move

>> No.50308623

Reminder: Please try my script. It is in beta, and will be for n00bs, but rightnow I just need testers. Give me any suggestions/bug reports please! I just figured out how to do versions and terminal-based git on Github so that will come in handy. Please test it!

https://github.com/Chocolate-Chip-Computing/DebianNewbieScript

>> No.50308742

>>50308534
Yes.

>> No.50308753

>>50308742
ls -l

>> No.50308909

>>50308753
What does this do?

>> No.50310967

>>50303712
It worked! Thank you! Thank you so much!

>> No.50311155

>>50299071
chef

>> No.50311403

I have set up an administrator account on Ubuntu with password. I would love to create a standard user account with no password.
I tried:
useradd myname
passwd -d myname

However when I try to switch accounts, the login still wants password from me and won't accept blank.

>> No.50311409

Which DE has the best HiDPI support? Seems they all suck in one way or another.

>> No.50311419
File: 80 KB, 500x737, 59ea2c81-b474-4b02-a347-d14ae3b459e0..jpg [View same] [iqdb] [saucenao] [google] [report]
50311419

I am currently setting up my desktop with programs and I am pretty upset. Almost nothing works without troubleshooting. Ncmpcpp still gives me errors at visualisation but at least it works.
I wanted to use ranger but for image preview I need w3m. However for the image display I need urxvt. Now urxvt gives me trouble by not reading Xsessions and interfering with xfce terminal. And I can't copy paste with c and v, need to use middle mouse

Point is that I don't know is supposed to be like that "arch way" or is that just bag luck and most should be fine.
I just want to rice but outside of feh everything needed troubleshooting.
Yes I mad.

>> No.50311444

>>50311419
>Using ricer programs without the necessary GNU/Linux experience
>Complains when it doesn't work
I'm not trying to be condescending, but you should probably just stick to a DE and the programs that it ships.

>> No.50311481

>>50308909
removes /home. DO NOT RUN IT!

>> No.50311529

Guys, I need advice.

Was new to linux, and I thought the idea of a separate home partition was stupid, so I put everything together

I now realize I was wrong.

My current setup is:
sda1 /boot -1G
sda2 [swap] -1G
sda3 / -100G
sdb1 /media -2TB

I want to put home on sdb1 and of course retain the data I have right now on home and on media, etc...

Is it as simple as copying the contents of home in /media and the re-mounting sdb1 as /home in fstab?

>> No.50311560

>>50311529
>Is it as simple as copying the contents of home in /media and the re-mounting sdb1 as /home in fstab?
Pretty much.

>> No.50311565

>>50311529
Yes, it's as simple as moving it.

>> No.50311575

How do I configure grub to boot an encrypted archlinux partition? I have an unencrypted boot partition with grub installed on it, it's working fine, I followed the archlinux guide to configure it (I'm not sure where to configure it, I've tried a few places, none of them worked) but it just always boots without decrypting anything. It's only a luks encryption.

>> No.50311579

>>50295686
The friendly GNU+Linux thread.

>> No.50311627

>>50311565
>>50311560
ok one more thing. Do I need to the folder structure to be like

/home/username

or does just

/username

I believe it's the latter, since the whole HD will be an home folder, right? What if I want only a subdir of sdb1 mounted as home? Is the only thing I can do to create another partition on sdb?

Also one last thing. What happens if I don't move the files from /sda3/home/ to /sdb1/, but just copy them? Do the files on sda3 just get de-indexed or will it create problems? Does the space free itself up?

>> No.50311628

>>50311529
Your /boot is too big and your swap is too small.

But to answer your question, yes that's pretty much it since the system doesn't explicitly depend on /home (unlike /usr which would be a little harder to move) Also, you might use cp -a in order to preserve permissions.

>> No.50311641

>>50311627
You can mount a subdirectory of the drive as /home, that's fine.

>> No.50311687

>>50311628
I've put things like sysrescue and other recovery utilities in there, in case my other partitions somehow fuck up.

Also about swap, I've set swappiness to minimum since root is on a SSD, and I've got 8gb of ram anyway.

>>50311641
How would I go about doing that?

UUID=601df9b1-909c-490b-a3d3-c2ff405a0239 /media ext4 rw,relatime,data=ordered 0 2

This is how sdb1 is mounted right now

If I want a subdir of sdb to be mounted as /home what should I write?

UUID=601df9b1-909c-490b-a3d3-c2ff405a0239/home /home ext4 rw,relatime,data=ordered 0 2

? I have to rely on UUIDs since I also happen to do some tech support on this PC, and I frequently move HDDs around.

>> No.50311785

>>50311444
Maybe you are right but I want to use them.

So it's supposed to be like that and I need to learn the common mistakes. Ricing sure is harder than it looks.
If I never start I never progress

>> No.50311798

>Using GPL v3 software
You fags make me sick, especially Americans who use it. Literally unconstitutional, the BSD license provides true freedom.

>> No.50311827

>>50311798
Enjoy getting cucked by Sony, Microsoft and the likes.

>> No.50311902

>>50311827
>Want to invent a new transport method
>Some faggot invented the wheel and GPL'd it
>Sorry bro, can't have you selling your car and making money off of it, it has to be FREE!
Freetards should kill themselves, they represent such a perversion of 'free' it's unbelievable.

>> No.50311914

Is there any real difference between Arch and Gentoo, besides you having to compile everything in Gentoo? Arch even allows you to compile you own packages anyway, so it's not like Gentoo offers way more customizability or anything.

Do correct me if I'm mistaken.

>> No.50312071

>>50311914
USE Flags. Also the ABS (Arch build system) isn't quite as easy to use as emerge: there isn't any equivalent of "emerge world" or whatever.

>> No.50312085

>>50311902
Freedom includes the right to own slaves. Anything less is a perversion of 'freedom'.

>> No.50312104

>>50311627
>/username
That could only happen if you changed /etc/default/useradd or /etc/passwd so users would consider / as a home directory which is retarded.

>What if I want only a subdir of sdb1 mounted as home?
There are 2 options.
Either do as above ie. change "/home" in /etc/passwd to "/media/subdir" for your user,
Or (the easier way) symlink /home to /media/subdir
In both cases, you need /dev/sdb1 mounted to /media (and presumably you've copied your /home to /media/subdir)

>What happens if I don't move the files from /sda3/home/ to /sdb1/, but just copy them?
Nothing. The files on sda3 would just remain there.
You can wipe it and use it for something else.

>>50311687
>UUID=601df9b1-909c-490b-a3d3-c2ff405a0239/home
This won't work.
You can't "mount a subdirectory" you can only mount a filesystem (which in your case resides on a block device)
If you want to use a subdirectory from a filesystem as your home then see above.

>> No.50312242

I just want to pop in and let everyone know how much I fucking hate the Linux filesystem. Can we PLEASE transition to something that makes sense, a la GoboLinux? Even just getting rid of some of the redundant directories would be good enough for me.

>> No.50312280

>>50312071
>there isn't any equivalent of "emerge world"
It isn't really useful to compile everything. 0.12% performance increase and "bloat" isn't a valid excuse on modern machines.

>> No.50312316

>>50312242
The FHS is certainly a lot better than the clusterfuck that is Windows' filesytem. Sure it has its weird legacy baggage, but most of it makes sense.

>> No.50312384

How do I remove my title bar? I run linux mint.

The fact that it is there is horrific.

>> No.50312616

>>50312384
Title bar on firefox is what I meant

>> No.50312631

>>50312384
>>50312616
yes

>> No.50312705

>>50312316
Why do all of those legacy directories have to be created by default? Why can't they be created on demand? It makes it nigh impossible to track down configuration options when I have to search through 5 bin directories, 5 etc directories, and 5 opt directories

>> No.50312734

>>50311575
>>50311575
>>50311575

>> No.50312753

>>50312705
Because it's a standard, and programs expect those things to be in those places.
>Why can't they be created on demand?
Who is going to be the one to create them?

>> No.50312797

Is there any other good pdf reader besides okulus and evince? Evince has some crappy font rendering and okulus needs a shitton of KDE packages just to work.

>> No.50312921

>>50312753
Package manager

Or shit software could just use a simple if directory exists check during installation/configuration. I do it with all my programs, I can't see why enterprise software in the repos can't be expected to do it as well

>> No.50313097

>>50302477
Xfce is one if the most customizable DEs.

>> No.50313113

>>50303379
Icecat/iceweasel

>> No.50313139

>>50296882
>dat exe rant
holy shit, that is some basement autist salt

>> No.50313356

>>50300947
>nearly done
it took them longer to sort out that clusterfuck of a kernel than it did to build the whole userspace for it.

>> No.50313415

>>50311575
I modified "GRUB_CMDLINE_LINUX="cryptdevice=/dev/device:name"" in /etc/default/grub.cfg, remade the config file, didn't work, I tried to edit it in the boot loader by pressing e then booting, nothing, I modified mkinitcpio before everything, I don't know what I missed. Can anybody help me?

>> No.50313443

>>50313415
>/etc/default/grub.cfg
/etc/default/grub*

>> No.50313449

>>50312705
>It makes it nigh impossible to track down configuration options when I have to search through blah blah blah

Why are you configuring anything anywhere except in /home or at the very most /etc and /home ? Why would you look for any bin directorates other than /usr/local/bin? Any other bin directories you shouldn't be touching anyway? Any why would you be messing around with bin files anyway? That's the job of your package manager. If you're just make/sudo make installing willy nilly then you're an idiot.

>> No.50313459

>>50313415
what kind of error if any are you getting?
what kind of partition is it (format, mount point, encryption type)?

>> No.50313489

>>50303379
>non-botnet browser
icecat.
>some of the best loonix c++ IDE's?
depends what you're looking for, but in general vim (or any other text editor) and make do the job perfectly.
But I heard so many different opinions in /g/ and in other places that just browse
https://en.wikipedia.org/wiki/Comparison_of_integrated_development_environments#C.2FC.2B.2B
and test them.
codeblocks is fine in my opinion

>> No.50313491

>>50313459
When booting I just get "Failed to find cpu0 device node", I don't get prompted for the password, then I get thrown in a recovery shell.

>> No.50313502
File: 503 KB, 483x761, aya_no__1_.png [View same] [iqdb] [saucenao] [google] [report]
50313502

Messing around with audacious and conky. Noticed that my weeb music with japanese title looks weird. How do i fix that?. And also is there a way to not display the artist's name with audacious_title?

>> No.50313504

>>50313459
And I'm using a normal luks encryption on an ext4 formatted partition containing the system files, with an unencrypted boot partition.

I set it up with cryptsetup

>> No.50313527
File: 20 KB, 483x504, 1438035108690.png [View same] [iqdb] [saucenao] [google] [report]
50313527

>>50297648

>> No.50313542
File: 50 KB, 615x409, peed.jpg [View same] [iqdb] [saucenao] [google] [report]
50313542

>>50313449
>willy nilly

>> No.50313607

>>50313504
I tried to modify the colours in /etc/default/grub then remade the config and it's still black an white. That would mean it's either not making or not reading the config. What could be the cause?

>> No.50313651

>>50313607
post the contents of grub somewhere

>> No.50313749

>>50313651
it's the normal grub file with "GRUB_CMDLINE_LINUX="cryptdevice=/dev/sda1:cryptsys"" added and a colour theme uncommented

I really don't want to go through the trouble of uploading /etc/default/grub online from the usb boot command line

>> No.50313778
File: 371 KB, 1500x999, 1419067232716.jpg [View same] [iqdb] [saucenao] [google] [report]
50313778

Where can I find the list of programs that init executes when the kernel is booted?
>I'm using Ubuntu

>> No.50313913

>>50313749
there dosnet seem to be anything wrong with that line, some people seem to use :lvm instead of :cryptsys but that may be depreciated.

the cpu0 thing means nothing, it seems to be an error in 4x kernels.

The only thing i can figure is something else is hanging up the process, assuming you built the kernel and used the appropriate options for grub to support booting from encrypted devices.

>> No.50313939

>>50313913
assuming I didn't build the kernel right, could you link a guide to doing so, so I can try to rebuild it?

>> No.50314040

>>50313939
you just add lvm2 and encrypt hooks to /etc/mkinitcpio.conf and run mkinitcpio -p linux, that will build the appropriate kernel.

as for grub make sure
GRUB_ENABLE_CRYPTODISK=y
GRUB_CMDLINE_LINUX="cryptdevice=/dev/sda1:lvm"
are in the appropriate places in /etc/default/grub then do the usual
grub-mkconfig -o /boot/grub/grub.cfg
grub-install /dev/sda
to generate a new grub.cfg

>> No.50314092

>>50313502
>tfw none of the conky config found on net works. Text goes through itself and looks like gibberish

>> No.50314298

>>50314040
I just did all of this, but now it shows an error at the top before doing the usual boot error where it just doesn't detect my root drive and doesn't prompt me for the password. The error is: "error: device name required"

I only added the lvm2 hook to mkinitcpio.conf, which I didn't have because the wiki didn't tell me to add, I changed the name to /dev/sda1:lvm.

But now the grub menu changed colour, so that's good.

>> No.50314386

>>50314298
how are you identifying drives? Label/UUID/dev?
it might just be that grub is expecting one name and getting another, uuid will be the same always, label should be the same but can become muddled with containers like lvm and dev can change.

>> No.50314429

>>50314386
I'm identifying with /dev, I wrote exactly what you told me to, and that's how I've been identifying them for the whole installation.

I just noticed that when I look at the arch linux boot parameters, there's "set root='hd0,msdos3", which is my boot partition. That's normal?

>> No.50314608

>>50311902
You can sell gpl3 licensed stuff.

>> No.50314636

>>50314429
yeah, thats the address the bios initially reports for the drive and format of MBR. its stupid, but correct.

change :lvm back to :cryptsys

if you followed the arch wiki on this then cryptsys is the name of the volume according to /dev/mapper so it has to be the same.

>> No.50314793

>>50312104
Well, I did it, everything works.

I just opted to makes sdb1 /home and created a subfolder there with my user subdir and another named /data with the data that was in /media before.

Ended everything by doing an fstrim, it processed a lot of bytes, but the available disk space of my / partition didn't change.

I suspect the old /home directory is still linging somewhere in my SSD. Is there a way to check if there's a directory hidden beneath what I mounted over it?

>> No.50314797

>>50314636
The name is assigned when you open it if I recall correctly, so it shouldn't matter. The problem right now is that it doesn't prompt me, everything else should work. I added root=/dev/mapper/cryptsys after cryptdevice=UUID=(the UUID, just to make sure):cryptsys and the error is: device '/dev/mapper/cryptsys' not found. Skipping fsck. Unable to find root device '/dev/mapper/cryptsys'

That's normal because it's not decrypting the fucking /dev/sda1 partition to create /dev/mapper/cryptsys

That's what I need to fix and I have no idea how.

>> No.50314959

>>50314797
i came across this:
$ sudo nano /etc/default/grub

Include the following parameter

GRUB_GFXPAYLOAD_LINUX=text

$ sudo update-grub

see if it causes the prompt to spawn
its from an ubuntu forum so ymmv

original thread: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1359689

>> No.50315060

trying to install Linux Mint on my old laptop, burned the ISO to a DVD and did the install but after the install is over the DVD is ejected and the cmd window telling that the pc is shuting down just stucks

>> No.50315239

>>50314959
nope, no prompt

>> No.50315371

>>50315239
https://bbs.archlinux.org/viewtopic.php?id=80467

runnin on fumes at this point, give this a shot.

>> No.50315965

I'm trying to install keepass2 in openSUSE under mono. I downloaded the keepass2 .src.rpm that is on keepasses downloads page for openSUSE. But when trying;

rpm -i keepass2 .src.rpm

I get:

warning: Header V3 DSA/SHA1 Signature, key ID 3f882d82: NOKEY

How do I get this working, I want it so I can use GoogleSync and KeePassHttp plugins.

If this is impossible, can you recommend a free pass manage that syncs with Win/Android/Linux?

>> No.50315970

>>50315371
great success or miserable failure?

>> No.50315989

NEXT THREAD :
>>50315976

>>50315976

>>50315976

>>
Name (leave empty)
Comment (leave empty)
Name
E-mail
Subject
Comment
Password [?]Password used for file deletion.
Captcha
Action